problemas con el firewire

Imagen de fergodoym
0 puntos

Hola a todos.
Tengo un Dell Inspiron 6400 con puerto ieee1394 de 4 pines y ubuntu 8.4 instalado. Hace poco tiempo necesite pasar unos videos desde una mini dv y me encontre con el siguiente problema: no reconoce el puerto firewire.
Probe con dvgrab y me dice: no camera exists
Kino lo lanzo como sudo y cargo los modulos ieee1394, video 1394, raw1394, cambio los permisos y nada.

Lo extraño es que aun cuando puedo cargar los modulos 1394 cuando hago un lshw no me aparece ningun dispositivo firewire, lo mismo pasa cuando ejecuto un lspci.
copio este ultimo

00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 01)
00:1c.3 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 4 (rev 01)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 01)
00:1f.2 IDE interface: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA IDE Controller (rev 01)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 01)
03:00.0 Ethernet controller: Broadcom Corporation BCM4401-B0 100Base-TX (rev 02)
0b:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)

copio lsmod | grep 1394

video1394 19384 0
ohci1394 34096 1 video1394
raw1394 29400 0
ieee1394 95544 3 video1394,ohci1394,raw1394

Mi duda es si tengo un problema de hardware o si simplemente no puedo activar mi firewire, en este ultimo caso como poder activarlo.
Gracias.