A Intrepid con el Alternate CD

+1
0
-1

Bien, después de las dos últimas formas de actualizar que he probado (gestor de actualizaciones y archivo sources.list), se me ha ocurrido probar el Alternate CD a ver si va mejor. Aquí pongo mi odisea:

  • Quito los repositorios no oficiales del sources.list; me bajo la ISO del Alternate de Ubuntu por Torrent, casi a la velocidad máxima de mi red; compruebo su MD5; lo monto; ejecuto "sudo /media/iso/cdromupgrade"; espero un rato, reinicio y ya está. Fin.

Bueno, la verdad es que ya me había hecho a la idea de tener que reinstalar desde cero, pero en fin, otra vez será.

Lo que no consigo que me vaya son los drivers de la Nvidia (tengo que usar Vesa: 800×600 y sin Compiz). Nada más después de actualizar iban a 1024×768, pero al intentarlos reinstalar con mi querido Envy han muerto. También se me han quitado algunos programas, así que lo mismo aprovecho y reinstalo Hardy, o intento bajar la versión de Xorg para que los drivers sean compatibles.

Eso sí: los vídeos de YouTube me van.

Comentarios

Imagen de totemax

te comento, esque creo haber leido en las notas de la version los drivers oficiales de nvidia y ati de ciertas graficas no iban a funcionar en esta version y que habia que aguantarse con los que vienen. De todas formas leete las notas de la version aki:

Esta es una de las cosas por las cuales yo me e kedado en 8.03 LTS.

un saludo y suerte

Imagen de akdmia

En Intrepid los modulos para el kernel se compilan distintos que en hardy (o anteriores).
ahora se usa "dkms", que es un framework para compilar modulos del kernel y que se recompilen automaticamente cada vez que actualizas el kernel (y sus headers)
O sea, la idea es que lo instalas una vez, y te olvides del problema.

A mi me funciono de 10.
instale los paquetes
dkms, nvidia-glx-173 y linux-headers-[version de tu kernel]

luego ejecutas un "sudo nvidia-xconfig" y te genera el xorg.conf.

Imagen de jgajardo

Hola:

Te cuento cómo solucioné el problema de la gráfica. Actualmente tengo en mi equipo 2 tarjetas de video Geforce 6800 GT, y no lograba hacer que el driver de nvidia funcionara,despúes de instalarlo las X no iniciaban y quedaba en la pantalla de login en bash. Al revisar el log de inicio del servidor X (/var/log/Xorg.0.log)
me di cuenta que el problema era que no obstante figuraban las tarjetas no se detectaban adecuadamente. para solucionarlo fue necesario indicarle al servidor X que tarjeta debía usar como primaria con la instrucción BusID en la sección "Device" del archivo de configuración (/etc/X11/xorg.conf), en mi caso quedo:

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BusID "PCI:04:00:00"
EndSection

El BusID lo saque del Xorg.0.log la línea en cuestión dice:

(--) PCI: (0@4:0:0) nVidia Corporation NV45 [GeForce 6800 GTO] rev 162, Mem @ 0xfa000000/0, 0xd0000000/0, 0xfb000000/0, BIOS @ 0x????????/131072
(--) PCI: (0@5:0:0) nVidia Corporation NV45 [GeForce 6800 GTO] rev 162, Mem @ 0xf7000000/0, 0xc0000000/0, 0xf8000000/0, BIOS @ 0x????????/131072

Espero te sirva