(Solucionado) Tras actualizar a 8.10 desde 8.04 no conecta wifi

Imagen de Big_che
0 puntos

Hola

He actualizado Ubuntu a la version 8.10 y he perdido la conectividad wifi.

Tengo un portatil Acer con wifi atheros5007G y uso ndiswrapper con el driver de 64 bits de la tarjeta, con la version 8.04 iba correcto pero ahora cuando intenta conectarse a la wifi se queda atascado con la password de la red. Uso WPA2.

Alguien puede indicarme porque ahora no reconoce la password de red?
Gracias
Un saludo

Imagen de nlaguna
+1
0
-1

Hola vi esto en un foro y espero te sirva a ni me sirvio mucho....

sudo modprobe ath5k

ath5k es el nuevo driver. Si funciona, podés cargarlo en el archivo /etc/modules para que se cargue en el inicio. Para eso lo editás

sudo nano /etc/modules

agregás una línea que diga ath5k, guardás y listo.
En el peor de los casos, volvé a instalar el otro madwifi, pero por si las dudas poné en el backlist los módulos ath_hal y ath5k, para evitar conflictos:

sudo nano /etc/modprobe.d/blacklist

agregás lo siguiente

backlist ath5k
backlist ath_hal

El módulo ath5k se instala junto con el linux-backports-modules

sudo apt-get install linux-backports-modules-$(uname -r)

+1
0
-1
Imagen de folken20x
+1
0
-1

ATENCION:
Tengo entendido que backport vuelve ubuntu inestable.

a mi me paso igual, reinstala ubuntu desde 0 "la 8.10 me refiero" y te cogera la targeta sin necesidad de poner el driver de windows.
despues para tener un asistente decente prueba esta guia
http://www.ubuntu-es.org/index.php?q=node/104418


http://ubuntucrew.blogspot.com/
Bienvenidos tripulantes
+1
0
-1

http://ubuntucrew.blogspot.com/
Bienvenidos tripulantes
Imagen de Big_che
+1
0
-1

Hola

Gracias a los dos por la ayuda.

En principio voy a probar con backport, de momento ha funcionado a la primera. Lo he instalado a traves de Synaptic (añade otros dos modulos), he editado /etc/modules para añardir ath5k y quitar ndiswrapper y tambien he editado /etc/modprobe.d/blacklist para eliminar ath_pci y añadir ndiswrapper (esto ultimo creo que no seria necesario si lo desinstalo) y tras reiniciar ha conectado a la primera.

Si como dice folken20x esta solucion vuelve inestable el OS intentare a instalar desde cero

Un saludo y gracias one more time


El que devora tus entrañas y lo disfruta

Ubuntu 8.04 hardy 64bits
Acer aspire 5715Z

+1
0
-1

El que devora tus entrañas y lo disfruta

Ubuntu 64bits 8.04 hardy -> 8.10 Intrepid Ibex -> 9.04 Jaunty Jackalope -> 9.10 Karmic Koala -> 10.04 Lucid Lynx -> 10.10 Maverick Meerkat -> 11.04 Natty Narwhal
Acer aspire 5715Z

Imagen de Big_che
+1
0
-1

Hola

Despues de estar unos dias funcionando correctamente empiezo a sufrir las inestabilidades del paquete backport-modules, ciertamente aparecen bastantes warnings en syslog de fallos de este paquete. De momento solo me ha afectado una vez directamente (no funcionaba la tarjeta wifi).

Un saludo


El que devora tus entrañas y lo disfruta

Ubuntu 8.04 hardy 64bits
Acer aspire 5715Z

+1
0
-1

El que devora tus entrañas y lo disfruta

Ubuntu 64bits 8.04 hardy -> 8.10 Intrepid Ibex -> 9.04 Jaunty Jackalope -> 9.10 Karmic Koala -> 10.04 Lucid Lynx -> 10.10 Maverick Meerkat -> 11.04 Natty Narwhal
Acer aspire 5715Z