Cómo instalo Xvkbd

Imagen de franjrs
0 puntos

Hola.

¿Me podeís ayudar a instalar un programa?

Se puede descargar desde su web y lo descomprimes y me encuentro con una carpeta con archivos y no se qué hacer para instalar el programa.

En la web sale lo siguiente:

Install

1. untar the source in a directory, and move to the directory

2. If you wish to use genuine Xaw insead of Xaw3d, edit Imakefile and remove (or comment-out) `#define XAW3D'.

When you are installing xvkbd (for example) in very old systems, you may also want to remove `#define XTEST' and `#define I18N' to disable XTEST and internationalization facility respectively.

3. Run xmkmf; make install install.man

Ayudarme por favor.

Imagen de franjrs
+1
0
-1

¿Alguien me ayuda?

Siento postear otra vez...

+1
0
-1
Imagen de bitland
+1
0
-1

apt-cache search virtual keyboard

+1
0
-1
Imagen de franjrs
+1
0
-1

¿Quieres que ponga eso en una consola no? Ok.

+1
0
-1
Imagen de franjrs
+1
0
-1

Hola de nuevo.

He hecho lo que dices y me dice que para instalar ponga sudo apt-get install xvkbd

Lo pongo y sale esto:

Leyendo listas de paquetes... Hecho
Creando árbol de dependencias
Leyendo información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que usted pidió una situación imposible o, si está usandi la distribución inestable, que algunos paquetes necesarios no han sido creados o han sido movidos fuera de Incoming.

Como sólo solicito una única operación, es extremadamente posible que el paquete simplemente no sea instalable y debería de rellenar un informe de error contra ese paquete.
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen depedencias incumplidas:
xvkbd: Depende de: xaw3dg (>= 1.5+E.1) pero no es instalable
E: Paquetes rotos

+1
0
-1
Imagen de bitland
+1
0
-1

El comando "apt-cache search virtual keyboard" me da como resultado:

kbd - Linux console font and keytable utilities
kvkbd - Virtual keyboard for KDE
matchbox-keyboard - Teclado en pantalla
texlive-latex-extra - TeX Live: Paquetes suplementarios LaTeX
g15daemon - Screen multiplexer for Logitech G15 Keyboard
klavier - A virtual keyboard for KDE
mscore - Full featured WYSIWYG score editor
mscore-common - Full featured WYSIWYG score editor (common files)
qemulator - a solution for easy setup and management of qemu
rhinote - virtual sticky-notes for your desktop
vkeybd - Virtual MIDI Keyboard
xvkbd - software virtual keyboard for X11
desktop-multiplier - Userful's Virtualized X-Server (Trial Version)
dosemu - Emulador Linux DOS

Prueba con alguno de los otros, que supongo te harán la misma función.

P.D. Estoy con Xubuntu 8.10, a ver si eso afecta...

+1
0
-1
Imagen de franjrs
+1
0
-1

-

+1
0
-1
Imagen de franjrs
+1
0
-1

No, salen más, pero me sale un mensaje parecido al que puse antes tras poner sudo apt-get install x-programa.

+1
0
-1
Imagen de Goyo
+1
0
-1

¿No será >=1.5+E-1? ¿Qué versión de Ubuntu usas?

+1
0
-1
Imagen de franjrs
+1
0
-1

¿Qué es >=1.5+E-1? Es la 8.04.

+1
0
-1
Imagen de Goyo
+1
0
-1

Esto:

xvkbd: Depende de: xaw3dg (>= 1.5+E.1) pero no es instalable

Creo que lo has copiado mal.

La versión de xvkbd en Hardy es la 2.8-1, según http://packages/ubuntu.com. Este paquete depende de xaw3dg (>= 1.5+E-1). En Hardy está xaw3dg (1.5+E-15) así que no debería haber problemas. Comprueba en Synaptic qué versiones de estos paquetes están disponibles.

+1
0
-1
Imagen de franjrs
+1
0
-1

No me sale nada de xaw3dg...

+1
0
-1
Imagen de Goyo
+1
0
-1

Asegúrate de que tienes activado el repositorio main y recarga la lista de paquetes.

+1
0
-1
Imagen de franjrs
+1
0
-1

Gracias Goyo, ya me deja instalar.

+1
0
-1