ATI, como siempre.

+1
0
-1

Hola a todos.

Parece ser que cuatro años después del nacimiento de Ubuntu, los usuarios de uno de los dos fabricantes de tarjetas de vídeo más importantes (ATI) aún tenemos que seguir peleándonos con el sistema operativo y con los dichosos controladores. Yo no sé si esto obedece a dejadez por parte de los desarrolladores del software de vídeo para sistemas que no sean el de siempre, a intereses comerciales o a alguna otra razón que se me escapa, el caso es que me resulta totalmente imposible hacer funcionar mi Intrepid Ibex con los controladores propietarios de ATI.

Bien es cierto que en anteriores versiones me ha funcionado, de mejor o peor manera, pero al final han acabado arrancando. Esto, que en teoría debería ser tan fácil como instalar el controlador, ejecutarlo y como mucho reiniciar, se vuelve tarea imposible, cuando te hacen buscar tutoriales por todo Internet, al final, al menos en mi caso, para nada.

Claro que existen los controladores libres, que ya vienen por defecto en el sistema según lo instalas, y aunque sólo tengo palabras de agradecimiento en cuando al esfuerzo de la comunidad para desarrollar unos controladores decentes (parece de chiste que el software de terceros sea más fiable que el de los propios fabricantes de la tarjeta), el rendimiento de éstos me resulta insuficiente, notando cierta ralentización en los efectos de escritorio, y resultando totalmente imposible ejecutar aplicaciones exigentes (videojuegos en 3D).

Lo que me resulta absolutamente frustrante es que después de nuevas versiones del sistema operativo, lo normal es que los fallos se corrijan, se arreglen los errores y todo funcione cada vez mejor. Sin embargo, con las sucesivas versiones de Ubuntu y las de los controladores ATI, todo parece ir al revés. Hardy Heron tuve que dejarlo por imposible (ni siquiera me funcionaron los controladores libres) y me quedé en Gutsy, esperando esta nueva versión, a ver si la cosa mejoraba. Y aunque al principio pareció ser así, tuve que darme de morros con la realidad, al ver que al intentarlo con los dichosos controladores propietarios seguían como siempre. Peor si cabe, ya que mal que bien, antes conseguía que funcionaran.

Me he pateado toda la red buscando soluciones, experiencia de personas que hubieran pasado por lo mismo que yo y lo hayan solucionado, tutoriales, aplicaciones (ni siquiera puede recurrir a Envy, que tantas veces me salvó la vida en el pasado, porque ahora también me falla), incluso archivos xorg.conf para mi tarjeta de vídeo (ATI Mobility Radeon 9700). Ya estoy cansado de probar cosas y de ver que al contrario que en otros aspectos, donde todo es cada día más fácil y mejor, los señores de ATI se llenan la boca con su tan cacareado soporte para Linux, cuando la triste realidad es que a día de hoy, varios años después del nacimiento de nuestra querida distro, no han sido capaces de realizar un software decente para su propio hardware y haya que tirar de la comunidad si queremos algo aceptable, que no definitivo.

No quisiera que nadie viese en estas palabras acritud, sólo es que escribo desde la frustración y la impotencia que me supone el tener que volver a Gutsy (7.10), que fue la última versión en la que los drivers propietarios funcionaron como deben. Creo que esto me pasa por meterme en berenjenales (¿realmente necesito tener la última versión del sistema operativo, cuando la versión de hace un año funciona perfectamente?), y he decidido no volver a actualizar de versión al menos hasta que cambie de ordenador.

Me gustaría saber si alguien más ha tenido la misma experiencia, a ver si es que al final va a resultar que todo esto no son más que figuraciones mías y realmente no es que los controladores sean malos, es que son a prueba de incompetentes.

Saludos y gracias por leerme.

Comentarios

Imagen de guman

bueno ya veo k somos dos k por el mismo problema estamos en gutsy hasta ahora....
no se trata de k me guste tener efectos 3d como el cubo , se trata de k las cosas trabajen de acuerdo a lo k estan pre-establecidas, pero ni modo con este detalle, parece ser k estaremos durante algun tiempo en gutsy hasta k tomemos la desicion de migrar al costo de la asceleracion 3d.....

Como son las cosas, me encantaba Gnome....ahora lo odio!!!
Y como antes no me gustaba Xfce , no entiendo por que ahora lo adoro!!!

Imagen de dcentellas

Tengo la misma gráfica que tú y estoy exactamente igual. Los últimos drivers que me funcionaron creo que son los Catalyst 8.7 con Hardy Heron. Después de ese todos me dan un segmentation fault al ejecutar el aticonfig. El problema es que además con Intrepid parece que sólo funciona con los 8.9 o 8.10 (ahora no recuerdo). He probado infinidad de tutoriales y configuraciones y no ha habido forma. Al final me he quedado con los drivers libres en Intrepid que por lo menos funcionan más o menos. Eso sí, tengo que reconocer que esta es la primera versión en que recién instalado ya tenía aceleración 3D, aunque le falte algo de rendimiento.
Ahora estoy buscando un nuevo portátil para cambiarmelo asi que no me voy a esforzar más. El problema es que el que me gusta más y está bien de precio es el Dell Studio y viene con... una ATI.... bufffff... no se si atreverme otra vez con ellos o gastarme algo más de pasta y buscar uno que me venga con NVIDIA.

Imagen de Treno

A mi tambien me pasa lo mismo con la misma targeta, es un infierno, lo dejé por imposible ya.

Imagen de elarhg

tengo el mismo problema, esto ya me saa de casillas cuando estoy viendo algun movie, esta comiensa a parpadear asi que no se puedea apreciar el video. y que pena por la
comunidad de usuarios de ubuntu, ya somos nosotros los afectados todos los q tenemos un video ATI q pena mi laptop justamente me venga asi. ya que mi desktop si va todo bien ya q cuenta con una NVIDEA.
esperemos q esto se solucione pronto, o seguira dandonos un dolor decabeza.

Elar Herreros Guerrero

Elar Herreros Guerrero

Imagen de dcentellas

Lo de los parpadeos del video se puede solucionar cambiando el modo de salida de video del reproductor. Por lo menos se puede hacer con Totem, Mplayer y VLC. Si buscas un poquito gloogueando lo encontrarás fácilmente, si no lo encuentras dímelo y ya te lo busco yo.

Imagen de dcentellas

Bueno, por fin he encontrado un driver que funciona en mi mobility 9700, pero es una versión beta todavía sin publicar. Acaba de salir el 9.1 que no funciona tampoco, éste es el 9.2.
http://www.ati-forum.de/files/Downloads/Driver/Linux_catalyst_9.2_CES_09_preview_driver.zip
Yo lo he probado y realmente funciona.
Instrucciones para instalarlo:
Descomprimir el archivo y luego en la consola ejecutar lo siguiente.

sudo sh ./Linux_catalyst_9.2_CES_09_preview_driver.run --buildpkg Ubuntu/intrepid

sudo dpkg -i xorg-driver-fglrx_8.580-0ubuntu1_i386.deb fglrx-kernel-source_8.580-0ubuntu1_i386.deb fglrx-amdcccle_8.580-0ubuntu1_i386.deb

sudo aticonfig --initial -f

Para más información:
https://bugs.launchpad.net/ubuntu/jaunty/+source/fglrx-installer/+bug/284408

Imagen de dcentellas

POR FIN!!! EL último driver de ATI (Catalyst 9.3) ya me funciona correctamente sin parpadeos ni nada, incluso con Compiz y todo. Aún tengo algún que otro fallo en algunas aplicaciones como Cheese (webcam) pero solo tengo que desactivar compiz y ya funciona perfecto. ¡¡¡ALELUYA!!!