Kernel y gcc

Imagen de Pryrios
0 puntos

Buenas a todos,

Resulta que estoy intentando instalar mi modem ADSL Sagem F@st 800 y tengo que instalar el eagle-usb y tal. Pero al configurar, descubro que no puedo instalarlo porque el compilador gcc que tengo es la versión 4.0.2 y el gcc que ha sido usado por el kernel es el 3.4.5.

Por culpa de esto me da errores al hacer el make. La verdad es que, al ser bastante novato con linux, no se exactamente que debo hacer. ¿Recompilar el kernel? La versión del kernel que tengo es la 2.6.12-9-386.

¿Alguna sugerencia, por favor?

Imagen de Pryrios
+1
0
-1

Se me ha olvidado decir que no encuentro la version 3.4.5 del gcc por la web, cosa que me ha dejado un poco a cuadros Oo.

Por otra parte, ¿podria poner la version 3.4.4 y que me funcionase?

--
Pryrios

+1
0
-1

--
Pryrios

Imagen de SaintK
+1
0
-1

Saludos. Lo que tendrías que hacer es reemplazar el enlaze simbólico que apunta a gcc 4 por uno que apunte a gcc 3.4. Primero instala gcc 3.4.5 y luego cambia el enlace:
sudo rm /usr/bin/gcc
sudo /usr/bin/gcc3.4 /usr/bin/gcc

Saludos y espero te sirva, Germán.

+1
0
-1
Imagen de Hach Winik
+1
0
-1

Que tal Pryrios, yo lo he solucionado haciendo lo siguiente:
primero como superusuario
sudo su
pswrd
CC=gcc-3.4
export CC
exit

y luego como usuario normal
CC=gcc-3.4
export CC
después compilas, y listo.
Suerte!

+1
0
-1

Saludos

José Leopoldo Sánchez Ramos