Error en la instalación de WINFF (ResuelTo)

Imagen de cHemarY
0 puntos

Estoy instalando winff desde: http://www.gnomefiles.org/app.php/WinFF; clico donde pone "WinFF 0.43 I386 DEB", le digo que abra con el instalador de paquetes Gdebi, y cuando se abre el instalador me da un mensaje de error: "Dependency is not satisfiable: libpango 1.0-0".

He visto en synaptic que si desisntalo libpango 1.0-0, cosa que no he hecho, se desinstalan muchísimos programas, así que deduzco que la solución es otra.

¿Hay otra manera de instalar el winff?.

Muchas gracias.

Imagen de arturom
+1
0
-1

Hola,
tu problema es el contrario, gDebi te dice que necesita libpango1.0-0
Prueba escribiendo en una consola:

aptitude search libpango

a la izquierda debe aparecer un i junto a libpango1.0-0 y libpango1.0-0.common, si no es así, instala el que te falte con:

sudo aptitude install libpango1.0-0.loquetefalte

si tienes instalados los dos y aún así te devuelve un error, lee con atención el mensaje de GDebi, igual te pide que instales libpango1.0-0.dev

Un saludo
ArturoM

+1
0
-1

Un saludo
ArturoM

Imagen de cHemarY
+1
0
-1

Esto es lo que pone que tengo:

p libpango1-ruby - Pango bindings for the Ruby language
p libpango1-ruby1.8 - Pango bindings for the Ruby language
i libpango1.0-0 - Layout and rendering of internationalized
p libpango1.0-0-dbg - The Pango library and debugging symbols
i libpango1.0-common - Modules and configuration files for the Pa
p libpango1.0-dev - Development files for the Pango
p libpango1.0-doc - Documentation files for the Pango

 

-----------------------------------------------------------------------------------------

Lo que ayer creía todo el mundo y lo que Ud. cree hoy, no lo creerán mañana más que los necios.
Sir Francis Crick.

+1
0
-1

 

[2, 3, 5, 7, 11, 13, 17, 19, 23, 29]

Lo que ayer creía todo el mundo y lo que Ud. cree hoy, no lo creerán mañana más que los necios. Sir Francis Crick.

Imagen de arturom
+1
0
-1

Hola,
pues si lo tienes instalado, instala la versión de desarrollo,a ver si va a ser eso. Usa:

sudo aptitude install libpango1.0-dev

y vuelve a intentar la instalación del winff, si aún asi te da error, puedes desinstalar el dev así:

sudo aptitude purge libpango1.0-dev

Un saludo
ArturoM

+1
0
-1

Un saludo
ArturoM

Imagen de cHemarY
+1
0
-1

He instalado nuevos paquetes, ahora queda así:

p libpango1-ruby - Pango bindings for the Ruby language
p libpango1-ruby1.8 - Pango bindings for the Ruby language
i libpango1.0-0 - Layout and rendering of internationalized
i libpango1.0-0-dbg - The Pango library and debugging symbols
i libpango1.0-common - Modules and configuration files for the Pa
i libpango1.0-dev - Development files for the Pango
p libpango1.0-doc - Documentation files for the Pango

Pero sigue dando el mismo error.

 

-----------------------------------------------------------------------------------------

Lo que ayer creía todo el mundo y lo que Ud. cree hoy, no lo creerán mañana más que los necios.
Sir Francis Crick.

+1
0
-1

 

[2, 3, 5, 7, 11, 13, 17, 19, 23, 29]

Lo que ayer creía todo el mundo y lo que Ud. cree hoy, no lo creerán mañana más que los necios. Sir Francis Crick.

Imagen de arturom
+1
0
-1

Hola,
¿puedes instalar desde consola el paquete con:

sudo dpkg -i nombredelpaquete.deb

y postear aquí la respuesta que te da?

Un saludo
ArturoM

+1
0
-1

Un saludo
ArturoM

Imagen de cHemarY
+1
0
-1

Este es el resultado:

Seleccionando el paquete winff previamente no seleccionado.
(Leyendo la base de datos ...
168238 ficheros y directorios instalados actualmente.)
Desempaquetando winff (de winff_0.43-0ubuntu1~ppa1h_i386.deb) ...
dpkg: problemas de dependencias impiden la configuración de winff:
winff depende de libpango1.0-0 (>= 1.20.5); sin embargo:
La versión de `libpango1.0-0' en el sistema es 1.18.3-0ubuntu1.
dpkg: error al procesar winff (--install):
problemas de dependencias - se deja sin configurar
Se encontraron errores al procesar:
winff

 

-----------------------------------------------------------------------------------------

Lo que ayer creía todo el mundo y lo que Ud. cree hoy, no lo creerán mañana más que los necios.
Sir Francis Crick.

+1
0
-1

 

[2, 3, 5, 7, 11, 13, 17, 19, 23, 29]

Lo que ayer creía todo el mundo y lo que Ud. cree hoy, no lo creerán mañana más que los necios. Sir Francis Crick.

Imagen de cHemarY
+1
0
-1

Tiene la versión 1.18.3-0 de linpango1.0-0 y necesita la versión 1.20.5 o superior. He buscado en google y he encontrado en: https://launchpad.net/ubuntu/hardy/lpia/libpango1.0-0/1.20.5-0ubuntu1; que es el libpango que necesito.

El problema radica en que cuando me pongo a instalar el paquete: libpango1.0-0_1.20.5-0ubuntu1_lpia.deb; me da el siguiente error: Wrong architecture 'lpia', y con la arquitectura no me atrevo a hacer nada sin saber lo que hago.

 

-----------------------------------------------------------------------------------------

Lo que ayer creía todo el mundo y lo que Ud. cree hoy, no lo creerán mañana más que los necios.
Sir Francis Crick.

+1
0
-1

 

[2, 3, 5, 7, 11, 13, 17, 19, 23, 29]

Lo que ayer creía todo el mundo y lo que Ud. cree hoy, no lo creerán mañana más que los necios. Sir Francis Crick.

Imagen de cHemarY
+1
0
-1

Ya voy comprendiendo, el paquete que tengo que bajar es el libpango1.0-0_1.20.5-3_i386.deb, y lo he encontrado aqui: http://packages.debian.org/es/sid/i386/libpango1.0-0/download. Lo he bajado y he hecho: sudo dpkg -i libpango1.0-0_1.20.5-3_i386.deb, aqui muestro el resultado:

(Leyendo la base de datos ...
168146 ficheros y directorios instalados actualmente.)
Preparando para reemplazar libpango1.0-0 1.18.3-0ubuntu1 (usando libpango1.0-0_1.20.5-3_i386.deb) ...
Desempaquetando el reemplazo de libpango1.0-0 ...
dpkg: problemas de dependencias impiden la configuración de libpango1.0-0:
libpango1.0-0 depende de libpango1.0-common (>= 1.20.5-3); sin embargo:
La versión de `libpango1.0-common' en el sistema es 1.18.3-0ubuntu1.
libpango1.0-0 depende de libc6 (>= 2.7-1); sin embargo:
La versión de `libc6' en el sistema es 2.6.1-1ubuntu10.
libpango1.0-0 depende de libcairo2 (>= 1.6.4-6.1); sin embargo:
La versión de `libcairo2' en el sistema es 1.4.10-1ubuntu4.4.
libpango1.0-0 depende de libdatrie0 (>= 0.1.2); sin embargo:
La versión de `libdatrie0' en el sistema es 0.1.1-4.
libpango1.0-0 depende de libglib2.0-0 (>= 2.16.0); sin embargo:
La versión de `libglib2.0-0' en el sistema es 2.14.1-1ubuntu1.
dpkg: error al procesar libpango1.0-0 (--install):
problemas de dependencias - se deja sin configurar
Se encontraron errores al procesar:
libpango1.0-0

Ahora si que estoy definitivamente perdido.

 

-----------------------------------------------------------------------------------------

Lo que ayer creía todo el mundo y lo que Ud. cree hoy, no lo creerán mañana más que los necios.
Sir Francis Crick.

+1
0
-1

 

[2, 3, 5, 7, 11, 13, 17, 19, 23, 29]

Lo que ayer creía todo el mundo y lo que Ud. cree hoy, no lo creerán mañana más que los necios. Sir Francis Crick.

Imagen de arturom
+1
0
-1

Hola de nuevo,
vamos a probar otra cosa,

  • ve al menú Sistema->Administración->Gestor de paquetes Synaptic
  • una vez escrita la contraseña pulsa sobre la opción del menú Configuración
  • elije Repositorios
  • Selecciona la pestaña Actualizaciones
  • marca la casilla Actualizaciones recomendadas
  • Acepta la recarga de la lista de paquetes (si no te ofrece actualizar la lista, pulsa sobre el botón Recargar
  • Pulsa sobre el botón Buscar y escribes libpango
  • mira a ver si aparece la versión 1.20, si es así instálala

Si ya tenias marcada la opción Actualizaciones recomendadas simplemente cierra Synaptic e intenta usar la siguiente orden:

sudo gDebi Paquete_Descargado_Del_Libpango.deb

date cuenta que gDebi puede instalar los paquetes que faltan siempre que los encuentre en los repositorios.

Suerte
Un saludo
ArturoM

+1
0
-1

Un saludo
ArturoM

Imagen de cHemarY
+1
0
-1

La opción Actualizaciones recomendadas ya está instalada, así que le he introducido la siguiente orden: sudo gdebi libpango1.0-0_1.20.5-3_i386.deb

y me da el siguiente resultado:

Reading package lists: Done
Reading state information: Done
Reading state information: Done
Reading state information: Done
Este paquete no es instalable
Dependency is not satisfiable: libpango1.0-common

 

-----------------------------------------------------------------------------------------

Lo que ayer creía todo el mundo y lo que Ud. cree hoy, no lo creerán mañana más que los necios.
Sir Francis Crick.

+1
0
-1

 

[2, 3, 5, 7, 11, 13, 17, 19, 23, 29]

Lo que ayer creía todo el mundo y lo que Ud. cree hoy, no lo creerán mañana más que los necios. Sir Francis Crick.

Imagen de arturom
+1
0
-1

Pues ya sabes lo que debes hacer, descargalo del mismo sitio que el anterior e intenta instalarlo con:

sudo gdebi paquete_descargado.deb

Un saludo
ArturoM

+1
0
-1

Un saludo
ArturoM

Imagen de cHemarY
+1
0
-1

He ido instalando los paquetes de los que dependian unos de otros hasta que podido instalar el winff.

Ahora solo me queda probarlo.

 

-----------------------------------------------------------------------------------------

Lo que ayer creía todo el mundo y lo que Ud. cree hoy, no lo creerán mañana más que los necios.
Sir Francis Crick.

+1
0
-1

 

[2, 3, 5, 7, 11, 13, 17, 19, 23, 29]

Lo que ayer creía todo el mundo y lo que Ud. cree hoy, no lo creerán mañana más que los necios. Sir Francis Crick.

Imagen de arturom
+1
0
-1

Hola,
me alegro de que lo hayas resuelto.

Un saludo
ArturoM

+1
0
-1

Un saludo
ArturoM