(Solucionado) Aceleración gráfica no se puede activar. Nvidia Glx Legacy.

Imagen de gioubuntu
0 puntos

Hola. La compu es una Sony Vaio PCV-RX93M con tarjeta gráfica Nvidia Geforce2 MX con 32MB. Es una gráfica integrada en el Motherboard. La versión de Ubuntu que uso es la Hardy (8.04).

Estoy usando el driver nvidia-glx-legacy, que es el que le corresponde por ser una tarjeta antigua, pero, aunque sí tengo resolución de 1024x768, la aceleración gráfica no funciona.

Desde consola: sudo glxinfo

name of display: :0.0
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual

   visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
 id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
0x21 24 tc  1  0  0 c  .  .  0  0  0  0  0  0  0  0  0  0  0  0 0 None
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
0x22 24 dc  1  0  0 c  .  .  0  0  0  0  0  0  0  0  0  0  0  0 0 None
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
0x23 24 tc  1  0  0 c  .  .  0  0  0  0  0  0  0  0  0  0  0  0 0 None
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
0x24 24 tc  1  0  0 c  .  .  0  0  0  0  0  0  0  0  0  0  0  0 0 None
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
0x25 24 tc  1  0  0 c  .  .  0  0  0  0  0  0  0  0  0  0  0  0 0 None
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
0x26 24 tc  1  0  0 c  .  .  0  0  0  0  0  0  0  0  0  0  0  0 0 None
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
0x27 24 tc  1  0  0 c  .  .  0  0  0  0  0  0  0  0  0  0  0  0 0 None
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
0x28 24 tc  1  0  0 c  .  .  0  0  0  0  0  0  0  0  0  0  0  0 0 None
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
0x29 24 tc  1  0  0 c  .  .  0  0  0  0  0  0  0  0  0  0  0  0 0 None
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
0x2a 24 tc  1  0  0 c  .  .  0  0  0  0  0  0  0  0  0  0  0  0 0 None
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
0x2b 24 tc  1  0  0 c  .  .  0  0  0  0  0  0  0  0  0  0  0  0 0 None
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
0x2c 24 tc  1  0  0 c  .  .  0  0  0  0  0  0  0  0  0  0  0  0 0 None
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
0x2d 24 tc  1  0  0 c  .  .  0  0  0  0  0  0  0  0  0  0  0  0 0 None
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
0x2e 24 dc  1  0  0 c  .  .  0  0  0  0  0  0  0  0  0  0  0  0 0 None
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
0x2f 24 dc  1  0  0 c  .  .  0  0  0  0  0  0  0  0  0  0  0  0 0 None
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
0x30 24 dc  1  0  0 c  .  .  0  0  0  0  0  0  0  0  0  0  0  0 0 None
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
0x31 24 dc  1  0  0 c  .  .  0  0  0  0  0  0  0  0  0  0  0  0 0 None
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
0x32 24 dc  1  0  0 c  .  .  0  0  0  0  0  0  0  0  0  0  0  0 0 None
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
0x33 24 dc  1  0  0 c  .  .  0  0  0  0  0  0  0  0  0  0  0  0 0 None
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
0x34 24 dc  1  0  0 c  .  .  0  0  0  0  0  0  0  0  0  0  0  0 0 None
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
0x35 24 dc  1  0  0 c  .  .  0  0  0  0  0  0  0  0  0  0  0  0 0 None
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
0x36 24 dc  1  0  0 c  .  .  0  0  0  0  0  0  0  0  0  0  0  0 0 None
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
0x37 24 dc  1  0  0 c  .  .  0  0  0  0  0  0  0  0  0  0  0  0 0 None
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
0x38 24 dc  1  0  0 c  .  .  0  0  0  0  0  0  0  0  0  0  0  0 0 None
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
0x91 32 tc  1  0  0 c  .  .  0  0  0  0  0  0  0  0  0  0  0  0 0 None
Fallo de segmentación

Este es el contenido de mi xorg.conf:

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc105"
	Option		"XkbLayout"	"latam"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
EndSection

Section "Device"
	Identifier	"nVidia Corporation NVCrush11 [GeForce2 MX Integrated Graphics]"
	Driver		"nvidia"
	BusID		"PCI:2:0:0"
	Option		"UseFBDev"		"true"
EndSection

Section "Monitor"
	Identifier	"HMD-A420"
	Option		"DPMS"
	HorizSync	30-60
	VertRefresh	50-75
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Device		"nVidia Corporation NVCrush11 [GeForce2 MX Integrated Graphics]"
	Monitor		"HMD-A420"
	DefaultDepth	24
	SubSection "Display"
		Depth		1
		Modes		"1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		4
		Modes		"1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		8
		Modes		"1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		15
		Modes		"1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		16
		Modes		"1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		24
		Modes		"1024x768" "800x600" "640x480"
	EndSubSection
EndSection

Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		"Default Screen"
EndSection

Espero no olvidar algún dato importante.

Gracias,
Gio

-- (Solución)

Instalar este driver: http://us.download.nvidia.com/XFree86/Linux-x86/71.86.06/NVIDIA-Linux-x8...

Añadir al xorg.conf:

Section "Extensions"
Option "Composite" "Disable"
EndSection

Con esto los comandos "glxinfo y glxgears" ya muestran la salida correcta.

Imagen de Sanguinario_Joe
+1
0
-1

Hola!

Por un lado ¿que version de ubuntu gastas?

Por otro, ¿¿el driver legacy ha tenido alguna vez aceleracion 3D??

Yo de ti probaria a ponerme los mas modernos (aunque no correspondan a tu grafica), e ir decreciendo.

Es mas, ahora no lo recuerdo, y no tengo el portatil a mano para mirarlo, pero en intrepid, en el gestor de controladores restringidos, te da un toque sobre este asunto.

Suerte y saludos!!!

+1
0
-1
Imagen de gioubuntu
+1
0
-1

Ubuntu 8.04.

Hasta donde sé, el driver sí tiene aceleración. Y controladores más recientes bloquean el sistema.

Gracias,
Gio

+1
0
-1
Imagen de Peluchon
+1
0
-1

Instala los drivers de la página de Nvidia de la serie 96 por ejemplo de esta dirección

http://www.nvidia.com/object/linux_display_x86_96.43.07.html

Ubuntu User # 15474

+1
0
-1

Ubuntu User # 15474

Imagen de gioubuntu
+1
0
-1

Los instalé como sugieres, pero han bloqueado el sistema: del logo de Nvidia no pasa con ese driver.

¿Alguna sugerencia para hacer funcionar la aceleración con el driver de Synaptic nvidia-glx-legacy?

Gracias,
Gio

+1
0
-1
Imagen de Sanguinario_Joe
+1
0
-1

No usas 64 bits claro...

Por ahi recomiendan exactamente esta version del driver:

http://www.nvidia.com/object/linux_display_ia32_1.0-9631.html

Recuerda que debes tener las X desactivadas para instalar.

Alli aparece documentacion de sobra sobre como deberia estar montado.

Has actualizado el kernel?? La ultima version del kernel para hardy daba problemas con algunas graficas (sobretodo ATI)

Estas seguro que la grafica va bien? Tienes un windows para comparar?

No se me ocurren asi mas cosas...

Saludos!!!

+1
0
-1
Imagen de gioubuntu
+1
0
-1

Ese driver tampoco funciona. :(

No es problema de la tarjeta, sí tengo Windows y ahí funciona bien. Seguiré buscando...

Gracias.

+1
0
-1