[Como] Fallos en arranque con particiones....

Imagen de PabliNet
0 puntos

Les voy a contar lo que me sucedió y cómo lo arreglé. Eso sí, ya estaba pensando en formatear y comprar un nuevo disco rígido...

Cuando arranco la PC me aparece un error en /dev/sda5 (la /home) y daba la opción de obviar el error (Control+D) o de arreglarlo manualmente.

Como soy vago para el inglés presionaba Control+D y hasta que algún lugar le algo que dice no recuerdo si login o contraseña. Ahí empiezo a investigar y también leo root. Entonces pienso: ¿No me pedirá la contraseña del root? pruebo y era eso. Bien, entonces significa que me dice que lo tenía que lo tenía que arreglar manualmente y además me mostraba una ruta que no sabía si era de un directorio o de un fichero... probé en borrar ese fichero o directorio (lo que me debe marcar es que el error debe estar ahí). Le di # reboot y entró al login Gnome.

Reinicié de nuevo y seguí el error, entonces pensé: ese fichero debe tener mal el código, me fijaré con el gedit y... ESE FICHERO TENÍA GRABADO EL INFORME DEL ERROR QUE ME TIRABA. Me estoy refiriendo a: /var/log/fsck/checkfs.

Y ahí me dije: que genio es Ubuntu, te copia en un archivo el informe del error, para puedas preguntar en Internet sin necesidad de escribirlo en un papel y volverlo a tipear. ¿Por qué Windows no será así?

Bue'... San Google nos ayudará y...

Para arreglar los clusters tipié:

# fsck /dev/sda5

Ahí tenes que eligir 1 o 2.

Y tipié otra vez:

# fsck /dev/sda5

... y a meterle a todo la Y

Cuando terminé le volví a dar # reboot.

Entro al login del Gnome y al logearme me decía que no aparecía la carpeta /home/«usuario».

Reinicio la PC, ya no me tira más el error de arranque, entra el login de Gnome, me logeo y... entra sin problemas. Me fijo y tengo la partición /home intacta de pura suerte.