Utiliza joystick de PlayStation para jugar cualquier juego con qjoypad

Imagen de Leandro Weisheim
0 puntos

Después de buscar y probar varias alternativas, como joy2key, encontré una utilidad, muy buena, llamada qjoypad, es totalmente configurable, y realmente muy fácil de utilizar e instalar.
Sólo tienes que descargar:

http://ufpr.dl.sourceforge.net/sourceforge/qjoypad/qjoypad-3.4.1.tgz

descomprímelo en tu directorio personal,

luego entras a la carpeta

cd qjoypad-3.4.1


cd src/

y ejecutas:

 ./config
make
make install

Después pruebas si no hay ningún error, y ejecutas

qjoypad

Y aparecerá un joystick en tu barra de tareas, das doble click en él y ya puedes configurar tu joystick, con las teclas del teclado o movimientos del mouse, que utilizas para jugar, y después lo minimizas, y entras a tu juego, y listo!. Bárbaro, también puedes abrir block de notas para probar si escribe las teclas que programaste, y después es cuestion de ponerse a configurar, porque puedes crear muchas configuraciones para cualquier juego en segundos,..

Para finalizar, crea un acceso directo en Sistema, Preferencias, Menú Principal, que aparezca en Aplicaciones, Juegos, que ejecute
/usr/local/bin/qjoypad
y como ícono,
/usr/local/share/pixmaps/qjoypad/gamepad4-64x64.png

Es bárbaro,,,

Imagen de Silveste
+1
0
-1

Lo único malo es que no está en los repositorios por que la verdad es que merece la pena.

En la página de descargas solo está disponible el deb para i386 y los que tenemos amd64 nos tenemos que resignar a compilarlo (espero que no por mucho tiempo). A continuación os pongo los problemas que yo tuve, por si le pasa a alguien:

Cuando ejecuté ./config me dio este error:
Line51: qmake: orden no encontrada
y luego no me dejaba hacer make.
Se soluciona instalando qt3-designer (y el resto de paquetes que también te instala)

sudo aptitude install qt3-designer

Al hacer make me devolvió otro error
/usr/bin/ld: can not find -lxtst
que se corrige instalando libxtst-dev

sudo aptitude install libxtst-dev

Y por fin!!
Ahora he conseguido jugar al Regnum Online con mi mando jeje
Muchas gracias por la noticia Leandro!!

+1
0
-1
Imagen de pandacriss
+1
0
-1

hola amigo
espero que tu cuenta siga activa
gracias por las pistas de las dependencias
las instale y pero aun me da un error

root@panda-desk:/home/panda/Downloads/qjoypad-3.4/src# make
g++ -c -pipe -g -Wall -W -O2 -D_REENTRANT -DDEVDIR='"/dev/input"' -DICON24='"/usr/local/share/pixmaps/qjoypad/icon24.png"' -DICON64='"/usr/local/share/pixmaps/qjoypad/icon64.png"' -DQT_NO_DEBUG -DQT_THREAD_SUPPORT -DQT_SHARED -DQT_TABLET_SUPPORT -I/usr/share/qt3/mkspecs/default -I. -I. -Itrayicon -I/usr/include/qt3 -o layout_edit.o layout_edit.cpp
In file included from trayicon/trayicon.h:25,
from layout.h:34,
from layout_edit.h:13,
from layout_edit.cpp:1:
/usr/include/qt3/qimage.h: In member function ‘bool QImageTextKeyLang::operator<(const QImageTextKeyLang&) const’:
/usr/include/qt3/qimage.h:61: warning: suggest parentheses around ‘&&’ within ‘||’
In file included from layout_edit.h:13,
from layout_edit.cpp:1:
layout.h: At global scope:
layout.h:93: error: ISO C++ forbids declaration of ‘LayoutEdit’ with no type
layout.h:93: error: expected ‘;’ before ‘*’ token
error.h:8: warning: ‘void error(QString, QString)’ defined but not used
make: *** [layout_edit.o] Error 1

debo instalar algo mas?
gracias

psd: ubuntu 10.04 64 bits
intento instalar qjoypad-3.4

+1
0
-1
Imagen de Leandro Weisheim
+1
0
-1

Es bueno que hayas mencionado posibles problemas de dependencias, que yo no tuve, porque seguramente ya las tenía instaladas.
A jugar con el joystick!!!

Abajo el imperialista Winbasura. Todos por Ubuntu linux!

+1
0
-1

Abajo el imperialista Winbasura. Todos por Ubuntu linux!