ASRock K8NF4G-SATA2

Según he leído, esta nueva placa base no esta soportada por el kernel 2.6.12 de Ubuntu 5.10 "The Breezy Badger".
Así que seguí los consejos del tio que decía esto e instalé la nueva versión de núcleo 2.6.14, según él sí soporta la ASRock K8NF4G-SATA2. Aunque parezca mentira conseguí configurar e instalar la nueva versión del kernel, pero ahora no se como especificar mi hardware. Dado que la placa base integra la LAN, Audio, i video... esto es que no funciona practicamente nada, consigo entrar en entorno gráfico porqué en xserver-xorg he especificado mi tarjeta de video como una vesa (que siempre funciona...)

No existe alguna forma en Ubuntu de especificar el hardware manualmente?
A alguien se le ocurre alguna solución?

nota: no importé mi antigua configuración del kernel.

Gracias de antemano!

Imagen de Anónimo
+1
0
-1

estoy tratando de probar linux con esta placa base, baje el DVD del kubuntu amd64. pero no puedo entar en kde con el live dvd. se queda en modo consola con un error que dice no screens found.

Quería probarlo primero desde el disco. he buscado solución por varios foros y dice que hay que actualizar los drivers o usar el modo vesa, pero ¿como hago para poner el modo vesa desde el live disk??

también me interesa mucho que ayuden al compañero de arriba porque cuando instale al disco duro de seguro tendré que hacer lo mismo que él, si pueden detallar los pasos les agradecería mucho y nos ayudarían a los dos.

Saludos

+1
0
-1
Imagen de Anónimo
+1
0
-1

ok ya lo hice el comando era sudo dpkg-reconfigure xserver-xorg

+1
0
-1
Imagen de Anónimo
+1
0
-1

vale ya lo tenemos en modo grafico pero no tengo ni red ni internet ni sonido tengo la misma placa, es la k8nf4-sata2, el problema es que tengo 16 equipos y ninguno ve internet.
gracias por vuestra ayuda de antemano

+1
0
-1
Imagen de fefos
+1
0
-1

ya lo tengo en modo grafico, aunque configurado como vesa, tengo red pero no tengo sonido, dice que no hay dispositivos de E/S he leido algo que hay que hacer con alsa pero todavia nada si alguien tiene alguna idea ahora es el momento...

bueno sigo probando

+1
0
-1
Imagen de fefos
+1
0
-1

la direccion es:
http://www.realtek.com.tw/downloads/dlhd-2.aspx?lineid=2004052&famid=200...(Linux)
bueno ahora solo hay que instalarlos jaja se que va con alsa pero hasta ahi
tambien he conseguido los drivers de video la direccion es :
http://www.nvidia.com/object/linux_display_amd64_1.0-8178.html
tambien hay que instalarlos; pero te lo cuentan aqui:
http://www.nvnews.net/vbulletin/showthread.php?s=fd1986e22d1de6e8f9e8b85...

si sigues los pasos, te dice que te tienes que salir del modo x y demomento no se como se hace
seguire contando mis avances...
bueno creo que ahora me voy a dormir que va siendo hora

+1
0
-1
Imagen de fefos
+1
0
-1

estoy pensando en escribir un libro ....
creo que lo llamare:
"edubuntu los drivers y su puta madre "

porque me tiene por instalar guindos y pasar de todo

+1
0
-1
Imagen de fefos
+1
0
-1

Con la ayuda de NeoRazorX y alo tengo configurado:

Para instalar linux en esta placa por ahora yo te recomiendo Ubuntu, pero si no te correo mucha prisa, casi que es mejor que te esperes al 1 de junio y poner directamente la Ubuntu 6.04, que tiene lo último de lo último ;-)

Si le quieres instalar Ubuntu 5.10, que es la que yo tengo, pues simplemente haces una instalación normal, de las de siguiente, siguiente, siguiente ... Nota: instala la versión de 32 bits, no la de 64, porque vas a echar en falta mucho software.

Una vez instalado ubuntu te dará error al iniciar el servidor X, esto es porque la GeForce 6100 es muy nueva y no estaba soportada en Ubuntu 5.10, pero si en la 6.04. Para solucionar esto le das a no, y te aparece una pantalla de login en texto. Pones tu login y contraseña y entonces escribes (sin el $):

$ sudo /etc/init.d/gdm stop
$ sudo nano /etc/X11/xorg.conf

Y te aparece un editor de texto muy sencillo. Buscas donde pone:
driver "nv"
Y lo sustituyes por:
driver "vesa"

Para guardar pulsa Ctrl+o y para salir Ctrl+x
Ahora ejecuta:

$ sudo /etc/init.d/gdm start

Y ya tienes modo gráfico. Actualiza la distribución y reinicia.
Ahora en abres un terminal (aplicaciones >> accesorios >> terminal) y ejecuta:

$ sudo gedit /etc/apt/sources.list

Te saldrá un editor de textos. Borra todo el texto y sustituye por este:

deb http://es.archive.ubuntu.com/ubuntu breezy main restricted
deb-src http://es.archive.ubuntu.com/ubuntu breezy main restricted
deb http://es.archive.ubuntu.com/ubuntu breezy-updates main restricted
deb-src http://es.archive.ubuntu.com/ubuntu breezy-updates main restricted
deb http://es.archive.ubuntu.com/ubuntu breezy universe multiverse
deb-src http://es.archive.ubuntu.com/ubuntu breezy universe multiverse
deb http://es.archive.ubuntu.com/ubuntu breezy-backports main restricted universe multiverse
deb-src http://es.archive.ubuntu.com/ubuntu breezy-backports main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu breezy-security main restricted
deb-src http://security.ubuntu.com/ubuntu breezy-security main restricted
deb http://security.ubuntu.com/ubuntu breezy-security universe multiverse
deb-src http://security.ubuntu.com/ubuntu breezy-security universe multiverse
# amarok
deb http://kubuntu.org/packages/amarok-1.3.8 breezy main
# extras
deb http://ubuntu-backports.mirrormax.net/ breezy-extras main restricted universe multiverse
# Opera
deb http://deb.opera.com/opera/ etch non-free
## plf primary repo
## http 100mbit/s mirror provided thanks to OVH http://ovh.com
deb http://packages.freecontrib.org/ubuntu/plf/ breezy free non-free
deb-src http://packages.freecontrib.org/ubuntu/plf/ breezy free non-free

Con estos repositorios de software tienes acceso a más de 18.000 paquetes :D

Guarda y cierra el editor. Ahora ejecuta:

$ sudo apt-get update

Esto actualizará tu lista de paquetes. Es posible que tarde un montón, porque hay un repositorio que se peta de vez en cuando. Si peta, pulsa Ctrl+c y vuelve a intentar. Y si no va de ninguna forma, borra las dos últimas lineas.

Ahora ejecuta:

$ sudo apt-get dist-upgrade

Esto te actualizará la distribución con los últimos repositorios. Luego reinicia.

Ahora toca instalar el software que necesitemos. Abre el synaptic (sistema >> administración >> gestor de paquetes synaptic).
- Busca "build" por nombre y selecciona el paquete "build-esential".
- Busca "gcc" y selecciona gcc 3.4.
- Busca "g++" y selecciona g++ 3.4.
- Busca "headers" y selecciona linux-headers ... 386.
- Busca "restricted" y selecciona con el botón derecho del raton "borrar completamente" todos los restricted modules que encuentres.
- Busca "linux" y selecciona linux-source y linux-sound-base.
- Busca "alsa" y selecciona alsa-base, alsamixergui, alsa-source y alsa-utils.

Ahora vamos a instalar los drivers de nvidia. Vamos a http://www.nvidia.com/object/unix.html y selecciona Linux IA32 y bajate el archivo .run

Copia el archivo a tu carpeta personal (no en el escritorio) y cierra la sesión (no vale apagar). Ahora pulsa Ctrl+Alt+F1 y te aparecerá una pantalla de login, logueate y ejecuta:

$ sudo /etc/init.d/gdm stop
$ export CC=gcc-3.4
$ sudo chmod +x NVIDIA-loquesea.run
$ sudo sh NVIDIA-loquesea.run

Te saldrá el instalador de nvidia, le das a aceptar, siguiente, siguiente, siguiente y luego te dirá si quieres que te modifique el archivo xorg.conf, le dices que si.

$ sudo reboot

Y ya tienes aceleración 3D. Notarás que al inicio sale un logo de nvidia ;-)

Ahora vamos a por el sonido. Bajamos el driver de http://www.realtek.com.tw/downloads/dlac97-2.aspx?lineid=5&famid=12&seri...
Te vas a la sección donde one linux y te bajas el archivo.

Ahora lo descomprimes en tu carpeta personal y hacemos lo mismo que antes. Cerramos la sesión, Ctrl+Alt+F1, nos logueamos y ejecutamos:

$ sudo /etc/init.d/gdm stop
$ export CC=gcc-3.4
$ cd realte-loquesea
$ sudo sh install

Lo dejamos que trabaje (tarda mucho) y luego nos sale un asistente que al final emite un sonido, porque ya tenemos sonido.

Ahora reiniciamos:

$ sudo reboot

Y ya tenemos Ubuntu listo.

http://s2.bitefight.es/c.php?uid=61709

+1
0
-1
Imagen de Anónimo
+1
0
-1

Yo tambien tengo es placa y mi problema es que no tengo red, lo he configurado manualmente por que asi es como tngo el router, y le pongo la direccion a pelo al eth0 yy le digo tb cual es la puerta de enlace, y nada que no va, le hago ping a la puerta de enlace y se me pierden los paquetes, no se ya lo que hacer, si alguien puede que me ayude. Gracias

+1
0
-1
Imagen de fefos
+1
0
-1

EN ADMINISTRACION-RED-DNS pon las DNS de tu provehedor de internet en telefonica me sirve 194.224.52.36 y 194.224.53.37 tienes q poner las dos y borrar la direccion del router aqui.

+1
0
-1
Imagen de Anónimo
+1
0
-1

Ya tengo todo el ubuntu instalado solo que ahora no se com hacer para que el sonido este en los 5 altavoces del 5.1 q tengo ya que de momento solo se escucha por el delantero derecho y el delantero izquierdo. Alguien me puede ayudar?

+1
0
-1
Imagen de Anónimo
+1
0
-1

Hola, saludos a todos.

Tengo el mismo modelo de Asrock K8NF4G-SATA2, estoy removiendo por todas partes, en busca de info para soporte de la placa en ubuntu 5.10 Breezy Badger pero nada. Solo queria preguntaros si teneis alguna novedad al respecto. No solo no funciona el video y sonido sino otros componenetes, con $lspci vereis que la mayoria de componentes son unknown hace falta soporte para toda la paca base,

Agradeceria postearais si hay alguna novedad.

Gracias anticipadas.

PD.Funciona lo del kernel 2.6.14?

+1
0
-1
Imagen de pow3r
+1
0
-1

Tengo la misma mother board, K8NF4G y estoy sin sonido en breezy, si alguien logra hacerlo funcionar que eche una mano.

+1
0
-1

pow3r

Imagen de orejasdetrapo
+1
0
-1

Te has mirado "La Gran Guia No Oficial De ubuntu" yo tampoco tenia sonido y lo solucione, no se como, pero lo solucione haciendo algo de esa guia.

+1
0
-1
Imagen de Anónimo
+1
0
-1

Yo uso SUSE 10.0
Mi problema con el audio lo solucioné con los drivers de NForce de la pagina de Nvidia, ahora va todo el sonido pero.... el único "error" es que en la configuración del sonido através del Yast no me sale la tarjeta.
Gracias Linux por ser tan desconocido y tratarnos como ignorantes...

+1
0
-1
Imagen de Anónimo
+1
0
-1

Pues otro que se apunta al club jeje... no pensaba yo que al comprar un nuevo pc me iva a topar con estos problemas en fin... mientras el esfuerzo sea para volver a tener el flamante Ubuntu en el pc. Mi pregunta es si la tarjeta ethernet esta soportada en Ubuntu 5.10, he visto que algunos de vosotros os funciona bien y en cambio hay otros que no conseguis conectar a internet como es mi caso. Agradeceiria mucho a los que les funcione la red que me explicaran como han conseguido utilizarla, si han hecho alguna modificacion en el sistema para que Ubuntu la detecte o en teoria ya la deberia detectar automaticamente? He leido en un foro externo que a un chaval le dejo de funcionar la tarjeta de red al actualizar la bios pero no se, yo no he actualizado la mia. He intentado buscar algo acerca de los drivers de Realtec que es el manufacturador de la tarjeta integrada y no he visto nada de nada, a ver si me podeis prestar una ayudita, gracias!

+1
0
-1
Imagen de Anónimo
+1
0
-1

Bueno pues parece que ya lo tengo solucionado. Ayer estube batallando para conseguir que me funcionara la red pero no hubo manera, configure la red para obtener la direccion dinamicamente ya que mi ISP funciona de ese modo y el DNS tambien me lo otorga automaticamente al darme la direccion IP. En cambio hoy, acabo de encender el Ubuntu y me he metido directamente en Firefox y cual ha sido la sorpresa? Taxan!!! Internet funcionando!! Apuntad otro caso mas de expediente X!! xD, no lo entiendo porque mira que revise veces y veces todas las configuraciones y la IP que me marcaba el "ifconfig" era la 127.0.0.1 que es la IP del propio host, cosa que todo apuntaba a que la tarjeta no funcionaba correctamente, de lo contrario en todo caso al haber establecido una IP por DHCP me tendria que haber asignado una direccion APIPA en el caso de no establecer comunicacion con el router o algo, por eso pense que era cosa de drivers. En fin, claramente Ubunutu 5.10 soporta esta ethernet integrada sin necesidad de drivers, a eso es donde quería llegar.

Saludos!

+1
0
-1