[SOLUCIONADO] Consultas sobre pasar de Hardy a Intrepid

Imagen de martincasc
0 puntos

Hola amigos, que tal? Quiero hacer una consulta antes de mandarme y arruinar todo lo que hice hasta ahora.

Resulta que me bajé el ISO alternate de Intrepid, y la verdad que me pica un poco el bichito para actualizar mi Hardy. El tema es el siguiente, uso Linux desde que salió Hardy. Ahora estando en casa de mis padres y en su PC, estoy logrando de apoco introducirlos en el mundo de Ubuntu, lamentablemente mi conexión de internet no es rápida, por ello, actualizarlo me llevó bastante tiempo, asi como también encontrar respuestas a pequeñas cosas hasta dejarlo lo más completo posible para las cosas que hacen ellos (aunque no soluciono lo de ver pps o escuchar el audio adjunto usando powerpoint viewer). Es por eso que estoy reacio a instalar la nueva versión de Ubuntu para no tener que empezar todo de nuevo, ya que si bien tengo todos los paquetes guardados, asumo que no son los mismos los paquetes de Hardy para Intrepid. Se que les choca un poco verme frente a la PC tanto tiempo y sobre todo porque tengo que preparar la ultima materia de mi carrera para febrero...

Es por eso que me surgió el siguiente interrogante, bueno, luego de bajar el ISO Alternate e introducirlo, me aparece la opción de actualizar. Lo que quisiera saber es: las consecuencias, o sea, se instala el nuevo SO borrando todo lo que tengo o simplemente actualiza los componentes, respetando themes, iconos, sonidos, programas tipo OpenOffice 3.0 (ya que II no lo trae?), Avant Windows navigator... en fin, la duda es como opera? como actualizador respetando los paquetes y configuraciones existentes o me instala el SO desde O; aclarando siempre, usando la opción que aparece insertando el CD con el ordenador encendido, cuando detecta el cd con paquetes y pregunta si deseo abrir el gestor de archivadores o bien Iniciar la Actualización.

Y lo segundo, he logrado que mi viejo se interese tanto en Ubuntu que me ha pedido que se lo instale en la PC de su oficina, el tiene un Dual Core (o Core 2 Duo, no recuerdo exactamente). Ahora, puedo instalar el Ubuntu que tengo en mi celeron y Pentium IV (el de 32 bits) o debo instalar el de 64 bits?. Si no entiendo mal, el Dual Core solo soporta 32 bits, no así el Core 2 Duo, el cual soporta 64 bits. Entonces la pregunta es: en un procesador como el Core 2 Duo, puedo instalar Ubuntu de 32 bits?

Resumiendo:

1º en mi Pentium IV tengo Hardy Heron 8.04.2 y me intriga actualizar a I.I., a ello apuntan las preguntas de la primera parte de mi post.

2º luego, en la PC de la oficina de mi padre, quiero instalar Ubuntu 8.10; puedo instalar Ubuntu de 32 bits? o si es un Core 2 Duo, debo si o si instalarle la versión de 64 bits?

3º y para terminar, una tercer y última pregunta: es tan notable la diferencia entre H.H. y I.I. como para realizar la actualización? o me conviene esperar a Jaunty con el nuevo Kernelaso que treaerá?

Muchas gracias amigos!!

Imagen de hugolino
+1
0
-1

La pregunta 2, podés instalar de 32bits, porque todos los procesadores tienen soporte de instrucciones de 32bits, no hay problema. Lo bueno es que con 32bits vas a tener mejor compatiblidad con todo.

La pregunta 3, te anda bien hardy? si te anda todo yo te recomiendo el refrán que dice que si anda, no lo arregles ;).

Podés probar Intrepid en modo LiveCD para ver si te reconoce todo el hardware antes de actualizar si querés hacerlo de todas formas.

+1
0
-1
Imagen de martincasc
+1
0
-1

hugolino, muchas gracias por tomarte el tiempo y responder... perfecto entonces, solucionado la pregunta 2, ahora, siendo así, es recomendable el de 32 bits siempre? en que difiere con el de 64 bits?

Respecto de la pregunta 3: he recibido el cd desktop original y lo he corrido, anda todo lo que normalmente se usa en una PC familiar, y me quedé encantado con las nuevas opciones... pero me sigue quedando inconclusa la primer pregunta, por lo menos para ir tomando más conocimiento sobre el asunto...

Muchas gracias!!!

+1
0
-1
Imagen de hugolino
+1
0
-1

La actualización simplemente actualiza paquetes pero mantiene todo lo que tengas configurado.

A veces puede traer problemas si instalaste vos por tu cuenta algo que tenga que trabajar directo con el kernel por medios que no sean synaptic (por ejemplo, los driver de placas nvidia bajados directo de la página oficial, tienen problemas al cambiar de kernel). De todas formas, al actualizar, luego en el grub te aparece para cargar el kernel anterior si el nuevo falla en algo (aunque con los demás paquetes actualizados), yo justamente hago eso, actualicé al a 8.10 pero me quedé con el kernel de la 8.04 por problemas con la webcam y la placa nvidia muy viejita.

Sobre lo de 32bits y 64bits, 64bits es mejor, es un tema de procesador. Un procesador de 64bits puede hacer cosas del doble de bits, por ejemplo.... no sé... una operación de dos números muy grandes (MUY) capaz en un procesador de 32bits se hace en dos pasos y en uno de 64bits (con SO de 64bits) en un paso solo, ganando velocidad. El tema es que esa velocidad no es el doble, porque no todo el tiempo necesita los 64bits del paso y con 32 le alcanzaría (me fui un poco por las ramas creo :P).

El problema de los 64bits es las incompatibilidades, por ejemplo, flash player de 64 bits recién está en estado alpha, wine de 64bits mucho menos que alpha, java de 64bits está andando bien creo, y la lista puede seguir. Yo te recomiendo, salvo que uses todos programas que sean compatibles con 64bits, que te quedes con 32bits.

Igual si vas a actualizar no podés pasar e 32 a 64 creo, vas a seguir en 32bits a menos que hagas una instalación limpia.

+1
0
-1
Imagen de martincasc
+1
0
-1

.. bueno,muchas gracias todo más que claro entonces... quizas me largo a hacer la actualización desde el CD alternate, supongo que me llevará unas horas porque tendrá que actualizarme los demás paquetes que tengo...

Respecto de los kerneles que tengo instalados puedo borrarlos y seguir tu consejo, dejando el ultimo que estoy usando ahora por cualquier cosa, pero no tengo nada raro instalado ni he hecho nada salvo el boockmarck applet y las librerias para hacer el easymenu para mi querido modmovil.com ;)

Y respecto de pasar de 32 bits a 64 bits, me quedó re claro... Sabía eso de que no puedo pasar de 32 a 64 actualizando, sino que quería saber si el Alternare 8.10 de 32 bits me servía para una arquitectura que soporta 64 bits, por el hecho de no tener que volver a dejar 8 hs la compu para descargar la versión 64bits...

Muchas gracias por la respuesta, muy completa y aclaradora... Marco este tema como SOLUCIONADO entonces!!

Gracias, un abrazo!

+1
0
-1