Pete tras upgrade parcial (¿se puede hacer 'downgrade'?)

Imagen de porras
0 puntos

Saludos a todos, os cuento qué tripa se le ha roto a dos de las ubuntus que tenemos en el curro:

Tenemos 7 wartys, que funcionan que te cagas, esa es la premisa 1.

Hay un programa (planner) que dos de los usuarios necesitan, y necesitan una feature que no está en la versión 0.11 (la que viene con warty) y sí en la 0.12 (la que viene con hoary).

Con todas las reservas, seguí las instrucciones que leí en varios sitios para mezclar dos ramas (este uno de ellos, creo, aunque no recuerdo el enlace), tanto particularizadas para Ubuntu como generales para Debian, a saber:

  • Añadir los sources de hoary al sources.list
  • Definir warty como release predeterminada en apt.conf
  • update
  • apt-get -t hoary install planner

De modo que se instaló la versión 0.12 de planner, y se actualizaron unos cuantos paquetes (unos 10) que ya estaban instalados pero en versiones anteriores. Tras unas cuantas pruebas, GNOME (los paquetes actualizados creo que pertenecían en su totalidad a GNOME y GTK) y planner funcionan bien.

Al reiniciar, el servidor X no arranca, en ninguno de los dos equipos. Dice que ya se está ejecutando otro servidor en ese vt (mentira). Me gustaría pudiérais darme alguna pista para, subsidiariamente:

  • Arreglar el fallo y que arranque correctamente
  • HAcer un downgrade y que todo vuelva a ser como antes (warty pelada, planner 0.11)
  • Averiguar qué paquetes se actualizaron y hacer el downgrade de forma manual

Gracias a todos, y felices reyes =;-)

Imagen de Lord_ZealoN
+1
0
-1

Si, como dices, es una warty pelada, yo creo que lo más rápido sería reinstalar, y ahorraras mucho tiempo.
---
Lord_ZealoN - El predicador | LU:#370919
Guía: http://guia-ubuntu.org/
FAQ: http://www.ubuntu-es.org/book/view/171
How-TO's http://www.ubuntu-es.org/book/view/103

+1
0
-1

---
Lord_ZealoN - El predicador | LU:#370919
Guía: http://guia-ubuntu.org/
FAQ: http://www.ubuntu-es.org/book/view/171
How-TO's http://www.ubuntu-es.org/book/view/103

Imagen de AlvaroBF
+1
0
-1

Nein!, el problema es del GDM no de las X (ocurre a menudo al mezclar hoary con warty) lo unico que debes hacer es instalarte el GDM de hoary (o instalarte otro XDM , KDM) no reinstales!

+1
0
-1