Solución al error de verificación de firmas GPG de Launchpad.

Imagen de jmpastor
0 puntos

Saludos:

En estos días si teneis agregado algún repositorio de la plataforma Launchpad a vuestra lista de Orígenes del software, seguramente os habreis encontrado con que desde hace poco tiempo devuelve errores de verificación de las llaves al actualizar la lista de paquetes.
Esto ocurre porque Launchpad está ofreciendo firmas únicas para cada PPA.

La solución a estos errores pasa sencillamente por acudir a la página de cada proyecto, descargar la clave del repositorio e importarla desde Origenes del Software en la pestaña de Autenticación.

Si tienes un repositorio de Launchpad agregado no es mucho trabajo descargar e importar la clave, pero si tienes unos cuantos se puede hacer un poco pesado. Como alternativa, el usuario blackgr en UbuntuForums ha publicado un pequeño script no oficial que descarga e instala todas las claves de los repositorios que tengas en tu lista.

En este caso, sólo hay que descargar el paquete ZIP (se requiere estar registrado en UbuntuForums para descargar adjuntos), descomprimirlo y ejecutar el script “launchpad-update“ desde el terminal:

$ sudo unzip launchpad-update-final.zip

Y lo ejecutamos de la siguiente manera:

$ sudo ./launchpad-update "intrepid" o "hardy", os dejará elegir la versión de Ubuntu.

O haciendo doble click sobre él.

--
Merchandlinux.
"Ser libre es gratis... Pero no siempre es posible."

Imagen de slap
+1
0
-1

+1
0
-1

Saludos.

0000 start out (+FD),A
           ld  BC, +7FFF
           jp 03CB, RAM-CHECK

http://www.injiniero.es

Imagen de jmpastor
+1
0
-1

Saludos:

Pido disculpas, no estaba seguro de donde tenía que ir, muchas gracias por aclararmelo para futuras aportaciones.

+1
0
-1
Imagen de tanchita
+1
0
-1

Hola! tengo un problema, he encontrado este script en diferentes post y todos me llevan a Ubuntuforums, mi problema es que no lo puedo descargar me dice que no tengo los permisos necesarios, me hice un usuario y todo y aun asi no me deja, me dice lo mismo de antes
que puede ser?

+1
0
-1
Imagen de juanherreros
+1
0
-1

Seguid este enlace, da la solución al error. A mí me ha servido:

"http://www.noticiasubuntu.com/ubuntu-9-10-karmic-koala-facilita-anadir-r..."

Sistema>administracion>Gestor de paquetes Synaptic>Repositorios>Otro software
añadimos lo que nos indica el post, refrescamos y eliminamos el origen similar pero antiguo (http://ppa.launchpad.net...) Podemos desmarcarlo para ver si funciona la sustitución. Si es así, debemos eliminarlo definitivamente. El repositorio correcto es:
http://ppa.launchpad.net/do-core/ppa-ubuntu karmic main.
Perdonad si este post es confuso pero es que soy novato en la materia y llevo toda la tarde intentando solucionar el bug mirando en diferentes foros.
Un saludo.

+1
0
-1
Imagen de interz
+1
0
-1

GRACIAS STALKER ES COMO LO MECIONANSTE... FUE MAS ENTENDIBLE PERO GRACIAS TAMBIEN A TODOS AQUELLOS QUE SE PRESTAN A DAR SOPORTE

+1
0
-1