Actualizacion a Catalyst 9.2. Faltan modos de pantalla. (Solucionado)

Imagen de CJMax
0 puntos

Hola. Hace unos días actualicé el driver propietario Catalyst de mi placa de video ATI Radeon HD 3200 (Integrada en chipset 780G) desde su versión 9.1 a la reciente 9.2. Pero para mi sorpresa, luego de desinstalar la version 9.1, reinstalar la 9.2 y reiniciar, faltaban algunos modos de pantalla como por ejemplo el de 1600x1200 (entre varios otros), que era el que estaba usando con la anterior versión. Luego volví a la versión 9.1, y efectivamente los modos de pantalla que habían desaparecido aparecían nuevamente y funcionaban. La máxima resolución que me permite alcanzar con el nuevo driver es de 1280x1024.

El monitor que estoy usando es el Samsung SyncMaster 796 MB, aunque no he logrado que Ubuntu me lo reconozca.

Si ingreso al Catalyst Control Center, tengo disponibles los siguientes modos de pantalla:

Con el driver 9.1:

320x200, 60 Hz
320x200, 75 Hz

320x240, 60 Hz
320x240, 75 Hz

400x300, 60 Hz
400x300, 75 Hz

512x384, 60 Hz
512x384, 75 Hz

640x400, 60 Hz
640x400, 75 Hz

640x480, 60 Hz
640x480, 72 Hz
640x480, 75 Hz
640x480, 85 Hz
640x480, 90 Hz
640x480, 100 Hz
640x480, 120 Hz
640x480, 160 Hz

720x480, 60 Hz

800x600, 56 Hz
800x600, 60 Hz
800x600, 70 Hz
800x600, 72 Hz
800x600, 75 Hz
800x600, 85 Hz
800x600, 90 Hz
800x600, 100 Hz
800x600, 120 Hz

1024x768, 43 Hz
1024x768, 60 Hz
1024x768, 70 Hz
1024x768, 72 Hz
1024x768, 75 HZ
1024x768, 85 Hz
1024x768, 90 Hz
1024x768, 100 Hz

1152x864, 43 Hz
1152x864, 47 Hz
1152x864, 60 Hz
1152x864, 70 Hz
1152x864, 75 Hz
1152x864, 85 Hz

1280x720, 60 Hz

1280x768, 60 Hz

1280x960, 60 HZ

1280x1024, 43 Hz
1280x1024, 47 Hz
1280x1024, 60 Hz
1280x1024, 70 Hz
1280x1024, 75 Hz

1400x1050, 60 Hz

1440x900, 60 Hz

1600x1200, 60 Hz

Con el driver 9.2:

320x200, 60 Hz
320x200, 75 Hz

320x240, 60 Hz
320x240, 75 Hz

400x300, 60 Hz
400x300, 75 Hz

512x384, 60 Hz
512x384, 75 Hz

640x400, 60 Hz
640x400, 75 Hz

640x480, 60 Hz
640x480, 72 Hz
640x480, 75 Hz
640x480, 85 Hz

720x480, 60 Hz

800x600, 56 Hz
800x600, 60 Hz
800x600, 72 Hz
800x600, 75 Hz
800x600, 85 Hz

1024x768, 60 Hz
1024x768, 70 Hz
1024x768, 75 HZ
1024x768, 85 Hz

1152x864, 60 Hz
1152x864, 75 Hz

1280x720, 60 Hz

1280x768, 60 Hz

1280x960, 60 HZ

1280x1024, 60 Hz
1280x1024, 75 Hz

Agrego además el contenido del archivo xorg.conf (el cual no ha cambiado en nada al actualizar la version del driver):


# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg
# commented out by update-manager, HAL is now used
#Section "InputDevice"
#	Identifier	"Generic Keyboard"
#	Driver		"kbd"
#	Option		"XkbRules"	"xorg"
#	Option		"XkbModel"	"pc105"
#	Option		"XkbLayout"	"latam"
#EndSection
# commented out by update-manager, HAL is now used
#Section "InputDevice"
#	Identifier	"Configured Mouse"
#	Driver		"mouse"
#	Option		"CorePointer"
#EndSection

Section "ServerLayout"
	Identifier     "Default Layout"
	Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Files"
EndSection

Section "Module"
	Load  "glx"
EndSection

Section "ServerFlags"
	Option	    "Xinerama" "off"
EndSection

Section "Monitor"
	Identifier   "aticonfig-Monitor[0]-0"
	Option	    "VendorName" "ATI Proprietary Driver"
	Option	    "ModelName" "Generic Autodetecting Monitor"
	Option	    "DPMS" "true"
EndSection

Section "Device"
	Identifier  "aticonfig-Device[0]-0"
	Driver      "fglrx"
	BusID       "PCI:1:5:0"
EndSection

Section "Screen"
	Identifier "aticonfig-Screen[0]-0"
	Device     "aticonfig-Device[0]-0"
	Monitor    "aticonfig-Monitor[0]-0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection

Es una lastima si no puedo recuperar los modos de pantalla desaparecidos, ya que se me hace un poco incómodo trabajar en las resoluciones que permite la nueva versión, y por eso reinstalé la 9.1. Además en la nueva versión se han arreglado algunos bugs como por ejemplo el funcionamiento de los videos a pantalla completa entre otros, y funcionan muy bien. Sería una pena desperdiciar estos drivers.

¿Alguien tiene idea de cual es la causa de que se pierdan estas resoluciones y/o como se pueden recuperar para poder trabajar con los drivers nuevos?

Saludos y muchas gracias

Imagen de CJMax
+1
0
-1

Ante todo disculpas, ya que gran parte de la solución estaba bastante tratada en el foro, sólo que no supe buscar bien.

Y algo que me había olvidado de aclarar. Estoy usando Intrepid.

La solución fue agregar unas líneas al xorg.conf. Ya había intentado algo de esto previamente, pero como no funcionó y sabía que el contenido del archivo no había cambiado luego de la actualización del driver, supuse que la solución no estaba por ese camino. El contenido del xorg.conf queda así:

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg
# commented out by update-manager, HAL is now used
#Section "InputDevice"
#	Identifier	"Generic Keyboard"
#	Driver		"kbd"
#	Option		"XkbRules"	"xorg"
#	Option		"XkbModel"	"pc105"
#	Option		"XkbLayout"	"latam"
#EndSection
# commented out by update-manager, HAL is now used
#Section "InputDevice"
#	Identifier	"Configured Mouse"
#	Driver		"mouse"
#	Option		"CorePointer"
#EndSection

Section "ServerLayout"
	Identifier     "Default Layout"
	Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Files"
EndSection

Section "Module"
	Load  "glx"
EndSection

Section "ServerFlags"
	Option	    "Xinerama" "off"
EndSection

Section "Monitor"
	Identifier   "aticonfig-Monitor[0]-0"
	Option	    "VendorName" "ATI Proprietary Driver"
	Option	    "ModelName" "Generic Autodetecting Monitor"
	Option	    "DPMS" "true"
	HorizSync    30 - 85         -------------------------------------------Agrego esto
      	VertRefresh   50.0 - 160.0   -------------------------------------------y esto
EndSection

Section "Device"
	Identifier  "aticonfig-Device[0]-0"
	Driver      "fglrx"
	BusID       "PCI:1:5:0"
EndSection

Section "Screen"
	Identifier "aticonfig-Screen[0]-0"
	Device     "aticonfig-Device[0]-0"
	Monitor    "aticonfig-Monitor[0]-0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
		Modes    "1600x1200"    ----------------------------------------y esto también
	EndSubSection
EndSection

Bueno, ya había intentado agregar la línea Modes en la sección "Screen" pero, como decía antes, no obtuve ningún resultado. Lo siguiente que intenté, después de leer bastante más :P, fué agregar las líneas de frecuencias horizontal y vertical (HorizSync y VertRefresh) en la sección "Monitor", pero aunque logré algo, además de las resoluciones que quería usar se habilitaban resoluciones muy altas que mi monitor no soportaba (mayores a 1600x1200. Tengo entendido que el monitor puede dañarse si se usan por mucho tiempo), y además algunas veces, aunque no siempre, aparecían algunas distorsiones raras en la imagen del monitor, así que volví a sacar las líneas. Después, y solo por probar, agregué nuevamente las líneas de sincronismo, y además también agregué la línea Modes en la sección "Screen" (ya había intentado esto por separado). Esa fue la solución. Solo aparecían los modos de pantalla que mi monitor soportaba, y además ya no se veían distorsiones.

Estuve leyendo bastante y no me queda claro de todas formas porqué con los drivers anteriores me tomaba todos los modos de pantalla sin tocar nada, y ahora tuve que modificar el xorg.conf para que funcione. Lo que alcanzo a entender es que se está dejando de usar el xorg.conf para pasar a automatizar la detección de hardware mediante el sistema HAL (que aparentemente también sería reemplazado en el futuro por otro sistema mejor).

Uffff.. :D...

Resumiendo entonces:
La solución fue editar el xorg.conf, que se encuentra en la dirección /etc/X11/ , y agregar en la sección "Monitor" las líneas HorizSync y VertRefresh con los valores de frecuencias correctos para mi monitor (que tomé del manual del mismo), y la línea Modes en la sección "Screen". Solo obtuve buenos resultados agregando las tres líneas juntas.

Bueno, espero que le sirva a alguien.

Ahora, con los nuevos drivers puedo ver vídeos a pantalla completa sin que se trabe!!!! , aunque desactivando el gestor de ventanas de compiz, pero bueno, antes ni así... ;). Saludos y suerte.

+1
0
-1