desactivé por error bus de comunicaciones en ubuntu 7.10 64 bit SOLUCIONADO

Imagen de hugokamm
0 puntos

por error en mi sistema ubuntu 7.10 64 bit desactivé en sistema-administracion-servicios el bus de comunicaciones (un cliqueo doble desafortunado)
cuando arranca da el siguiente mensaje en la sesión gráfica:
failed to initialize HAL
¿existe alguna forma de reparar el error sin reinstalar todo el sistema?
intenté sudo aptitude reinstall dbus pero no funcionó (claro no puede entrar en internet durante el proceso)
gksu services-admin no me permite entrar
¿hay algo que se pueda hacer?

en este momento puedo trabajar dentro de ubuntu en modo gráfico pero sin acceso a internet ni a las unidades ópticas (usb y lectograbadora cd/dvd) y desde mis máquinas virtuales windows sobre vmware la única forma de entrar o sacar datos es por la disquetera, por supuesto la red armada con samba a través del router no anda.

el sistema es:
ubuntu 7.10 kernel 2.6.22.14 generic 64 bit
procesador athlon 3000 64 bits
4 Gb memoria RAM
Placa GeForce 6200
Disco 250 Mb
Sistema de archivos
particion directorio formato tamaño
/dev/sda1 / ext3 38,7 Gb
/dev/sda3 /home ext3 148,1 Gb
/dev/sda6 /media/sda7 vfat 37,6 Gb

desde ya agradezco cualquier ayuda

Imagen de hugokamm
+1
0
-1

para poder seguir trabajando utilice un Live Cd ubuntu 7.1
luego de arrancado hice lo siguiente

1 - cargar todos los repositorios de synaptic posibles
2 - ejecutar reload dentro de synaptic
3 - instalar mc, el LIVE no lo trae y lo uso mucho
4 - en System/Administration/Network introducir el nombre del Workgroup
5 - en System/Administration/Shared Folders habilitar carpetas compartidas
para ello el sistema carga samba
6 - borrar /etc/samba/smb.conf y reemplazarlo por el que uso habitualmente, con cuidado de que la linea interface en la seccion Networking sea correcta
7 - instalar la impresora predeterminada

Tambien instale el Vmware server (que funciono) pero no pude abrir las maquinas virtuales que normalmente utilizo porque me dice que no tengo permisos

De esta forma los programas de linux los ejecuto en esta PC con el LIVE CD y lo que corre en windows en mi PC de reserva que accede a la carpeta compartida con samba por medio de la red a traves del router.
Ees una solucion de emergencia pero bueno, se hace lo que se puede.

estuve comparando /etc/init.d/ del sistema dañado y del LIVE y encontre que el LIVE tiene los siguientes archivos ejecutables que no estan en el otro.

ubiquity
portmap
nfs-kernel-server
nfs-common
casper

por las dudas los copie al init.d del sistema dañado y reinicie con este ultimo pero no tuve buen resultado.

Aguardo una mano salvadora

Saludos a todos

+1
0
-1
Imagen de hugokamm
+1
0
-1

El inconveniente quedó solucionado simplemente tecleando desde una terminal en modo texto:

$ sudo /etc/init.d/dbus restart

A continuación en modo gráfico
Sistema - Administracion - Servicios
y habilitar nuevamente el Bus de Comunicaciones.

Todo esto ha servido para aprender un montón de cosas acerca del sistema, metiéndome en init.d y viendo para que sirve cada cosa, investigar y finalmente llegar a la conclusión de cuál sería el comando a aplicar.

Utilizo el sistema desde hace un año pero soy un usuario final, no un estudioso del sistema ni cargo sistemas operativos sólo para ver cómo son y si alguno tiene ventaja sobre otro. Es decir, soy el objetico de los desvelos de las personas que crearon este sistema.
A ellos quiero darles gracias de todo corazón por haber creado este maravilloso sistema operativo que permite aún a personas como yo, que ya superaron los 60, entrar en el mundo del software libre y volver a tomar el control de la P C, casi perdido desde la epoca del D.O.S.

Asimismo a los que como yo recién comienzan, que ante un inconveniente tomen las cosas con calma y no reinstalen el sistema así como así, que Ubuntu cuando cierra una puerta en algún lugar abre una ventana.

+1
0
-1