CÓMO instalar el Java de Sun como un paquete .deb con java-package

Imagen de waju
0 puntos

Publicado en la dirección http://www.ubuntu-es.org/node/11311

---

Con esta receta vamos a poder instalar la versión de Java que queramos en nuestro sistema, empaquetándola en un paquete .deb, lo que la integrará completamente dentro del sistema y la hará utilizable por otras aplicaciones, además de permitirnos una instalación limpia y una actualización sencilla en el futuro.

Nota: Únicamente he probado la creación de paquetes con el Java de Sun.

El paquete .deb nos creará además los enlaces en los navegadores que tengamos instalados para que el plugin java esté habilitado en ellos.

Para conseguir esto realizaremos los siguientes pasos:

1º. Instalación del paquete java-package (y sus dependencias).

$ sudo apt-get install java-package

2º. Vamos a la dirección http://www.sun.com y nos bajamos la versión de Java que queramos. En mi caso he descargado la versión JRE 5.0 Update 6, la última versión disponible -en el momento de escribir esta receta- para usuarios finales (no desarrolladores).

3º. Nos situammos en la carpeta donde está la descarga y como usuarios limitados hacemos:

$ fakeroot make-jpkg instalador_de_java.bin

Con man make-jpkg podremos ver todas las opciones disponibles del programa.

Nota: El usuario limitado debe poder escribir en la carpeta donde esté el instalador de Java.

Esto nos crea un paquete deb con el Java especificado.

4º. Instalación del paquete.

$ sudo dpkg -i paquete_java.deb

En mi caso, el paquete deb se llama sun-j2re1.5_1.5.0+update06_i386.deb.

5º. Reinicia el navegador web y comprueba que Java está correctamente instalado visitando la dirección http://www.java.com/en/download/help/testvm.xml. Debajo de donde dice Test your JVM deberías ver la mascota de Sun bailando, junto a cuadro de con la información de tu versión de Java instalada.

Imagen de waju
+1
0
-1

Hola:

Yo antes utilizaba la versión de Java JRE 5.0 Update 2. Al ver la Update 6, descargué esa y borré la anterior. Despues de hacer muchas pruebas, puedo confirmar (hasta donde he podido averiguar) que la JRE 5.0 Update 6 funciona perfectamente en mozilla-firefox, mozilla, ¡pero no en Galeon!. Como Galeon es mi navegador por defecto, agradecería si alguien me pudiera indicar donde descargar la versión JRE 5.0 Update 2.

Gracias.

+1
0
-1