Problema en la DNS impide cargar google y gmail correctamente, en Ubuntu 8.04 y Ubuntu 8.10 [Solucionado]

Imagen de marietaubuntu
0 puntos

Hola amigos de Ubuntu-es:

Hace 4 días no he podido cargar las paginas de www.google.cl, www.google.com, www. google.es, etc ni gmail, y antes lo hacía sin problemas. En el mismo PC tengo una partición con Windows XP y carga correctamente esas páginas.

Publiqué unas preguntas (salió duplicado sin querer) en los foros de ubuntu-es, sección internet: http://www.ubuntu-es.org/index.php?q=node/113248 y http://www.ubuntu-es.org/index.php?q=node/113249 bajo los títulos "No puedo cargar www.google.com ni gmail en ubuntu Hardy Heron ni Intrepid Ibex" y "Problema al cargar google y gmail desde firefox en ubuntu (no en windows, en el mismo PC)"

Luego de pasar por varias reinstalaciones de navegadores, e incluso formatear mi partición de Ubuntu Hardy Heron 8.04 para reemplazarla por Ubuntu Intrepid Ibex 8.10 (por cuenta propia), ví un consejo del usuario jakgt, y anoté en la consola Terminal:

$ ping www.google.com

y la respuesta fue:

$ ping: unknown host www.google.com

Busqué en internet (por yahoo) la respuesta "unknown host www.google.com" y apareció el tema en el sitio de la comunidad de Ubuntu Sud África: https://lists.ubuntu.com/archives/ubuntu-za/2006-May/000282.html

Como recomendaba ese sitio, probé ingresando en el terminal lo siguiente:

$ ping 216.239.59.99 (que es la dirección de google.com)

y funcionaba, así que probé ingresando en Firefox y en Epiphany lo mismo:

http://216.239.59.99/

Y en ambos lee bien la página de inicio de www.google.com, pero no pasa de ahí y no muestra las páginas con resultados de las búsquedas ni gmail.

De acuerdo al foro del portal Ubuntu Sud África ya citado, es un problema de IP DNS.
En otro foro de ubuntu.es, titulado "problema al configurar IP estática en red wireless" (http://www.ubuntu-es.org/index.php?q=node/62464#comment_form) ví que el usuario Capa hablaba de un problema similar:

"Está clarísimo que es un problema de DNS.

Si con DHCP te funciona y con IP fija puedes acceder al router pero no a Internet, está claro que es un problema de DNS.

Configura tú IP fija.

Hazle un ping a 64.233.183.147 ( es de Google ), verás que tienes contestación.

Ahora hazle un ping a www.google.es , verás que no contesta.

O sea que no puede resolver los nombres de dominio, problema DNS.

Configura los DNS de tu servidor , o si no, pónle como DNS la IP de tu router ( 192.168.0.1 ).

Me cuentas... "

Como el foro es del año 2007 ni intenté preguntar, pero veo que probablemente en mi problema hay algo similar.

Buscando en la web por altavista encontré el siguiente vínculo

http://wiki.bandaancha.st/C%C3%B3mo_elegir_las_DNS#.C2.BFDebo_cambiar_la...

donde explican cómo cambiar la DNS. Transcribo:

"En Linux

1. Edita el archivo /etc/resolv.conf

vi /etc/resolv.conf

2. Tendrá un contenido similar al siguiente

nameserver 80.58.61.250
nameserver 80.58.61.254

3. Modifica las IP's que aparecen, o añade otras nuevas

4. Para que dichas IP's sigan vigentes tras reiniciar el sistema, edita el fichero /etc/dhcp3/dhclient.conf,
y añade al final la siguiente línea:

supersede domain-name-servers XX.XX.XX.XX, YY.YY.YY.YY;

donde XX.XX.XX.XX e YY.YY.YY.YY son, respectivamente, las IP's de las DNS primaria y secundaria deseadas.

5. Guarda el nuevo contenido de ambos ficheros.

6. Y por último, para que los cambios surtan efecto inmediatamente ejecutar en un terminal (con privilegios de
superusuario):

/etc/init.d/networking restart "

Pero no estoy segura de qué número poner en las nuevas IPs DNS primaria y secundaria deseadas, además ¿cómo entro como superusuario?

Hasta aquí llegaron mis conocimientos. ¿Alguien sabe qué más puedo hacer? ¿cómo configuro la DNS de mi servidor, o cómo pongo la DNS de la IP de mi router?

Atentamente

María Antonieta

Imagen de Gabriel_M
+1
0
-1

Hola mar...:

Utiliza los servidores de OpenDNS, para conocer el porque de la recomendación, busca en la red.

El procedimiento es el siguiente:

1. Pulsa el botón derecho del mouse en el icono de red en la barra superior a la derecha.

2. Elige editar las conexiones.

3. En la ventana emergente que se abre, titulada conexiones de red, ilumina tu conexión.

4. En la nueva ventana emergente, titulada Editando Auto etho, pulsa en la pestaña Ajustes de IPv4.

5. Dentro de Ajustes de IPv4, cambia en Metodo de Automatico (DHCP) a solo direcciones.

6. Pon en Servidores DNS Servers: 208.67.222.222, 208.67.220.220

7. Pulsa aplicar, y cierra todas las ventanas.

VII. Pulsa Aplicaciones - Accesorios - Terminal, en la consola que se abre ejecuta las ordenes, escribiendolas y dando enter a continuación.

     sudo cp /etc/resolv.conf /etc/resolv.conf.auto
     sudo gedit /etc/dhcp3/dhclient.conf

En el archivo que se abre coloca al final la siguiente línea:

    prepend domain-name-servers 208.67.222.222,208.67.220.220;

Guarda el archivo, cierra gedit y ejecuta en la consola:

    
     sudo ifdown eth0 && sudo ifup eth0 

9. Ve al sitio http://welcome.opendns.com para confirmar que tu ordenador esta funcionando con esas direcciones

Si tu tarjeta de red no es eth0, cambia eth0 por la que corresponde a tu tarjeta.
Saludos.
Gabriel.



Solo doy soporte para Ubuntu - 22 Mad Jaunty User.
+1
0
-1
Imagen de marietaubuntu
+1
0
-1

¡Muchísimas Gracias Gabriel !!

Has solucionado mi problema!

Realicé paso a paso tus indicaciones, y ahora puedo abrir sin problemas google y gmail desde ubuntu. ¡Estoy tan feliz!
Ahora publicaré tu respuesta con el crédito y el link respectivo en los 2 foros que había abierto, para que los usuarios que tenían mi mismo problema puedan solucionarlo también.

Genial!

Muchísimas gracias! No sé qué más decir, ¡eres fantástico!

María Antonieta

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

Hola mar...:

De nada y felicitaciones por el logro.

Los post ya estan cerrados porque al ser multiples de igual tenor, se incumplian las normas del foro. Tienen el link referencial hacia este post que permanece abierto.

Saludos.
Gabriel.


Solo doy soporte para Ubuntu - 6666 - Más malo que el diablo.
+1
0
-1
Imagen de marietaubuntu
+1
0
-1

Gracias!

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

Hola vik...:

La fuente que mencionas, Open DNS solo indica como establecer gráficamente la configuración del sistema para usar en Ubuntu OpenDNS, mediante los mecanismos usuales y habituales, propios de la distribución.

El post y los otros post se refieren a los problemas:

Problema en la DNS impide cargar google y gmail correctamente, en Ubuntu 8.04 y Ubuntu 8.10

No puedo cargar www.google.com ni gmail en ubuntu Hardy Heron ni Intrepid Ibex.

Problema al cargar google y gmail desde firefox en ubuntu (no en windows, en el mismo PC).

No es entonces OpenDNS quien en su página llegó a la conclusión, obtenida del minucioso estudio de todos los elementos brindados como partes integrantes de las dificultades planteadas, consistente en que:

Los problemas presentados por los usuarios, obedecian a que los servidores DNS por ellos utilizados
con el fin de traducir las URL que se escriben en la barra de direcciones de sus navegadores web
por la correspondiente IP del sitio, estaban funcionando en forma inadecuada y era conveniente 
cambiarlos por otros mas confiables, tales como los de OpenDNS o similares.

Tal conclusión, que fue redefinida y condensada, mediante la recomendación sugerida de usar los
DNS de OpenDNS, y que felizmente les permitió solucionar las dificultades presentadas, me pertenece, y son resultado de la combinación de inducción y deducción retroalimentadas, basadas en los conocimientos adquiridos a lo largo de mis casi 58 vueltas alrededor del sol.

Saludos.
Gabriel.



Solo doy soporte para Ubuntu - Es preferible callar y pasar por idiota, que hablar y demostrarlo.
+1
0
-1
Imagen de claudio2m
+1
0
-1

hola, esta solución es para el ethernet pero para el wifi?, a mi me pasa con la red de mi casa....

saludos

+1
0
-1
Imagen de marietaubuntu
+1
0
-1

Hola claudio2m!

Mi conexión también es wifi: basada en la conexión de cable del proveedor y mediante un router se distribuye la señal de forma inalámbrica a toda la casa.
A mí me resultó bién siguiendo paso a paso el consejo de Gabriel Muñoz, si tienes este mismo tipo de conexión te debería servir.

Saludos

María Antonieta

+1
0
-1
Imagen de marietaubuntu
+1
0
-1

Bueno, vikingo gal, respecto a la autoría, creo que Gabriel Muñoz tiene razón, es el único que al leer el post encontró la solución al problema de mi conexión y funciona perfecto, nadie más dió en el clavo, y la recomendación que dió en este foro sobre cómo usar OpenDNS para corregir el fallo de conexión es simple y eficaz, y estoy segura que salvará a muchos usuarios como yo.

Me recuerda a una historia que leí por ahí (no recuerdo la fuente en este momento, lo siento, así que lo busqué en google y como salía la misma historia contada de varias maneras en distintas partes, decidí colocar la primera que salió en el listado http://www.bgallardo.com/2006/03/25/el-tornillo-y-el-ingeniero-informatico/), que dice así: "es el caso del ingeniero que fue llamado a arreglar una computadora muy grande y extremadamente compleja, una computadora que valía 12 millones de euros. Sentado frente a la pantalla, oprimió unas cuantas teclas, asintió con la cabeza, murmuró algo para sí mismo y apagó el aparato. Procedió a
sacar un pequeño destornillador de su bolsillo y dio vuelta y media a un minúsculo tornillo. Entonces encendió de nuevo la computadora y comprobó que estaba trabajando perfectamente. El presidente de la compañía se mostró encantado y se ofreció a pagar la cuenta en el acto.
- ¿Cuánto le debo? -preguntó.
- Son mil euros, si me hace el favor.
- ¿Mil euros? ¿Mil euros por unos momentos de trabajo? ¿Mil euros por apretar un simple tornillito? ¡Ya sé que mi computadora cuesta 12 millones de euros, pero mil euros es una cantidad disparatada! La pagaré sólo si me manda una factura perfectamente detallada que la justifique.

El ingeniero asintió con la cabeza y se fue. A la mañana siguiente, el presidente recibió la factura, la leyó con cuidado, sacudió la cabeza y procedió a pagarla en el acto, sin chistar. La factura decía:

Servicios prestados:

Apretar un tornillo ------------- 1 euro
Saber qué tornillo apretar ------ 999 euros
Total = 1000 euros"

Ok

Saludos, y sigue adelante Gabriel Muñoz, ayudando a los que no sabemos qué tornillo apretar.

Atentamente

María Antonieta

+1
0
-1
Imagen de locovicen
+1
0
-1

hola yo con firefox en ubuntu 8.04.2 tengo el problema de que no me carga el correo electronico de gmail, pero google si que funciona perfetamente, incluso carga la pagina de gmail para introducir la contraseña, pero al introducirla y darle a aceptar no entra en mi correo electronico, solo vuelve aparecer la misma pagina de gmail para volver a introducir la contraseña, he probado con opera y gmail me funciona perfetamente, ¿Por que en firefox 3 no funciona y en opera si? hah y tengo flash instalado ya que me suena aver leido que sin flash no funciona gmail.

Lo que se dice en este foro es la solucion a mi problema?¿?

Gracias a todos

+1
0
-1
Imagen de josepzin
+1
0
-1

Puf... que estoy en mis primeros tiempos de Ubuntu, donde todo me resulta desconocido y por lo tanto mas complicado... pero ¡es que ni puedo entrar al Gmail!!! :(

Hice todos los pasos de arriba, voy a la página de OpenDNS me felicita, etc etc pero sigo sin poder entrar al Gmail...

EDITO: me dejé llevar por la desesperacion... acabo de borrar cookies y cache y ya todo funciona.

¿A que se debe que haya que hacer esto?

+1
0
-1

.: [url=http://www.josezanni.com]Diseño web multimedia 3D, José Zanni[/url] .:. [url=http://www.glest.org]Glest, juego RTS OpenSource[/url] .:. [url=http://www.josezanni.com/blog]Ungoliante Blog[/url] :.

Imagen de porquero
+1
0
-1

Hola amig@s

Bueno este bug es una molestia, pero creo que al configurar los dns, ubuntu agrega la IP de nuestro proveedor de internet y ahí empiezan nuestros problemas.

Bueno lo único que hice fue solamente dejar la ip 192.168.0.1 y quitar la otra; y para el otro archivo:
supersede domain-name-servers 192.168.0.1;

espero les sirva. no se mucho de redes pero me sirvió... ;)

+1
0
-1
Imagen de lopulus
+1
0
-1

Hola! yo tengo un problema similar. No abre gmail y si, por ejempo youtube (supongo mas pesada). yo tengo el modem claro 3g e160 y ubuntu 9.10.
Espero me puedan ayudar.

Gracias totales----

Lopulus

+1
0
-1

Lopulus