(SOLUCIONADO)No funciona la tarjeta ethernet intel pro 100 en mi portatil, controlador e100

Imagen de locovicen
0 puntos

Hola desde hace un tiempo ubuntu no puedo conectarme a internet através del cable rj45 y no entiendo porque, desde siempre me ha funcionado, hasta en el cd live de ubuntu 7.10 y el cd 8.04 lts ha dejado de funcionar ¿A que puede ser debido?

Esto es lo que sale al poner el comando lspci

lspci
00:00.0 Host bridge: Intel Corporation Mobile 945GME Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GME Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 01)
00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2 (rev 01)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 01)
00:1f.2 SATA controller: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA AHCI Controller (rev 01)
02:06.0 CardBus bridge: ENE Technology Inc CB1410 Cardbus Controller (rev 01)
02:08.0 Ethernet controller: Intel Corporation 82562ET/EZ/GT/GZ - PRO/100 VE (LOM) Ethernet Controller Mobile (rev 01)
10:00.0 Network controller: Broadcom Corporation BCM4311 802.11b/g WLAN (rev 01)

y esto al poner el comando ifconfig

ifconfig
eth0      Link encap:Ethernet  direcciónHW 00:1a:73:d8:78:8d  
          ARRIBA DIFUSIÓN MULTICAST  MTU:1500  Métrica:1
          RX packets:1392 errors:0 dropped:0 overruns:0 frame:14
          TX packets:1441 errors:6 dropped:0 overruns:0 carrier:0
          colisiones:0 txqueuelen:1000 
          RX bytes:1293360 (1.2 MB)  TX bytes:228133 (222.7 KB)
          Interrupción:17 

lo        Link encap:Bucle local  
          inet dirección:127.0.0.1  Máscara:255.0.0.0
          dirección inet6: ::1/128 Alcance:Anfitrión
          ARRIBA LOOPBACK CORRIENDO  MTU:16436  Métrica:1
          RX packets:1260 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1260 errors:0 dropped:0 overruns:0 carrier:0
          colisiones:0 txqueuelen:0 
          RX bytes:63000 (61.5 KB)  TX bytes:63000 (61.5 KB)

como se ve solo me reconoce la tarjeta wifi como eth0

Imagen de locovicen
+1
0
-1

Nadie sabe porque no me reconoce el ethernet?

+1
0
-1
Imagen de locovicen
+1
0
-1

a fecha de hoy sigue sin funcionarme con ubuntu 9.10

http://wificripter.blogspot.com/

+1
0
-1
Imagen de locovicen
+1
+1
-1

Buscando la encontre fuente: http://www.ubuntugeek.com/fix-for-intel-cards-with-broken-eeprom-e100-dr...

Por lo visto hay un fix con el controlador e100

Tan solo hay que escribir en el terminal:

sudo bash -c 'echo "options e100 eeprom_bad_csum_allow=1" >> /etc/modprobe.d/options'
sudo update-initramfs -u

y reiniciar el ordenador.

http://wificripter.blogspot.com/

+1
+1
-1
Imagen de locovicen
+1
+1
-1

El archivo "options" ha sido sustituido en las versiones más recientes del kernel, por un archivo de opciones con el nombre de cada componente y extensión .conf, con lo que para que funcione habría que hacer lo siguiente:

sudo bash -c 'echo "options e100 eeprom_bad_csum_allow=1" >> /etc/modprobe.d/e100.conf'
sudo update-initramfs -u

y como no, reiniciar el ordenador.

+1
+1
-1