Ayuda configuracion ATI

Imagen de Pikao
0 puntos

Buenas, tengo un amd64 3500 (64 bits) , ubuntu 64 instalado y una tarjeta grafica Radeon X700 SUPER de 512 megas.
Llevo tres dias mirando foros y aplicando soluciones, pero no he conseguido activar la aceleración.
Si instalo los drivers propietarios de ATI me da un error con las libSDL aunque ejecuta fglrxconfig.
Y si instalo xorg-driver-fglrx funciona , pero no tengo activada la aceleracion.
cuando ejecuto glxgears no sale nada:

X connection to :0.0 broken (explicit kill or server shutdown).

Encontre una pagina donde habia unos parches http://ati.cchtml.com/show_bug.cgi?id=198#c4
pero no se si no lo se aplicar bien o que pasa, que sigue sin activarse, hago todos los pasos, pero cuando dice luego instala todos los paquetes ¿que paquetes?

Bueno si alguien que lo ha conseguido , espero su ayuda, gracias.

Imagen de Anónimo
+1
0
-1

A mí me ha funcionado con:

1º) Desinstala todos los paquetes que hayas instalado en tus intentos fallidos (importante. Yo no lo hice en un principio y no me funcionó).

2º) Vete a wiki.ubuntu.com/BinaryDriverHowto/ATI

En cuatro pasos te lo explican, es una tontería de nada. Y a funcionar.

+1
0
-1
Imagen de Pikao
+1
0
-1

he seguido los pasos y nda. Pero es que hay varios cual segusite tu? ten en cuenta que yo tengo 64 bits, tu tienes 64? y la tarjeta es pci express

Podrias pasarme tu xserver.conf? gracias

+1
0
-1
Imagen de Orejapico
+1
0
-1

El correspondiente a la versión de Ubuntu que utilices. Yo usé el de Hoary, ya que es mi versión.

xserver.conf no tengo. Te paso el contenido de xorg.conf

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following commands:
#
# cp /etc/X11/xorg.conf /etc/X11/xorg.conf.custom
# sudo sh -c 'md5sum /etc/X11/xorg.conf >/var/lib/xfree86/xorg.conf.md5sum'
# sudo dpkg-reconfigure xserver-xorg

Section "Files"
FontPath "unix/:7100" # local font server
# if the local font server has problems, we can fall back on these
FontPath "/usr/lib/X11/fonts/misc"
FontPath "/usr/lib/X11/fonts/cyrillic"
FontPath "/usr/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/Type1"
FontPath "/usr/lib/X11/fonts/CID"
FontPath "/usr/lib/X11/fonts/100dpi"
FontPath "/usr/lib/X11/fonts/75dpi"
# paths to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
EndSection

Section "Module"
Load "bitmap"
Load "dbe"
Load "ddc"
Load "dri"
# Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "record"
Load "type1"
Load "vbe"
SubSection "extmod"
Option "omit XFree86-DGA"
EndSubsection
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "keyboard"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "es"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
EndSection
Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizScrollDelta" "0"
EndSection

Section "Device"
Identifier "ATI Technologies, Inc. Radeon Mobility 9600/9700 M10/M11 (RV350 NP)"
Driver "fglrx"
BusID "PCI:1:0:0"
EndSection

Section "Monitor"
Identifier "Monitor genérico"
Option "DPMS"
Modeline "1280x800@60" 83.91 1280 1312 1624 1656 800 816 824 841
EndSection

Section "Screen"
Identifier "Default Screen"
Device "ATI Technologies, Inc. Radeon Mobility 9600/9700 M10/M11 (RV350 NP)"
Monitor "Monitor genérico"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1280x800" "1024x768" "800x600" "640x480" "640x400"
EndSubSection
SubSection "Display"
Depth 4
Modes "1280x800" "1024x768" "800x600" "640x480" "640x400"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x800" "1024x768" "800x600" "640x480" "640x400"
EndSubSection
SubSection "Display"
Depth 15
Modes "1280x800" "1024x768" "800x600" "640x480" "640x400"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x800" "1024x768" "800x600" "640x480" "640x400"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x800" "1024x768" "800x600" "640x480" "640x400"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "Synaptics Touchpad"
EndSection

Section "DRI"
Mode 0666
EndSection

+1
0
-1

 

**************************************************************

-Si en la caja dice "Funciona en Windows XP o superior", ¿por qué no consigo arrancarlo en mi Ubuntu?