Interrupcion durante la actualizacion de gutsy a hardy

Imagen de fernandour
0 puntos

Hola,

Me sucedio eso que tanto advierten durante la actualizacion con do-release-upgrade.

Me encontraba actualizando mi ubuntu server de gutsy a hardy por ssh, baje todos los paquetes y luego comenzo a instalar.
En una de las ventanas de confirmacion me pregunto sobre el archivo de apache y por error me sali de la instalacion

Setting up apache2.2-common (2.2.8-1ubuntu0.5) ...

Configuration file `/etc/apache2/apache2.conf'
 ==> Modified (by you or by a script) since installation.
 ==> Package distributor has shipped an updated version.cd /hoe
   What would you like to do about it ?  Your options are:
    Y or I  : install the package maintainer's version
    N or O  : keep your currently-installed version
      D     : show the differences between the versions
      Z     : background this process to examine the situation
 The default action is to keep your current version.
*** apache2.conf (Y/I/N/O/D/Z) [default=N] ?

revise las diferencias ya que habia configurado apache hace poco, mientras estaba guardando los cambios me equivoque y me sali del proceos de instalacion.

He tratado de buscar en internet alguna forma de continuar con el proceso y no he encontrado como.

Tengo dos ubuntu servers dedicados y solo puedo acceder a ellos via ssh.
En el servidor que estoy tratando de continuar la actualizacion, es un server de produccion, con apache php perl mysql ftp y varios sitios web, ya tengo la mayor parte respaldado, y no quiero hacer nada mas en el servidor porque por el momento todo funciona aparentemente bien.

como puedo saber si el servidor quedo inestable o no? como puedo continuar con la instalacion? o como puedo saber que debo reparar a mano?

En el peor de los casos ya tengo un plan para mover los sitios a otro server, y reinstalar ubuntu server pero es bastante trabajo y problemas por que mover sitios implica mover dns eso siempre es complicado.

Por el momento el servidor no lo he reiniciado y no lo voy a hacer hasta que agote todas las posibilidades. apache php y mysql funciona bien y voy a probar otras cosas en las proximas horas :( ya vi que locate no funcionaba, me costo desinstalarlo pero despues de eso lo volvi a instalar y ahora funciona bien

Agradezco cualquier ayuda

este es el log de todo lo que habia hecho despues de descargar y desempaquetar los archivos

Setting up libc6-i686 (2.7-10ubuntu4) ...

Setting up update-inetd (4.27-0.6) ...

Setting up netbase (4.30ubuntu1) ...
Installing new version of config file /etc/protocols ...

Setting up libperl5.8 (5.8.8-12ubuntu0.4) ...

Setting up busybox-initramfs (1:1.1.3-5ubuntu12) ...
Setting up cpio (2.9-6ubuntu1) ...

Setting up libklibc (1.5.7-4ubuntu4) ...
Setting up klibc-utils (1.5.7-4ubuntu4) ...
Setting up module-init-tools (3.3-pre11-4ubuntu5.8.04.1) ...
Installing new version of config file /etc/modprobe.d/arch/i386 ...
Installing new version of config file /etc/modprobe.d/blacklist ...

Setting up libvolume-id0 (117-8ubuntu0.2) ...
Setting up procps (1:3.2.7-5ubuntu3) ...
Installing new version of config file /etc/sysctl.conf ...
 * Setting kernel variables...                                                  error: "vm.mmap_min_addr" is an unknown key
                                                                         [fail]

Setting up uuid-runtime (1.40.8-2ubuntu2) ...

Setting up ucf (3.005) ...

Setting up util-linux-locales (2.13.1-5ubuntu3) ...

Setting up libncursesw5 (5.6+20071124-1ubuntu2) ...

Setting up libssl0.9.8 (0.9.8g-4ubuntu3.5) ...
Checking for services that may need to be restarted...done.
Checking init scripts...
Nothing to restart.

Setting up libbz2-1.0 (1.0.4-2ubuntu4) ...

Setting up bzip2 (1.0.4-2ubuntu4) ...

Setting up libsqlite3-0 (3.4.2-2) ...

Setting up mime-support (3.39-1ubuntu1) ...
Installing new version of config file /etc/mime.types ...

Setting up python2.5 (2.5.2-2ubuntu4.1) ...

Setting up python (2.5.2-0ubuntu1) ...

Setting up ash (0.5.4-8ubuntu1.1) ...

Setting up initscripts (2.86.ds1-14.1ubuntu45.1) ...
Installing new version of config file /etc/init.d/checkfs.sh ...
Installing new version of config file /etc/init.d/checkroot.sh ...
Installing new version of config file /etc/init.d/mountkernfs.sh ...
Installing new version of config file /etc/init.d/mtab.sh ...
Installing new version of config file /etc/init.d/sendsigs ...
Installing new version of config file /etc/init.d/umountfs ...
Installing new version of config file /etc/init.d/umountroot ...
Installing new version of config file /etc/init.d/waitnfs.sh ...
Installing new version of config file /etc/network/if-up.d/mountnfs ...

Setting up upstart (0.3.9-2) ...

Setting up upstart-compat-sysv (0.3.9-2) ...
Installing new version of config file /etc/event.d/rcS-sulogin ...

Setting up upstart-logd (0.3.9-2) ...
Setting up libntfs-3g23 (1:1.2216-1ubuntu3) ...

Setting up ntfs-3g (1:1.2216-1ubuntu3) ...
update-initramfs: deferring update (trigger activated)

Setting up libxcb1 (1.1-1ubuntu1) ...

Setting up libxcb-xlib0 (1.1-1ubuntu1) ...

Setting up libmysqlclient15off (5.0.51a-3ubuntu5.4) ...

Setting up psmisc (22.6-1) ...

Setting up x11-common (1:7.3+10ubuntu10.2) ...
Installing new version of config file /etc/X11/Xsession ...
Installing new version of config file /etc/gdm/failsafeDexconf ...
Installing new version of config file /etc/gdm/failsafeXServer ...

Setting up python-central (0.6.7ubuntu0.1) ...

Setting up lsb-release (3.2-4ubuntu1) ...

Setting up apt-utils (0.7.9ubuntu17.2) ...

Setting up python-apt (0.7.4ubuntu7.5) ...

Setting up libsigc++-2.0-0c2a (2.0.17-2ubuntu3) ...

Setting up libcwidget3 (0.5.8-1ubuntu1) ...

Setting up aptitude (0.4.9-2ubuntu5) ...

Setting up libconsole (1:0.2.3dbs-65ubuntu7) ...

Setting up console-tools (1:0.2.3dbs-65ubuntu7) ...
update-initramfs: deferring update (trigger activated)

Setting up console-terminus (4.20-6) ...

Setting up xkb-data (1.1~cvs.20080104.1-1ubuntu8) ...
Setting up dhcp3-common (3.0.6.dfsg-1ubuntu9) ...
Setting up dhcp3-client (3.0.6.dfsg-1ubuntu9) ...

Setting up eject (2.1.5-6ubuntu1) ...
Setting up ethtool (6-0) ...
Setting up gettext-base (0.17-2ubuntu1) ...

Setting up gpgv (1.4.6-2ubuntu5) ...
Setting up libgpg-error0 (1.4-2ubuntu7) ...

Setting up libgcrypt11 (1.2.4-2ubuntu7) ...

Setting up libopencdk10 (0.6.6-1ubuntu1) ...

Setting up libtasn1-3 (1.1-1) ...

Setting up libgnutls13 (2.0.4-1ubuntu2.3) ...

Setting up libidn11 (1.1-1) ...

Setting up libkeyutils1 (1.2-4) ...

Setting up libkrb53 (1.6.dfsg.3~beta1-2ubuntu1.1) ...

Setting up libusb-0.1-4 (2:0.1.12-8) ...

Setting up iproute (20071016-2ubuntu2) ...
Setting up iputils-ping (3:20071127-1) ...
Setting up less (418-1) ...

Setting up libdbus-1-3 (1.1.20-1ubuntu3.2) ...

Setting up libfribidi0 (0.10.9-1) ...

Setting up libiw29 (29-1ubuntu2) ...

Setting up libnewt0.52 (0.52.2-11.2ubuntu1) ...

Setting up libsysfs2 (2.1.0-4) ...

Setting up net-tools (1.60-19ubuntu1) ...
Setting up netcat-traditional (1.10-36) ...

Setting up netcat (1.10-36) ...
Setting up pciutils (1:2.2.4-1.1ubuntu6) ...

Setting up belocs-locales-bin (2.4-2.2ubuntu7) ...
Setting up locales (2.7.9-4) ...
Installing new version of config file /etc/belocs/iso-639.def ...
Generating locales...
  en_US.UTF-8... done
Generation complete.

Setting up ntpdate (1:4.2.4p4+dfsg-3ubuntu2.1) ...
Installing new version of config file /etc/network/if-up.d/ntpdate ...

Setting up startup-tasks (0.3.9-2) ...
Setting up sudo (1.6.9p10-1ubuntu3.4) ...

Setting up system-services (0.3.9-2) ...
Installing new version of config file /etc/event.d/tty1 ...

Setting up usbutils (0.73-5ubuntu2) ...

Setting up libgpmg1 (1.19.6-25ubuntu1) ...

Setting up vim-common (1:7.1-138+1ubuntu3.1) ...

Setting up vim-runtime (1:7.1-138+1ubuntu3.1) ...
Processing /usr/share/vim/addons/doc

Setting up vim (1:7.1-138+1ubuntu3.1) ...

Setting up vim-tiny (1:7.1-138+1ubuntu3.1) ...

Setting up whiptail (0.52.2-11.2ubuntu1) ...
Setting up wireless-tools (29-1ubuntu2) ...
Setting up wpasupplicant (0.6.0+0.5.8-0ubuntu2) ...

Setting up apparmor (2.1+1075-0ubuntu9.2) ...
Installing new version of config file /etc/apparmor/rc.apparmor.functions ...
Installing new version of config file /etc/apparmor.d/abstractions/authentication ...
Installing new version of config file /etc/apparmor.d/abstractions/base ...
Installing new version of config file /etc/apparmor.d/abstractions/fonts ...
Installing new version of config file /etc/apparmor.d/abstractions/freedesktop.org ...
Installing new version of config file /etc/apparmor.d/abstractions/nameservice ...
Installing new version of config file /etc/apparmor.d/abstractions/python ...
Installing new version of config file /etc/init.d/apparmor ...
Loading AppArmor profiles  Skipping profile /etc/apparmor.d/usr.sbin.mysqld.dpkg-new
: Warning.
Reloading AppArmor profiles  Skipping profile /etc/apparmor.d/usr.sbin.mysqld.dpkg-new
: Warning.

Setting up bash-completion (20060301-3ubuntu3) ...
Installing new version of config file /etc/bash_completion ...

Setting up libisc35 (1:9.4.2.dfsg.P2-2ubuntu0.1) ...

Setting up libdns35 (1:9.4.2.dfsg.P2-2ubuntu0.1) ...

Setting up libisccc30 (1:9.4.2.dfsg.P2-2ubuntu0.1) ...

Setting up libisccfg30 (1:9.4.2.dfsg.P2-2ubuntu0.1) ...

Setting up libbind9-30 (1:9.4.2.dfsg.P2-2ubuntu0.1) ...

Setting up liblwres30 (1:9.4.2.dfsg.P2-2ubuntu0.1) ...

Setting up bind9-host (1:9.4.2.dfsg.P2-2ubuntu0.1) ...
Setting up cpp-4.2 (4.2.4-1ubuntu3) ...
Setting up cpp (4:4.2.3-1ubuntu6) ...

Setting up bsdmainutils (6.1.10ubuntu2) ...

Setting up command-not-found-data (0.2.17ubuntu1) ...
Setting up python-gdbm (2.5.2-0ubuntu2) ...
Setting up command-not-found (0.2.17ubuntu1) ...
Installing new version of config file /etc/zsh_command_not_found ...

Setting up cron (3.0pl1-100ubuntu2) ...
Installing new version of config file /etc/cron.daily/standard ...
 * Starting periodic command scheduler crond                             [ OK ]

Setting up dnsutils (1:9.4.2.dfsg.P2-2ubuntu0.1) ...

Setting up dosfstools (2.11-2.3ubuntu1) ...
Setting up ed (0.7-1ubuntu1) ...

Setting up libmagic1 (4.21-3ubuntu1) ...

Setting up file (4.21-3ubuntu1) ...
Setting up friendly-recovery (0.1.2) ...
Setting up groff-base (1.18.1.1-16) ...

Setting up hdparm (8.6-1ubuntu1) ...
Installing new version of config file /etc/udev/rules.d/85-hdparm.rules ...
 Removing any system startup links for /etc/init.d/hdparm ...

Setting up info (4.11.dfsg.1-4) ...

Setting up iptables (1.3.8.0debian1-1ubuntu2) ...

Setting up iputils-arping (3:20071127-1) ...
Setting up iputils-tracepath (3:20071127-1) ...

Setting up libisc32 (1:9.4.2-10ubuntu0.1) ...

Setting up libdns32 (1:9.4.2-10) ...

Setting up libedit2 (2.9.cvs.20050518-4) ...

Setting up libexpat1 (2.0.1-0ubuntu1) ...

Setting up libgc1c2 (1:6.8-1.1) ...

Setting up libparted1.7-1 (1.7.1-5.1ubuntu9.1) ...

Setting up libpcap0.8 (0.9.8-2) ...

Setting up logrotate (3.7.1-3ubuntu0.8.04) ...
Setting up lshw (02.12.01-2ubuntu1.1) ...
Setting up lsof (4.78.dfsg.1-3) ...
Setting up ltrace (0.5-3ubuntu1) ...
Installing new version of config file /etc/ltrace.conf ...
Setting up man-db (2.5.1-3) ...
Installing new version of config file /etc/manpath.config ...
Installing new version of config file /etc/cron.daily/man-db ...
Installing new version of config file /etc/cron.weekly/man-db ...

Setting up manpages (2.77-1) ...
Setting up mlocate (0.18-2ubuntu1) ...
Adding group `mlocate' (GID 117) ...
Done.

Setting up mtr-tiny (0.72-2ubuntu1) ...
Setting up nano (2.0.7-1ubuntu1) ...

Setting up libck-connector0 (0.2.3-3ubuntu5) ...

Setting up openssh-blacklist (0.1-1ubuntu0.8.04.1) ...
Setting up openssh-client (1:4.7p1-8ubuntu1.2) ...
Installing new version of config file /etc/ssh/ssh_config ...

Setting up openssh-server (1:4.7p1-8ubuntu1.2) ...
Installing new version of config file /etc/init.d/ssh ...
Installing new version of config file /etc/default/ssh ...
Creating SSH2 RSA key; this may take some time ...
Creating SSH2 DSA key; this may take some time ...
 * Restarting OpenBSD Secure Shell server sshd                           [ OK ]

Setting up parted (1.7.1-5.1ubuntu9.1) ...
Setting up popularity-contest (1.43ubuntu1) ...
Installing new version of config file /etc/cron.weekly/popularity-contest ...

Setting up pppoeconf (1.17ubuntu1) ...

Setting up python-support (0.7.5ubuntu1) ...

Setting up rsync (2.6.9-6ubuntu2) ...

Setting up strace (4.5.15-1.1ubuntu1) ...
Setting up tcpdump (3.9.8-2) ...
Setting up ufw (0.16.2.4) ...

Creating config file /etc/ufw/before.rules with new version

Creating config file /etc/ufw/before6.rules with new version

Creating config file /etc/ufw/after.rules with new version

Creating config file /etc/ufw/after6.rules with new version

Setting up ubuntu-standard (1.102) ...
Setting up update-manager-core (1:0.87.31) ...

Setting up linux-sound-base (1.0.16-0ubuntu4) ...

Setting up alsa-base (1.0.16-0ubuntu4) ...
Installing new version of config file /etc/modprobe.d/alsa-base ...
Installing new version of config file /etc/apm/scripts.d/alsa ...

Setting up libasound2 (1.0.15-3ubuntu4) ...
You may need to execute the asoundconf(1) set-default-card macro.

Setting up alsa-utils (1.0.15-3ubuntu2) ...
Installing new version of config file /etc/init.d/alsa-utils ...

Setting up libapr1 (1.2.11-1) ...

Setting up libpcre3 (7.4-1ubuntu2.1) ...

Setting up elinks-data (0.11.3-5ubuntu2) ...
Setting up liblua50 (5.0.3-3) ...

Setting up liblualib50 (5.0.3-3) ...

Setting up libruby1.8 (1.8.6.111-2ubuntu1.2) ...

Setting up elinks (0.11.3-5ubuntu2) ...
Installing new version of config file /etc/elinks/elinks.conf ...

Setting up libfreetype6 (2.3.5-1ubuntu4.8.04.2) ...

Setting up installation-report (2.31ubuntu1) ...

Setting up libxml2 (2.6.31.dfsg-2ubuntu1.3) ...

Setting up php5-common (5.2.4-2ubuntu5.6) ...
Installing new version of config file /etc/cron.d/php5 ...
Setting up php5-cli (5.2.4-2ubuntu5.6) ...
Replacing config file /etc/php5/cli/php.ini with new version

Setting up php5-mysql (5.2.4-2ubuntu5.6) ...

Setting up libpng12-0 (1.2.15~beta5-3ubuntu0.1) ...

Setting up libdb4.2 (4.2.52+dfsg-4) ...
Setting up libdb4.4 (4.4.20-11) ...
Setting up libdb4.5 (4.5.20-11) ...
Setting up libglib2.0-0 (2.16.6-0ubuntu1.1) ...

Setting up libltdl3 (1.5.26-1ubuntu1) ...

Setting up m4 (1.4.10-1) ...

Setting up mc (1:4.6.1-8ubuntu1) ...

Setting up rar (1:3.7.1-1) ...
Setting up screen (4.0.3-7ubuntu1) ...
Installing new version of config file /etc/screenrc ...

Setting up unzip (5.52-10ubuntu2) ...
Setting up nmap (4.53-3) ...

Setting up sendmail-cf (8.14.2-2build1) ...
Setting up libx11-data (2:1.1.3-1ubuntu2) ...
Setting up libx11-6 (2:1.1.3-1ubuntu2) ...

Setting up libxpm4 (1:3.5.7-1) ...

Setting up libt1-5 (5.1.1-5) ...

Setting up perl-modules (5.8.8-12ubuntu0.4) ...
Setting up perl (5.8.8-12ubuntu0.4) ...

Setting up libwww-perl (5.808-1) ...
Setting up udev (117-8ubuntu0.2) ...
Installing new version of config file /etc/udev/rules.d/05-options.rules ...
Installing new version of config file /etc/udev/rules.d/20-names.rules ...
Installing new version of config file /etc/udev/rules.d/40-permissions.rules ...
Installing new version of config file /etc/udev/rules.d/80-programs.rules ...
Installing new version of config file /etc/udev/rules.d/90-modprobe.rules ...
Installing new version of config file /etc/udev/rules.d/75-cd-aliases-generator.rules ...
Installing new version of config file /etc/udev/rules.d/75-persistent-net-generator.rules ...
Installing new version of config file /etc/init.d/udev ...
update-initramfs: deferring update (trigger activated)

Setting up initramfs-tools (0.85eubuntu39.3) ...
update-initramfs: deferring update (trigger activated)

Setting up grub (0.97-29ubuntu21.1) ...
Searching for GRUB installation directory ... found: /boot/grub
Searching for default file ... found: /boot/grub/default
Testing for an existing GRUB menu.lst file ... found: /boot/grub/menu.lst
Searching for splash image ... none found, skipping ...
Found kernel: /boot/vmlinuz-2.6.22-14-server
Found kernel: /boot/memtest86+.bin
Found kernel: /boot/vmlinuz-2.6.24-24-server
Found kernel: /boot/vmlinuz-2.6.22-14-server
Found kernel: /boot/memtest86+.bin
Replacing config file /var/run/grub/menu.lst with new version
Updating /boot/grub/menu.lst ... done


Setting up linux-image-2.6.24-24-server (2.6.24-24.53) ...
Running depmod.
update-initramfs: Generating /boot/initrd.img-2.6.24-24-server
Running postinst hook script /sbin/update-grub.
Searching for GRUB installation directory ... found: /boot/grub
Searching for default file ... found: /boot/grub/default
Testing for an existing GRUB menu.lst file ... found: /boot/grub/menu.lst
Searching for splash image ... none found, skipping ...
Found kernel: /boot/vmlinuz-2.6.24-24-server
Found kernel: /boot/vmlinuz-2.6.22-14-server
Found kernel: /boot/memtest86+.bin
Replacing config file /var/run/grub/menu.lst with new version
Updating /boot/grub/menu.lst ... done


Setting up linux-ubuntu-modules-2.6.24-24-server (2.6.24-24.39) ...
update-initramfs: Generating /boot/initrd.img-2.6.24-24-server

Setting up libdbi-perl (1.601-1) ...
Setting up libdbd-mysql-perl (4.005-1) ...
Setting up mysql-client-5.0 (5.0.51a-3ubuntu5.4) ...
Setting up mysql-server-5.0 (5.0.51a-3ubuntu5.4) ...
Installing new version of config file /etc/init.d/mysql-ndb-mgm ...
Installing new version of config file /etc/init.d/mysql-ndb ...
Installing new version of config file /etc/init.d/mysql ...
 * Stopping MySQL database server mysqld                                 [ OK ]
Reloading AppArmor profiles Warning: found /etc/apparmor.d/force-complain/usr.sbin.mysqld, forcing complain mode
/sbin/apparmor_parser: Unable to replace "/usr/sbin/mysqld".  Profile doesn't conform to protocol
 Profile /etc/apparmor.d/usr.sbin.mysqld failed to load
: Failed.
invoke-rc.d: initscript apparmor, action "force-reload" failed.
invoke-rc.d: release upgrade in progress, error is not fatal
 * Starting MySQL database server mysqld                                 [ OK ]
 * Checking for corrupt, not cleanly closed and upgrade needing tables.

Setting up mysql-server (5.0.51a-3ubuntu5.4) ...
Setting up console-setup (1.21ubuntu9) ...
Installing new version of config file /etc/init.d/keyboard-setup ...
Installing new version of config file /etc/init.d/console-setup ...
 * Setting up console font and keymap...                                 [ OK ]
update-initramfs: deferring update (trigger activated)

Setting up libsasl2-modules (2.1.22.dfsg1-18ubuntu2) ...
Setting up libsasl2-2 (2.1.22.dfsg1-18ubuntu2) ...

Setting up libldap-2.4-2 (2.4.9-0ubuntu0.8.04.2) ...
Installing new version of config file /etc/ldap/ldap.conf ...

Setting up libcurl3-gnutls (7.18.0-1ubuntu2.1) ...

Setting up gnupg (1.4.6-2ubuntu5) ...
Setting up klogd (1.5-1ubuntu1) ...
Installing new version of config file /etc/init.d/klogd ...
 * Stopping kernel log daemon...                                         [ OK ]
 * Starting kernel log daemon...                                         [ OK ]

Setting up sysklogd (1.5-1ubuntu1) ...
Installing new version of config file /etc/init.d/sysklogd ...
 * Stopping system log daemon...                                         [ OK ]
 * Starting system log daemon...                                         [ OK ]

Setting up pcmciautils (014-4ubuntu1) ...
Installing new version of config file /etc/init.d/pcmciautils ...

Setting up tasksel-data (2.70ubuntu6) ...
Setting up ubuntu-keyring (2008.03.04) ...
gpg: key 437D05B5: "Ubuntu Archive Automatic Signing Key " 17 new signatures
gpg: key FBB75451: "Ubuntu CD Image Automatic Signing Key " 14 new signatures
gpg: Total number processed: 2
gpg:         new signatures: 31
gpg: no ultimately trusted keys found

Setting up librpc-xml-perl (0.59-2) ...
Setting up apparmor-utils (2.1+1075-0ubuntu9.2) ...
Setting up libpq5 (8.3.7-0ubuntu8.04.1) ...

Setting up libaprutil1 (1.2.12+dfsg-3) ...

Setting up apache2-utils (2.2.8-1ubuntu0.5) ...
Setting up apache2.2-common (2.2.8-1ubuntu0.5) ...

Configuration file `/etc/apache2/apache2.conf'
 ==> Modified (by you or by a script) since installation.
 ==> Package distributor has shipped an updated version.
   What would you like to do about it ?  Your options are:
    Y or I  : install the package maintainer's version
    N or O  : keep your currently-installed version
      D     : show the differences between the versions
      Z     : background this process to examine the situation
 The default action is to keep your current version.
*** apache2.conf (Y/I/N/O/D/Z) [default=N] ? d