Actualizar el kernel de ubuntu 9.04 64 bits (solucionado).

Imagen de Milo Antares
0 puntos

Hola amigos mira estube leyendo y vi que ubuntu 9.04 no trae el kernel mas nuevo quisiera saver como actualizarlo al mas nuevo sin muchos rollos y que sea lo mas claro posible ya que me imagino que muchos queremos tener el kernel mas nuevo y no nos queremos esperar hasta la nueva version de ubuntu 9.10.

Si se que hay muchos tutoriales pero no les entieno muy bien y no hay muchos para 64 bits nose si cambie algo perdon por la ignorancia y espero que me ayuden, que tengan un buen dia.

Imagen de oneko
+1
0
-1

Aquí están las instrucciones para compilar un nuevo kernel:

https://help.ubuntu.com/community/Kernel/Compile

De todas formas no tiene sentido poner un kernel mas reciente a no ser que tengas lguún problema que no esté solucionado en la versión que viene con Jaunty.

+1
0
-1
Imagen de Milo Antares
+1
0
-1

Gracias por la ayuda y es para ver si este kernel detecta bien mi sony ericson c902 vale cuidate y que tengas una buena tarde bye.


Que tengan suertecita.
+1
0
-1

Que tengan suertecita.
Imagen de EnriqueK
+1
0
-1

En la siguiente página están disponibles kernels precompilados listos para instalar sin mas trámites, solo debes elegir la versión y descargar tres o cuatro archivos .deb , los pones a todos ellos dentro de una carpeta m abre un ternminal dentro de esa carpeta y pones sudo dpkg -i *.deb
http://kernel.ubuntu.com/~kernel-ppa/mainline/

+1
0
-1
Imagen de Milo Antares
+1
0
-1

Muchas gracias por la ayuda fue sencilla la solucion con esos kerneles precompilados creo que lo mas dificil fue dirigirme ala carpeta por terminal jajajaja, ok muchas gracias cuidence y que tengan buen dia bye.


Que tengan suertecita.
+1
0
-1

Que tengan suertecita.
Imagen de Alberto Aru
+1
0
-1

Hola, me he bajado la última versión, pero no da resultados

pili@pili:~$ cd /home/pili/Descargas
pili@pili:~/Descargas$ sudo dpkg -i *.deb
(Leyendo la base de datos ...
146421 ficheros y directorios instalados actualmente.)
Preparando para reemplazar kernelcheck 1.2.5+bzr20100416-1mlrepo1 (usando kernelcheck_1.2.5+bzr20100416-1mlrepo1_all.deb) ...
Desempaquetando el reemplazo de kernelcheck ...
Seleccionando el paquete linux-headers-3.7.0-030700rc4 previamente no seleccionado.
Desempaquetando linux-headers-3.7.0-030700rc4 (de linux-headers-3.7.0-030700rc4_3.7.0-030700rc4.201211041435_all.deb) ...
dpkg: error al procesar linux-headers-3.7.0-030700rc4-generic_3.7.0-030700rc4.201211041435_amd64.deb (--install):
la arquitectura del paquete (amd64) no corresponde con la del sistema (i386)
Seleccionando el paquete linux-headers-3.7.0-030700rc4-generic previamente no seleccionado.
Desempaquetando linux-headers-3.7.0-030700rc4-generic (de linux-headers-3.7.0-030700rc4-generic_3.7.0-030700rc4.201211041435_i386.deb) ...
Seleccionando el paquete linux-image-3.7.0-030700rc4-generic previamente no seleccionado.
Desempaquetando linux-image-3.7.0-030700rc4-generic (de linux-image-3.7.0-030700rc4-generic_3.7.0-030700rc4.201211041435_i386.deb) ...
Done.
Seleccionando el paquete linux-image-extra-3.7.0-030700rc4-generic previamente no seleccionado.
Desempaquetando linux-image-extra-3.7.0-030700rc4-generic (de linux-image-extra-3.7.0-030700rc4-generic_3.7.0-030700rc4.201211041435_i386.deb) ...
Configurando kernelcheck (1.2.5+bzr20100416-1mlrepo1) ...

Configurando linux-headers-3.7.0-030700rc4 (3.7.0-030700rc4.201211041435) ...
dpkg: problemas de dependencias impiden la configuración de linux-headers-3.7.0-030700rc4-generic:
linux-headers-3.7.0-030700rc4-generic depende de libc6 (>= 2.11); sin embargo:
La versión de `libc6' en el sistema es 2.9-4ubuntu6.
dpkg: error al procesar linux-headers-3.7.0-030700rc4-generic (--install):
problemas de dependencias - se deja sin configurar
Configurando linux-image-3.7.0-030700rc4-generic (3.7.0-030700rc4.201211041435) ...
Running depmod.
update-initramfs: Generating /boot/initrd.img-3.7.0-030700rc4-generic
Running postinst hook script /sbin/update-grub.
Searching for GRUB installation directory ... found: /boot/grub
Searching for default file ... found: /boot/grub/default
Testing for an existing GRUB menu.lst file ... found: /boot/grub/menu.lst
Searching for splash image ... none found, skipping ...
Ignoring Xen kernel on non-Xen host: vmlinuz-3.7.0-030700rc4-generic
Found kernel: /boot/vmlinuz-3.5.3-030503-generic
Found kernel: /boot/vmlinuz-2.6.38-020638-generic
Found kernel: /boot/vmlinuz-2.6.28-11-generic
Found kernel: /boot/memtest86+.bin
Updating /boot/grub/menu.lst ... done

Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/nvidia-common

Configurando linux-image-extra-3.7.0-030700rc4-generic (3.7.0-030700rc4.201211041435) ...
Running depmod.
update-initramfs: Generating /boot/initrd.img-3.7.0-030700rc4-generic
Running postinst hook script /sbin/update-grub.
Searching for GRUB installation directory ... found: /boot/grub
Searching for default file ... found: /boot/grub/default
Testing for an existing GRUB menu.lst file ... found: /boot/grub/menu.lst
Searching for splash image ... none found, skipping ...
Ignoring Xen kernel on non-Xen host: vmlinuz-3.7.0-030700rc4-generic
Found kernel: /boot/vmlinuz-3.5.3-030503-generic
Found kernel: /boot/vmlinuz-2.6.38-020638-generic
Found kernel: /boot/vmlinuz-2.6.28-11-generic
Found kernel: /boot/memtest86+.bin
Updating /boot/grub/menu.lst ... done

Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/nvidia-common

Procesando disparadores para man-db ...
Se encontraron errores al procesar:
linux-headers-3.7.0-030700rc4-generic_3.7.0-030700rc4.201211041435_amd64.deb
linux-headers-3.7.0-030700rc4-generic
pili@pili:~/Descargas$ uname -r
2.6.28-11-generic
pili@pili:~/Descargas$

¿qué hago?

+1
0
-1

~ Un viaje de mil leguas comienza con un paso. ~

Imagen de Gabriel_M
+1
+1
-1

... de Ubuntu tienes instalada?
Para Quantal solo funcionan hasta la 3.5.7
Para Precise solo funcionan hasta la 3.4

+1
+1
-1
Imagen de Alberto Aru
+1
0
-1

Creo que lo puse en el comentario anterior, es la 9.04

+1
0
-1

~ Un viaje de mil leguas comienza con un paso. ~

Imagen de Gabriel_M
+1
+1
-1

.. solo funciona hasta la 2.6.32.9

+1
+1
-1
Imagen de Alberto Aru
+1
0
-1

Aun así, debería dejarme actualizar el kernel a la 2.6.32 para actualizarlo a ubuntu 10.04 y ahí ir subiendo

¡Gracias por comentar!

+1
0
-1

~ Un viaje de mil leguas comienza con un paso. ~

Imagen de Gabriel_M
+1
+1
-1

... para actualizar a la 10.04 debes:
Abrir un terminal y editar el archivo sources.list, borrar su contenido y dejarlo con los repositorios de la 10.04, guardar el archivo, cerrar el editor y actualizar el sistema.

sudo su
nano /etc/apt/sources.list
deb http://old-releases.ubuntu.com/ubuntu/ lucid main restricted
deb http://old-releases.ubuntu.com/ubuntu/ lucid-updates main restricted
deb http://old-releases.ubuntu.com/ubuntu/ lucid universe
deb http://old-releases.ubuntu.com/ubuntu/ lucid-updates universe
deb http://old-releases.ubuntu.com/ubuntu/ lucid multiverse
deb http://old-releases.ubuntu.com/ubuntu/ lucid-updates multiverse
deb http://old-releases.ubuntu.com/ubuntu/ lucid-security main restricted
deb http://old-releases.ubuntu.com/ubuntu/ lucid-security universe
deb http://old-releases.ubuntu.com/ubuntu/ lucid-security multiverse

apt-get update
apt-get dist-upgrade
dpkg --configure -a
apt-get install -f
apt-get autoremove
apt-get clean
reboot

+1
+1
-1
Imagen de Alberto Aru
+1
0
-1

Lo he hecho, pero no pasa nada :\ Muchas gracias de todos modos

+1
0
-1

~ Un viaje de mil leguas comienza con un paso. ~