Error al instalar driver propietario de la Ati X1250

Lo primero, buanas a todos, y gracias por vuestro tiempo

Mi portátil es un Samsung R60 Plus, cuya gráfica, integrada en placa, es la Ati X1250.

Me instalé Ubuntu 9.04 (de 64 bits) hace un par de semanas, y aunque soy muy novato en todo esto de los repositorios, paquetes, y Linux en general, me las he arreglado para instalar compiz, y personalizarme un poco Gnome.

Bien, resulta que en el momento en que aparece algo en 3D en mi monitor, se nota una tremenda disminucion del rendimiento, por lo cual decidí irme a la pagina de ati a descargarme el driver para mi tarjeta.

Al bajármelo, me encuentro con un .run, extensión que yo no conocía, así que me fui al manual que la misma pagina de ati me proporcionaba.

Ahi me encuentro con que tengo que ejecutar estas líneas:

1 Launch the Terminal Application/Window and navigate to the ATI Proprietary
Linux driver download.
2 Enter the command sh ./ati-driver-installer-9.2-x86.x86_64.run to launch the
ATI Proprietary Linux driver installer.

En teoría, al ejecutar esa línea, debería saltar el instalador, pero...

cabanur@cabanur-laptop:~$ cd Escritorio

cabanur@cabanur-laptop:~/Escritorio$ ls
ati-driver-installer-9-3-x86.x86_64.run

cabanur@cabanur-laptop:~/Escritorio$ sh ./ati-driver-installer-9-3-x86.x86_64.run
Created directory fglrx-install.qXPnPz
Verifying archive integrity... All good.
Uncompressing ATI Proprietary Linux Driver-8.593..........................(muuuchos puntos) ......
==================================================
ATI Technologies Linux Driver Installer/Packager
==================================================

Error: ./default_policy.sh does not support version
default:v2:x86_64:lib32::none:2.6.28-13-generic; make sure that the version is being
correctly set by --iscurrentdistro

Removing temporary directory: fglrx-install.qXPnPz

cabanur@cabanur-laptop:~/Escritorio$

Y ahi se queda la cosa...

Lo más seguro es que sea cualquier tontería, pero el caso es que he mirado tanto en esta web como en google, y no encuentro nadie que tenga este mismo error (y mira que es dificil T.T)

Y ahora la pregunta del millón: Alguien sabe cómo puedo solucionar esto?

Gracias de verdad por la ayuda, espero algun dia saber lo suficiente como para devolver el favor ^^

Imagen de steev_666
+1
0
-1

Aguas por k eres novato y pro desgracia los drivers propietarios de ATI han dejado de funcionar, y si instalas kualkier version te kedara Administracion Controladores de hardware, y activa los drivers de la komunidad

se descarga instala, reinicia y listo

vas a Systema> preferencias > Apariencia y si kieres activas los efectos de escritorio.

Se supone ati iva a sakar kontroladores kada 3 meses para las series anteriores pero por el momento y segun revise la paguina no es asi, asi k solo keda esperar y aguantar hasta k salgan drivers nuevos.

es la opcion mas sencilla para k no tengas problemas, en dado kasi si aun asi prefieres buskar mas, adelante pero talvez se te vuelva algo komplikado si nunca has usado linux,

mientras los de la komunidad te trabajaran bien.

SALUDOS

+1
0
-1

MB: Asus Croshair Formula IV ROG

Mem: 4 Gb Kingston HiperX 2000 Mhz 9-9-9-24

Procesador: AMD 1090T BE @ 4.0 (en proceso de mas overclokeo :D)

T/Video: Ati All-In-Wonder x1900 256Mb @ (600CoreX1200Mem)

T/Sonido: Sb Audigy 2 ex +

Imagen de arturojota
+1
0
-1

steev_666, que forma de escribir tienes. Por favor vigila tu ortografia.

+1
0
-1
Imagen de Caballero de Nurgon
+1
0
-1

Aish... ya me dijeron que Ati y Linux no se llevan particularmente bien, en especial con las tarjetas integradas, pero que la misma compañía deje de dar soporte me parece ya demasiado.

En fin, habra que aguantarse con los Driver Propietario. Al menos ahora me funcionan, que cuando intenté instalar ubuntu 7.04 en este mismo portatil, jamás consegui arrancar el entorno gráfico.

En fin, muchas gracias ^^

+1
0
-1

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Mi filosofía es: El sexo no es pecado

Imagen de silveztre
+1
0
-1

Creo que lo puedes solucionar si antes de cargar el instalador del driver (la línea: sh ./ati.....) te conviertes en administrador, para ello usa:
"sudo su" y a continuación entra la clave de usuario.
Luego ya puedes lanzar el instalador de los drivers. Esta misma tarde lo he hecho yo y me ha funcionado.

Saludos,

+1
0
-1
Imagen de carlosubuntu904
+1
0
-1

hola a todos,

tengo el mismo problema al instalar los drivers en mi toshiba pro L300D que viene con dicha tarjeta de video Ati X1250, sr caballero si logras intalar los drivers pasa el dato.. yo sigo buscando info de lograrlo te informo. ya intente lo que comento el amigo silveztre pero por lo menos a mi no me dio resultado.. gracias igual por tu sugerencia

en el manual de instalacion dado por ati hace acotacion a esto:

Note: If a Linux 2.6.11 or newer kernel was built with CONFIG_AGP
enabled, the kernel AGP frontend is required to load the fglrx kernel
module. To identify whether your kernel was built with CONFIG_AGP
enabled, look for CONFIG_AGP=y in the kernel config file, or if the
'agpgart' module is loaded.

algun diestro en linux nos pueda dar una mano

Saludos

+1
0
-1
Imagen de Caballero de Nurgon
+1
0
-1

Ya lo intenté; antes de empezar nada ponia en la consola "sudo -s" y metía la contraseña, pero el resultado es el mismo. He probado "pa porsi" usando "sudo su" en vez de "sudo -s", pero nada T.T

Mira, a lo mejor los admins me llaman la atención, pero me cago en Ati. No me vuelvo a comprar una en la vida D:

Ya me repito, pero para estas cosas nunca está de mas: Gracias a todos, de verdad ^^

PD: ¿Soy el único al que le salen todos los mensajes de este hilo como en tachado?

+1
0
-1

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Mi filosofía es: El sexo no es pecado

Imagen de pinchulman
+1
0
-1

jeje! a mi también me aparece todo tachado... por ahi es esta placa tan complicada que tenemos xD (ati raedom x1250), yo tengo el mismísimo problema que "Caballero de Nurgon", me aparecen los mismos mensajes de error... o lo que sea

Error: ./default_policy.sh does not support version
default:v2:x86_64:lib32::none:2.6.28-13-generic; make sure that the version is being
correctly set by --iscurrentdistro

Removing temporary directory: fglrx-install.NXBFwS

ya borre todo lo que encontré con fglrx... y sigue igual o me falta borrar algo o no se que pasa

espero que laguien arregle esto...

barrilete cósmico!!! de que planeta viniste para dejar en el camino tanto inglés!!!

+1
0
-1

barrilete cósmico!!! de que planeta viniste para dejar en el camino tanto inglés!!!

Imagen de syswarp
+1
0
-1

Si bajaron el driver propietario primero hagan lo siguiente (como root o o sudo ):

./ati-driver-installer-9-3-x86.x86_64.run  --listpkg

Ese comando arroja la lista de drivers dentro del programa y deberan elegir el que les corresponda con su distro instalada.

Ej.

./ati-driver-installer-9-3-x86.x86_64.run  --buildpkg Ubuntu/jaunty

.... y ya esta.

+1
0
-1
Imagen de wizardmaster
+1
0
-1

ola amigo antes que nada cambiale el nombre a tu run x ejemplo controlador.run i pegas el ruin en una carpeta dentro de home x ejemplo yo
1abres termina
2 comando sudo su
3 cd /home
4cd /yo
5 sudo chmod a+x controlador.run
6 sudo ./controladro,run
7 sudo reboot
i asi se intalaria correctamente tu controlado.run
espero averte ayudado

+1
0
-1

^^!