No consigo ejecutar juegos 3D

Imagen de abmptc
0 puntos

Hola,

He instalado el juego: "Trigger Rally". Me descargue el paquete .deb, y lo instalé sin problemas.
Pero no consigo hacerlo funcionar:

a@a-desktop:~$ trigger
Trigger init
Build: 0.5.2 on Sep 6 2008 at 14:17:17
Initialising PhysFS
Set writable user directory to "/home/a/"
Reset writable user directory to "/home/a/.trigger"
Application base directory "/usr/games/"
Main game data directory datadir="/usr/share/trigger-data"
Loading game configuration
Initialising SDL
Create window and set video mode
Failed to create window or set video mode
SDL error: Couldn't find matching GLX visual
Try changing your video settings in data/trigger.config
a@a-desktop:~$

Tengo instalado Ubuntu 8.10, y mi tarjeta gráfica es: NVIDIA GeForce 9500 GS

He estado investigando en Internet, pero no he conseguido solucionar el problema. Algunas de las comprobaciones que he hecho:

En Sisteama; Administracion; Contrloadores de Hardware; He verificado que tengo correctamente instalada la última versión que me indica de mi tarjeta gráfica Nvidia (la 180).

a@a-desktop:~$ lspci
05:00.0 VGA compatible controller: nVidia Corporation Device 0644 (rev a1)

a@a-desktop:~$ glxgears
Xlib: extension "GLX" missing on display ":0.0".
Error: couldn't get an RGB, Double-buffered visual

a@a-desktop:~$ glxinfo|grep rendering
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual or fbconfig
Xlib: extension "GLX" missing on display ":0.0".

a@a-desktop:~$ cat /etc/X11/xorg.conf
Section "Monitor"
Identifier "Configured Monitor"
EndSection
Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
DefaultDepth 24
EndSection
Section "Module"
Load "glx"
EndSection
Section "Extensions"
Option "Composite" "Enable"
EndSection
Section "Device"
Identifier "Configured Video Device"
Option "AddARGBGLXVisuals" "true"
Option "RenderAccel" "true"
Option "AllowGLXWithComposi te" "true"
Driver "nvidia"
Option "NoLogo" "True"
EndSection

¿Se os ocurre donde puede estar el problema?

Muchas gracias de antemano y un saludo.
abmptc