No me deja instalar drivers nvidia 9800 gt (Cerrado por obsoleto)

Imagen de moloboo
0 puntos

Pues eso, intento instalarlos bien desde sistemas, administración, controladores de hardware, reinicio y nada, al intentar activar efectos visuales me responde que los controladores no están instalados.¿Alguna idea?

Imagen de catrip
+1
0
-1

Un control mucho mas "exacto" al momento de instalar drivers NVIDIA es mediante una herramienta llamada Envy.

Esta herramienta te muestra el mejor driver para tu tarjeta de video, instala todo lo necesario y activa por ti.

Si lo quieres instalar sigue esta guía:

1.- Abres terminal y escribes:

sudo apt-get install envyng-core 

(Si te pide instalar otros paquetes, acepta, ya que envy requiere otros paquetes adicionales para su funcionamiento)

Ahora, una vez instalado envy:

2.- En la misma terminal escribes esto:

envyng -t

Te pedirá tu contraseña.

Ahora te mostrará esta pantalla:

http://catrip.files.wordpress.com/2009/07/pantallazo-catripcatrip-laptop...

Si te das cuenta, la opción que tu deberás elegir es la "1", INSTALL THE NVIDIA DRIVER.

Después de seleccionar la opción 1, ahora envy te mostrará una pantalla como la siguiente donde te muestra los drivers disponibles y también te mostrará (mediante un signo +) el driver compatible y recomendado para tu tarjeta de video:

http://catrip.files.wordpress.com/2009/07/pantallazo-catripcatrip-laptop...

NOTA: Si te fijas en la imagen anterior, a mí me muestra que puedo instalar el driver 190 de NVIDIA, que es la mejor opción y es compatible, por lo tanto yo tendría que seleccionar la opción 0, pero si a tí te muestra que otra versión del driver de NVIDIA es la mejor opción y es compatible tu deberás seleccionar el número que le corresponda.

3.- Por último dejas que envy trabaje, descargue e instale el driver y por último te mostrará un mensaje de que debes reiniciar el equipo para que los cambios surtan efecto.

Espero que te sirva esta simple guía...

® Sé libre, sé tu mismo, usa Ubuntu

+1
0
-1
Imagen de clamide
+1
0
-1

Hola:
Acabo se seguir paso a paso tus intrucciones y me da el siguiente error. ¿Sabes qué puedo hacer? Hace tiempo que intento instalar los drivers de mi nvidia sin conseguirlo...

Se encontraron errores al procesar:
/var/cache/apt/archives/nvidia-glx-195_195.30-0ubuntu1~karmic~nvidiavdpauppa5_i386.deb
Traceback (most recent call last):
File "interface.py", line 432, in
a.mainMenu()
File "interface.py", line 295, in mainMenu
a.driverMenu('nvidia')
File "interface.py", line 333, in driverMenu
self.process(self.abstract.install, package)
File "interface.py", line 391, in process
myFunction(myArgs)
File "/usr/lib/python2.6/dist-packages/Envy/abstraction.py", line 155, in install
self.pkg.install(packages, self.widget)
File "/usr/lib/python2.6/dist-packages/Envy/packagemanager.py", line 164, in install
self.cache.commit(UiFetchProgress(widget, self.isText), UiInstallProgress(widget, self.isText))
File "/usr/lib/python2.6/dist-packages/apt/cache.py", line 318, in commit
raise SystemError("installArchives() failed")
SystemError: installArchives() failed

Gracias y un saludo.

+1
0
-1
Imagen de clamide
+1
0
-1

Tras una actualización que el sistema me ha pedido, por lo visto la configuración de la tarjeta gráfica ha vuelto a su estado más primario, esto es, sin los efectos del compiz (vamos que tengo el escritorio con unos iconazos tremendos, por poner sólo un ejemplo)
He tratado, pues de reinstalar los drivers de la nvidia con el envy y me da lo siguiente:

1
Traceback (most recent call last):
File "interface.py", line 432, in
a.mainMenu()
File "interface.py", line 295, in mainMenu
a.driverMenu('nvidia')
File "interface.py", line 322, in driverMenu
self.driverPage(driver)
File "interface.py", line 216, in driverPage
candidateLen.append(len(details['candidate']))
TypeError: object of type 'NoneType' has no len()

¿Sabes cómo puedo hacer para instalar de nuevo los drivers de la nvida (creo que me funcionaban los de la versión 185)?????

+1
0
-1
Imagen de ivanstron
+1
0
-1

muchas gracias che, me funciono perfecto

+1
0
-1
Imagen de jantonino40
+1
0
-1

Hola Catrip, ya habia usado esto del envy antes, con mi antiguo P.IV y una grafica AGP que tenía, ahora con la distro 9.10 me ha instalado la version 185.

Aunque la temperatura esta un poquito elevada (73º) me gustaria saber si se puede instalar los ultimos drivers de Nvidia, los 190 a ver si estos me permiten controlar la velocidad del ventilador de la grafica.

O quizas sabes de alguna aplicacion para hacer esto???

Gracias por tu atención

Un saludo

+1
0
-1

Ubuntu 9.10 - Gigabyte EP45-DS5 - C2Q 6600 2.4GHz - EN9800 GT

Imagen de catrip
+1
0
-1

Lo que puedes hacer es:

1.- Agregar el repositorio de controladores para tarjetas NVIDIA, solo abres terminal y escribes:

sudo add-apt-repository ppa:nvidia-vdpau/ppa

2.- Verás como se agrega el repositorio junto con su respectiva llave, ahora, en la misma terminal:

sudo apt-get update

Esto para que Ubuntu "vea" los paquetes de dicho repositorio

3.- A continuación instalas un archivo para que Ubuntu pueda reconocer el nuevo driver:

sudo apt-get install nvidia-190-modaliases

Esto se utiliza para que el driver puede ser "visto" desde la aplicación de Controladores de Hardware de Ubuntu.

Por último, ejecuta la aplicación de "Controladores de Hardware" (Sistema --> Administración --> Controladores de Hardware)

Y verás algo como esto:

Clic aquí para ver la imagen

En tu caso te debe mostrar algo similar.

Fíjate que tendrás activado el driver para la rama 185, por lo que deberás desactivarlo, reiniciar, volver a ejecutar la aplicación de Controladores de Hardware y ahora seleccionar el driver de la rama 190.

NOTA:

Es posible que algunas aplicaciones "no soporten" este nuevo driver y se desinstalarán, en mi caso se desinstalaron Amarok y K3B, por esa razón volví al driver 185.

® Sé libre, sé tu mismo, usa Ubuntu

+1
0
-1
Imagen de clamide
+1
0
-1

Hola:
Acabo de leer tus indicaciones porque estoy tratando de instalar los drivers de mi tarjeta gráfica (Nvidia)
Al principio el karmic me decía que tenía que activar el 185...pero no me ha dejado. He leído y hecho ya bastantes cosas como, por ejemplo, tratar de instalar la versión 190 pero tampoco me deja. El último error que me da es este:

W: Duplicate sources.list entry cdrom://Ubuntu 9.10 _Karmic Koala_ - Release i386 (20091028.5) karmic/main Packages (/var/lib/apt/lists/Ubuntu%209.10%20%5fKarmic%20Koala%5f%20-%20Release%20i386%20(20091028.5)_dists_karmic_main_binary-i386_Packages)
W: Duplicate sources.list entry cdrom://Ubuntu 9.10 _Karmic Koala_ - Release i386 (20091028.5) karmic/restricted Packages (/var/lib/apt/lists/Ubuntu%209.10%20%5fKarmic%20Koala%5f%20-%20Release%20i386%20(20091028.5)_dists_karmic_restricted_binary-i386_Packages)

Ya no sé qué hacer. ¿Tienes alguna idea, puedes echarme una mano con el asunto?
Gracias y saludos.

+1
0
-1
Imagen de ajavi3r
+1
0
-1

saludos...

tengo una tarjeta nvida geforce 9400 gt y he intentado lo siguiente:

1.- instalar el controlador "ejecutando la aplicación "controladores de Hardware" (sistema > administración > controladores de Hardware" y en efecto comenzó a descargar e instalar el controlador pero al cabo de mucho tiempo la descarga no avanza si no hasta aproximadamente el 50%

2.- por consola utilizando la herramienta "Envy" pero me da el siguiente error:

result could not be parsed
Error in function pulse
Traceback (most recent call last):
File "/usr/lib/python2.6/dist-packages/Envy/packagemanager.py", line 76, in pulse
self.newObject.updateUi(percent)
File "interface.py", line 65, in updateUi
numHashes = int(round(numHashes))
TypeError: an integer is required

3.- descargando el controlador por la pagina de Nvidia pero al momento de la descarga, esta se realiza en la misma ventada del firefox y descargando una serie de caracteres totalmente extraños y ni idea de lo que sucedió!!!

4.- la ultima sugerencia de "CATRIP" pero al ejecutar la aplicación de "controladores de hardware" me sucede lo mismo que la primera vez la descarga e instalación se detiene mas o menos avanzado el 50%

agradezco su ayuda!!!

saludos

+1
0
-1

Angel Javier Ballestero Contreras

IEEE Student Member

angel_ballestero@hotmail.com

Imagen de catrip
+1
0
-1

También tenía el mismo "problema" con la descarga de los drivers, pero, podemos acelerar la velocidad de conexión a Internet en Ubuntu, lo que vas a hacer es:

Abrir la terminal y escribir:

sudo gedit /etc/sysctl.conf

Y, al final del archivo que se abra, tu debes escribir (mejor copia y pega) lo siguiente:

net.ipv4.tcp_window_scaling = 0
net.ipv6.conf.all.disable_ipv6 = 1

Guardas los cambios en el archivo, y reinicias tu equipo, ahora notarás que la velocidad de descarga se incrementa de forma muy notoria, entonces vuele a intentar descargar los drivers...

® Sé libre, sé tu mismo, usa Ubuntu

+1
0
-1
Imagen de ptt28
+1
0
-1

Pues yo he probado de todo y no hay manera. despues de hacer una instalación limpia de ubuntu 9.10, probé la que me recomendaban en Controladores de Hardware de Ubuntu, (185) y despues de reiniciar sale el logo y pantalla negra. con envyng-core lo mismo, bajandome los drivers desde la web de nvidia, el último que hay dispnible (190), parando el gdm, me pasa lo mismo, pantalla negra. Al final lo estoy usando con el controlador básico que lleva ubuntu.

PD: Para bajar el driver desde la web de nvidia y no salga los carácteres esos, lo he hecho con firefox, es pulsar con el boton derecho del mouse sobre el botón de descarga del driver y elegir "guardar enlace como..." y eliges la carpeta donde quieras que se guarde.

Pd2: Acabo de cambiar el kernel, antes usaba el 2.6.33-19.21 y ahora la 2.6.33-20.33. reinicio, voy a a los recomendados de hardware de ubuntu y está la 195 y al descargar me da error. me da error con todas las recomendadas, 185, 190 y 195. uso envyng -t para descargar la 195, ya que en modo grafico tambien me da error, y la descarga y cuando está apunto de finalizar la instalacion, me da error en la linea 318 del cache.py

Podré, algun día instalar los drivers de nvidia? en el portatil tengo Ati y 0 problemas a la hora de instalar los controladores gráficos, pero en este, el de sobremesa, madre mía.

+1
0
-1
Imagen de crock
+1
0
-1

Hola, que tal, soy nuevo en este foro y como nuevo que soy no tengo ni idea de linux, y necesito ayuda para instalar mi tarjeta gráfica nvidia 9800 gt he intentando poner el comando para instalar en envy ese.

sudo apt-get install envyng-core

Y cuando lo pongo en la terminal dice lo siguiente:

circa@circa-P5QL-PRO:~$ sudo apt-get install envyng-core
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
E: No se ha podido localizar el paquete envyng-core

Estoy cabreadisimo no tengo huevos a instalar los drivers y tengo muchas ganas de hacer funcionar steam en ubuntu que me pide una versión de drivers superiores o iguales a los 310.

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

Este post es antiguo y completamente obsoleto. Se cierra.

+1
0
-1