¿¿¿Como reiniciar una red inalabrica con Ndiswrapper???

Imagen de firewall27
0 puntos

Hola a todos

Resulta que poseo 2 PC al lado de un router conectadas inalabricamente. Una de ellas con Ubuntu 8.4 y otra con windows xp

Como en ubuntu utilizo ndiswrapper para poder conectarme, a veces me sucede cuando estoy navegando que mi pc pierde completamente la conecteccion con el router, y es mas, no detecta ninguna red vecina, cuando en todo moment la pc con windows, sigue conectada y viendo a las demas redes, por lo tanto es un problema de ndiswrapper.Desde este momento en el que la pc ya no puede ver ninguna red inalabrica, por mas que haga mil millones de veces "iwlist wlan0 scan" me dice que no encuentra naaada y la unica solucion que tengo es reiniciar la PC y vengo a este foro para saber si hay alguna otra forma de "reiniciar" mi sistema inalabrico, sin necesidad de reiniciar todo mi s.o
Probe reiniciando el modulo con: modprobe -r ndiswrapper y modprobe ndiswrapper pero sigue igual.

Probe mil veces reiniciar el demonio de red (/etc/init.d/networking restart) pero no le hace ni cosquillas, es mas probe detener el demonio de red en un momento donde estaba navegando sin problemas y aunque le dije que lo finalize con un STOP seguia conectado miren:

gabriela@Gabriela-Ubuntu:~$ sudo su
[sudo] password for gabriela:
root@Gabriela-Ubuntu:/home/gabriela# /etc/init.d/networking stop
* Deconfiguring network interfaces... [ OK ]
root@Gabriela-Ubuntu:/home/gabriela# ping www.google.com
PING www.l.google.com (74.125.159.104) 56(84) bytes of data.
64 bytes from yi-in-f104.google.com (74.125.159.104): icmp_seq=1 ttl=49 time=162 ms
64 bytes from yi-in-f104.google.com (74.125.159.104): icmp_seq=2 ttl=50 time=196 ms

--- www.l.google.com ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 999ms
rtt min/avg/max/mdev = 162.175/179.397/196.619/17.222 ms
root@Gabriela-Ubuntu:/home/gabriela#

Alguna idea para no tener que seguir reinicianndo la PC???

ALGUNOS DATOS:

root@Gabriela-Ubuntu:/home/gabriela# lspci
00:00.0 Host bridge: Intel Corporation 82865G/PE/P DRAM Controller/Host-Hub Interface (rev 02)
00:01.0 PCI bridge: Intel Corporation 82865G/PE/P PCI to AGP Controller (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev c2)
00:1f.0 ISA bridge: Intel Corporation 82801EB/ER (ICH5/ICH5R) LPC Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801EB/ER (ICH5/ICH5R) IDE Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801EB/ER (ICH5/ICH5R) SMBus Controller (rev 02)
00:1f.5 Multimedia audio controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation NV34 [GeForce FX 5500] (rev a1)
02:05.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
02:09.0 SATA controller: Initio Corporation INI-1623 PCI SATA-II Controller (rev 02)
02:0a.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8185 IEEE 802.11a/b/g Wireless LAN Controller (rev 20)
root@Gabriela-Ubuntu:/home/gabriela# 
Imagen de firewall27
+1
0
-1

Porque me aparece eso de Navegador safari para Ubuntu si yo no lo puse!!!!

+1
0
-1