Libcupsys2 en Karmic, imposible instalar impresora

Imagen de tor-quemao
0 puntos

Buenas a todos.

Al grano. He instalado la beta de Karmic. Todo perfecto hasta que he probado a instalar los drivers de la impresora, una Canon lbp-1120. Su instalación necesita libcupsys2, por lo tanto, me da error. En los repositorios ya no aparece, sí lo hacía en los de Jaunty.

He intentado bajar el paquete de Debian, sin embargo, al intentar instalarlo me dice que existe incompatibilidad entre este paquete y libcups2, que sí está instalado y que sí aparece en los repositorios...

Si alguien tiene alguna idea para solucionar esto, me hará un gran favor. Si no, hasta aquí ha llegado la impresora o hasta Jaunty ha llegado Ubuntu.

Gracias.

Imagen de JhonQ
+1
0
-1

¿Has probado a crear un enlace simbólico (ln -s libcup....) antes de instalar los manejadores de la impresora?

+1
0
-1
Imagen de tor-quemao
+1
0
-1

Gracias por la respuesta pero, bueno, la solución era más simple. Hay que bajar el paquete antiguo desde los repositorios de debian e instalarlo a capón.

Aquí dejo el enlace por si a alguien le viene bien.

http://packages.debian.org/es/etch/libcupsys2

+1
0
-1
Imagen de mismatso
+1
0
-1

Amigo tor-quemao, tengo el mismo problema, pero no entiendo como fue que usted lo soluciono, no entiendo eso de instalarlo a capón.

Me seria de mucha ayuda si usted puede ampliar la información de como consiguió instalar ese paquete viejo sin que le de el problema de los conflictos entre libcupsys2 (viejo) y el libcups2 (nuevo).

De antemano muchas gracias!

+1
0
-1
Imagen de mismatso
+1
0
-1

Ya encontré una forma más limpia de solucionar el problema que me encontraba al tratar de instalar una impresora canon.

Al instalar el driver que se baja desde el sitio oficial, se truncaba la instalación por dependencias rotas, faltaba libcupsys2 que ahora en Karmic es libcups2, busque un paquete de transición para Karmic Koala pero no lo encontré. Sin embargo en un foro en inglés me encontré que alguien había probado con el paquete de transición para Jaunty, lo probé, y efectivamente funciona en Karmic.

Aquí les dejo el vinculo para descargar este paquete de transición: libcupsys2

Luego de instalarlo, se podrá instalar los drivers que tenían dependencia con libcupsys2.

Nota: No indiqué el modelo exacto de la Impresora Canon porque no es relevante, esta solución vale para cualquier impresora cuyo driver dependa de libcupsys2.

+1
0
-1
Imagen de tor-quemao
+1
0
-1

Perdón por no haber contestado antes y perdón por utilizar la expresión coloquial. Si, exactamente, se trata de bajar desde la dirección que puse antes, el repositorio de debian:

http://packages.debian.org/es/etch/libcupsys2

El paquete libcupsys2. Es un paquete .deb con lo cual, una vez descargado basta con pulsar sobre él para que se instale automáticamente.

Ahora no recuerdo, pero cuando he instalado en el PC de sobremesa Karmic, además de libcupsys2, los drivers de la impresora me decían que faltaba otro paquete. Lo solucioné de la misma forma. Entrando en la página del repositorio de debian, buscando el paquete en cuestión e instalándolo. Hecho esto ya se pueden instalar los drivers de la impresora sin problemas.

+1
0
-1
Imagen de juan juan
+1
0
-1

Hola, tengo el mismo problema y he podido descargarme el libcupsys2 pero no me deja instalarlo, me dice lo siguiente:

Error: rompe el paquete existente "libcups2
conflicto: libcupsys2

Eso es porque Ubuntu 9.10 utiliza el libcups2 en lugar del libcupsys2 ¿como puedo solucionarlo?

+1
0
-1
Imagen de tor-quemao
+1
0
-1

Yo lo instalé sin problemas pero desde entonces volví a Jaunty porque con Karmic soy víctima de un bug con el rsyslog que más que bug es un "bujero". Parece ser con el rsyslog se ha solucionado o está a punto y en cuanto pueda volver a usarlo te diré se me pasa lo mismo o si encuentro alguna solución.

La verdad es que esta versión (Karmic) se está poniendo muy cargante. Me siento bastante defraudado con ella. Otra cosa que tampoco funciona y hay que recurrir a una versión antigua es gscan, aunque esto supongo que no es problema de Ubuntu, sino de la aplicación. En fin, paciencia.

+1
0
-1
Imagen de tor-quemao
+1
0
-1

Utilizando el driver CAPTDRV180.tar.gz es necesario tener instalados antes los siguientes paquetes que ya no aparecen en los repositorios de Karmic:

gcc-3.3-base_3.3.6-15_i386.deb

libstdc++5_3.3.6-15_i386.deb

libcupsys2_1.3.9-17ubuntu3.1_all.deb

Lo que no he tenido ningún problema es para instalar libcupsys 2, al menos en esa versión. No me ha dado ningún conflicto con libcups2 y no tengo la menor idea de por que a juan juan, no le permite la instalación. Lo siento.

+1
0
-1
Imagen de googolplex
+1
0
-1

Jóvenes yo tengo el mismo problema pero no he podido instalar el libcupsys2 abri un terminal y puse sudo apt-get install libcupsys2 y me tiró lo siguiente

tux00@tux00-desktop:~$ sudo apt-get install libcupsys2
[sudo] password for tux00:
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
El paquete libcupsys2 es un paquete virtual provisto por:
libcups2 1.4.1-5ubuntu2.1
Necesita seleccionar explícitamente uno para instalar.

pero no se cual es el que tengo que seleccionar o como se selecciona
disculpen si es muy básica la pregunta pero estoy comenzando en linux

Desde Guatemala apoyando un mundo y software libre

+1
0
-1

Desde Guatemala apoyando un mundo y software libre

Imagen de tor-quemao
+1
0
-1

No sé, yo he instalado sin problemas los tres paquetes del mensaje anterior con gdebi.

Asegurate que estás bajando el paquete correcto y la versión correcta. Hazlo desde esta dirección:

http://packages.debian.org/es/etch/libcupsys2

Y además comprueba que el paquete que descargas es este:

libcupsys2_1.3.9-17ubuntu3.1_all.deb

+1
0
-1
Imagen de googolplex
+1
0
-1

Gracias por tu respuesta pero si intente descargar el paquete de ésta página pero cuando lo voy a instalar me da el siguiente error

Error: Rompe el paquete existente 'libcups2' conflicto: libcupsys2 (< 1.3.7-6)

si alguien se le ocurre que puedo estar haciendo mal se los agradecería mi máquina es una Core 2 Duo 2.8 ghz y me baje el paquete i386 así que el paquete está bien pero talvez la versión no
Gracias

Desde Guatemala apoyando un mundo y software libre

+1
0
-1

Desde Guatemala apoyando un mundo y software libre

Imagen de googolplex
+1
0
-1

Gracias por tu respuesta pero ya había intentado traté de instalarlo desde la página y me descargué el paquete arquitectura i386 pues es el que me corresponde (tengo un core 2 duo 2.8 ghz) y me dice lo siguiente
Error: Rompe el paquete existente 'libcups2' conflicto: libcupsys2 (< 1.3.7-6)
si alguien sabe que estoy haciendo mal o ideas para solucionarlo les agradeceré, pues parece que el paquete actual libcups2 no deja instalar el anterior

Desde Guatemala apoyando un mundo y software libre

+1
0
-1

Desde Guatemala apoyando un mundo y software libre

Imagen de tor-quemao
+1
0
-1

A lo mejor estoy diciendo una tontería mayúscula pero prueba a ver qué pasa si desinstalas libcups2 e instalas en su lugar libcupsys2. Otra cosa no se me ocurre. Yo instalé sin problemas esos paquetes y tengo la impresora funcionando, eso sí, con el molesto inconveniente de tener que ejecutar $ sudo /etc/init.d/ccpd start cada vez que la enciendo.

+1
0
-1
Imagen de googolplex
+1
0
-1

No pude instalarla porque al querer instalar el paquete libcupsys2 me decía que hay un conflicto con el paquete libcups2 un compañero mío logró instalar los paquetes a mano y por fin logre hacer funcionar la impresora pero en una actualización que hice ya no pude seguir utilizándola ahora me aparece una advertencia cups-missing filter y ya no la he podido volver a usar

Desde Guatemala apoyando un mundo y software libre

+1
0
-1

Desde Guatemala apoyando un mundo y software libre

Imagen de maestrenavarro
+1
0
-1

Hola, tengo instalado Karmic Koala y he estado siguiendo el hilo de este post. Al bajar el archivo libcupsys2_1.3.9-17ubuntu3.1_all.deb, no me funciono al instalarlo, me salia un reporte de que el archivo estaba dañado. Así que entré a la página que postearon http://security.ubuntu.com/ubuntu/pool/universe/c/cups/ y de alli baje el archivo libcupsys2_1.3.9-17ubuntu3.4_all.deb de fecha 10 de Nov 2009, lo instale y funcionó, ahora tengo mi impresora Cqnon iP 1200 trabajando. Este era un paso vital para no regresarme a Windows, ya que apenas estoy empezando en Ubuntu y me está gustando. Gracias por su ayuda.

+1
0
-1
Imagen de BRNrules
+1
0
-1

Maestronavarro. Has dado con la tecla, compañero. Yo también he encontrado la solución gracias a tu maravilloso link. Lo único, decir que ya hay versiones más modernas del libcupsys2 que la que mencionas, pero es una puntualización sin importancia.

Un saludo, y de verdad, MUCHAS GRACIAS!!

+1
0
-1
Imagen de gladiator--1
+1
0
-1

Hola, keria agredecer a maestrenavarro por el link k me ha dado me ha funcionado al final, buff despues de mucho tiempo he llegado a ver este hilo y fui probando en cada uno hasta que en el tuyo ha funcionado,
de verdad k muchas gracias

saludos

+1
0
-1
Imagen de AdrianZR1
+1
0
-1

Mil gracias a todos, Yo tenia un problema similar con uan canon ip1900 y no podia instalarla, y tambien me ponia ese error porque tenia el libcups2 y necesitaba el libcupsys2, habia pensado en quitar libcups2 pero eso significaba tener que quitar varios programas, entonces despues de batallar varios dias buscando que hacer encontre este tema en este foro, no saben lo mucho que batalle, pero ya esta lista, muchas gracias.

+1
0
-1
Imagen de adelmalo
+1
0
-1

Hola.
Estoy con la última versión de Ubuntu (12.4, creo) y tengo a mi lado una fantástica impresora Dell 720 que no funciona con windows 7, pero que por lo que he leido en mil foros se puede usar en Linux con un driver de una impresora Lexmark serie Z600. He seguido muchos pasos, pero básicamente el error que veo es el mismo que tuvisteis vosotros, me dice que para qué quiero el lipcupsys2 si tengo el libcups... Y he probado con la solución que dice maestronavarro (aunque el enlace ya está desfasado, he encontrado el mismo archivo con idéntica fecha en http://vm3.willowgarage.com/security.ubuntu.com/ubuntu/pool/universe/c/c... ),
pero a mi sigue sin funcionarme por el mismo conflicto:
dpkg: regarding .../libcupsys2_1.3.9-17ubuntu3.4_all.deb containing libcupsys2:
libcups2 conflicts with libcupsys2
libcupsys2 (version 1.3.9-17ubuntu3.4) is to be installed.
dpkg: error processing /home/ubuntu/Descargas/libcupsys2_1.3.9-17ubuntu3.4_all.deb (--install):
conflicting packages - not installing libcupsys2

He probado a instalarlo en el terminal, y nada. Ni con poderes de sudo.
¿Alguien sabe qué es lo que me puede fallar o faltar?
Sé que ha pasado mucho tiempo desde el último comentario, pero creo que es mejor comentar aquí que abrir un nuevo post.
Gracias

+1
0
-1
Imagen de adelmalo
+1
0
-1

Encontré un minicomentario de un tal Uri Herrera en un post y siguiendo sus pasos conseguí que más o menos funcionase (aunque sinceramente no tengo ni idea de qué significa cada uno):
1. Instalar libstdc++5 (yo lo encontré aquí: packages.debian.org/en/sid/libstdc++5)
2. Según el post de donde he sacado la información, habría que instalar getlibs-all.deb (yo lo bajé de djlab.com/stuff/getlibs-all.deb); pero yo he probado a no instalarlo y me funciona igual.
3. Instalar lexmark.z600-0.4.deb (enlazados directamente desde el foro, en https://help.ubuntu.com/community/HardwareSupportComponentsPrinters/Lexm...)
4. Ir a la configuración de la impresora y elegir el driver de Lexmark z600, que aparece el último.

A mí, así, me funciona la Dell 720, y supongo que también lo harán las Lexmark. Suerte

+1
0
-1
Imagen de cardelle
+1
0
-1

Horribleeeeee!
Editado: transgrede las normas:

Cómo contestar consultas y comentarios
    Cíñete al tema, si la consulta trata sobre ‘A’, ese debe ser el tema de tu respuesta. 
+1
0
-1