¿existe un software para instalar paquetes de todo tipo?

Imagen de lachatunga
0 puntos

Primero, antes de que me crucifiqueis, deciros que sólo llevo una semana en Ubuntu (vengo de windows lógicamente). Me encanta, de hecho cuando enciendo Windows ahora me resulta tremendamente rancio, quiero quedarme en linux definitivamente. Todo en Ubuntu me parece genial, me encanta el sistema para instalar paquetes que viene en aplicaciones y el synaptic. El problema viene cuando necesitas una aplicación para algo específico y no viene en estos (y no se como lo hago pero atraigo este tipo de necesidades). Por ejemplo, tengo una grabadora lightscribe y como es lógico, me gustaría usar esa función, como no hay ningún programa ya en ubuntu que lo haga (si existe estaría muy agradecido en conocerlo) busco aplicaciones en internet, la web de lightscribe, lacie etc... Intento instalarlos: paquetes deb, rpm etc... lo intento por todos los medios, he visto foros, he seguido los pasos que indican en las mismas webs de las aplicaciones... creerme que lo he intentado pero ha sido imposible, tanto a través del terminal como con los deb me han dado errores varios que no tienen solución (ni forzando arquitectura en los deb) es una cuestión de compatibilidad, no escribo esto para solucionar este problema concreto, mi pregunta es bién sencilla:

Al igual que existen programas maravillosos para pasar un video al formato que quiera uno, toda una serie de aplicaciones excelentes en ubuntu ¿no hay ninguno que se ocupe de instalar todo tipo de paquetes, tengan el formato que tengan, que sea capaz de reconocerlo e instalarlo sin problemas? y si no existiera tal aplicación ¿sería tan complicado de hacer?

Realmente este es el único pero que le veo a linux, todo lo demás me está convenciendo de momento, infinitamente mas que windows.

gracias

Imagen de furtaxi
+1
0
-1

Synaptic, y añadir y quitar, son las herramientas gráficas para instalar miles de aplicaciones.

Luego, tienes webs como http://www.getdeb.net/, donde hay más paquetes.

Y don Google, siempre está dispuesto a ayudarte.

Pero, por la propia filosofía de GNU/Linux, de que cada uno aporta lo que puede y quiere, lo único estándar que hay... es el código fuente, y a compilar.

Sería apretar demasiado a los desarrolladores exigirles que prueben cada línea de código en todas las distribuciones y sus versiones de GNU/Linux.

Mi WEB 100 % GNU/Linux: www.vigovideo.es
El que busca encuentra. El que no, se pierde. Arriba a la derecha, un precioso buscador.

+1
0
-1

Mi web : www.vigovideo.es
Buscar es más rápido que esperar una respuesta.

Imagen de lachatunga
+1
0
-1

No tengo ni idea de programación así que si es tan complicado no he dicho nada, bastante tenemos con que sea gratis. Gracias por la rápida contestación.

+1
0
-1
Imagen de furtaxi
+1
0
-1

Otras distribuciones, usan paquetería .rpm.

Gentoo, exige inexorablemente compilar. Pero todo, no sólo las aplicaciones. Desde el kernel, hasta el último módulo de hardware. Lógicamente, su rendimiento es muy superior a Ubuntu, por ejemplo, pero cualquier cambio que se le quiera hacer, supone una buena cantidad de trabajo, tanto para el admnistrador del sistema como para la máquina.

Ubuntu es un "hijo" de Debian, y, por lo tanto, usa los paquetes .deb, que presentan como gran ventaja, su facilidad de uso.

Pero permite compilar el código fuente, optimizándolo para la máquina, o convertir los .rpm mediante la utilidad Alien.

Así, dicho por encima, que con el tema, te puedes complicar todo lo que quieras.

:)

Mi WEB 100 % GNU/Linux: www.vigovideo.es
El que busca encuentra. El que no, se pierde. Arriba a la derecha, un precioso buscador.

+1
0
-1

Mi web : www.vigovideo.es
Buscar es más rápido que esperar una respuesta.

Imagen de curritox
+1
0
-1

Date una vuelta por aqui, igual tienes suerte y puedes hacer funcionar la impresion en tu grabadora...

http://www.lacie.com/products/product.htm?pid=10803

posteado por al amigo sajnox

sajnox
March 18th, 2008, 09:48 PM
Hace un tiempito me compre una grabadora de DVD con lightscribe, en un principio me habia propuesto averiguar un poco cuales eran compatibles con linux y esas cosas, pero ya que iba a comprar una Asus DRW-1814BL, y que generalmente el hard de marca no tiene problemas con Linux. La compre y listo.

Llegue a casa, la instale y obviamente me la reconocio sin un minimo de problemas, solo me faltaba conseguir algun programa que imprimiera sobre los discos, no solo que los grabase.

Consulte a mi amigo Google y encontre esto:

http://www.lacie.com/products/product.htm?pid=10803

Primero instale las librerias que usa el programa desde esta pagina http://www.lacie.com/support/drivers/driver.htm?id=10095

Luego baje este programa http://www.lacie.com/support/drivers/driver.htm?id=10094@

Y Luego agregue un lanzador para poder accederlo desde el menu de aplicaciones. El lanzador lo cree con gksudo ya que para imprimir sobre el cd pide permisos de root, por lo que el comando del lanzador es el siguiente
gksudo 4L-gui

Ultimo punto: como los paquetes que baje son rpm y por que soy una persona muy comoda los transforme en .deb con alien, para eso ejecute

sudo alien -v lightscribe-1.8.15.1-linux-2.6-intel.rpm

sudo alien -v 4L-1.0-r6.i586.rpm

Y con eso ya tenia los paquetes deb para instalarlos con un simple doble click.

Solo hay que buscar un poco, casi todo, y digo casi, pues eso, que tiene solucion!! :)

+1
0
-1
Imagen de redda
+1
0
-1

sudo apt-get install alien
man alien

Igual tienes suerte y encuentras lo que buscas en otra paqueteria.

+1
0
-1