retraso al maximizar ventanas

Imagen de rcarmonas
0 puntos

buenas soy ususario de ubuntu desde hace ya algunos años y todo perfecto, pero al comprarme un portatil nuevo (toshiba satellite p300-23f), me ha surgido un problemilla con compiz. le he instalado los drivers de la pagina de ati, y ningun error, pero al activar compiz, noto que cuando tienes una ventana minimizada y la maximizas tarda como un segundo en maximizarse, no es muy grave pero es bastante molesto.

alguien me puede dar una solucion??

Imagen de angelferrer73
+1
0
-1

Siento no poder ayudarte pues me pasa exactamente lo mismo, mi equipo es un P-IV a 3.4 Ghz, 2 Gb de Ram, Ubuntu 9.04 con Gnome, tengo una ATI RADEON HD 3850, instalé los drivers privativos de ATI y ya me pasaba esto, los desinstalé y volví a instalarlos pero esta vez bajando los drivers de ati para linux(siguiendo tuto de esta web), sigue tardando mucho maximizar una ventana o redimensionarla, a mi me tarda a veces hasta ¡¡¡ 4 segundos !!! es demasiado, me he fijado que le cuesta mucho más si la ventana que maximizas es grande que si es pequeña, así como al redimensionar, si haces una ventana más grande de lo que es, le cuesta pero, si la haces más pequeña no le cuesta nada.
No tengo idea si el problema puede venir de los drivers de la ATI o es del gestor de ventanas, me he vuelto loco cambiando configuraciones de Compiz a ver si hay alguna que ralentiza pero nada, solo con que estén activos los efectos de escritorio ya tengo el problema.
Otro detalle: esos segundos que le cuesta maximmizarse se oye un pequeño murmullo que diría con casi total seguridad que viene de la gráfica.

Como siempre MUCHAS GRACIAS de antemano a quien pueda ayudarnos con este problema que la verdad es molesto, tanto que me planteo quitar los efectos de escritorio

+1
0
-1
Imagen de angelferrer73
+1
0
-1

Buenas de nuevo, hoy mismo he actualizado mi ubuntu 9.04 a la nueva versión 9.10 Karmic Koala, la pantalla de entrada y los iconos le dan un aspecto bastante mejorado para mi gusto, pero el problema al redimensionar ventanas persiste. La verdad es una pena porque por lo demás va estupendo, pero es muy frustrante trabajar así, espero que alguien nos pueda echar una mano.

Graciass.

+1
0
-1
Imagen de dorian90
+1
0
-1

ami me pasaba algo parecido con el decorador de ventanas emerald ya que le habia cambiado los front ala barra de titulo para que se vea mas grande si usan emerald prueben achicandola si no me entendieron pregunten suerte!!!

+1
0
-1
Imagen de Tanis13
+1
0
-1

Si alguien deja un tenedor en medio del camino, cogelo, es tuyo.

A mi me ocurre exactamente lo mismo, tengo un sony vaio vgn-fw21e con una ati radeo hd 3400 y cuando activo los efectos de escritorio me tarda en maximizar, pero no solo eso, los dock normalmente se ven mal o lento, es como si tubiera la aceleración grafica a medias activada. En un page lei que era debido a que ubuntu usa un xorg server que tiene este problema con este tipo de tarjeta, pero no encontre ninguna solución, asi que por favor ayudaa, he estado investigando y parece ser que el problema es bastante común y ocurre normalmente con las ati radeon hd 3XXX y ubuntu asi que creo que el problema debe de estar ahí.

+1
0
-1

Si alguien deja un tenedor en medio del camino, cogelo, es tuyo.

Imagen de angelferrer73
+1
0
-1

Parece que estamos fastidiados entonces, yo me estoy planteando cambiar la gráfica por una nvidia, aunque sé que la ATI es una pasada para el win2, no se, habrá que poner un anuncio a ver que sacamos. Espero que esta información le pueda servir a quien esté pensando comprar un pc, portátil o directamente una gráfica para utilizar con ubuntu, con esta se va a desesperar. No entiendo como un problema de este tipo no se resuelve por parte de ATI ni incluso por la parte de ubuntu, recuerdo que estamos hablando de redimensionar una ventana, no de un determinado programa o juego....
Bueno, mientras buscamos una solución a nuestro problema(más o menos drástica), vamos a confiar como siempre en la ayuda de algún usuario que nos pueda dar alguna pista.

Graciass

+1
0
-1
Imagen de dreKion
+1
0
-1

a mi me pasa lo mismo pero desde hace un año... yo tengo una ATI HD 3650 y el problema es que yo no puedo cambiarla va integrada en mi portatil...

saludos

+1
0
-1
Imagen de eQuaLiTY
+1
0
-1

Yo tengo un Toshiba A300-228, con una fabulosa ATI Mobility Radeon™ HD 3470 con soporte Tecnología HyperMemory™ que te cagas... y si le pongo los controladores para usar los efectos, lo mismo que a vosotros, va muy lento... pero lo mejor de todo es que cuando reinicio... tachán! Kernel Panic, o eso parece, se enciende y se apaga intermitentemente la lucecita del BloqMayus... y no continua, y es cuando se va a iniciar GDM... así que ahora estoy sin aceleración gráfica. Creo recordar que con la 8.10 de Ubuntu, lo de las ventanas iba igual de lento (eso seguro) pero me iniciaba sin problemas.

Esperemos que lo puedan solucionar...

Saludos.

+1
0
-1
Imagen de cricri1991
+1
0
-1

Buenas, despues de tanto tiempo, encontré la solución al problema. Espero que les sea útil.

--------------------------------------------
En caso de que despues de seguir con todos los pasos no puedan entrar en modo gráfico al Ubuntu, entren en modo [b]Recovery[/b], luego a la terminal (opcion ->Shell) e instalen los drivers de video nuevamente:

sudo -s
./ati-driver-installer-9-11-x86.x86_64.run

--------------------------------------------

Hace ya un buen rato que poste algo con respecto de lag o retraso que sufria Ubuntu 9.04 al usar los efectos de Compiz por la versión que se usa de X.Org Server (1.6) y los contraladores ATI fglrx.

El problema se notaba al maximizar o restaurar las ventanas minimizas, tardaba como 2 segundos en hacer la animación o de plano se la saltaba. Ahora ya una versión parcheada del X.Org Server que soluciona el problema. Todo esto después del salto.

Despues vamos a Origenes de software que esta en Sistema -> Administración -> Orígenes de software para agregar los siguientes repositorios, en la pestaña Software de terceros y luego en el botón añadir escribir lo siguiente [Actualización 5-dic-09]:

deb http://ppa.launchpad.net/launchpad-weyland/xserver-nobackfill/ubuntu karmic main
deb-src http://ppa.launchpad.net/launchpad-weyland/xserver-nobackfill/ubuntu karmic main

Este paso ya no es necesario en Karmic Koala **. *Esto es una linea a la vez, después cerramos, no se preocupen si sale alguna advertencia de NO_PUBLIC KEY porque es lo que sigue.
Abrimos una terminal y escribimos

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys AF1CDFA9

Esto permite importar la llave para el repositorio que necesitamos*
Una vez hecho esto escribimos en consola

sudo apt-get update && sudo apt-get upgrade

Con esto hacemos una actualización de software y con ello el parcheo del X.Org Server

Es recomendable que bajen la versión más reciente del controlador de ATI en vez de usar el se encuentra Controladores de hardware, lo pueden encontrar aquí: http://support.amd.com/us/gpudownload/Pages/index.aspx

Para instalar este controlador con extensión .run se hace de la siguiente forma:
Navegar en consola hasta la carpeta donde esta el controlador con: cd
Usar los comandos (en mi caso es una ATI Mobility Radeon HD 3450 y es Ubuntu de 64 bits):

chmod +x ati-driver-installer-9-6-x86.x86_64.run
sudo ./ati-driver-installer-9-6-x86.x86_64.run

Con esto abriremos el instalador y solo damos siguiente hasta finalizar, reiniciamos y estará todo perfectamente sin más retrasos ni flicker (parpadeo en video) ni ningún error de video.

Saludos.

+1
0
-1
Imagen de juandbboy
+1
0
-1

si, esta es la solucion, a mi me funciono, al principio tuve problemas, pero porq no lo estaba haciendo en modo RECOVERY, ni me cargaba, se quedaba en negro, pero luego ...de hacer todo eso, entre en modo recovery y reinstale los drivers de ATI, y fue si no reiniciar y ya, todo muy bien, los efectos andan sin ningun retraso en el minimizar ni nada, gracias por la solucion!

+1
0
-1
Imagen de loboxnp
+1
0
-1

Hola, saludos desde Venezuela....

Soy en nuevo, mi primera distro linux es Ubuntu 10.04 64 bits, y mi entorno gráfico padece de retraso al maximizar o minimizar ventanas. Tengo una tarjeta gráfica ati radeon 3870. Seguí las instrucciones pero no me funciono.

No se como actualizar los repositorios para software de terceros para xorg. no se cuales son las url actuales.

Mucho agradecería actualizar la información para solventar mi problema.

Agradeciendo de antemano....

Saludos.........................

+1
0
-1

Mientras sigas haciendo lo que haces, mas tiempo seguirás siendo quien eres....

Imagen de angelferrer73
+1
0
-1

Gracias cricri1991 por tus indicaciones pero a mi al menos no me ha servido. Tengo Ubuntu Karmic, así que no he añadido los repositorios como indicabas, bajé e instalé el controlador de ATI, todo correcto, tengo los ATI Catalyst pero el retraso en las ventanas sigue igual, es más, mientras una ventana se está abriendo o redimensionando el equipo pierde por un segundo el sonido si estás escuchando música o algo.
Agradezco cualquier ayuda que pueda ser de utilidad, es frustrante tener una gráfica tan potente y que sea un problema abrir una simple ventana

Saludos

+1
0
-1
Imagen de seiryu89
+1
0
-1

A mi me pasa lo mismo que a vosotros, tengo una ATI HD 3400.
Cosas que me ocurren:
1- Maximizar y minimizar ventanas tarda mucho, alrededor de 2 segundos. Solo pasa cuando tengo compiz activado, da igual si no tengo NINGUN plugin activado, con el hecho de tener compiz activado ya tarda en maximizar y minimizar.

2- Como al usuario de arriba, la musica se corta cuando maximizo o minimizo, cuando abro firefox o algun programa que requiera inicializar una ventana nueva, incluso si le pongo al programa de musica(rythmbox) como maxima prioridad(prioridad -19).

3- Alguna vez, intentando arreglar el problema, cuando ejecutaba el comando "gdm stop" o "gdm restart" me saltaba con un segmentation fault.

4- Viendo videos(tanto por web como utilizando Totem) va muy muy lento, hasta el punto de no poder ver el video. Incluso aveces el sistema, mientras veia un video, entraba en kernel panic o saltaba el modo texto con una "trace" de la pila(stack).

5- Problemas de dibujado de las ventanas; quiero decir que cuando muevo una ventana por el escritorio, todo lo que se ve debajo de esta ventana(otras ventanas etc.) quedan "pintadas" con el rastro de la ventana que estoy moviendo(pasa durante 1 segundo o 2). Es algo bastante feo y molesto. Es como lo que ocurre en el SO windows cuando explorer.exe se queda colgado.

Todo esto me ha pasado desde la version Ubuntu 8.10 hasta la actual, 9.10. Todo ello formateando el ordenador en cada version (8.10->9.04->9.10), por lo tanto no es debido a alguna configuracion que yo haya tocado o a algun programa que yo haya instalado.
Tengo los drivers de la tarjeta instalados y con direct rendering=yes.
Cuando ejecuto glxgears me pone unos 10000 frames in 5.0 seconds, y cuando la ventana del glxgears esta maximizada pone unos 700 frames cada 5.0 segundos.

Con windows, la tarjeta funciona a la perfección (lo digo para descartar problemas de hardware de la tarjeta).

¿Alguien tiene alguna idea de que poder hacer o a que es debido? Despues de tanto trastear y buscar, supongo que sera de la tarjeta gráfica o los drivers de la misma, pero me sorprende que incluso no pueda oir musica normalmente, sin cortes, por culpa de la tarjeta gràfica o de su bajo rendimiento.

+1
0
-1
Imagen de cricri1991
+1
0
-1

Prueben bien las indicaciones que dejé, porque hasta ahora son los únicos que me dicen que no les funciona. :P
Traten de seguirlo al pie de la letra.

Un abrazo. y suerte,

+1
0
-1
Imagen de loboxnp
+1
0
-1

Hola a todos,....

Para la solución que se propone, podrías publicar (actualización del post) para la versión 10.04 64 Bits. Mucho lo agradecería.

Saludos desde Venezuela

+1
0
-1

Mientras sigas haciendo lo que haces, mas tiempo seguirás siendo quien eres....

Imagen de angelferrer73
+1
0
-1

Te puedo asegurar que lo hice al píe de la letra y sigue sin funcionar, todos los efectos de compiz(cubo, zoom...) funcionan perfectamente, y los últimos drivers de ATI se instalan sin errores, pero con las ventanas hay un problema pero no logro encontrar solución

Gracias de todos modos

+1
0
-1
Imagen de angelferrer73
+1
0
-1

Por fin ha llegado la nueva versión de ubuntu, 10.04, aunque la verdad que no tenía muchas esperanzas, pero alguna sí tenía en que con la nueva versión pudiese solucionarse este problema tan molesto. El caso es que seguimos en lo mismo, en cuanto tuve todo instalado y preparado, en el momento que en Apariencia marqué los efectos visuales como Normal o Extra, volvemos a las mismas, el mismo retraso al redimensionar ventanas que tenía con ubuntu 9.10

+1
0
-1
Imagen de angelferrer73
+1
0
-1

Ahora sí, por fin he conseguido solucionar el problema de retrasos al redimensionar ventanas y los controladores ATI, dado que arrastraba ya varios problemillas de ubuntu 9.10, me decidí a instalar el 10.04 desde cero, vamos, respetando el home pero por lo demás como una instalación limpia. De este modo he conseguido resolver este tan molesto problema, desde el primer momento puedes activar los efectos de escritorio al máximo y no da ningún problema, no he necesitado instalar drivers privativos ni siquiera instalar los catalyst..., de momento va todo como la seda. Espero que siga así.

Graciass

+1
0
-1
Imagen de 1antares1
+1
0
-1

Lo que pasa es que al Instalar el Ubuntu 10.04 de 0, sin instalar Drivers, sin activarlos, tendrás los "Drivers por defecto de Ubuntu", pero si vas a Sistema > Administración > Controladores de Hardware, tendrás los "Controladores Privativos" desactivados.

Y si utilizas los controladores por defecto, el Compiz a una resolucion de 1280 a 1400, el efecto de minimizar y maximizar con "Fuego (Quemar)", se te ralentiza.

Con los controladores "Privativos" por defecto, corre todo rápido y a los FPS correspondientes, pero el "Efecto de Maximizar" ventanas, se cuelga, tiene retraso (Como todos acá) y aún, no podemos aprovechar la Tarjeta al 100%.

O es una de 2: "Aquí explicado":

http://www.ubuntu-es.org/node/140679

Espero que alguien pueda ayudarme con éste problema :( Gracias de antemano.

+1
0
-1

30 de Marzo 2008 - [Gabi & José] | Numeoli

Sólo hay 2 clases de personas. Las que piensan que hay 2 clases de personas y las que no.

Imagen de 1antares1
+1
0
-1

Ahora si, conseguí la solución al 100%.

Si algunos ven éste tema, puedo comentarles que hacer para que utilicen Drivers Privativos con ATI de su página oficial sin RETRASOS ni problemas.

Y aparte, con la velocidad FPS que corresponde a cada tarjeta.

Utilizo un monitor 1440x900 de Resolución y 60Hz y aún, me corre perfecto ahora. Los efectos en tiempo real, pero aún tengo problemas con los videos, que tienen esas rallas horizontales feos.

Pero ya falta poco, me imagino que esas rayas son los Codecs. Saludos!

+1
0
-1

30 de Marzo 2008 - [Gabi & José] | Numeoli

Sólo hay 2 clases de personas. Las que piensan que hay 2 clases de personas y las que no.

Imagen de angelferrer73
+1
0
-1

Pues estaría muy bien que nos explicases la solución, la verdad que tienes razón, el compiz no funciona del todo bien con los drivers genéricos de la 10.04. Y si instalas los privativos..... sorpresa, de nuevo los retrasos en las ventanas, esto es el cuento de nunca acabar, espero que nos reveles el secreto en cuanto puedas.
Muchas gracias de antemano.

+1
0
-1
Imagen de 1antares1
+1
0
-1

Ya con Ubuntu 10.10, se acabaron todos esos problemas y detalles.

Y también haré ahora una pequeña guía sobre como Instalar los Drivers de ATI HD y sobretodo, como hacer funcionar el Compiz Fusion correctamente ;)

Paciencia, mientras ve bajando con tranquilidad el Ubuntu 10.10, que se encuentra de 10.

Ahora si que esto es vida! ;)

Saludos!

+1
0
-1

30 de Marzo 2008 - [Gabi & José] | Numeoli

Sólo hay 2 clases de personas. Las que piensan que hay 2 clases de personas y las que no.

Imagen de titomak
+1
0
-1

Hola, buenos días, tengo la "fortuna" de poseer una ATI, y con todas las distros me daba el mismo problema. Era activar el composite de metacity o activar los efectos de Compiz, y se generaba retraso en minimizar y maximizar, etc...
Buscando, al final he encontrado algo que a mi si que me va, por que daba igual los drivers que me ponia (actualmente tenngo una ATI 3650 con los drivers 10.5 )

Asi que para os funcione correctamente hay que hacer esto:

sudo aticonfig --set-pcs-str=DDX,Direct2DAccel,TRUE

La referencia la teneis en la página del autor...

http://enalpha.com/2010/04/18/habilitar-aceleracion-direct2d-en-tarjetas...

Saludos

+1
0
-1
Imagen de 1antares1
+1
0
-1

Pero había una solución mucho más fácil y era sólo parchar el Xorg.

De ésta manera:

http://flups.net/linux-y-gnu-f19/parchear-xorg-en-ubuntu-10-04-lucid-lyn...

Así, el retraso se quitaba, es por ello que digo que con Ubuntu 10.10, ya ése "Parche" estaba hecho y venía ya el Xorg mejorado/reparado, es por ello que animo a que utilicen la versión 10.10, y los que ya la han utilizado, que comenten si aún poseen el mismo problema.

Pero que extraño ¿Por que el mismo inconveniente, tienen soluciones tan independientes?

Que yo sepa, yo parché el Xorg y todo perfecto.

Igual, a cualquiera de las 2 opciones, cualquier usuario tiene donde elegir y entre más soluciones, mucho mejor ;)

Que bueno que compartas la solucón anterior, me sonaba conocida.
Saludos!

+1
0
-1

30 de Marzo 2008 - [Gabi & José] | Numeoli

Sólo hay 2 clases de personas. Las que piensan que hay 2 clases de personas y las que no.

Imagen de rommel2729
+1
0
-1

HOLA USO UBUNTU RESIEN UNOS MECES,LO QUE ME SUCEDE ES QUE AL QUERER INSTALAR COMPIS PARA TENER EFECTOS 3D EN MI NOTEBBOT ACER ASPIRE 5530G CON UNA PLACA DE VIDEO ATI DE 64 BIS BUENO AHORA AL BAJAR EL ESCRITORIO AL VER ALGO SE ME DEMORA COMO SI ESTUBIERA FILMADO EL MONITOR ASI COMO C BE EN LA TV UN MONITOR CON RAYAS Y CUANDO QUIERO VER UN VIDEO Q ESTA MINIMISADO EN GRANDE SE ME CUELGA PA MAQUINA YA DESACTIVE COMPIS Y NADA PORFABOR SI ALGUIEN ME PODRIA AYUDAR DESDE YA MUCHAS GRACIAS.ROMMEL

+1
0
-1

ROMMEL

Imagen de 1antares1
+1
0
-1

Que tal!

Recomiendo que habras un tema con el inconveniente respectivo para otorgarte mejor información o ayuda para así no desordenar o "desvirtuar" el tema anterior que por lo visto, ya fue solucionado. Es para evitar romper las normas.

Crea un nuevo tema y luego pasas el link para irnos allá! ;)

Saludos!

+1
0
-1

30 de Marzo 2008 - [Gabi & José] | Numeoli

Sólo hay 2 clases de personas. Las que piensan que hay 2 clases de personas y las que no.