Pregunta sobre comportamiento con NTFS

Imagen de Gmaster
0 puntos

Buenos Dias, creo este post para consultarles sobre algo que note, de la cual no encuentro informacion en ningun lado.

En mi disco siempre tuve muchos sistemas, hasta hace unos meses tenia ubuntu 9.04 y Suse de Linux, y Xp de Windows con NTFS.

Con todas las distros de linux que tenia, me pasaba que cuando salia del XP de mala manera (corte de electricidad o tilde del sistema), y luego ingresaba a cualquier linux, el mismo no me montaba la particion NTFS, ni por consola ni nada. La solucion era ingresar a ese Xp mal cerrado, cerrarlo bien y luego regresar a Linux. Ahi si lo detectaba y montaba sin ningun problema.

Acabo de instalar ubuntu 9.10 beta, hice la misma prueba y me monto el NTFS sin ningun problema. Es decir, como que este problema esta solucionado.

Entonces, mis preguntas son:

¿Hay registro de que a mas personas les ocurran lo mismo con las versiones anteriores?.
¿ubuntu 9.10 ha realizado cambios respecto a la version anterior en cuanto al driver NTFS?.

Saludos!.

Imagen de Gmaster
+1
0
-1

Que decepcion :( , un foro oficial de Ubuntu donde nadie conoce que modificaciones tienen las distintas versiones del producto que ustedes mismo promocionan...

Bueh, ira al tacho nomas...

+1
0
-1
Imagen de furtaxi
+1
0
-1

No es un "Foro Oficial" de Ubuntu...

Ësto no lo paga Canonical, ni están por aquí los desarrolladores para explicar lo que hacen, y porqué...

De una versión a otra, incluso, de la actualización de un sólo paquete al siguiente, hay enormes cambios. Muchos de ellos, son transparentes al usuario. De repente, algo que no funciona, se pone en marcha. A veces, al revés, y hay que esperar el parche.

Pero no saldrá de ubuntu-es, al menos, en su conjunto. Aunque puede que muchos de sus miembros colaboren en la solución.

Que te sea leve el tacho.

:)

Mi WEB 100 % GNU/Linux: www.vigovideo.es
El que busca encuentra. El que no, se pierde. Arriba a la derecha, un precioso buscador.

+1
0
-1

Mi web : www.vigovideo.es
Buscar es más rápido que esperar una respuesta.

Imagen de LuisRioCaribe
+1
0
-1

A mi me ocurre lo mismo, si se mal apaga el xp no veo las particiones NTFS, lo cual me perjudica ya que en ellas es donde tengo toda la data.

Ahora les cuento algo, no se si calificar de anecdotico o que.... hace poco me ocurrio que por un apago una maquino con solo Windows Xp se daño, mepidieron ayuda y yo la arranque con un Live CD de UBUNTU 7.04, con eso pude hacer respaldo de la carpeta MIS DOCUMENTOS de Xp, podia leer y escribir perfectamente TODAS las particiones...

El caso es que "encontre" mi CD extraviado de UBUNTU 8.04 y levanté la maquina de nuevo con ese Live CD... cual no sería mi sorpresa que no pude leer las particiones NTFS y me salia el mensajito de que Windows no cerró las particiones correctamente... tuve que volver al LIVE CD 7.04 para culminar el respaldo y luego no me quedo otra que formatear y reinstalar windows, a pesar de todo lo que el dueño dle equipo vio con Ubuntu no me dejó instalarlo.... que se le va a hacer

+1
0
-1
Imagen de Gmaster
+1
0
-1

furtaxi y LuisRioCaribe gracias por responder :)

Entre como en desesperacion, no por el error, sino porque en ningun lado encontre info al respecto y daba la sensacion de que me pasaba solo a mi. Me alegro que ese error se haya solucionado.

Creo que a mi tambien me paso algo parecido a lo que dice Luis, determinado cd Live me detectaba la NTFS y el Linux instalado no. Aunque ya no recuerdo que versiones eran... pero si puedo afirmar que no era solo un bug del Ubuntu, sino que era generalizado para todas las distros.

Opino en que dejen el tema abierto, a lo mejor es un simple error de configuracion que alguien conoce, y que podria ayudar a mucha gente que tenga versiones viejas :)

saludos!.

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

Hola gma...:

1- Tal como te informaron, este es un simple foro de usuarios de Ubuntu,

asi que algunas cuestiones seran respondidas con menor o mayor acierto,

según nuestra experiencia y muchas otras quedaran sin respuesta, porque

no sabemos nada al respecto del tema planteado.

2- Dado que el sistema ntfs, es un sistema privativo, desarrollado por

Microsoft, quién jamás informó nada al respecto de su código, implementación

y particularidades, los desarrolladores de GnuLinux, mediante tecnologia

inversa desarrollaron ntfs-3g, una excelente aplicación, tipo driver en

espacio de usuario, que permite montar, leer y escribir en particiones con

ese sistema de archivos. Como este sistema de archivos privativo, muy

superior al obsoleto fat32 y bastante inferior a los nativos de GnuLinux,

es endeble y mal conocido en profundidad, por defecto cuando a través de

ntfs-3g GnuLinux detecta que se ha cerrado mal, tiene errores y/o inconsistencias

no lo monta por seguridad, y deja al libre albedrío del usuario utilizar el

montaje manual con la opción force, haciendo responsable el usuario por la

pérdida de datos y/o del sistema de archivos que esta opción podría ocasionar.

En definitiva, no es un problema del driver sino una medida de seguridad.

Saludos.
Gabriel.



Solo doy soporte para Ubuntu: Un sistema operativo superior, moderno, optimizado, seguro, evolutivo y completo.
+1
0
-1
Imagen de LuisRioCaribe
+1
0
-1

Gracias Gabriel por la explicación... perooo... me generaste una pregunta... y disculpe lo poco conocedor...
¿como monto la partición con FORCE? digo para casos como el que me paso donde habia que recuperar data y ya XP habia "muerto"

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

Hola Luis....:

Primero, averiguar cual es la partición ntfs
ejecutando en consola:

sudo fdisk -l (es ele)

Segundo, crear el directorio donde montarla
ejecutando en consola

sudo mkdir /media/ntfs

Tercero darle permisos de lectura escritura al
directorio, ejecutando en consola

sudo chmod -Rf 777 /media/ntfs

Cuarto montar la partición con la opción force,
suponiendo sea /dev/sda1, eejcutando en consola:

sudo mount -t ntfs-3g -o force,uid=1000,gid=1000,fmask=0113,dmask=0002 /dev/sda1 /media/ntfs

-t ntfs-3g es el driver específico para el sistema de archivos

-o force opción de forzar el montaje cuando la partición no fue
desmontada correctamente

/dev/sda1 es la partición a montar, cambiar por la correcta

uid=1000 es el uid de usuario, se investiga con la orden
sudo cat /etc/passwd |grep usuario

gid=1000 el el gid de usuario

fmask=0113 es para que otorgar permisos rw sobre los archivos

dmask=0002 es para otorgar permisos rwx

/media/ntfs es el directorio donde montar la partición

Si la partición estuviere dañada, mediante ntfsfix de las
ntfsprogs es posible intentar repararla.

Saludos.
Gabriel.



Solo doy soporte para Ubuntu - 6666 - Más malo que el diablo.
+1
0
-1
Imagen de Gmaster
+1
0
-1

Quedo bien claro... para montarla hay que hacer todo eso.

Hablando del tema, comento algo que me ocurrio. Note que cada vez que queria cargar una particion, el sistema la monta y me pide el pass. Entonces, busque en google la manera de que se auto-monte, y en todos lados dicen que lo hacen con un programa que te da 2 casillas para tildar, si no mal recuerdo, era algo de permitir escritura en medios extraibles. Comprobe que nada tiene que ver con el tema esa aplicacion.

Como no encontre respuestas, abri el fstab y note que no estaban especificadas las particiones alli. Entonces, desmonte todo, cree las carpetas de montaje y cree las lineas en el fstab, y problema solucionado, al iniciar monta automaticamente lo que quiero.

Entonces me pregunto, porque no hace esto automaticamente?. Y me respondo: ¿tal vez porque hay que especificar los puntos de montaje durante la instalacion?.

Nunca le di importancia al punto de montaje de las NTFS cuando instalo el linux.

Me quedo pendiente el tema de la pass. Creo que lo que hice, fue cambiarle los permisos a la carpeta de montaje, y asi no me pide pass cada vez que quiero acceder a esa particion, pero no estoy seguro, en este momento estoy en Win. Gracias por la explicacion de esos permisos, ya lo hare bien con el UID y GID.

Saludos!.

+1
0
-1