No arranca la máquina con Xubuntu 9.10 - 10.04 sin un monitor conectado (Solucionado)

Imagen de jropero
0 puntos

¡Hola!

He actualizado mi Xubuntu 9.04 a la 9.10 y ahora no arranca si no tiene un monitor conectado.

Debe quedarse justo al principio, en el nuevo XSplash, o antes incluso, porque se queda completamente colgado justo después del GRUB.

Ya en la 9.04 me ocurría lo mismo (no arrancaba sin un monitor conectado y saltaba la configuración de las X) pero lo resolví con las indicaciones en Debian-es, es decir, poniendo un configuración por defecto en el xorg.conf.

Sin embargo dicho workaround no parece funcionar con la 9.10

¿Alguna idea para arrancarlo sin monitor?. La idea es poderlo arrancar y controlarlo vía VNC (Escritorio remoto).

Muchas gracias por vuestra ayuda.

Imagen de Gabriel_M
+1
0
-1

Hola jro.....:

Prueba editar tu archivo xorg.conf y dejar

estas secciones asi:

Section "Monitor"
Identifier "Monitor generico"
HorizSync 30-71
VertRefresh 50-160
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Monitor generico"
Device "Default Device"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1024x768" "800x600"
EndSubSection
EndSection

Saludos.
Gabriel.



Solo doy soporte para Ubuntu - Hay tres clases de personas - Las que saben contar y las que no.
+1
0
-1
Imagen de jropero
+1
0
-1

He dejado el xorg.conf así


Section "Device"
	Identifier	"Configured Video Device"
EndSection

Section "Monitor"
	Identifier	"Monitor generico"
	HorizSync 30-71
	VertRefresh 50-160	
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Monitor		"Monitor generico"
	Device		"Configured Video Device"
	DefaultDepth 24
	SubSection "Display"
		Depth 24
		Modes "1024x768" "800x600"
	EndSubsection
EndSection

Pero el comportamiento es el mismo, se para justo después de GRUB

¿Hay algún log de error o sitio donde tener más detalle de lo que está pasando?

+1
0
-1
Imagen de Huelva
+1
0
-1

He actualizado a 9.10 y ahora resulta que no me arranca sin monitor, lo cual es un problema, ya que lo tengo metido en un armario de la cocina y lo manejo con el vnc.

Vamos que tengo el mismo problema. He probado lo que ponéis por aquí y no funciona...

Navegando, navegando encontré esto

http://ubuntuforums.org/showthread.php?t=51587
http://blog.kcsystems.com.ve/index.php/2009/10/31/resolucion-de-pantalla...

Lo he probado todo pero el ubuntu 9.10 no arranca sin monitor... me vuelvo con mi imagen a 8.10 que no tiene este problema..

+1
0
-1

Ubuntu 8.10 -> 14.04

Imagen de astursaul
+1
0
-1

pero como no va a arrancar si el monitor solo sirve para ver lo que ocurre en el pc mientras este encendida la pantalla mientras arranque la torre que mas te da la pantalla

posdata me dics como usas el vnc que llevo tiempo intentandolo y nada

gracias por adelantado

+1
0
-1
Imagen de Huara
+1
0
-1

A mi me pasa lo mismo, resulta que mi pantalla se paga al iniciar xubuntu por un tema de la resolucion, a pesar de lees mucho de las configuracions del Xorg.conf no logre arreglarlo. Este problema en el ubuntu normal lo solucionaba apagando la pantalla y prendiendola cuando estava todo el escritorio cargado, pero resulta que en xubuntu cuando apagamos la pantalla logro entrar a la parte donde te pide las pass y usuario, despues si no apago la pantalla esta se apaga sola y si la apago y la enciendo en un rato me vuelve a preguntar el user y la pass, trate de configurarlo para entrar sin que me pidiera login y pass pero no lo pude hacer, finalmente reinstalle el ubuntu normal pero el compu al ser viejo anda muy lento y con xubuntu andava muy veloz. Debo agregar que 1 vez de cada 10 no se apagava la pantalla al ingresar al escritorio despues de poner la clave.

+1
0
-1
Imagen de anticuado
+1
0
-1

Poniendo esto en Xorg.conf

Section "Device"
Driver "vesa"
Identifier "Configured Video Device"
Option "NoDDCValue"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection

Sin embargo este truco no me vale para la 10.04, alguien sabe por qué?

+1
0
-1
Imagen de kakomalo
+1
0
-1

Mi caso supongo que es bastante parecido al vuestro. Lo que necesitaba era un equipo desatendido al que conectarme remotamente por VNC cuando fuera necesario.

Despues de leer bastante, en un monton de foros lo he solucionado así:

  • Como servidor de VNC uso x11vnc que a diferencia que el resto de los servidores no crea una nueva sesión al conectarte, si no que muestra lo que esta sacando por pantalla (al estilo habitual de los VNC de windows).

    Como hay varios usuarios dados de alta y necesito cambiar entre ellos, lo que hago es lanzar en VNC con la Xauthority del gdm (normalmente en /var/run/gdm/), así el servidor VNC comienza en la pantalla de selección de usuarios.

    La unica complicación que me presentaba era el respawn (para que puedas cambiar de usuario y no mate el proceso VNC cuando vuelve al gdm) con el nuevo arranque upstart.

    Para eso creas un nuevo fichero nombre.conf en /etc/init/ con esto

    # x11vnc
    #
    # This service launch x111vnc server form user selection screen.

    start on started gdm
    stop on runlevel [016]

    respawn
    exec /usr/bin/x11vnc -q -forever -rfbauth [ruta del passwd] -auth [ruta del authority del gdm] -display :0 (<- todo esto en una linea)

    Ayuda bastante los nuevos comandos del x11vnc -findauth and "-auth guess" para localizar la Xauthority

  • Una vez solventado el tema del VNC el problema esta en el arranque sin monitor. Para esto lo primero que hay que hacer es deshabilitar el sistema KMS (Kernel mode setting) de la siguiente manera:

    Editar el fichero /etc/default/grub y añadir el parámetro "nomodeset" a la línea GRUB_CMDLINE_LINUX.

    Ejecutar sudo update-grub.

    Ahora que el grub arranca sin monitor, hay que definirle uno "virtual" para las X, para esto hay que cambiar (o como en mi caso crear) el xorg.conf en /etc/X11/ y dejarlo así

    Section "Monitor"
    Identifier "Monitor generico"
    HorizSync 30-71
    VertRefresh 50-160
    EndSection

    Section "Screen"
    Identifier "Default Screen"
    Device "Configured Video Device"
    DefaultDepth 24
    SubSection "Display"
    Depth 24
    Modes "1024x768" "800x600"
    EndSubSection
    EndSection

    Section "Device"
    Identifier "Configured Video Device"
    Driver "vesa"
    Option "NoDDCValue"
    EndSection

Con esto he conseguido que arranque sin monitor eso si, solo a 800x600 no se por que no puedo ponerlo a 1024, pero vamos no me preocupa mucho.

Epero que no os haya resultado un toston.

Un saludo,

+1
0
-1
Imagen de Huelva
+1
0
-1

kakomalo eres un CRACK!!!!!

En fin, lo de Editar el fichero /etc/default/grub y añadir el parámetro "nomodeset" a la línea GRUB_CMDLINE_LINUX. está por todos los foros, pero lo de poner un monitor para que no se quede colgado no.

Por otro lado para tener cualquier resolución creo que hay otra solución, la de usar los drivers de nvidia, pero claro, el vnc no funciona, y habria que usar el x11vnc, pero la verdad paso, como bien dices con 800x600 basta.

+1
0
-1

Ubuntu 8.10 -> 14.04

Imagen de lacr
+1
0
-1

Gracias a todos y en especial a kakomalo por el aporte, he seguido los pasos para arrancar sin monitor (anteriormente ya tenia instalado el X11VNC) y el VNC me ha funcionado, sin monitor, perfectamente.

La resolución de 800x600 si me fastidiaba un poquillo, no es que fuera fundamental tenerla mayor, pero en ciertos programas no veía los menús completos... y fastidia cuando no puedes elegir.

He encontrado la solución en :
http://blog.mediafederation.com/andy-hawkins/ubuntu-headless-vnc-vesa-80...

Lo que hecho es lo siguiente:

Primero he vuelto a dejar la configuración inicial

en mi caso (tengo Ubuntu 10.04 LTS):

Editar el fichero /etc/default/grub y quitar el parámetro "nomodeset" a la línea GRUB_CMDLINE_LINUX.

Ejecutar

sudo update-grub

.

Esto lo he hecho porque si en un futuro cambio de idea, no me acordaré que he deshabilitado el sistema KMS (Kernel mode setting) y perderé más tiempo de lo debido si me hiciera falta. Este paso no es estrictamente necesario realizarlo.

Instalar el paquete xserver-xorg-video-dummy su descripción en Synaptic es la siguiente:
Este paquete proporciona un controlador de monitor de prueba, el cual
realmente no muestra nada.

sudo aptitude install xserver-xorg-video-dummy

y crear fichero /etc/X11/xorg.con con lo suguiente:

Section "Device"
     Identifier  "Configured Video Device"
     Driver      "dummy"
 EndSection
 
Section "Monitor"
     Identifier  "Configured Monitor"
     HorizSync 31.5-48.5
     VertRefresh 50-70
 EndSection
 
Section "Screen"
     Identifier  "Default Screen"
     Monitor     "Configured Monitor"
     Device      "Configured Video Device"
     DefaultDepth 24
     SubSection "Display"
     Depth 24
     Modes "1024x800"
     EndSubSection
 EndSection

Ahora el VNC funciona si arrancamos PC sin pantalla y me permite elegir resoluciones entre las resoluciones 1360x768, 1024x768, 800x600, 640x480 ....

La pega es que si ponemos un monitor este no mostrará nada por pantalla, ya ue el driver utilizado no utiliza ningún hardware, si queremos utilizar un monitor tendremos que eliminar el fichero /etc/X11/xorg.con (para ello tedrá que estar habilitado el sistema KMS, en Ubuntu 10.04) o volver al fichero anterior.

Un saludo,

+1
0
-1
Imagen de Huelva
+1
0
-1

bueno, si que arranca pero no muestra nada por vnc (no conecta) ni si le dejo uno puesto. He probado el
sudo aptitude install xserver-xorg-video-dummy

y no funciona ninguno de los métodos antiguos, así que me puse a investigar y bingo

http://ubuntuforums.org/showthread.php?t=1297815&page=3

Instalar el paquete xserver-xorg-video-dummy


sudo aptitude install xserver-xorg-video-dummy

/etc/X11/Xorg.conf

# Driver "dummy" needs package xserver-xorg-video-dummy.
# If resolutions up to 1600x1200 are enough for you, you may use driver "vesa".
# VideoRam needs to be big enough (8192 or 16384), otherwise there might be error messages in /var/log/Xorg.0.log.

Section "Device"
Identifier "Headless x11vnc Video Device"
Driver "dummy"
# Driver "vesa"
VideoRam 16384
EndSection

# Modelines calculated at http://www.arachnoid.com/modelines/index.html (removed trailing "_60.00" in mode names).
# HorizSync, VertRefresh ranges need to be big enough, otherwise there might be error messages in /var/log/Xorg.0.log.

Section "Monitor"
Identifier "Headless x11vnc Monitor"
HorizSync 22 - 83
VertRefresh 50 - 76
# 1024x768 @ 60.00 Hz (GTF) hsync: 47.70 kHz; pclk: 64.11 MHz
Modeline "1024x768" 64.11 1024 1080 1184 1344 768 769 772 795 -HSync +Vsync
# 1152x864 @ 60.00 Hz (GTF) hsync: 53.70 kHz; pclk: 81.62 MHz
Modeline "1152x864" 81.62 1152 1216 1336 1520 864 865 868 895 -HSync +Vsync
# 1280x800 @ 60.00 Hz (GTF) hsync: 49.68 kHz; pclk: 83.46 MHz
Modeline "1280x800" 83.46 1280 1344 1480 1680 800 801 804 828 -HSync +Vsync
# 1280x1024 @ 60.00 Hz (GTF) hsync: 63.60 kHz; pclk: 108.88 MHz
Modeline "1280x1024" 108.88 1280 1360 1496 1712 1024 1025 1028 1060 -HSync +Vsync
# 1360x1024 @ 60.00 Hz (GTF) hsync: 63.60 kHz; pclk: 116.01 MHz
Modeline "1360x1024" 116.01 1360 1448 1592 1824 1024 1025 1028 1060 -HSync +Vsync
# 1440x900 @ 60.00 Hz (GTF) hsync: 55.92 kHz; pclk: 106.47 MHz
Modeline "1440x900" 106.47 1440 1520 1672 1904 900 901 904 932 -HSync +Vsync
# 1600x1200 @ 60.00 Hz (GTF) hsync: 74.52 kHz; pclk: 160.96 MHz
Modeline "1600x1200" 160.96 1600 1704 1880 2160 1200 1201 1204 1242 -HSync +Vsync
# 1680x1050 @ 60.00 Hz (GTF) hsync: 65.22 kHz; pclk: 147.14 MHz
Modeline "1680x1050" 147.14 1680 1784 1968 2256 1050 1051 1054 1087 -HSync +Vsync
# 1920x1080 @ 60.00 Hz (GTF) hsync: 67.08 kHz; pclk: 172.80 MHz
Modeline "1920x1080" 172.80 1920 2040 2248 2576 1080 1081 1084 1118 -HSync +Vsync
# 1920x1200 @ 60.00 Hz (GTF) hsync: 74.52 kHz; pclk: 193.16 MHz
Modeline "1920x1200" 193.16 1920 2048 2256 2592 1200 1201 1204 1242 -HSync +Vsync
EndSection

# Use modes defined in "Modeline" entries above.

Section "Screen"
Identifier "Headless x11vnc Screen"
Monitor "Headless x11vnc Monitor"
Device "Headless x11vnc Video Device"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1024x768" "1152x864" "1280x800" "1280x1024" "1360x1024" "1440x900" "1600x1200" "1680x1050" "1920x1080" "1920x1200"
EndSubSection
EndSection

Y funciona perfectamente a 1920x1200, pero claro, con el gran inconveniente de que no se ve nada por el monitor

+1
0
-1

Ubuntu 8.10 -> 14.04