¿Ubuntu 9.10 sin grub2? (Solucionado)

Imagen de barca
0 puntos

No se si será muy descriptivo el título del hilo, pero les comento mi duda:

He actualizado el sistema de la versión 9.04 a la 9.10. Tras la actualización me pide reiniciar el ordenador y tras el reinicio me encuentro con la misma apariencia del grub que tenía, ya se que la mejora apariencia del grub2 no es asombrosa pero...me llamó la atención. Ya dentro del sistema arranco el gestor de paquetes synaptic y compruebo que grub2 no está instalado, se mantiene la instalación de grub.
Y aquí mi duda: ¿karmic no funciona sólo con grub2?.

Agradecería que me resolvieran esta duda, y me aconsejen mantener grub o instalar grub2. El sistema, en su primer día de karmic, se mantiene más o menos bien (sólo he tenido un cuelgue del sistema al iniciar el sistema, justo antes de pedirme el usuario y contraseña).

Gracias de antemano.

Imagen de guillermoz0009
+1
0
-1

Hola Amigo:

Pues siempre son mas recomendables las instalaciones limpias, es decir, que descarges la imagen (ISO), desde el Sitio Oficial de Ubuntu y reinstales el Sistema, en tu caso supongo que lo hiciste desde un comando Presionando Alt + F2 (corrigeme si estoy mal), y por esa razon (pienso) que solo se actualizo el Sistema mas no el Grub.

Aun no he terminado de investigar cuales son los cambios notables del Grub 2, ya que yo lo veo casi igual, solo que cambiaron algo el tipo de las letras, pero igual el otro Grub sirve, no te preocupes.

Mi recomendacion: Descarga el Live Cd (El ISO) desde la pagina de Ubuntu y has una instalacion limpiesita.

Suerte


Mantenimiento Preventivo Y Correctivo a Pc's, Redes, y GNU/Linux

"Porque el conocimiento es para todos"

Visita:
http://zeta-9.blogspot.com

+1
0
-1

Colaborador en Mantenimiento Preventivo Y Correctivo a PC's, Redes, y GNU/Linux

Más Info, tutoriales, recuros, tips, etc en:

http://blog.blogspot.com/

Imagen de barca
+1
0
-1

Actualicé mediante el Gestor de Actualizaciones, Actualizar Distribución.

Casi siempre he leído en el foro que es mejor hacer actualizaciones limpias, pero me decidí a actualizar el sistema porque al tener /home en otra partición si el sistema no se comporta bien puedo instalar de cero (reconozco que algo de pereza me daba tener que instalar otra vez los programas que tengo).

Gracias, sinceramente, por tu respuesta y tu consejo.

+1
0
-1
Imagen de Goyo
+1
0
-1

¿karmic no funciona sólo con grub2?.

Ya ves que no, puede funcionar con ambas versiones. En instalaciones nuevas se instala grub2, pero en actualizaciones se conserva el antiguo grub.

Agradecería que me resolvieran esta duda, y me aconsejen mantener grub o instalar grub2.

Hombre, supongo que la razón por la que no se actualiza a grub2 es porque conservar la configuración y que funcione igual es algo complicado de hacer automáticamente. Dependiendo de las ganas que tengas de probar el nuevo, te puedes arriesgar. En caso de problemas siempre está la documentación y super grub.

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

Hola bar...:

Desde la salida de jaunty, con kernel con soporte para el

sistema de archivos ext4, Ubuntu tiene una versión del Grub

legacy que lo soporta.

Si bien Karmic, por defecto en instalaciones limpias instala

el Grub2, trabaja perfectamente y hasta quizas mejor con el

Grub legacy, el Grub2 aun es beta.

Ahora, en mi caso siempre pruebo lo nuevo para experimentar,

y estoy utilizando el Grub2 desde Jaunty resolviendo los

contratiempos que aparecen, en el caso de los usuarios comunes

y más en los que usan el ordenador para trabajar, ¿para qué quieren

cambiar un cargador de arranque, que solo aparece, cuando aparece,

unos segundos al iniciar el ordenador, seguro y super probado,

por otro, aun experimental e indocumentado?

Saludos.
Gabriel.



Solo doy soporte para Ubuntu - 6666 - Más malo que el diablo.
+1
0
-1
Imagen de barca
+1
0
-1

Goyo y Gabriel, gracias por uniros al hilo.
No voy a arriesgarme a tener problemas con el gestor de arranque por verlo diferente durante unos segundos, mientras que funcione estable el ordenador (intento olvidar los formateos y reinstalaciones de windows).

Me quedo con vuestras respuestas y consejos.

+1
0
-1
Imagen de kifto
+1
0
-1

saludos

mi duda es la siguiente. Ahora tengo en el disco duro los siguientes sistemas operativos:

- windows 7 ultimate 32 bits
- mac os x 10.5.5
- Ubuntu 9.04 32 bits

Estoy dándole vueltas a meter ubuntu 9.10 64 bits, pero tengo dudas sobre todo por el GRUB, si el grub que me va a instalat el ubuntu 9.10 64 bits me va a dar problemas a la hora de reconocerme los otros sistemas que tengo en el PC o algo parecido.

Por cierto, en mi caso yo tambien ería partidario de mantener el grub actual antes de tener que verme bregando con gestores de arranques varios o problemas similares al instalar el grub2

Gracias a tod@s y un saludo

+1
0
-1
Imagen de Pablo_F
+1
0
-1

Hol a klifto, es que tu caso es muy diferente al de barca. Barca hace un upgrade pero grub se le queda como está porque grub2 no es un upgrade de grub (una versión más reciente de grub) sino un paquete diferente, un "nuevo grub". Como bien le aconsejan no necesita grub2 y deja el grub que ya tiene que hace muy bien su función y no sirve para nada más que para gestionar el arranque de varios sistemas.

Ahora bien, tu consulta (que creo que debería en otro hilo) no tiene nada que ver. Si quieres instalar un sistema con otra arquitectura diferente necesitas una instalación limpia. Karmic te va a instalar grub2. ¿Que grub2 va a reconcer tus otros sistemas? Esperemos que sí. Hasta que no lo intentes no lo vas a saber. Pero dejar de instalar 9.10 sólo por desconfianza al gestor de arranque, no sé... Y si algo va mal tendrá arreglo. El miedo te hace perderte algo muy bueno, en mi opinión. Me encanta karmic, va de lujo.

Haz lo que te parezca mejor. A mí desde luego una instalación limpia de karmic (32 bit) con grub2 me ha funcionado perfectamente y veo mis otros sistemas (otro Linux y un Windows).

Saludos, Pablo.

+1
0
-1

"Los analfabetos del siglo XXI no serán aquellos que no sepan leer y escribir, sino aquellos que no sean capaces de aprender, olvidar lo aprendido y aprender de nuevo" (Alvin Toffler)

Imagen de kifto
+1
0
-1

gracias, Pablo, por tu respuesta

hombre, menciono lo del grub porque recuerdo haber leido anteriormente que el grub de ubuntu 64 bits daba problemas a la hora de reconocer otros sistemas de 32bits instalados en el equipo. Si eso es cierto, instalo el de 32bits y punto.

ya he tenido en otras ocasiones problemas con el grub y por lo general siempre los he solucionado, pero siempre ha sido en 32 bits. Tengo poca experiencia con los SOs de 64bits, precisamente por eso me apetecia probar este nuevo ubuntu 9.10 de 64bits, pero la verdad, si eso me puede suponer instalar de nuevo windows 7 y sobre todo mac OS (con lo latoso que es instalarlo en mi PC) pues paso de los 64bits y me quedo con los 32bits

+1
0
-1
Imagen de Pablo_F
+1
0
-1

kifto, sabes que el software libre no es un producto, es un proceso. Lo que no funcionaba ayer puede funcionar hoy, gracias a la comunidad de usuarios y al buen trabajo de los desarrolladores y los distribuidores.

Tus otros sistemas no se van a ver afectados por grub2. Lo peor que puede pesar es que no arranquen. Eso se arregla mucho más fácil que tener que instalar otra vez todo el sistema operativo.

Pero en fin, el miedo es libre. Haz lo que te parezca mejor, sólo recordarte que una cosa es el arranque del SO y otra el SO en sí, que a grub, plim.

Saludos, Pablo

+1
0
-1

"Los analfabetos del siglo XXI no serán aquellos que no sepan leer y escribir, sino aquellos que no sean capaces de aprender, olvidar lo aprendido y aprender de nuevo" (Alvin Toffler)

Imagen de kifto
+1
0
-1

gracias de nuevo, Pablo

Me has animado a darle un tiento al 9.10 de 64bits, a ver si se lleva bien con el windows7 32bits y el Leopard que ya tengo en el HDD y la cosa no me hace dedicarle demasiado tiempo.

Si no es asi, ya abriré un nuevo hilo con mis problemas

Gracias de nuevo y un saludo a tod@s

+1
0
-1
Imagen de zero_7005
+1
0
-1

Instale el 9.10 hace 2 dias cuando casi habia salido y nada... no me sale el grub 2 me sale un 1.97 BETA...

alguien sabe si es que ahy que activarlo???

x cierto cual consideran el mejor gestor de grub??

Se les agradece las respuestas...

HP DV7-1020us
Windows 7 Ultimate 64 bits
Linux Ubuntu 9.10 64 bits

+1
0
-1

HP DV7-1020us
Windows 7 Ultimate 64 bits
Linux Ubuntu 9.10 64 bits

Imagen de Gabriel_M
+1
0
-1

Hola zer...:

Ese es el Grub 2 actual, 1.97 beta.

Saludos.
Gabriel.



Solo doy soporte para Ubuntu - 6666 - Más malo que el diablo.
+1
0
-1
Imagen de zero_7005
+1
0
-1

Me mojaron como dicen x aca...

En muchos lugares lei eso que lo mejor era instalar de forma limpia el 9.10 (no actualizando), ok lo hice hace 2 dias
hasta lo instale en un Disco duro por aparte donde tengo mi otro sistema operativo, pero no me sale el grub 2
me sale un grub 1.97 BETA... osea... yo baje el disco desde la pagina oficial... no se que pasaria... ya lo actualice y nada el grub sigue
igual de feo... es mas hasta dura mucho en cargar...
alguien sabe si es que ahy que activar algo?

Aprovecho para preguntar cual consideran que sea el mejor gestor de Grub que recomiendan...
Se agradece...

HP DV7-1020us
Windows 7 Ultimate 64 bits
Linux Ubuntu 9.10 64 bits

+1
0
-1

HP DV7-1020us
Windows 7 Ultimate 64 bits
Linux Ubuntu 9.10 64 bits

Imagen de Goyo
+1
0
-1

no me sale el grub 2 me sale un grub 1.97 BETA

Aquí tienes la explicación:

http://www.ubuntu-es.org/?q=node/120290#comment-340844

+1
0
-1
Imagen de Malakaraconk
+1
0
-1

Hola a todos tengo una maquina con ubuntu 9.10 64bits con una particion con guindosXp 64 bits al principio todo muy bien pero de un dia para otro guindos no arranca

me sale el siguiente error
error: invalid signature
press any key to continue...

sin embargo ubuntu arranca bien que es lo que más me importa pero necesito arrancar guindos por tema de vicio "que es para lo único que lo utilizo"

Por otra parte cuando me sale el grub para elegir el S.O veo que ha sufrido un cambio,parpadea el grub,cosa que antes no hacia.

Ha alguien le ha pasado esto???

Un saludo

+1
0
-1
Imagen de Pablo_F
+1
0
-1

Prueba a poner en la terminal:

sudo update-grub2

A ver si se arregla, y si no ya veremos.

+1
0
-1

"Los analfabetos del siglo XXI no serán aquellos que no sepan leer y escribir, sino aquellos que no sean capaces de aprender, olvidar lo aprendido y aprender de nuevo" (Alvin Toffler)

Imagen de Malakaraconk
+1
0
-1

Gracias por responder Pablo_F

Hice el sudo update-grub2,lamentablemente no se ha solucionado me sale lo siguiente en el terminal:

Generating grub.cfg ...
Found linux image: /boot/vmlinuz-2.6.31-14-generic
Found initrd image: /boot/initrd.img-2.6.31-14-generic
grub-probe: error: Cannot find a GRUB drive for /dev/sdb6.  Check your device.map.

grub-probe: error: Cannot find a GRUB drive for /dev/sdb6.  Check your device.map.

Found memtest86+ image: /boot/memtest86+.bin
Found Windows XP Professional x64 Edition on /dev/sdb1
grub-probe: error: Cannot find a GRUB drive for /dev/sdb1.  Check your device.map.

done

Por otro lado,cuando te sale el grub,apretando e puedes editar unos parámetros

esto es lo que me sale dentro de "Windows XP Professional x64 Edition on /dev/sdb1"

drivemap -s (hd0) ${root]
chainloader +1

Saludos!!! y gracias por tu tiempo

+1
0
-1
Imagen de Pablo_F
+1
0
-1

Haz:

locate device.map

cat /ruta/a/device.map

Saludos, Pablo

+1
0
-1

"Los analfabetos del siglo XXI no serán aquellos que no sepan leer y escribir, sino aquellos que no sean capaces de aprender, olvidar lo aprendido y aprender de nuevo" (Alvin Toffler)

Imagen de lambres
+1
0
-1

Hola Pablo_F
me funcionó lo que indicas,
Te cuento que tengo el sistema de esta manera
Actualizé el sistema y al elegir Windows me daba el error: invalid signature

Tengo dos discos, en /dev/sda o (hd0) tengo un disco en NTFS que es IDE el cual lo toma como ptimario antes de los SATA
Luego tengo un Disco SATA en (hd1) que es /dev/sdb
Acá te copio lo que da el fdisk -l
---------------------------------------------------------------------------------
lucia@LUCIA-PC:~$ sudo fdisk -l

Disco /dev/sda: 203.9 GB, 203928109056 bytes
255 cabezas, 63 sectores/pista, 24792 cilindros
Unidades = cilindros de 16065 * 512 = 8225280 bytes
Identificador de disco: 0x026e787a

Disposit. Inicio Comienzo Fin Bloques Id Sistema
/dev/sda1 1 24793 199144448 7 HPFS/NTFS

Disco /dev/sdb: 250.1 GB, 250059350016 bytes
255 cabezas, 63 sectores/pista, 30401 cilindros
Unidades = cilindros de 16065 * 512 = 8225280 bytes
Identificador de disco: 0x88935ab8

Disposit. Inicio Comienzo Fin Bloques Id Sistema
/dev/sdb1 * 1 13 102400 7 HPFS/NTFS
La partición 1 no termina en un límite de cilindro.
/dev/sdb2 13 14661 117657600 7 HPFS/NTFS
/dev/sdb3 14661 29704 120832000 83 Linux
/dev/sdb4 29704 30402 5603328 82 Linux swap / Solaris
-----------------------------------------------------------------------------------
Dentro de ubuntu cuando hacía uodate-grub2 me daba la siguiente salida:
lucia@LUCIA-PC:~$ sudo update-grub2
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-2.6.31-14-generic
Found initrd image: /boot/initrd.img-2.6.31-14-generic
grub-probe: error: Cannot find a GRUB drive for /dev/sdb3. Check your device.map.

grub-probe: error: Cannot find a GRUB drive for /dev/sdb3. Check your device.map.

Found memtest86+ image: /boot/memtest86+.bin
Found Windows 7 (loader) on /dev/sdb1
grub-probe: error: Cannot find a GRUB drive for /dev/sdb1. Check your device.map.

done
----------------------------------------------------------------------------------
En el device.nap, por lo que vos aclarabas, me estaba faltando el (hd1) apuntando a (/dev/sdb)
lucia@LUCIA-PC:~$ cat /boot/grub/device.map
(hd0) /dev/sda
----------------------------------------------------------------------------------
Lo edité y lo agregué quedando:

lucia@LUCIA-PC:~$ cat /boot/grub/device.map
(hd0) /dev/sda
(hd1) /dev/sdb
----------------------------------------------------------------------------------
Actualicé el grub y ahora lo reconoce correctamente
lucia@LUCIA-PC:~$ sudo update-grub2
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-2.6.31-14-generic
Found initrd image: /boot/initrd.img-2.6.31-14-generic
Found memtest86+ image: /boot/memtest86+.bin
Found Windows 7 (loader) on /dev/sdb1
done

y lo mejor es que encima booteo correctamente.

Gracias y espero que pueda ayudar a alguien que tenga el mismo problema.
Me imagino que es un bug del ubuntu, si alguien lo puede informar... se los agradezco,

lambres

+1
0
-1

Uso Código Abierto y Software Libre,
Cada día somos mas....

Imagen de darjo
+1
0
-1

Lo edité y lo agregué quedando:

lucia@LUCIA-PC:~$ cat /boot/grub/device.map
(hd0) /dev/sda
(hd1) /dev/sdb

Tenía el mismo problema (2 discos duros). Agregando "(hd1) /dev/sdb" y rehaciendo el grub se solucionó.

Muchas gracias, me estaba volviendo loco.

+1
0
-1

. Volviendo a Ubuntu 9.10 en AMD Athlon II X2 245 Processor @ 2.9GHz - Nvidia GeForce 9300 GS (Monitor + TV -> sólo con driver 173 que no funciona bien en Lucid).
. Debian Lenny en Notebook Bangho(AR) - Chipset VIA P4M900 + VT8237

Imagen de nobody
+1
0
-1

ya que mensionan grub2, tengo un problema, hice una instalacion en limpio, todo normal pero al reiniciar me da leyenda de error: biosdisk wrute errorf, me gustaria tener una guia de como solventar o hacer para que me arranque ubuntu, porque de presione una tecla para continuar no paso, ya habri un hilo sobre esto pero nadie comenta del asunto, ya me he leido muchos post de como editar el tal grub2 pero todos hacen un enfacis en el puto guindows, lo que me confunde ya que solo quiero los pasos has aqui y el otro, esto para solucionar mi problema.
agradezco mucho cualquier sugerencia.

+1
0
-1
Imagen de dogodo123
+1
0
-1

a mi tampoko me arranca
A mi me pasa lo mismo k a este y tengo una pregunta!
No seria mas facil que si a varias personas les pasa lo mismo, no seria mas facil colgarlo en internet para que lo descarguen lo que tienen este problema en particular???
Yo tengo instalado el ubuntu en el windowns XP, si me meto a grub endisk no deberia aver algo dentro??
(si alguien tiene el (ubuntu 9.10 koala...)k me envie x msn el grub por favor)
xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

¡¡¡¡¡¡AYUDA!!!!!!

+1
0
-1
Imagen de zero_7005
+1
0
-1

Hola como van todos??

Miren yo actualice una vez mi compu del 9.04 64 bits al 9.10 64 y funciono de lo mas bien...
ahora x cosas de la vida se me murio el duro q ya tenia su ratito trabajando y he instalado la version 9.10
el grub2 o mas bien el 1.97 BETA es el q viene en esa y es super feo... bueno igual q el por defecto del 9.04

A los q tienen el 9.10 con el grub 1.97 BETA les dejo esta guia para q cambien la imagen de fondo del grub2, cosa q se hacia con
programas como el ubuntu Tweak super facilmente pero ahora con este nuevo no se puede... x lo menos no encontre un programa decente
para hacerlo.

http://elrincondepachango.blogspot.com/2010/01/linux-ubuntu-modificar-gr...
ahy los espero no olviden postear a ver si les sirvio... lol

HP DV7-1020us
Windows 7 Ultimate 64 bits
Linux Ubuntu 9.10 64 bits
OSX 10.6 Snow Leopard (proximamente)

+1
0
-1

HP DV7-1020us
Windows 7 Ultimate 64 bits
Linux Ubuntu 9.10 64 bits

Imagen de ivancarrerah
+1
0
-1

Estaba requetebien instalando ubuntu por doquier y editando el menu.lst a mi antojo!
Ahora tengo un inicio lento, problemas para editar y ordenar el arranque, y para limpiar entradas obsoletas!
Por favor, como hago para que no se me desinstale el grub en próximas actualizaciones, y para no usar el grub 2 en las nuevas desde disco?

+1
0
-1
Imagen de gameroquai
+1
0
-1

Hola a ver si alguien me puede ayudar, estoy con el mismo problema. Soy muy novato y he leido bastante sobre esto y no me funciona nada.
Aqui os dejo como tengo mis discos duros:

Disco /dev/sda: 160.0 GB, 160041885696 bytes
255 cabezas, 63 sectores/pista, 19457 cilindros
Unidades = cilindros de 16065 * 512 = 8225280 bytes
Identificador de disco: 0x0004252d

Disposit. Inicio Comienzo Fin Bloques Id Sistema
/dev/sda1 * 1 19457 156288321 7 HPFS/NTFS

Disco /dev/sdb: 500.1 GB, 500107862016 bytes
16 cabezas, 63 sectores/pista, 969021 cilindros
Unidades = cilindros de 1008 * 512 = 516096 bytes
Identificador de disco: 0xd92a3277

Disposit. Inicio Comienzo Fin Bloques Id Sistema
/dev/sdb1 2 651940 328577256 f W95 Ext'd (LBA)
/dev/sdb2 651941 969021 159808824 83 Linux
/dev/sdb5 2 645981 325573888+ 7 HPFS/NTFS
/dev/sdb6 645982 651940 3003304+ 82 Linux swap / Solaris

Disco /dev/sdc: 500.1 GB, 500107862016 bytes
255 cabezas, 63 sectores/pista, 60801 cilindros
Unidades = cilindros de 16065 * 512 = 8225280 bytes
Identificador de disco: 0x52f5bd90

Disposit. Inicio Comienzo Fin Bloques Id Sistema
/dev/sdc1 1 60801 488384001 83 Linux

Despues con el comando sudo gedit /boot/grub/device.map Me sale esto:


(hd0)	/dev/sda
(hd1)	/dev/sdb
(hd2)	/dev/sdc

He probado todo lo que decis y no me vale nada. Me da este error constantemente al actualizar el grub:

Generating grub.cfg ...
Found linux image: /boot/vmlinuz-2.6.31-20-generic
Found initrd image: /boot/initrd.img-2.6.31-20-generic
Found linux image: /boot/vmlinuz-2.6.31-14-generic
Found initrd image: /boot/initrd.img-2.6.31-14-generic
Found memtest86+ image: /boot/memtest86+.bin
Found Windows NT/2000/XP on /dev/mapper/nvidia_bbddbbgg1
grub-probe: error: no mapping exists for `nvidia_bbddbbgg1'
done

Perdonar por la edicion del mensaje es que es el primero que pongo, a ver si me podeis echar una mano.

+1
0
-1