WiFi y desconexiones constanstes..

Imagen de Freddie79
0 puntos

Hola a todos!
Lo primero, facilito los datos de mi equipo:
Acer Aspire One AOA 150
Targeta Wifi Atheros AR5007EG
Bien, decir que mi equipo tiene hecho un dualboot, Windows 7 y Ubuntu 9.10, y este problema es exclusivo de Ubuntu, ya que con Windows no sucede..
Os explico, cuando instale Ubuntu quede fascinado, lo noto como mas robusto, mas estable y me da la sensacion de que todo es como menos forzado que en Windows, hasta el punto que creo que voy a quitar Windows definitivamente, la cuestion es que antes de hacerlo he querido probar a hacer todas las cosas que hago con Windows y aqui me di cuenta del problema: tengo varias cuentas de RS y MU, en Windows uso JDownloader, asi que lo instale en Ubuntu, configure las cuentas y me puse a bajar archivos para probar, mi sorpresa fue que el wifi se cae constantemente, lo mismo sucedio al instalar Deluge Torrent y poner a descargar archivos, la red se cae constantemente..
Buscando lei algo de activar los controladores privativos y de terceros, pero al abrir la aplicacion esta busca y me dice simplemente que no se estan usando controladores privativos en este equipo, y no me da opcion de ver los que hay disponibles ni activar nada..
Para navegacion, mensajeria, Skype, Liferea, y todo lo que incluye Evolution ni un solo problema..
Hay alguna solucion a este problema? Que puedo hacer?
La verdad es que esto me jode bastante, pues me gusta mucho Ubuntu y desde que lo instale no he vuelto a pasar por Windows!
Gracias a todos y saludos!

Imagen de CHuLoYo
+1
0
-1

Qué wifi tienes?

lspci
lsusb
lshw | grep network

---------
Marcos Pérez

+1
0
-1
Imagen de Freddie79
+1
0
-1

Hola compi! lo primero, muchas gracias por responder, aqui te pego todo el log con los resultados de los comandos que me has pedido:

root@Fr3ddi3-AAO:~# lspci
00:00.0 Host bridge: Intel Corporation Mobile 945GME Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GME Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2 (rev 02)
00:1c.2 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 3 (rev 02)
00:1c.3 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 4 (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA IDE Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 02)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 02)
03:00.0 Ethernet controller: Atheros Communications Inc. AR5001 Wireless Network Adapter (rev 01)
root@Fr3ddi3-AAO:~# lsusb
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 003: ID 0c45:62c0 Microdia Sonix USB 2.0 Camera
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 046d:c526 Logitech, Inc.
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
root@Fr3ddi3-AAO:~# lshw | grep network
*-network
*-network

He hecho algunas pruebas y he podido comprobar que la red solo se cae cuando uso Wifi, si conecto con el cable de red, no hay problema ni con Torrent ni con JDownloader, pero me va fatal, puesto que como todo lo tengo por wifi, el router esta casi escondido jajaja..
Muchas gracias y saludos!

+1
0
-1
Imagen de CHuLoYo
+1
0
-1

03:00.0 Ethernet controller: Atheros Communications Inc. AR5001 Wireless Network Adapter (rev 01)

Mira si te puede servir la página de linux wireless para instalar los drivers de atheros: ath5k ó ath9k (prueba primero ath5k y si on va, prueba la otra).

http://linuxwireless.org/en/users/Drivers/ath5k
http://linuxwireless.org/en/users/Drivers/ath9k

Por cierto, tienes activados todos los repositorios, backports incluidos? Porque ahí puede estar tu ath5k en controladores de hardware restringidos.

---------
Marcos Pérez

+1
0
-1
Imagen de Freddie79
+1
0
-1

Entiendo que los repositorios son las fuentes de instalacion de software, o sea SISTEMA/ADMINISTRACION/ORIGENES DEL SOFTWARE,correcto? pero he mirado ahi y no veo nada de backports..
Solo hay dos fuentes:
http://archive.canonical.com/ubuntu + el codigo fuente, esta desmarcada, venia asi por defecto y
http://ppa.launchpad.net/tualatrix/ppa/ubuntu + el codigo fuente, pero estas son de cuando instale el ubuntu tweak..
Que tengo que hacer para activar los backports?
De nuevo, muchas gracias compi!
Saludos!

+1
0
-1
Imagen de CHuLoYo
+1
0
-1

Sí, los repos son eso :). Mira, escribe esto en tu terminal:

gksudo gedit /etc/apt/sources.list

Cópialo todo y pégalo aquí.

---------
Marcos Pérez

+1
0
-1
Imagen de Freddie79
+1
0
-1

Bueno, ahi va eso:

# deb cdrom:[Ubuntu 9.10 _Karmic Koala_ - Release i386 (20091028.5)]/ karmic main restricted
# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.

deb http://es.archive.ubuntu.com/ubuntu/ karmic main restricted
deb-src http://es.archive.ubuntu.com/ubuntu/ karmic main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://es.archive.ubuntu.com/ubuntu/ karmic-updates main restricted
deb-src http://es.archive.ubuntu.com/ubuntu/ karmic-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://es.archive.ubuntu.com/ubuntu/ karmic universe
deb-src http://es.archive.ubuntu.com/ubuntu/ karmic universe
deb http://es.archive.ubuntu.com/ubuntu/ karmic-updates universe
deb-src http://es.archive.ubuntu.com/ubuntu/ karmic-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://es.archive.ubuntu.com/ubuntu/ karmic multiverse
deb-src http://es.archive.ubuntu.com/ubuntu/ karmic multiverse
deb http://es.archive.ubuntu.com/ubuntu/ karmic-updates multiverse
deb-src http://es.archive.ubuntu.com/ubuntu/ karmic-updates multiverse

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
# deb http://es.archive.ubuntu.com/ubuntu/ karmic-backports main restricted universe multiverse
# deb-src http://es.archive.ubuntu.com/ubuntu/ karmic-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu karmic partner
# deb-src http://archive.canonical.com/ubuntu karmic partner

deb http://security.ubuntu.com/ubuntu karmic-security main restricted
deb-src http://security.ubuntu.com/ubuntu karmic-security main restricted
deb http://security.ubuntu.com/ubuntu karmic-security universe
deb-src http://security.ubuntu.com/ubuntu karmic-security universe
deb http://security.ubuntu.com/ubuntu karmic-security multiverse
deb-src http://security.ubuntu.com/ubuntu karmic-security multiverse
deb http://ppa.launchpad.net/tualatrix/ppa/ubuntu karmic main
deb-src http://ppa.launchpad.net/tualatrix/ppa/ubuntu karmic main

Bueno, comentarte que he leido los enlaces que me has puesto anteriormente, los de los drivers ath5k y ath9k, y en la lista de dispositivos soportados no aparece el modelo de tarjeta wifi, AR5007EG, aunque veo que en el log anterior es detectada como AR5001..
Menudo lio jajajaja
Gracias y saludos!

+1
0
-1
Imagen de CHuLoYo
+1
0
-1

Vale, copia este texto y pégalo otra vez en tu sources.list:

# deb cdrom:[Ubuntu 9.10 _Karmic Koala_ - Release i386 (20091028.5)]/ karmic main restricted
# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.

deb http://es.archive.ubuntu.com/ubuntu/ karmic main restricted
deb-src http://es.archive.ubuntu.com/ubuntu/ karmic main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://es.archive.ubuntu.com/ubuntu/ karmic-updates main restricted
deb-src http://es.archive.ubuntu.com/ubuntu/ karmic-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://es.archive.ubuntu.com/ubuntu/ karmic universe
deb-src http://es.archive.ubuntu.com/ubuntu/ karmic universe
deb http://es.archive.ubuntu.com/ubuntu/ karmic-updates universe
deb-src http://es.archive.ubuntu.com/ubuntu/ karmic-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://es.archive.ubuntu.com/ubuntu/ karmic multiverse
deb-src http://es.archive.ubuntu.com/ubuntu/ karmic multiverse
deb http://es.archive.ubuntu.com/ubuntu/ karmic-updates multiverse
deb-src http://es.archive.ubuntu.com/ubuntu/ karmic-updates multiverse

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://es.archive.ubuntu.com/ubuntu/ karmic-backports main restricted universe multiverse
deb-src http://es.archive.ubuntu.com/ubuntu/ karmic-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb http://archive.canonical.com/ubuntu karmic partner
deb-src http://archive.canonical.com/ubuntu karmic partner

deb http://security.ubuntu.com/ubuntu karmic-security main restricted
deb-src http://security.ubuntu.com/ubuntu karmic-security main restricted
deb http://security.ubuntu.com/ubuntu karmic-security universe
deb-src http://security.ubuntu.com/ubuntu karmic-security universe
deb http://security.ubuntu.com/ubuntu karmic-security multiverse
deb-src http://security.ubuntu.com/ubuntu karmic-security multiverse
deb http://ppa.launchpad.net/tualatrix/ppa/ubuntu karmic main
deb-src http://ppa.launchpad.net/tualatrix/ppa/ubuntu karmic main

Luego guardas el documento y escribes en la consola:

sudo aptitude update
sudo aptitude safe-upgrade

Luego vete a controladores de Hardware restringidos y compruebalo.

De todas formas, lo intentaría con ath9k .

Un saludo.

---------
Marcos Pérez

+1
0
-1
Imagen de Freddie79
+1
0
-1

Hola compi! Acabo de hacer lo que me has dicho, me he dado cuenta que ahora al buscar actualizaciones descarga 66 archivos en la actualizacion de paquetes frente a los 47 de antes, de todos modos me dice que no hay nada que actualizar, que el sistema esta actualizado, desde terminal me dice que se descargaran 0 paquetes y se usara 0 espacio en disco.
Los controladores de hardware, ahora cuando lo abro no hace el gesto de buscar, simplemente me aparece la ventana sin nada dentro.
Solo por aprender un poco mas, se que he anadido algo a los repositorios, pero.. que he anadido?
En una ocasion, en este mismo portatil probe ubuntu 9.04 y en los controladores privativos me decia algo de madwifi, y use este controlador solo si tiene problemas o no se que rollos, pero no llegue a probarlo.. No recuerdo si mencionaba algo de ath5k o 9k..
Saludos!

+1
0
-1
Imagen de CHuLoYo
+1
0
-1

Simplemente has activado todos los repositorios de canonical oficiales. Es decir, descomentado esas líneas.
Si en vez de aptitude safe-upgrade haces un aptitude full-upgrade ?
Has probado con los ath5k y ath9k?

---------
Marcos Pérez

+1
0
-1
Imagen de Freddie79
+1
0
-1

Estoy leyendo por aqui y por alli, he leido que efectivamente los controladores que tendria que instalar son los ath5k, los cuales venian en Ubuntu 9.04, y en 9.10 o no vienen o no me aparecen por ningun sitio: ni en el Gestor de Paquetes Synaptic, ni en controladores de hardware y mucho menos en el centro de software..
Lo del full upgrade, lo mismo, se descaran 0 paquetes y se usaran 0 mb de espacio.
Saludos!

Edito: estoy leyendo una posible solucion Ndiswrapper, he encontrado un manual pero habla de la version de 8.04 de Ubuntu.. Seria viable en 9.10??
Me da miedo liarla jajajaja

+1
0
-1
Imagen de aladar696
+1
0
-1

hey amigo llegaste a resolver lo del wifi porque tengo el mismo problema en la v10.10 de ubuntu mi adaptador es un atheros ar5001 y ya me canse de buscar sin resultados ayuda

+1
0
-1