Ayuda con synaptic y/o apt-get

Imagen de christian_prez
0 puntos

Hola, muy buena lo primero decir que soy nuevo en este foro, y con Linux llevo un par de añitos, pero con SO basados en debian mas bien un par de meses.

El problema que tengo es el siguiente:

Tengo instalado ubuntu 9.04, y la verad que ningún problema, hasta que instale los escritorios de KDE y Xfce, a partir de ahi siempre que intento instalar cualquier otra cosa via; entorno gráfico o linea de comandos, em da este error:

E: dpkg se interrumpió, debe ejecutar manualmente «sudo dpkg --configure -a» para corregir el problema.

A lo cual, hago lo que me dice y me da esto:

Configurando initramfs-tools (0.92bubuntu29) ...
update-initramfs: deferring update (trigger activated)

Procesando disparadores para initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-2.6.32-020632rc6-generic
Cannot find /lib/modules/2.6.32-020632rc6-generic
update-initramfs: failed for /boot/initrd.img-2.6.32-020632rc6-generic
dpkg: el subproceso post-installation script devolvió el código de salida de error 1

Lo único que me salva de la situación momentaneamente, hasta que instalo algo es una purga, o eso creo. Lo que aplico es:

sudo dpkg -P -a

Tambien probé (apt-get -f install) y nada, el error creo que está en que hace referencia a "/lib/modules/2.6.32-020632rc6-generic"
El cual no tengo, y no sé como cambiar la referencia al modulo que tengo que es el "2.6.28-16-generic"

Probe a buscar la info por Goolge y demás foros, incluido aqui, y ya que no encontré la solución, pues me vi exponerlo aquí.

Espero que me podais ayudar y tb os pido una respuesta que no sea del tipo mira aqui a ver si te vale, necesito algo a tiro fijo.

Muchisimas gracias por adelantado.

Imagen de TheGodDemon
+1
0
-1

Copia en la terminal: sudo dpkg --configure -a , eso deberia bastar ,sino trata de instalar usando aptitude , como superusuario: sudo su , y luegos : aptitude install nombredelprograma.

+1
0
-1

gnulinuxfacil.blogspot.com

Imagen de jigoita
+1
+1
-1

Creo que es porque instalaste un kernel compilado por tí mismo, y luego lo borraste.

Esto es lo que puedes hacer:

sudo update-initramfs -d -k 2.6.31.4-custom

donde 2.6.31.4-custom es la versión del kernel que te da fallos, en tu caso creo que debes poner 2.6.32-020632rc6-generic

ojo! asegúrate de que ese kernel no es el que estás usando, porque haciendo el update-initramfs -d, lo que intentas es quitar los vestigios del kernel problemático que te queden por ahí.

si el update-initramfs te da un fallo, tal como:
Cannot delete /boot/initrd.img-2.6.31.4-custom, doesn't exist.

pues creas el archivo:
sudo touch /boot/initrd.img-2.6.31.4-custom

y pruebas otra vez el update-initramfs. Te lo digo porque yo tuve el mismo problema y así se me solucionó.

Un saludo

+1
+1
-1
Imagen de christian_prez
+1
0
-1

Efectivamente jogoita, se me solcionó como bien dices, jejeje pero lo fui averiguando con el comando MAN, y jugueteando con ello, y a base de ir por foros de Debian.

Muchisimas gracias por tu ayuda.

+1
0
-1