Tor - Vidalia (error al iniciar)

Imagen de skarevoluti
0 puntos

He instalado los paquetes tor, vidalia y polipo en mi Ubuntu karmic koala.

Al tratar de iniciar tor tanto desde vidalia como desde la terminal me sale el siguiente error:

manuel@manuel-laptop:~$ tor
Nov 16 22:02:30.165 [notice] Tor v0.2.1.20. This is experimental software. Do not rely on it for strong anonymity. (Running on Linux x86_64)
Nov 16 22:02:30.168 [notice] Initialized libevent version 1.4.11-stable using method epoll. Good.
Nov 16 22:02:30.168 [notice] Opening Socks listener on 127.0.0.1:9050
Nov 16 22:02:30.168 [warn] Could not bind to 127.0.0.1:9050: Address already in use. Is Tor already running?
Nov 16 22:02:30.168 [warn] Failed to parse/validate config: Failed to bind one of the listener ports.
Nov 16 22:02:30.168 [err] Reading config failed--see warnings above.

no se cual es el problema, probe reinstalando tor, pero no funcionó

agradezco mucho la colaboración al respecto.

Imagen de jrnogues
+1
0
-1

Hola,

Could not bind to 127.0.0.1:9050: Address already in use. Is Tor already running? <-Vidalia no puede abrir el puerto 9050 porque lo esta usando tor. Mata el proceso y después ejecuta vidalia.

Saludos.

+1
0
-1
Imagen de vedovatti
+1
0
-1

Ejecuta el comando:

sudo update-rc.d -f tor remove

Y reinicia el ordenador.

Después ejecuta el Vidalia y debería funcionar.

Suerte

+1
0
-1
Imagen de skarevoluti
+1
0
-1

muchas gracias por tu ayuda, lo probaré; tambien he pensado que puede ser el problema que esten instalados polipo y privoxy. probaré ambas cosas y les contaré. gracias de nuevo.

+1
0
-1
Imagen de JAVI52
+1
0
-1

Hola, llevo un par de días con este problema y no consigo solucionarlo, he leído y probado todo lo que he podido pero ya no me keda mas..:(

Tengo tor para que no se ejecute al inicio, he probado con rcconf, sudo update-rc.d -f tor remove, he mirado los puertos con netstat, lo he desisnstalado todo, lo he vuelto a instalar, he probado todo lo googleado, etc..:S (tmb deshabilité privoxy y polipo para que no arranquen al inicio pero tampoco)

Alguien sabe que puede ser, o al menos ver que programa está ocupando ese puerto?

(ed:tmb configuré privoxy con forward-socks4a / localhost:9050 .
la versión lucid usuando ubuntu10.10)

+1
0
-1
Imagen de Megaliz
+1
0
-1

¿Tienes el Boot-Up Manager? Si no lo tienes entonces:
$ sudo aptitude install bum

Ejecútalo: Sistema -> Aministración -> Boot-Up Manager o desde terminal $ sudo bum

Desactiva la casilla Anonymizing overlay network for TCP

Aplicas y listo, Tor no se ejecuta al iniciar sistema sino con Vidalia.

Espero que te sirva.

+1
0
-1
Imagen de rogerenrique
+1
0
-1

Maestroooo!!!!

+1
0
-1
Imagen de cololombardi
+1
0
-1

Sos un Megagroso, llevaba ya varios dias tratando de resolverlo y nada, hasta que pude encontrar tus sabias palabras, muchas gracias por compartirlo.

+1
0
-1