problemas emulando una trajeta de red a traves de usb

Imagen de kOz
kOz
0 puntos

Hola!!

Como soy nuevísimo, pues, como no, una pregunta para estrenarme como usuario.

Tengo ubuntu sin internet, ya que la castaña de portatil donde lo he instalado no tiene tarjeta de red, ni wireless, el winmodem q tiene incorporado no lo reconoce... etc etc. (si me decis que intente configurar el winmodem, lo he hecho x activa y x pasiva y no ha habido exito).
Entonces, como para actualizar repositorios y demas, hay que estar conectado a internet, voy a enchufarlo en casa de un amigo que tiene un router (thomson speedtouch (el que da wanadoo para los 20 megas)) con el que puedes conectarte a traves de el via usb y via ethernet.

Bueno (vaya parrafada que os estoy soltando para ser mi primer post), pues lo quiero conectar por usb, pero antes me he estado informando, y he encontrado dos formas buscando en esta pagina: una es instalando el eagle-usb y el rp-pppoe o algo asi, que lo he hecho y otra, un COMO que he encontrado del usuario caravena: http://www.ubuntu-es.org/node/7184 . Entonces, no se cual me recomendais , la primera opcion ya la tengo hecha, no he conseguido instalar el eagle-usb-2.0, pero instale el que me venia por defecto en ubuntu buscando en el synaptic, no se si valdra esta opcion, porque no se si es para modems ADSL o para todos (lo voy a enchufar (enchufar=conectar) a un router). Y la opcion del COMO de carvena (he seguido los pasos unas 3 veces), el comando insmod me da un error:

insmod: error inserting '/lib/modules/2.6.12-9-386/kernel/drivers/usb/net/usbnet.ko':
-l Unknown symbol in module

Como solo una de las dos opciones me funciona, pues eso, cual me recomendais, o que le pasa al insmod, o no es ninguna de estas dos y hay otra opcion o hay otra alternativa...

En fin, quiero enchufarlo a internet ya!!!! que no puedo instalar nada y me estoy empezando a estresar...

Gracias por vuestra atención y perdonad mi frustacion :P

Un saludo

Imagen de gabiel
+1
0
-1

La opción de usar rp-pppoe no es válida, puesto que te vas a conectar mediante un router, no directamente. En cuanto al error con insmod, es posible que el módulo usbnet dependa de otro, para que se cargue automáticamente utiliza modprobe (que es la forma recomendada de cargar módulos), basta con un sudo modprobe usbnet para cargar el módulo.

Después tan solo tendrás que enchufar el cable y configurar el interfaz de red, en este caso será /dev/usb0

Saludos.

--------
Para ver mi firma rasca aquí ===> ||||||||||||||||||||||||||||||||
Para ver algo más interesante, haz clic aquí.
Jabber ID: gabiel@jabber.org

+1
0
-1