Instalé 9.10 y no puedo iniciar con Windows (Solucionado)

Imagen de Chuqui
0 puntos

Hola amigos,

Cuando formateé mi PC, instalé primero Windows XP y luego Ubuntu 9.10. Hay veces en que necesito un par de aplicaciones de Windows, y ahora es uno de esos momentos. Lo extraño es que al encender el PC no me da la posibilidad de elegir, como sí me ocurría con distros anteriores.

¿Cómo puedo solucionar el problema?

Saludos y gracias.

Imagen de DavoX
+1
0
-1

Holas, soy nuevo y no se si esto te podria ayudar... a lo que entiendo es que cuando prendes la computadora no te da opcion y solo se va a ubuntu... alomejor deberias configurar algo en Sistema - Administracion - Administrador de arranque como el tiempo de espera. Perdon si la informacion es miy obsoleta, pero vi la oportunidad de ayudad y no dude :D ... espero te sirva de algo..

+1
0
-1
Imagen de tor-quemao
+1
0
-1

Es muy posible que el tiempo de espera de la pantalla de Grub sea demasiado corto. Cuando se cargue la Bios prueba a dar constantemente a alguna tecla de desplazamiento o mejor instala startupmanager. Lo tienes en los repositorios. Con eso puedes modificar el tiempo de espera de la pantalla de Grub, hacer que se muestre o no al inicio y alguna cosa más.

Si ese no es el problema, prueba a hacer esto:
$ sudo os-prober

$ sudo update-grub2

Así te debería reconocer automáticamente Windows y actualizar el menu.lst de forma que la próxima vez que reinicies te encuentres la opción de arrancar windows.

Saludos.

+1
0
-1
Imagen de sordoman
+1
0
-1

Si no te funciona la propuesta de tor-quemao, simplemente manten apretada la tecla "shift" o mayusculas y tendria que arrancanrte el grub por c.....

suerte

+1
0
-1
Imagen de Chuqui
+1
0
-1

@DavoX el admin de arranque no lo tenía, entonces lo instalé siguiendo el consejo de @tor-quemao, pero aunque le pongo 10 segundos, no me ofrece la opción de elegir al bootear.

@tor-quemao hice todo lo que me dijiste y no me muestra Window$ en el arranque. Los seteos de mi startupmanager son:

- tiempo en segundos: 10
- Default operating system: Ubuntu, Linux 2.6.31-14-generic
- Display: me imagino que da igual
- Misc: tengo chequeado "show text during reboot" y sin chequear "show boot splash"

@sordoman mantuve presionada la tecla shift, luego la mayúscula durante el arranque y no me da la opción de iniciar con Windows...

¿Alguna sugerencia?

Gracias!

+1
0
-1
Imagen de tor-quemao
+1
0
-1

Ya sé que es una pregunta tonta pero ¿al instalar Karmic no habrás dejado marcada la opción de usar el disco completo? Supongo que no, claro está.

En todo caso ¿cuando ejecutas $ sudo os-prober te aparece en la ventana de la terminal Windows como sistema detectado?

Despues, cuando actualizas el grub ¿te aparece Windows entre los sistemas que ha cargado en el menu.lst o como se llame en Karmic?

¿Estás usando Grub2, claro está?

En las opciones de startup manager ¿te aparece windows? me refiero al menú en el que eliges el OS por defecto

+1
0
-1
Imagen de Chuqui
+1
0
-1

Estimados,

Aquí van dos screenshots. Una del $ sudo os-prober y otra del Startup Manager. A ver si encuentran algo raro.

Gracias nuevamente.

+1
0
-1
Imagen de tor-quemao
+1
0
-1

Has puesto la imagen de update grub, no la de os-prober, pero en cualquier caso ahí también debería aparecer Windows.

Mira, por ejemplo, en mi sobremesa tengo Ubuntu 9.4 y en una partición de 30 gigas, Ubuntu 9.10. Si lanzo desde la 9.4 el os-probe, esto es lo que me aparece:

per@per-desktop:~$ sudo os-prober
/dev/sda6:Ubuntu 9.10 (9.10):Ubuntu:linux
per@per-desktop:~

Es decir, ha detectado la instalación de Karmic. Es ahí donde a ti te debería aparecer Windows, pero parece no estar por ninguna parte. ¿Estás seguro que al instalar Karmic no le digiste que ocupara todo el disco?

Ve a "Lugares", en el menú de Ubuntu y mira a ver si te aparece una unidad de disco con el tamaño que dejaste para Windows. Pica en ella. Te pedirá contraseña de Root. La escribes y comprueba que los archivos de Windows siguen ahí.

+1
0
-1
Imagen de Subdes
+1
0
-1

Bueno a mi me ha pasado algo similar.

Llevo todo el dia intentando hacer un Hidden menu del grub2 en 9.10
Y no se porque me ha dado por hacer

sudo os-prober

Y cuando e actualizado grub me ha desaparecido XP.

Lo curioso es que cuando ejecuto

sudo os-prober

Me sale de esta forma:

subdes@subdes-laptop:/$ sudo os-prober
/dev/sda1:Microsoft Windows XP Professional:Windows:chain

pero cuando hago sudo update-grub2 no me lo reconoce...

Salud. ;)

+1
0
-1

Lenovo 3000 N100 Rulando a tope con Hardy!!!

Imagen de Subdes
+1
0
-1

Solucionado.
De primeras he hecho lo que he visto en un foro de Debian, que era crear un Script en /etc/grub.d
pero cuando hacia
sudo update-grub2

No me aparecia, aunque al reiniciar si me muestra el XP y me lo arranca sin ningun problema, pero cuando me metia en el startupmanager no lo podia ver y a base de enredar...
Me he dado cuenta que el 30_os-prober se le habia ido el permiso de ejecucion.
Asi pues se lo he vuelto a dar, he eliminado el script que habia creado de windows y al hacer sudo update-grub

Ya me aparecia el XP y asi poder verlo en el startupmanager.

Asi pues gracias de todas formas :D

Salud. ;)

+1
0
-1

Lenovo 3000 N100 Rulando a tope con Hardy!!!

Imagen de Chuqui
+1
0
-1

Hola de nuevo a todos, especialmente a @tor-quemao

Vuelvo a la carga. Logré que me mostrara las opciones al inicio (ver screenshot), apretando muy rápidamente la tecla shift, sin parar. Pero no me muestra Windows. Estoy 100% seguro de que lo instalé antes de Ubuntu y de que está ocupando el espacio que le corresponde...

Sin embargo, parece que lo he perdido. ¿Qué dicen? ¿Se les ocurre algo que no sea volver a instalar ambos sistemas desde cero? ¿Por qué podría haber pasado esto?

Un abrazo.

+1
0
-1
Imagen de angelverde
+1
0
-1

Re-instala Grub.
****************************************************************
| El tux Angelverde « Un entusiasta Gnu/Linux/Ubuntero http://angelverde.info |
****************************************************************

+1
0
-1
Imagen de Chuqui
+1
0
-1

Hola nuevamente,

Instalé Grub. Digo instalé y no re-instalé porque al parecer no estaba instalado. Le di sudo apt-get install grub y lo hizo sin problemas.

Luego le di sudo gedit /boot/grub/menu.lst y me abre el archivo menu.lst en el gedit, pero está vacío. No hay absolutamente nada. Se supone que ahí deberían estar el menú de arranque o algo así, ¿correcto?

Ahora no sé qué más hacer. Y lamentablemente hay 2 programas de Windows que necesito usar (para lo cual pretendo usar VirtualBox). No quiero tener que reinstalar Windows y Ubuntu, por todo el tiempo que implica respaldar archivos y porque no tengo la seguridad de que esto no volvería a ocurrir... :(

Saludos!

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

Hola chu...:

Aparentemente el Grub2 esta dando muchas fallas, que hacen perder
tiempo en solucionarla y genera mucha angustia por no poder
iniciar los sistemas, te sugiero cambies tu Grub2 (1.97) por el
Grub Legacy (0.97)

Ejecuta en una consola (Aplicaciones - Accesorios - Terminal)

sudo su
cp /etc/default/grub /etc/default/grub.old
cp -R /etc/grub.d /etc/grub.d.old
cp -R /boot/grub /boot/grub.old
apt-get purge grub2 grub-pc
apt-get install grub
update-grub
grub-install /dev/sda
reboot

Saludos.
Gabriel.



Solo doy soporte para Ubuntu - 6666 - Más malo que el diablo.
+1
0
-1
Imagen de Chuqui
+1
0
-1

Hola nuevamente a todos. Seguí las instrucciones de Gabriel. Ejecuté línea por línea (supongo que así había que hacerlo), aunque debo reconocer que no sé en qué momento instala la versión antigua del Grub...

En fin... reinicié y ahora me da 2 segundos para presionar "Esc" y decidir alguna de las opciones que se ven en esta imagen. Es un avance, creo, pero no veo Windows por ningún lado.

Saludos!

(p.d. me gusta más la firma "Solo doy soporte para Ubuntu - 667 - Más malo que el diablo.")

xD

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

Hola chu...:

Averigua su partición ejecutando:

sudo fdisk -l (es ele minuscula)

Luego editas el menu.lst

sudo gedit /boot/grub/menu.lst

Y le agregas su entrada:

title Windows 
rootnoverify (hd0,0)  ---- /dev/sda es hd0 y /dev/sda1 es 0
makeactive
chainloader +1
boot

Saludos.
Gabriel.



Solo doy soporte para Ubuntu - Hay tres clases de personas - Las que saben contar y las que no.
+1
0
-1
Imagen de Chuqui
+1
0
-1

Hola Gabriel,

No supe identificar la partición. Esto es lo que me da el sudo fdisk -l

Disk /dev/sda: 120.0 GB, 120034123776 bytes
255 heads, 63 sectors/track, 14593 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x4ed24ed2

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1        5099    40957686    7  HPFS/NTFS
/dev/sda2            5100       14593    76260555    5  Extended
/dev/sda5            5100       14222    73280466   83  Linux
/dev/sda6           14223       14593     2980026   82  Linux swap / Solaris

Disk /dev/sdb: 120.0 GB, 120034123776 bytes
255 heads, 63 sectors/track, 14593 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x946085f4

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1               1       14593   117218241    c  W95 FAT32 (LBA)

No sé si es el que dice HPFS/NTFS (sda1) o el que dice Extended (sda2). Luego, no sé exactamente qué debo poner (ni donde) en el archivo menu.lst, que puedes ver aquí.

Una vez más, muchas gracias.

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

Hola chu...:

title Windows 
rootnoverify (hd0,0)
makeactive
chainloader +1
boot

Esta es la entrada para tu Windows

Saludos.
Gabriel.



Solo doy soporte para Ubuntu - Conozco muchas frases ingeniosas, pero no las recuerdo - Alzheimer.
+1
0
-1
Imagen de Chuqui
+1
0
-1

Hola Gabriel,

Gracias por la respuesta. Te has pasado. Mi primera duda es si eso lo escribo tal como están los otros 6 "title" o sobreescribo el siguiente?

title Chainload into GRUB 2

root f9579283-6dc7-4d5e-a7ec-48c3807590f7

kernel /boot/grub/core.img

Y me pregunto si después de eso veré las 2 opciones (Ubuntu y Windows) al iniciar, o debo hacer algo más. Por otro lado, actualmente tengo apenas 2 segundos para apretar "Esc" al iniciar y elegir, pese a que en el Startup Manager lo tengo configurado para 10 segundos.

Saludos y nuevamente gracias a todos por la ayuda.

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

Hola chu...:

1- Si no piensas volver al Grub2, sobreescribe esa opción.

2- Busca en el menu.list la opción
timeout
y aumenta el valor

Saludos.
Gabriel.



Solo doy soporte para Ubuntu - 6666 - Más malo que el diablo.
+1
0
-1
Imagen de Chuqui
+1
0
-1

Hola!

Gracias a toda la ayuda que recibí, el problema está solucionado.

Gracias!

+1
0
-1
Imagen de totoafrica
+1
0
-1

Hola gabriel, disculpa que te moleste pero he tenido un problema muy similar al de chuqui, al iniciar mi pc tampoco me da la opcion de windows, y sin embargo me da la opcion de 2 ubuntu (igual que el screenshot de chuqui)
Soy muy nuevo en esto y la verdad me cuesta mucho entenderlo, esto me dice la terminal, que deberia hacer??

Disco /dev/sda: 200.0 GB, 200049647616 bytes
255 cabezas, 63 sectores/pista, 24321 cilindros
Unidades = cilindros de 16065 * 512 = 8225280 bytes
Identificador de disco: 0xb7fbe1b5

Disposit. Inicio Comienzo Fin Bloques Id Sistema
/dev/sda1 * 1 192 1541216 0 Vacía
/dev/sda2 * 193 23673 188611132+ 7 HPFS/NTFS
/dev/sda3 23674 24321 5205060 5 Extendida
/dev/sda5 * 23674 24286 4923891 83 Linux

Disco /dev/sdb: 8032 MB, 8032092160 bytes
5 cabezas, 32 sectores/pista, 98048 cilindros
Unidades = cilindros de 160 * 512 = 81920 bytes
Identificador de disco: 0x00000000

Disposit. Inicio Comienzo Fin Bloques Id Sistema
/dev/sdb1 * 51 98048 7839808 c W95 FAT32 (LBA)

Desde ya muchas gracias!!

+1
0
-1
Imagen de guillermosolana
+1
0
-1

Hola!! a mi tambien me paso lo mismo, no tengo la opcion de elegir con que sistema entar, Yo no se mucho pero me parece que esto es un tema del grub. si alguien sabe reprogramar o configurar el grub porfa que nos tire una ayuda!!

+1
0
-1