problemas con HP DeskJet 400

Imagen de JMRG
0 puntos

Resulta que Ubuntu es tan bueno que ya incluye los drivers de mi HP Deskjet 400 y al agregarla crea una cola de impresión y todo. Pero a la hora de imprimir se queda en blanco, es decir no reacciona, no responde o no manda información a la impresora con lo que no hace nada de nada. ¿Alguien tiene respuesta a este problema? Gracias por adelantado.

Imagen de antequera
+1
0
-1

A mi me pasa lo mismo. he pasado por #ubuntu-es y he acabado en una pagina con instrucciones en ingles.

http://hpinkjet.sourceforge.net/install.php

he llegado al final y esto me sale,

root@aio:/home/ # sudo hp-setup -a

HP Linux Imaging and Printing System (ver. 0.9.9)
Printer/Fax Setup Utility ver. 1.2

Copyright (c) 2003-6 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

[ERROR]: No devices found.
[ERROR]: Error occured during interactive mode. Exiting.
root@aio:/home/ana/2006 #

manyana sigo

+1
0
-1
Imagen de antequera
+1
0
-1

lsmod | grep parport
parport_pc 31812 1
parport 32072 2 parport_pc,lp

si haces un: echo "hola mundo" > /dev/lp0

imprime "hola mundo" sin comillas

pero

cat archivo.txt > /dev/lp0

no funciona

habria que configurar el cups y es lo que te falla. cups es el controlador de impresoras en linux. CUPS = Common Unix Printing System.

Instalando la impresora. System - administration - printers. Primero quito la que tengo puesta.
cuando le doy a impresora nueva se abre la ventana tipica. le doy a new printer.

type: local printer.

Deberia salir una lista de impresoras detectadas. Pero sale:

printer port:
hp no_device_found

en donde dice use a detected printer, dice:
no printers detected

le doy a ...

"use another printer by specifying port"

le doy a paralell port #1

elijo la deskjet 400

sale un boton: driver: hpijs (recommended)

elijo ese y le doy a aplicar sin instalar driver. y entonces que pasa? que desaparece la ventana. y en la del printer, aparece hp 400 ready. Pero luego voy al openoffice, o a gedit, o la pagina de pruebas de la impresora y ocurre lo siguiente:

la lucecita que me dice que la impresora esta encendida empieza a flashear
la impresora hace un ruido tenue
el cartucho se desplaza hasta la mitad del carro
y la lucecita que en teoria me dice que el cartucho esta vacio flashea
ha petado

el cartucho esta lleno

ahora apagare la impresora, y cuando la encienda, imprimira caracteres raros, o lineas gruesas

Hasta aqui sin buscar el driver. Tambien se puede uno bajar un driver. se le baja, y en ubuntu suele quedar en el escritorio. Se le da al "forward", y sale una lista de marcas de impresoras. elijo hp,y sale lista de modelos. doy al 400... install driver.. me deja buscarlo...

HP_Deskjet_400-jpijs.ppd

pero cuando uso el driver que me he bajado pasa lo mismo que he descrito arriba exactamente.

Otra orden en consola:
dmesg | grep -i "lp"

$ dmesg | grep -i "lp"
[4294667.296000] On node 0 totalpages: 63472
[4294667.557000] Calibrating delay loop... 1314.81 BogoMIPS (lpj=657408)
[4294669.127000] ACPI: Power Resource [LPTP] (off)
[4294669.142000] PCI: If a device doesn't work, try "pci=routeirq". If it helps, post a report
[4294669.566000] PCI0 UAR1 UAR2 USB USB1 AC9 MC9 SLPB
[4294669.763000] Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
[4294700.158000] lp0: using parport0 (interrupt-driven).
[4294718.730000] eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
[4294727.538000] ACPI: Sleep Button (CM) [SLPB]

aqui,

4303219.517000] lp: driver loaded but no devices found

deberia decir que si tengo 'device'

conectada esta, los datos le llegan, imprime, .... que falla? el software de impresion. tiene que ser algo de cups.

http://anap.co.nr

+1
0
-1