problemas con teclado, teclas euro y arroba

Imagen de cucarin
0 puntos

hola, soy nuevo en el foro aunque llevo registrado algun tiempo y he leido bastante. Vengo de suse, despues pase a debian sarge y por problemas me baje la version de ubuntu brezy, la 5.10 creo que es, la cual me ha encantado y con la que me gustaria quedarme, pero resulta que el teclado no logro configurarlo para que las teclas de euro y arroba me funcionen.
he estado desde ayer navegando y leyendo pero todo lo que pruebo no me resulta, cada vez que cambio una opcion en el teclado me sale un error que dice:
error al activar la configuracion XKB.
podria deberse
a un fallo en la biblioteca libxklavier
a un fallo en el servidor x
y algo mas que no recuerdo, el caso que tanto en suse como en debian nunca tube problemas con el teclado.
ah otra cosa, antes tampoco me funcionaba la tecla ñ pero ya consegui que funcione.
si escribo en openoficce writer por ejemplo cuando doy altgr+E se me abre la pestaña editar en vez de escribir el euro.
ya he reconfigurado las locales y todo pero no doy con el tema.

bueno estoy a vuestra entera disposicion ya que me ha gustado mucho ubuntu y me gustaria estancarme en el una larga temporada.

un saludo.

Imagen de Everio
+1
0
-1

Pues no se a ke se deba tu problema o como es ke kieres ke funcione el arroba, con ke conbinacion ?, pero tal vez puede ser por ke no esta instalado el livxklavier, entra en Synaptic e instalalo si no esta instalado y tambien instala el livxclavier-dev. Haber si asi funciona.

Me dices a ver ke pasa !! Byes

+1
0
-1
Imagen de cucarin
+1
0
-1

bueno concretamente esto es lo que me sale al intentar modificar algo del teclado:
Error al activar la configuración XKB.
Podría deberse a varias circunstancias:
- un fallo en la biblioteca libxklavier.
- un fallo en el servidor X (utilidades xkbcomp, xmodmap)
- Un servidor X con una implementación incompatible con libxkbfile

Datos de la versión del servidor X:
The X.Org Foundation
60802000

Si informa de esta situación como un fallo, por favor incluya:
- El resultado de xprop -root | grep XKB
- El resultado de gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
con synaptic no me salen resultados para instalar nada de esto y respecto a lo de la arroba y el euro , en las demas distribuciones me han funcionado al teclear altgr+E para el euro y para la arroba alt gr+2
aunque ya he probado tecleando varias formas mas pero sin resultado.
las teclas con tres caracteres no van ninguna, ni arroba ni euro ni almoadilla...

saludos.

+1
0
-1
Imagen de FedeTheGreat
+1
0
-1

tenes el mismo problema que yo, tenes que seleccionar en tu xorg.conf que tipo de funciones va a tener tu teclado, yo todavia no averigue como pero hay un comando que hace eso junto con algunas cosas mas:
sudo dpkg-reconfigure xserver-xorg

Linux User #404818

+1
0
-1

Me gustan las cosas simples por eso uso Arch!
Linux User# 404818

Imagen de FedeTheGreat
+1
0
-1

ya lo solucione, tenia que elegir "nodeadkeys" cuando ejecutaba sudo dpkg-reconfigure xserver-xorg

Agregado:
no esta todo bien... me acabo de dar cuenta que perdi el tilde para marcar los acentos ahoar me aparece:"´i" en ves de sobre la i.....
alguien sabe esactamente que opciones de teclado debo elegir cuando configuro el xorg?
"\ | @ # € [ ] { }" estas son las teclas de tercera linea que funcionan con el Alt Gr.

Linux User #404818

+1
0
-1

Me gustan las cosas simples por eso uso Arch!
Linux User# 404818

Imagen de cucarin
+1
0
-1

pues navegando, navegando he encontrado por ahi que parece ser algo relacionado con un bug pero ninguna solución...me cachis...

espero que podamos encontrar pronto una solución.
yo todas las que he encontrado las he probado y nada de nada.
si quereis buscar por error xkb y vereis en google todos los temas que hay relacionados con esto.

saludos.

+1
0
-1
Imagen de Anónimo
+1
0
-1

La solucion posible está en EL IDIOMA DEL TECLADO.
Hacemos lo siguiente:
Panel de Control
Teclado
Idioma
Si aquí el idioma que viene no es "Español (España)", este es el problema.
Pinchamos Agregar
Buscamos en la lista Español (España)
Pinchamos Aceptar y en la pestaña idioma aparecerán ahora dos idiomas. Seleccionamos el que NO ES "Español (España)" y aceptamos todo...
¡ Venga a comprobar que funciona!

+1
0
-1
Imagen de Anónimo
+1
0
-1

Yo tengo el mismo problema.
Alguien encontró una solución?

Al que dejó el comentario anterior: al hacer eso es cuando pone "Error al activar la configuración XKB." etc, etc.

+1
0
-1
Imagen de potezno
+1
0
-1

Despues de muchas vueltas lo logré, puse lo siguiente en xorg.conf y luego reinicié:

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "keyboard"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "es"
EndSection

Espero q a vosotros tmb os sirva. Un saludo

+1
0
-1
Imagen de Anónimo
+1
0
-1

Yo tenía el mismo problema con Dapper. Mi teclado no reconocia la ñ ni la tecla ALT GR. Cuando queria corregir la configuración me daba el siguiente error:

Error al activar la configuración XKB.
Podría deberse a varias circunstancias:
- un fallo en la biblioteca libxklavier.
- un fallo en el servidor X (utilidades xkbcomp, xmodmap)
- Un servidor X con una implementación incompatible con libxkbfile

Datos de la versión del servidor X:
The X.Org Foundation
70000000

Si informa de esta situación como un fallo, por favor incluya:
- El resultado de xprop -root | grep XKB
- El resultado de gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd

Después de probar sin éxito todos los remedios expuestos en este y otros foros, Lo solucione cambiando la carpeta /etc/X11/xkb completa por la de otro ordenador correctamente configurado.
Si le interesa a alguien he colgado la carpeta xbk en http://www.e-ikasgela.net/xkb.tar.gz

+1
0
-1
Imagen de Anónimo
+1
0
-1

En la Consola.

sudo setxkbmap -layout 'es,es' -model pc105

No hay que comerse tanto la cabeza, linux no es dificil hay gente que se quiere complicar la vida que no es li mismo.

+1
0
-1
Imagen de Anónimo
+1
0
-1

Que tontería más grande has dicho. Puede que Linux no sea complicado, pero tu metodo "infalible" no funciona si el fallo está en xkb, y al fin y al cabo es donde está el problema.

+1
0
-1
Imagen de Anónimo
+1
0
-1

Sistema/Preferencias/Teclado/Distribuciones

Modelo de teclado: PC 105
Distribucion: (La de su teclado)

Listo, a otro tema.

+1
0
-1
Imagen de Anónimo
+1
0
-1

Tengo el mismo problema...

Vale ya de dar soluciones como la de

Sistema/Preferencias/Teclado/Distribuciones

Modelo de teclado: PC 105
Distribucion: (La de su teclado)

Que el problema es el fallo que da al intentar hacer eso mismo...

Ya estoy pensando que tendré que reinstalar Ubuntu Linux (por cierto que con la versión 5.10 todo iba bien...)

+1
0
-1
Imagen de Anónimo
+1
0
-1

Tengo un Laptop con tecla latinaamerica - pero parece que hay dos:

Sistema/Preferencias/Teclado - PC genérico 105 teclas (intl) - Latino america Eliminar teclas muertas
Sistema/Preferencias/Teclado - PC genérico 105 teclas (intl) - Latino america

Mi computadora de escritorio tiene lo de Latino america y parece que funcciona bien
Mi Laptop tiene lo del 'Eliminar teclas muertas', donde los simbolitas de çÇ´`^ tienen otra configuracion.

Pero si quiero poner un acento - checa que pasa: ´o´a El acento ya no va encima de la letra!
Que onda con esa configuraci´on!
Se puede reparar ´o hay actualizaciones???

Alguien mas tiene este problemita?

AndreasS

+1
0
-1
Imagen de Anónimo
+1
0
-1

este es para España

sudo setxkbmap -layout 'es,es' -model pc105

Este es para LatinoAmerica

sudo setxkbmap -layout 'es,la' -model pc105

Si sabes cual es el modelo de teclado ... bueno pues en lugar de pc105 se pone el modelo correcto y no ese que es generico

y ese problema esta cuando se modifica el xserver-xorg
y no se configura el teclado de manera correcta por que no saben lo que estan haciendo
cosa que tambien pasa en windows.

+1
0
-1
Imagen de Anónimo
+1
0
-1

Simplemente en las propiedades del teclado, metanse en el apartado que dice layout options, en español no recuerdo como es jeje y pues ahi donde dice selector del tercer nivel, significa que la arroba es una tecla pero del tercer nivel, por lo general en los latinos la tecla Q en algunos la tecla 2, no importa ahi le buscan, y ya seleccionan que tecla quieren que active el tercer nivel y ya con eso tienen todo listo

+1
0
-1
Imagen de Anónimo
+1
0
-1

Primero reemplacé mi carpeta /etc/X11/xkb por esta: http://www.e-ikasgela.net/xkb.tar.gz, que nos facilitó Anónimo en este mismo hilo y luego sencillamente en la consola:

$ sudo setxkbmap -layout 'es,es' -model pc105

Y solucionado mi problema.

Ahora, no tengo la menor idea cual era realmente el problema, eso deberá estudiarse más a fondo, pero más adelante, ahora me cansé.

Saludos.

ah perdón no ingresé con mi cuenta:

Saludos kike1965 :-)

+1
0
-1
Imagen de Kike1965
+1
0
-1

Como al iniciar continuaba con el problema y me salía un mensaje de error, puse en Sesiones>Programas de inicio 'setxkbmap -layout 'es,es' -model pc105', pero aún así persistía el mensaje de error al arrancar la máquina, aunque mi configuración de teclado funcionaba bien, entonces ingresé al método de entrada SCIM y en interfaz>configuración local, seleccioné 'Distribución del teclado' Español y listo, ahora todo marcha perfecto. :-)

Saludos.

+1
0
-1

K|Ke Linux Registered User # 417515

Imagen de Anónimo
+1
0
-1

Yo tenia el mismo problema pero con este comando: "sudo setxkbmap -layout 'es,es' -model pc105" desde el terminal todo quedo resuelto.

Y la verdad es que estoy de acuerdo en que fue por una mala reconfiguración de xserver ya que lo manipule para instalar la resolucion de 1024 x 768 y desde allí todo empezo a andar mal pero buneo ya muchas gracias.-

+1
0
-1
Imagen de Anónimo
+1
0
-1

Hola,

Despues de instalar 3 veces por varios motivos que ya estan solucionados. Ahora, no puedo entrar en ubuntu. Desde el momento que me sale la opcion de escribir usuario: al poner usuario sale uuuuuuuuuusssssssuuuuuaaaaarrrriiiiooooooooooooooooooooo. Y de verdad que lo hago con mucho cuidado para que no se repitan las letras, pero no hay manera. Despues de mil intentos he llegado a poner el usuario, pero... al llegar a la contraseña: lo mismo, y de aqui no paso. Esta ha sido la razon por la que he vuelto a instalarlo una vez mas...pero continuo con el mismo problema. El teclado no es USB, es un HP que va con el resto del equipo. Espero que me conteis alguna cosa sobre este tema.

Muchas Gracias

Un Saludo,

+1
0
-1
Imagen de Anónimo
+1
0
-1

Sin desmerecer la ayuda que prestan los que responden a los foros y agradeciéndosela enormemente - ¿cómo no? -, es cierto que hay veces que mucho comando y mucha historia y lo realmente efectivo es lo que se pasa por alto... Gracias por la efectiva simpleza de tu colaboración...

+1
0
-1
Imagen de Anónimo
+1
0
-1

será el sereno pero a mi me funcionó el comando sudo setxkbmap -layout 'es,es' -model pc105.
Gracias compa!!!

+1
0
-1
Imagen de Anónimo
+1
0
-1

Como hiciste que funcionara la tecla ñ?

+1
0
-1
Imagen de Anónimo
+1
0
-1

Si no te va la arroba, almuadilla, etc y tu Xorg tiene el siguiente sintoma:
(EE) Error loading keymap in /var/ bla bla bla
o bien te sale algo como:
Error interpreting include file "pc" bla bla

Entonces es muy problable que hayas pasado de XFree69 (Es broma 86) a xorg sin consultar con el vecino friki (ese soy yo)

xkbcomp no es capaz de cargar los esquemas de teclado porque al haber sido instalado no actualizo estos de forma correcta asi que haz lo siguiente como root (sic):
#cd /etc/X11/xkb/symbols
#mv pc pc.bak
#mv pc.dpkg-new pc

Ahora en tu KDE vete a Preferencias->Disposición del Teclado
y elige un teclado PC105 mas tu distribución de teclado preferida (Si ya tienes una distribución pues dale a eliminar y vuelve a añadirlo), dale a aplicar/aceptar y prueba la bonita arroba.

Si el problema persiste prueba con esta medicina:
http://ubuntuforums.org/showpost.php?p=465307&postcount=13

_o(·_·)o_______________ __ ___ _ __ _ _
|
| doCToR FriKi
| (Linux mola pero no tanto como Plan9)
|______________________________________ ____ __ __ _

+1
0
-1
Imagen de Anónimo
+1
0
-1

En esta dirección hay una muestra de los teclado yanqui y español:

http://www.structor.com.ar/teclado.html

También te podés bajar algunas letras.

Yo uso el USInternacional porque es más completo y sencillo que el español

22Jerán

+1
0
-1