Internet Ubuntu 9.10 (Solucionado)

Imagen de lofelip
0 puntos

Hola,

Tengo problemas con la conexion a Internet con Ubuntu 9.10. Me detecta la red Wifi, se conecta pero Internet no funciona. Alguna sugerencia?

Gracias.

Imagen de gandalfalexgan
+1
0
-1

Buenas lofelip

No has dado demasiada información sobre tu problema , pero uno de los posibles motivos,basado en lo poco que has dicho es la resolución de nombres.

Conectas pero no Navegas , Te refieres a eso no?

Por lo que supongo que cuando dices conectas estas completamente seguro que tienes conexión establecida con tu ISP pero no no accedes a internet mediante dominios.

Tienes que hacer lo siguiente:

Nos logeamos como root

$su root

Abrimos el fichero /etc/resolv.conf (asumo que tienes conocimiento de algun editor de consola , de no ser asi ,avisame que te indico como hacerlo)

y añadimos las siguientes lineas

nameserver (aqui pones la ip del DNS que te dio tu ISP)
nameserver (Aqui pones la segunda ip del DNS que te han dado)

Guardas y Cierras el fichero

Prueba a Navegar y debería irte

Si no conoces los DNS de tu ISP , busca en google cualquier dns que haya en tu pais , así podrás probar si ese era el fallo o no.

Un saludo
gandalfalexgan

Cualquier cosa correo a gandalf@alexgan.com

+1
0
-1
Imagen de lofelip
+1
0
-1

Gracias por la respuesta gandalfalexgan pero sigue sin funcionar. Si reconoce la red wifi, está conectado pero no funciona el navegador.

+1
0
-1
Imagen de Capa
+1
0
-1

Hazle un ping a un IP.
Si te contesta, tienes un problema de DNS. Prueba con los de OpenDNS.


Firma:
Hay 10 tipos de personas, las que entienden código binario y las que no.
GAMBAS-ES, aprende a programar !!!
+1
0
-1
Imagen de lofelip
+1
0
-1

Capa al hacer ping al google por ejemplo dice "Network is unreachable".

+1
0
-1
Imagen de raidon666
+1
0
-1

si tienes un servicio de internet al cual accedes con un usuario y contraseña, tendras que configurar el pppoe, si este es tu caso sigue los siguientes pasos:

1. Entrar a un terminal y logarte como root
2. escribir: pppoeconf (ahi cargara tus dispositivos de red)
3. pedira nombre de usuario el cual te dio la empresa de internet
4. pedira la contraseña
5. simplemente darle a todo Enter

si va todo bien, cuando termine este proceso tendras internet pero despues de tenerlo y antes de reiniciar recomendaria que instalaras el Wicd que es un administrador de redes como el Network-Manager que es el que trae ubuntu por defecto (los dos computadores en donde aparecen las redes), digo antes de reiniciar por que es muy probable que cuando reinicies no aparezcan las redes :s entonces si instalas el wicd, reinicias, te conectas a tu red y vuelves a hacer los 5 pasos anteriores y ya tendras internet, para conectar cada vez que enciendas tu pc y no tener que hacer los 5 pasos vas a una terminal te logeas como root y escribes: "pon dsl-provider" (sin comillas) y ya estaras conectádo ;)

+1
0
-1
Imagen de lofelip
+1
0
-1

Y a todo esto luego dicen que Ubuntu es mejor que Windows. Con esta conexión ya me había conectado antes y no hice nada de esos 5 pasos, ahora por arte de magia no me funciona. Porque da tantos problemas Ubuntu 9.10?

+1
0
-1
Imagen de Goyo
+1
0
-1

Y a todo esto luego dicen que Ubuntu es mejor que Windows.

Ten en cuenta que el criterio para decidir estas cosas no es "las tribulaciones de lofelip". Normalmente se usan razones de más peso (o a veces de menos, depende).

Con esta conexión ya me había conectado antes y no hice nada de esos 5 pasos, ahora por arte de magia no me funciona.

Esos cinco pasos no deberían ser necesarios si te conectas a través de un router, que es lo que yo imagino. Pero como no lo dices, cada uno imagina lo que se le antoja y te propone soluciones que pueden servir o no en tu caso.

Porque da tantos problemas Ubuntu 9.10?

Si realmente son tantos haría falta un libro para responder. En cuanto a los tuyos, con lo que has dicho hasta ahora es imposible saberlo, aunque yo sospecho que tu router no está conectado a Internet.

Copia aquí la salida de estos comandos:

iwconfig
ifconfig
route
+1
0
-1
Imagen de lofelip
+1
0
-1

Es de suponer que me conecto a través de un router wifi, digo yo. Parece ser que reinicio el router y si coge bien la conexión. Magia? puede ser.

Gracias de todas maneras.

+1
0
-1
Imagen de Goyo
+1
0
-1

Magia no, es relativamente habitual que se desconfiguren y haya que reiniciarlos.

+1
0
-1
Imagen de furtaxi
+1
0
-1

El hardware diseñado exclusivamente para Windows, sí. No te confundas.

Y si te dan el ordenador pelado, y tienes que poner tú Windows, tendrás que hacer más de cinco pasos. Y de 50, para que funcione. No compares un preinstalado y una pila de CDs de Drivers y Programas o una partición de recuperación, con un sistema operativo completo con muchas aplicaciones en los 700 Mb del Cd de Ubuntu.

Por cierto, ya que te gustan las quejas, pues yo tengo una. No has especificado nada relevante. Que tienes un ordenador con Wifi. Nada más.

O nos mandas la bola de cristal, o pones el hardware implicado, o lo copias en el buscador, que seguro que alguien ya ha posteado algo sobre el tema.

Mi WEB 100 % GNU/Linux: www.vigovideo.es
El que busca encuentra. El que no, se pierde. Arriba a la derecha, un precioso buscador.

+1
0
-1

Mi web : www.vigovideo.es
Buscar es más rápido que esperar una respuesta.

Imagen de lofelip
+1
0
-1

Lo que no entiendo es que porque tengo que poner datos de mi ordenador cuando con el ubuntu 8.. me lo pillaba bien. Y eso que dices de Windows, al instalarlo ya me pilla todo y no tengo que ir de foro en foro.

Por cierto, una vmware con ubuntu 9.10 desde windows me pilla correctamente Internet.

+1
0
-1
Imagen de raidon666
+1
0
-1

lastimosamente para muchos Linux no es como windows (solos clicks)

+1
0
-1
Imagen de furtaxi
+1
0
-1

Lo que no entiendo es que porque tengo que poner datos de mi ordenador cuando con el ubuntu 8.. me lo pillaba bien

Ubuntu no es Windows. Ubuntu 8.. no es ubuntu 9... De una versión a otra, hay importantes cambios.

A ver si lo entiendes así:

Lo que no entiendo es que porque tengo que vacunarme de gripe cuando con el tifus nunca tuve problemas .

Y eso que dices de Windows, al instalarlo ya me pilla todo y no tengo que ir de foro en foro.

De foro en foro, no, no los hay tan buenos para Windows como éste para Ubuntu.

Pero de CD en CD, no te libras. Veamos, componentes que traen (o deberían traer) controladores en Windows:

VGA, wifi, placa, sonido, impresora... espera... Lo dejamos en casi todo, y acabamos antes.

Mi WEB 100 % GNU/Linux: www.vigovideo.es
El que busca encuentra. El que no, se pierde. Arriba a la derecha, un precioso buscador.

+1
0
-1

Mi web : www.vigovideo.es
Buscar es más rápido que esperar una respuesta.

Imagen de lofelip
+1
0
-1

Al final lo he arreglado instalando el Wicd, parece que coge bien la red y se mantiene esa configuración.

+1
0
-1
Imagen de gandalfalexgan
+1
0
-1

Buenas lofelip

Me gustaria agradecer tu nefasto comportamiento , y gratitud a todos aquellos que han intentado ayudarte a pesar , de la falta de información que has dado. Me alegro que todos los que postean en este foro no sean tan perfectos y agradables como tu, pues no se que sería de nosotros.

Una última cosilla. No es obligatorio que utilices un sistema operativo basado en UNIX , digo yo que nadie te está obligando , así que si no eres capaz de comprender la potencia y facilidad que Ubuntu nos dá , SIN PAGAR NINGUNA LICENCIA , CON UNOS REPOSITORIOS BASTANTE AGRADABLES, sabes donde esta la puerta para volver a tu "maravilloso Windows" ese que nunca da pantallazos azules, ese que tienes que refrescar la pantalla despues de una sobredosis de escritorio, ese que ejecuta procesos con un consumo de procesador innecesarios, (Que Tu no veas los defectos no implica que no los tenga). Y eso de que no tienes que ir de foro en foro......es relativo ,será por que no sabes utilizar los suficiente tu entorno como para encontrar errores sin sentido que te rompen la cabeza) tampoco te habrás pasado cientos de horas busando sobre internet leyendo foros sobre windows( todos penosamente estructurados , donde la mayoria no tienen ni la menor idea de lo que contestan), Eso no pasa aquí , Ya que esto es una sociedad comunitaria de licencia libre , donde todos aprendemos a la vez y compartimos nuestros conocimientos para asi mejorar en comun, Algunos somos administradores desde hace muuchos años , otros no , pero no dudan en responder con Educacion y Basandose en sus duras experiencias y asi ayudar a gente como tu , que postea sobre errores que probablemente aparezcan en el FAQ, y que ya han sido respondidos.(Como ese de WICD). Asi que lo que deberías hacer es agradecer a toda la gente que HA PERDIDO EL TIEMPO respondiendote (Debido a tu vagancia de no saber buscar en un foro o no querer) .

Editado: Porcierto me olvidaba de comentar esa linea que decias , Con vmware me funciona. Me temo que no entiendes el objetivo de un sistema virtualizado........., Así que te lo comento en unas breves palabras.

Los hosts en un sistema virtualizado , "Virtualizan el hardware" en función al hardware que tienes. En Resumen navegabas por que usabas la tarjeta inalambrica hospedada en el anfitrión por lo que si navegas y has dejado por defecto La network virtual del VMWare (Como seguro has hecho) irá, pero eso no es gracias a tu Windows ,YA QUE si tuvieras un linux bien configurado y corrieras un Vmware tendrias cliente con los hosts
Un saludo
Gandalfalexgan

+1
0
-1
Imagen de lofelip
+1
0
-1

Pido perdón por si he molestado con los comentarios, pero eso es lo que me molesta de los linuxeros, que es Linux o nada. En cambio gente con windows y que también utiliza ubuntu y no son tan extremos. Pero a todo esto gracias por la ayuda.

+1
0
-1
Imagen de domingoxp
+1
0
-1

bueno a mi no me da problema el wifi y tengo el 9.10, bueno aunque al principio de medio pero era una caballa lo que tenia luego me funciono de maravillas el wifi.

PD: mi laptop es una hp pavilion dv4 1435dx

+1
0
-1
Imagen de Caminante7
+1
0
-1

Comentario moderado por Capa

Motivos:

Por favor lee las normas antes de publicar.

Si tienes problemas o dudas es necesario que abras tus propios hilos.

Gracias.


Equipo de Ubuntu-es

+1
0
-1
Imagen de Caminante7
+1
0
-1

Perdón
Creí estaba relacionado con mi duda. Lei todo, busqué en Google, busqué en ayuda de Ubuntu e intenté configurar DSL, Red Cableada y no encontré solución, por eso solicité ayuda.

De nuevo pido disculpas si incumplí con algo.

Gracias de todas formas

+1
0
-1
Imagen de andreslc47
+1
0
-1

Hola, entiendo tu problema con el acceso a internet, yo tuve el mismo problema hace unos dias y pude solucionarlo.
Lo que hice fue dejar el archivo interfaces de la siguiente forma:
--------------------------------------------
#sudo vi /etc/network/interfaces
auto lo
iface lo inet loopback
--------------------------------------------
Luego edite el archivo resolv.conf colocando la direccion ip de mi router (en este caso es: 192.168.1.1) como servidor DNS:
--------------------------------------------
#vi /etc/resolv.conf
nameserver 192.168.1.1
#sudo /etc/init.d/networking restart
--------------------------------------------
Finalmente el internet me funciono de inmediato sin necesidad de reiniciar mi P algooooo Ojala te sirva.

+1
0
-1
Imagen de rokoso
+1
0
-1

hola yo tengo un problema similar igual estoy recien usando ubuntu y estaba aprendiendo con ubuntu 9.04 con ese me podia conectar con el cable directo solamente y no inalambicamente es ke tengo notebook pero con el ubuntu 9.10 solo me reconoce el wifi pero no pasa nada y trate de hacer los 5 pasos ke decian pero dice ke no tengo instalado el root trate pero me salio cero en todo eso.. y nose de ke otra manera podre si me podrian ayudar o si me recomiendan instalar un version mas nueva porke taba revisando ke salio la 10.4 para notebook pero nose si me sirvira tengo un notebook dell porsiaka..

gracias si alguien me puede ayudar toy aprendiendo de apoko con linux..

+1
0
-1
Imagen de juan28a
+1
0
-1

y tu , felipe no se que, dices que windows es mejor que linux , porque TU , has tenido un problema, y a todos nosotros no nos ha surgido , por lo tanto hay que tener paciencia, amigo

+1
0
-1