instalar tarjeta de red usb tl-wn422g

Imagen de armandox
0 puntos

Hola de nuevo dando guerra
quiero instalar la tarjeta de red
marca: TP-Link
Modelo: TL-WN422G
Chip: Atheros (No Zydas)

So: Ubuntu 9.10

(No encuentro como instalar los drivers,ni los drivers)

Gracias

Imagen de elwizard
+1
0
-1

Tengo el mismo problema que tú.
Mismo SO, misma targeta WiFi. Me estoy documentando, pero no encuentro nada en ningún sitio, que pueda ayudarnos en el tema.

Si haces (en el terminal):
lsusb
Te aparecerá el bus y el dispositivo (device) que usa tu targeta de red.
Si te aparece Atheros, tienes entonces la versión 2.0 de la targeta.
Si te aparece Zydas, tienes la versión 1.0.

Si haces:
sudo lsusb -vs 001:002 (siendo 001 como bus y 002 como device: pon tus propios datos)
Te aparece todos los datos técnicos de la targeta.

En la actualidad busco una forma de instalarle el driver de XP o alguno que sea expecífico para Ubuntu, pero no encuentro nada 'funcional'.

Info:
http://doc.ubuntu-es.org/NDiswrapper

Me aparece como 'Hardware Present: no', esto significa que no está soportado por NDiswrapper.

Más info:
http://sourceforge.net/apps/mediawiki/ndiswrapper/index.php?title=TP-Lin...
Dice que si funciona, pero imagino que será la versión 1.0 (chip Zydas) y no la nueva versión 2.0 (Atheros).

Seguiré buscando a ver como se puede configurar la targeta, ya que si no, me temo que hemos perdido el dinero.

Ubuntu User #29271

+1
0
-1

Ubuntu User #29271

Imagen de elwizard
+1
0
-1

He enviado un email al centro de soporte internacional de TP-Link en www.tp-link.com, para preguntar por ello. Esperando respuesta. Si me contestan lo pongo en este hilo.
Ubuntu User #29271

+1
0
-1

Ubuntu User #29271

Imagen de armandox
+1
0
-1

Ya busque por todo internte pero nada solo la que corresponde a la V 1.0 que trae el driver zyda esa en ubntu 9.10 entra solita ya esta el driver generico en el kernel al igual que en wifislax 3.0 con inyeccion.

contacte al servicio tecnico tp-link y este es el mensaje (Este es el correo electronico para insistir mientras mas insistan mas probabilidades hay de que suelten información para un driver linux support.usa@tp-link.com , tambien sarah.li@tp-link.com ):

RE: tl-wn422g v 2.0?
De: Sarah.Li (sarah.li@tp-link.com)
Enviado: sábado, 26 de diciembre de 2009 05:11:19 a.m.
Para: 'armando computadoras armando computadoras'
CC: Alina Xue (alina.xue@tp-link.com); charles.wang@tp-link.com; 'Spencer Li' (spencer.li@tp-link.com); 'carl.liang' (carl.liang@tp-link.com)

Dear Customer,

Thank you very much for your email requesting information about our product.

Sorry to say that TL-WN422G doesn’t have a driver under Linux OS, so I am afraid there is no driver avaliable right now I can send.

Sorry for the inconvience and many thanks for your support to our product!

If you need any further help please feel free to contact with me.
Best Regards
----------------------------------------------

Sarah.Li

Technical Support Engineer
TP-LINK TECHNOLOGIES CO., LTD.
Tel: +86-755-2650-2769
Fax: +86-755-2663-6921
E-mail: sarah.li@tp-link.com
Website: www.tp-link.com/support/Support.asp

From: armando computadoras armando computadoras
Sent: Saturday, December 26, 2009 3:03 PM
To: support.usa@tp-link.com
Subject: tl-wn422g v 2.0

Hola tengo linux ubuntu 9.10, me comentaron que era un buen producto pero no quiere correr, me pueden enviar los drivers para ubuntu 9.10 , con el fin de que quede utilizable, gracias

me dicen que la v 1.0 corre corectamente en ubuntu 9.10 desgraciadamente tengo la v 2.0

+1
0
-1
Imagen de drbafle
+1
0
-1

Hola gente yo también ando agonizando con el tema, he probado todo de todos los foros y con todas las versiones de controladores en ndiswrapper, tanto los de la v 1 como los de la v 2, con los que mas lejos he llegado ha sido con los de vistax86 de la versión 2.0 de la tarjeta y probé con varias versiones de ubuntu, pero al hacer el dmesg no aparece en la lista, así que por lo que veo hay que esperar, yo me seguiré rayando y cuando consiga algo lo pongo por aquí a ver que tal.

Suerte gente

+1
0
-1

Un saludete

Imagen de sct999
+1
0
-1

yo también tengo esa tarjeta en la V 2.0

en la pagina de los compat wireless dice que ya está disponible
pero no se como instalarlos

en la página dice que se necesita el firmware que es un archivo .fw ese ya lo tengo
pero me pide modificar unas variables del kernel ... esto es lo que dice la página:

Configuring your kernel

Enable these options in your kernel config.

CONFIG_ATH_COMMON=m
CONFIG_ATH9K_HW=m
CONFIG_ATH9K_COMMON=m
CONFIG_ATH9K_HTC=m

Firmware

ar9271 requires firmware, you can get ar9271.fw from the firmware tree.

The firmware has to be placed in the correct location, usually /lib/firmware. This could vary among distributions, so check your distro's policies if loading of the firmware fails.

Supported Features

* Station Mode
* Monitor Mode
* IBSS Mode
* Legacy (11g) operation
* HT support
* TX/RX 11n AMPDU aggregation
* HW Encryption
* LED

TODO

* Suspend/Resume
* Powersave

+1
0
-1
Imagen de armandox
+1
0
-1

Pon el enlace a la pagian cita anteriormente para que podamos accesar a ella y ver si podemos hacerla funcionar.

Gracias

+1
0
-1
Imagen de rioport
+1
0
-1

http://wireless.kernel.org/en/users/Drivers/ath9k_htc

Dice que hay soporte ya para este chipset, pero no lo explica muy bien que digamos.

+1
0
-1

-- GC --

Imagen de rioport
+1
0
-1

Al menos a mi me ha funcionado, antes había intentado pero sin éxito, estaba usando las versiones de compat-wireless de marzo, cuando quize intentar con las primeras versiones de abril, me daba error a la hora de hacer make.
Bien el problema no era otra cosa que el ID de dispositivo, las versiones de marzo (y no se cuantas mas de las anteriores) traian soporte solo para el ID 0x9271 (TL-WN721N) por eso puede que a alguien le haya funcionado, pero no en los TL-WN422G v2, que su ID es 0x1006.
Bien pues he usado la version compat-wireless-2010-04-19.
Pasos, pues solo.

1 sudo make
2 sudo make install
reinician para no complicarse
conectan su adaptador
3 iwconfig
4 sudo ifconfig wlan1 up
En mi caso tengo wlan1 porque wlan0 es de la otra tarjeta que trae mi portatil (Intel 3945abg)

compat wireless:
http://wireless.kernel.org/download/compat-wireless-2.6/

patch, el link donde informan de este pequeño detalle:
https://patchwork.kernel.org/patch/89102/

Espero les sirva, saludos.

Edito:
Habia escrito mal la versión de compat-wireless, pero ya la corregí.

+1
0
-1

-- GC --

Imagen de ishinji_01
+1
0
-1

Que tal, me interesa saber como instalaste la tarjeta de red usb tl-wn422g. si puedes hacer un pequeno tutorial de lo que hiciste (paso a paso).

De antemano Gracias

mi correo ishinji_01@yahoo.com.mx

+1
0
-1
Imagen de Unkash
+1
0
-1

yo he hecho todo eso, pero usando la compat-wireless-2010-04-24, pero ni aun asi me funciona.

no ha habido errores ni en el make ni en el install, asi q no se porq sigue sin reconocermela al hacer iwconfig

xxx@xxx:~$ iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:"xxx"  
          Mode:Managed  Frequency:2.412 GHz  Access Point: xx:xx...  
          Bit Rate=12 Mb/s   Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=26/70  Signal level=-84 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

xxx@xxx:~$ 

+1
0
-1
Imagen de rioport
+1
0
-1

Haber, tu interfaz wlan0, supongo que es de otra tarjeta de red que tienes, es así?.
Yo tengo wlan0 y wlan1 porque tengo 2 tarjetas.

Ok, pero como que no te ha funcionado? lo he probado en:

Debian Lenny (Linux 2.2.26)
Debian Testing (linux 2.6.32)
Ubuntu 9.10 (Linux 2.6.31)
Ubuntu 10.04 RC (Linux 2.6.32)

Con estas versiones de compat-wireles:

compat-wireless-2010-04-19
compat-wireless-2010-04-23

Y ha funcionado, hasta se puede poner la tarjeta en modo monitor. Pero no es funcional por ahora, si intentas asociarte a la red (WEP), falla, si intentas un ataque de desautentificación (WPA), falla.
Varia la manera de fallar, pero el caso es que el indicador de BloqMayusc se queda enciende/apaga y ya no reponde para nada el sistema y hay que apagar a la mala.

Ah, se me olvidaba, necesitas el firmware.
Lo bajas de:
http://git.kernel.org/?p=linux/kernel/git/dwmw2/linux-firmware.git;a=blo...

ya que lo hayas bajado lo copias a /lib/firmware/

En mi caso como el firmware estaba en mi carpeta de usuario, hice esto:
sudo cp ar9271.fw /lib/firmware/

+1
0
-1

-- GC --

Imagen de rulos000
+1
0
-1

hola buenas tardes y antes que nada dar las gracias por haber me sacado de mas de un apuro aunque sea la primera vez q posteo, pero bueno cuando he tenido algun problemiya con ubuntu he entrado aqui y de leer sempre e podido solucionarlo, hasta hace una semana que yevo intentando hacer que funcione esta tarjet de red y no hay manera, he hecho todo lo que pone aqui y nada conecto la tarjeta al usb y no la detecta, he probado estas:
compat-wireless-2010-04-19
compat-wireless-2010-04-23
compat-wireless-2010-04-24

y nada no hay manera me pueden explicar un poko como lo han conseguido.
es q soy algo novatillo en linux y necesito hacer funcionar esta tarjeta en mi pc q no puedo conectarme xq borre el windows pensando q funcionaria la maldita tp-link, os lo agradeceria muxo...............

+1
0
-1
Imagen de sct999
+1
0
-1

En ubuntu 10.04 y en linux mint 8 con las versiones
compat-wireless-2010-04-19.tar.bz2 y
compat-wireless-2010-04-24.tar.bz2

http://wireless.kernel.org/download/compat-wireless-2.6/

todo lo que he hecho es

1.-Descargar el archivo ar9271.fw desde aquí http://git.kernel.org/?p=linux/kernel/git/dwmw2/linux-firmware.git;a=blo...

2.- Copiar el archivo ar9271.fw a la carpeta /lib/firmware
estando en la carpeta personal es:
sudo cp ar9271.fw /lib/firmware/

3.-En la carpeta compat-wireless-2010-xx-xx
sudo make esto tarda varios minutos...

4.-sudo make install

5.-sudo make unload

6.sudo make load

7.-reiniciar

8.-Conectar el adaptador... eso es todo

Muchas gracias a rioport, al ver su respuesta me motivó a hacerlo :P
ahora voy a ver que tal me va en debian, voy a instalarlo.

+1
0
-1
Imagen de shadowmanzon
+1
0
-1

soy muy muy nuevo en linux y hay cosas que aun no entiendo muy bien por ejempleo eso de
"2.- Copiar el archivo ar9271.fw a la carpeta /lib/firmware
estando en la carpeta personal es:
sudo cp ar9271.fw /lib/firmware/"
lo intente pero no pude yo lo hice arrastrandolo no se si eso sea copiar
me sale un error qeu dice
error al mover el archivo permiso denegado y los siguientes pasos tampoco los entiendo muy bien
gracias

+1
0
-1
Imagen de frico-ar-brc
+1
0
-1

Me registrè para agraderles.

Funcionò sin ningùn problema siguiendo las indicaciones de sct999.

Ubuntu 10.04 LTS 32b
Compat-wireless 2010-04-24

Muchas gracias
Saludos

+1
0
-1
Imagen de rioport
+1
0
-1

Hasta la versión 2010-04-26, que es la última por estas fechas (04-Mayo-2010) funciona te puedes conectar y la puedes poner en modo monitor.
Pero alguien podría decirme si le ha funcionado al realizar un ataque de desautentificación o asociarse a una red?, en resumen, alguien a sacado siquiera una contraseña WEP con este adaptador? inyectando tráfico a la red.

+1
0
-1

-- GC --

Imagen de sct999
+1
0
-1

.. a alguien más se le ha congelado la pc al estar conectado a internet con este adaptador?

+1
0
-1
Imagen de sct999
+1
0
-1

.. a alguien más se le ha congelado la pc al estar conectado a internet con este adaptador?

+1
0
-1
Imagen de rioport
+1
0
-1

No me ha servido para asociarme a la red o para hacer un ataque de desautentificación, se congela la PC. La versión con la que he probado es la compat-wireless-2010-05-06 . Pero si hay buen trafico en la red, no es necesario asociarse a la red, basta con tener paciencia y esperar a que se reúnan los suficientes IVS.

+1
0
-1

-- GC --

Imagen de sct999
+1
0
-1

A mi la pc se me congela navegando normalmente por internet... la señal me llega a un 40% no sé si eso tengo algo que ver, uso linux mint 8 y wicd para conectarme

+1
0
-1
Imagen de rioport
+1
0
-1

A mi no se me ha congelado la PC mientras navego en internet, pero si me ha pasado que se desconecta solo, aun cuando la señal es buena y tarda demasiado en volver a conectar.

+1
0
-1

-- GC --

Imagen de oscarinux
+1
0
-1

disculpen mi ignorancia
pero no encuentro la carpeta Compat-wireless 2010-04-24 que menciona sct999
agradesco su ayuda...

+1
0
-1
Imagen de kofii
+1
0
-1

SALU2 A TO2 PUES YO TAMBIEN TENGO ESA TARJETA INALAMBRICA Y SI ME FUNCIONO EN UBUNTU 10.04
Usando ndiswrapper que activa controladores de windows para tarjetas inalambricas en linux.EL PROCEDIMIENTO ES EL SIGUIENTE:

1. Abrimos una terminal: aplicaciones/accessorios/terminal
2. Escribimos sin las comillas y en el siguiente orden(copiar, pegar con el mouse tambien sirve):
"sudo apt-get install ndisgtk"
"sudo ndisgtk"
3. Ahora abrimos: sistema/administracion/controladores para redes inalambricas de windows

4. Se abre una ventanita, le damos instalar nuevo controlador
5. buscamos el controlador con nombre TL-WN422GDriver FilesWin2K_XPnetathuw.inf
el controlador bajalo de aqui:
http://hotfile.com/dl/73108945/1522cd3/drivers_tplink_tl-wn322gv3_4__tl-...

6. seleccionamos el archivo, abrir, instalar

si te sale esto en la ventanita:

volvemos a la terminal o abrimos uno nuevo y escribimos esto sin las comillas:

"sudo ndiswrapper -a 0cf3:1006 netathuw"
luego
"sudo ndiswrapper -m"
luego
"sudo ndiswrapper -ma"
después
"sudo ndiswrapper -mi"

en ese orden y esperando que termine cada proceso

Cerramos todo, reiniciamos, conectamos el usb y listo.
AMI ME FUNCIONO ESTE PROCEDIMIENTO EN UNA LAP ASI QUE INTENTENLO
AGRADECER NO CUESTA ESTA INFORMACION ES LA UNION DE LA INFO DE OTROS FOROS DUDAS A setzukun@gmail.com
NOTA: ESTOY TRATANDO DE HECHAR ANDAR LA MISMA INALAMBRICA EN GENTOO SI ALGUIEN ME PODRIA DAR INFO ACERCA DE ESTO SE LOS AGRADECERIA IGUAL AMI CORREO.

+1
0
-1
Imagen de cambiapiezas
+1
0
-1

kofii , sos un grande!!!! ; funciono de una! gracias , gracias , gracias!!!!!!!

me registre solo para dar gracias!! , hace rato que queria echar a andar este dongle usb en mi ubuntu!!
windows chau chau adios!!

pd: kofii , con tu permiso copio y guardo en un txt para futura referencia! , salu2

+1
0
-1
Imagen de pablo.s.bella
+1
0
-1

Muchas gracias por el dato. Me estaba volviendo loco para poder instalar la placa. Me llevó muchos días encontrarme con este hilo. No usaba ubuntu, porque no podía conectarme a la red, pero ahora....

+1
0
-1
Imagen de kpablinux
+1
0
-1

estimado el archivo el que subió ya no se puede descargar :(:(

+1
0
-1

KPLX

Imagen de kpablinux
+1
0
-1

estimados gracias a sus ayudas y la combinacion de varios tips entregados por ustedes, logre activar la tarjeta y funciona espectacular, de nuevo muchas gracias.

nota: para los que no puedan activar los compat-wireless (que fue mi caso y gracias a mi hermano el cual me orienta ya que lleva años trabajando con linux) hay que cambiar los atributos con chmode 777 compat-wireless-xxxx-xx-xx y seguir los pasos ya descritos sudo make, sudo make install y después que reinicie el equipo (y 2 días de quebrada de cabeza) opte por poner iwconfig y sudo ifconfig wlan1 up y funciono. :):)

+1
0
-1

KPLX