¿Por qué no termina de arrancar mi Ubuntu? (Solucionado)

Imagen de mariadelmar_vera
0 puntos

Buenas,

Resulta que cuando intento encender mi ordenador con Ubuntu, antes de que me arranque me da un error, del que no sale de ahí y no me permite que se ponga en funcionamiento.

El error que me da es el siguiente:

"One or more of the mounts listed in /etc/fstab cannot yet be mounted:
(ESC for recovery shell)
/: waiting for /dev/disk/by-uuid/5eb1fbfa-fc74-94a4-b4503e306cd9
/tmp: waiting for (null)
swap: waiting for UUID=adec75d2-8f3f-4b6c-0387c8260481"

Entonces yo al pulsar ESC, me aparece en pantalla lo siguiente:

"mountall: Cancelled
init: mountall main process (820) terminated with status 1
General error mounting filesystems.
A maintenance shell will now be started.
CONTROL-D will terminate this shell and re-try.
root@(none):~#"

Ahi en línea de comandos no se me ocurre qué escribir, quizás ahi este la solución a mi problema, ¿alguien me recomienda que puedo escribir ahí? A mi se me ocurre escribir CONTROL-D y entonces me aparece en pantalla:

"root@(none):~#exit
mountall start/starting
One or more of the mounts listed in /etc/fstab cannot yet be mounted:
(ESC for recovery shell)
/: waiting for /dev/disk/by-uuid/5eb1fbfa-fc74-94a4-b4503e306cd9
/tmp: waiting for (null)
swap: waiting for UUID=adec75d2-8f3f-4b6c-0387c8260481"

¿Por favor, alguien me podría ayudar a salir de este círculo vicioso y poder encender mi Ubuntu o por lo menos poder acceder a mi información para guardarla y formatear el Ubuntu si es la solución más fácil?

Muchas gracias a todos.

Imagen de furtaxi
+1
0
-1

¿ Tienes también Windows ? Pues scandisk desde él, y reinicias dos veces.

Además, arranca con un live cd, vete a Sistema Administración Gestor de particiones Gparted, haces un click a la primera partición, click derecho, verificar, aplicar.

Cuando acabe, con la siguiente. Hazlas de una en una. El proceso puede tardar bastante tiempo, ten paciencia.

No podrás hacerlo con particiones extendidas y de intercambio, céntrate en las primarias/lógicas.

Luego, reinicia.

Mi WEB 100 % GNU/Linux: www.vigovideo.es
El que busca encuentra. El que no, se pierde. Arriba a la derecha, un precioso buscador.

+1
0
-1

Mi web : www.vigovideo.es
Buscar es más rápido que esperar una respuesta.

Imagen de voyager1
+1
0
-1

Buenas

para poder darte un buen punto de partida para que tu puedas seguir investigando, sería muy conveniente que nos dieras más datos sobre que distribucion, que evolucion estás intentando arrancar, y sobre todo que estas haciendo antes de llegar a ese posible error.

Cuando nos puedas aportar más datos quizá se te pueda dar un punto de partida para poder seguir aprendiendo más sobre el mundo de las distribuciones de gnu con kernel linux

usuario de gnu con kernel linux número 481.784

Antes de preguntar suelo hacer ...RTFM y STFW, es decir, intento leer la correcta pagina del manual, y buscar la solución por la red. Evidentemente siempre me quedan manuales y paginas por leer, e intento

+1
0
-1

usuario de gnu con kernel linux número 481.784

Antes de preguntar suelo hacer ...RTFM y STFW, es decir, intento leer la correcta pagina del manual, y buscar la solución por la red. Evidentemente siempre me quedan manuales y paginas por leer, e intento

Imagen de mariadelmar_vera
+1
0
-1

Gracias por las respuestas.

No tengo partición.

Mi versión de Ubuntu es 9.04

El problema surgió porque estaba escribiendo las siguientes ordenes cuando se me apagó inesperadamente el ordenador:

Sudo su
aptitude update
aptitude install apache2
Añadí al archico /etc/apache2/apache2.conf ServerName 127.0.0.1
Edite el archivo /var/www/index.html
$ a2enmod ssl
$a2ensite ssl
$ /etc/init.d/apache2 restart
Y justo cuando abría una ventana en el navegador con la URL http://localhost se apagó el ordenador porque se fue la luz.

Muchas gracias por vuestra ayuda.

+1
0
-1
Imagen de furtaxi
+1
0
-1

Simplemente, el apagado brusco provocó errores.

Usa la solución del Live Cd que te puse arriba, en cinco minutos, listos.

Respecto a ésto:

A mi se me ocurre escribir CONTROL-D

No es escribirlo, sino usar la combinación de teclas CONTROL (CTRL) y la letra D. Te hubiera permitido arrancar, aunque no siempre. Haz lo del live CD.

Mi WEB 100 % GNU/Linux: www.vigovideo.es
El que busca encuentra. El que no, se pierde. Arriba a la derecha, un precioso buscador.

+1
0
-1

Mi web : www.vigovideo.es
Buscar es más rápido que esperar una respuesta.

Imagen de mariadelmar_vera
+1
0
-1

Lo siento.

Pero yo es que no tengo una partición, lo he intentado pero no sé, quizás se deba a que no tenga partición.

Gracias.

+1
0
-1
Imagen de furtaxi
+1
0
-1

A ver, los discos duros, para que funcionen, tienen que tener, al menos, una.

Por razones técnicas, bastante difíciles de explicar sin complicarse, es conveniente separar los distintos tipos de datos, y, la mejor forma, es usar una partición para cada cosa.

Si sólo tienes Ubuntu, en tu Disco hay, al menos, dos particiones.
/ (raiz), para tu sistema operativo Ubuntu
y una más de intercambio. Se usa para "aumentar" artificialmente la cantidad de memoria.

Es muy recomendable tener una tercera, donde se guarden tus archivos, y las configuraciones de tus programas, para que sean independientes del sistema operativo, y puedas reinstalar, actualizar, formatear, sin que se pierdan tus cosas. Se la llama /home (casa).

Así que si tienes particiones. Alguna de ellas quedó a medio grabar, cuando se cortó la luz, y ahora, el sistema no puede escribir o leer, porque hay algunos bits de datos que no están donde deberían. Normalmente, es que no encuentra una secuencia especial, la de final de fichero, que no se grabó.

Al verificar las particiones con el Gparted, se revisa cada archivo, y se ajustan los tamaños, añadiendo o quitando lo que haga falta para que se pueda usar el disco.

¿ Sabes arrancar con el Live CD ?

Tú pregunta, que te indicamos lo que haga falta.

Mi WEB 100 % GNU/Linux: www.vigovideo.es
El que busca encuentra. El que no, se pierde. Arriba a la derecha, un precioso buscador.

+1
0
-1

Mi web : www.vigovideo.es
Buscar es más rápido que esperar una respuesta.

Imagen de mariadelmar_vera
+1
0
-1

Muchas gracias, he seguido los pasos, sólo he podido para la primera partición, pero no me soluciona el problema, no lo entiendo.

+1
0
-1
Imagen de furtaxi
+1
0
-1

Es que los Administradores de aquí son muy crueles, y nos han quitado la telepatía y la bola de cristal...

:)

Veamos. Arranca otra vez con el live cd. Probar sin alterar el equipo.

Déjalo que acabe de iniciar. Pulsa éstas tres teclas, a la vez:

CONTROL ALT F2

Te aparecerá una pantalla negra, muy fúnebre... Tranquila, estás en lo que se llama consola.

Ahora, teclea éstas palabras mágicas:

sudo fsck -a -y

Respeta los espacios, los guiones, van pegados a la siguiente letra. Debería ponerse a comprobar todas tus particiones.

Cuando acabe, teclea:

sudo reboot

y se reiniciará el ordenador.

Todo en minúsculas.

Nos cuentas .... con detalle...please..
:)

Mi WEB 100 % GNU/Linux: www.vigovideo.es
El que busca encuentra. El que no, se pierde. Arriba a la derecha, un precioso buscador.

+1
0
-1

Mi web : www.vigovideo.es
Buscar es más rápido que esperar una respuesta.

Imagen de mariadelmar_vera
+1
0
-1

Al escribir sudo fsck -a -y me muestra por pantalla fsck 1.41.4 (27-Jan-2009)
y cuando reinicio me sigue dando el mismo error.

Muchas gracias, furtaxi, me caes bien, tienes mucha paciencia conmigo

+1
0
-1
Imagen de furtaxi
+1
0
-1

sudo fsck -y

A ver si así se lanza, sino, habrá que hacerlo partición por partición.

Mi WEB 100 % GNU/Linux: www.vigovideo.es
El que busca encuentra. El que no, se pierde. Arriba a la derecha, un precioso buscador.

+1
0
-1

Mi web : www.vigovideo.es
Buscar es más rápido que esperar una respuesta.

Imagen de mariadelmar_vera
+1
0
-1

Bien al hacer sudo fsck -y me aparece lo mismo fsck 1.41.4 (27-Jan-2009) ¿cómo se haría partición por partición?
Gracias y saludos.

+1
0
-1
Imagen de furtaxi
+1
0
-1

Cuando arranque, Aplicaciones accesorio terminal. Hazlo dos veces, para tener dos ventanitas.

Vete a la primera, y teclea:

sudo fdisk -l

(guión ele)

te sale algo así:

Disposit. Inicio Comienzo Fin Bloques Id Sistema
/dev/sdb1 * 1 973 7815591 83 Linux
/dev/sdb2 6080 19457 107458785 5 Extendida
/dev/sdb3 974 1097 996030 82 Linux swap / Solaris
/dev/sdb4 1098 6079 40017915 83 Linux
/dev/sdb5 6080 19457 107458753+ 83 Linux

Será diferente, yo tengo dos discos, y te he sacado la del segundo, por éso, pone /dev/sdb.... Si sólo tienes uno, en tu caso, pondrá /dev/sda.....

Ahora, te vas a la otra ventana, y haces:

sudo fsck -y /dev/RRRRRRR

Las RRRRR las sustituyes por cada partición que se mostró antes, por ejemplo

sudo fsck -y /dev/sda1

Lo haces para cada una de las entradas, menos las que te pongan NTFS (son de windows),

extendida = /dev/sdb2 6080 19457 107458785 5 Extendida (En mi caso)

y la de intercambio /dev/sdb3 974 1097 996030 82 Linux swap / Solaris ( en mi caso)

De todas formas, no te preocupes, si en alguna no se puede, no te deja. Pasas a la siguiente.

A ver si así vá.

Mi WEB 100 % GNU/Linux: www.vigovideo.es
El que busca encuentra. El que no, se pierde. Arriba a la derecha, un precioso buscador.

+1
0
-1

Mi web : www.vigovideo.es
Buscar es más rápido que esperar una respuesta.

Imagen de mariadelmar_vera
+1
0
-1

En una ventana del terminal se me muestra lo siguiente:
.............
/dev/sda1 ............ Linux
/dev/sda2 ............ Extendida
/dev/sda5 ............ Linux swap / Solaris

Mientras que el segunda ventana del terminal:
#sudo fsck -y /dev/sda1
fsck 1.41.4 (27-Jan-2009)
e2fsck 1.41.4 (27-Jan-2009)
/dev/sda1: limpio, 151408/18972672 ficheros, 2157083/75876995 bloques
#sudo fsck -y /dev/sda2
fsck 1.41.4 (27-Jan-2009)
e2fsck 1.41.4 (27-Jan-2009)
fsck.ext2: Attempt to read block from filesystem resulted in short read mientras se intentaba abrir /dev/sda2
¿Esta podría ser una partición de longitud cero?
#sudo fsck -y /dev/sda5
fsck 1.41.4 (27-Jan-2009)
fsck: fsck.swap: no se encontró
fsck: Error 2 mientras se ejecutaba fsck. swap para /dev/sda5

Después de esto he reiniciado el ordenador y sigue sin funcionar.

Muchas gracias y saludos.

+1
0
-1
Imagen de furtaxi
+1
0
-1

Postea aquí todo el resultado de sudo fdisk -l ... Hay cosas raras, y quiero darles un vistazo.

Por lo que has puesto, sólo tienes una partición primaria de Linux, que podría ser la /, con el /home dentro, y una extendida con un intercambio dentro.

Luego, de manera visual, vete a sistema-administración, monitor del sistema, pestaña de sistema de archivos, y cuéntanos qué ves, me dá que hay alguna partición más que no se monta.

Si puedes, le sacas un pantallazo, haciendo click en la ventana, y luego, ALT izquierdo más la tecla IMPR PANT/PET SYS (un sólo golpe de tecla, muy breve), y la subes a imageshack, o similar. Pon aquí el enlace para verlo.

Mi WEB 100 % GNU/Linux: www.vigovideo.es
El que busca encuentra. El que no, se pierde. Arriba a la derecha, un precioso buscador.

+1
0
-1

Mi web : www.vigovideo.es
Buscar es más rápido que esperar una respuesta.

Imagen de mariadelmar_vera
+1
0
-1

El resultado de fdisk -l es:

root@ubuntu:/etc# fdisk -l

Disco /dev/sda: 320.0 GB, 320072933376 bytes
255 cabezas, 63 sectores/pista, 38913 cilindros
Unidades = cilindros de 16065 * 512 = 8225280 bytes
Identificador de disco: 0x0d5f0d5e

Disposit. Inicio Comienzo Fin Bloques Id Sistema
/dev/sda1 * 1 37785 303507981 83 Linux
/dev/sda2 37786 38913 9060660 5 Extendida
/dev/sda5 37786 38913 9060628+ 82 Linux swap / Solaris

El pantallazo del sistema de archivos es el siguiente:
http://img38.yfrog.com/i/pantallazoyf.png/

Muchas gracias y saludos

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

Hola Maria del Mar:

Prueba lo siguiente:

Inicia con Ubuntu 9.10 livecd

En una consola (Aplicaciones - Accesorios - Terminal)
Ejecuta:

sudo su 
fsck -y /dev/sda1
mkdir /mnt/ubuntu
mount /dev/sda1 /mnt/ubuntu
mount --bind /proc /mnt/ubuntu/proc
mount --bind /dev /mnt/ubuntu/dev
mount --bind /sys /mnt/ubuntu/sys
chroot /mnt/ubuntu
dpkg --configure -a
apt-get update
apt-get install linux-backports-modules-2.6.31-15-generic linux-backports-modules-karmic 
linux-backports-modules-karmic-generic linux-headers-2.6.31-15 linux-headers-2.6.31-15-generic
linux-image-2.6.31-15-generic linux-image-generic
update-initramfs -u
update-grub
apt-get upgrade
apt-get install -f
umount /mnt/ubuntu/sys
umount /mnt/ubuntu/dev
umount /mnt/ubuntu/proc
reboot

Saludos.
Gabriel.



Solo doy soporte para Ubuntu - 6666 - Más malo que el diablo.
+1
0
-1
Imagen de mariadelmar_vera
+1
0
-1

Hola Gabriel.

Al intentar ejecutar fsck -y /dev/sda1
me ma mostrado el siguiente aviso:

fsck 1.41.4 (27-Jan-2009)
e2fsck 1.41.4 (27-Jan-2009)
/dev/sda1 está montado.

¡¡ATENCIÓN!! Ejecutar e2fsck en un sistema de ficheros montado
puede causar GRAVES daños al sistema de ficheros.

¿De verdad quiere continuar? (s/n)? no

revisión terminada.

Me ha entrado miedo, y por ello he duda en continuar, ¿tú me recomiendas que continue? Gracias.

Saludos

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

Hola Maria del Mar:

No, de ninguna manera, jamas debes reparar una partición montada.

Simplemente ejecuta este comando antes de revisar la partición:

umount /dev/sda1

Primero

sudo su

Luego ese comando

Y posteriormente continua con la secuencia

Saludos.
Gabriel.



Solo doy soporte para Ubuntu - 6666 - Más malo que el diablo.
+1
0
-1
Imagen de mariadelmar_vera
+1
0
-1

Bien siguiendo sus pasos al ejecutar
root@ubuntu:/# apt-get install linux-backports-modules-2.6.31-15-generic linux-backports-modules-karmic linux-backports-modules-karmic-generic linux-headers-2.6.31-15 linux-headers-2.6.31-15-generic linux-image-2.6.31-15-generic linux-image-generic
Al final del proceso me ha dado error en:
Se encontraron errores al procesar:
xserver-xorg
E: Sub-process /usr/bin/dpkg returned an error code (1)
No sé si será un error que deba tener en cuenta.
Luego al ejecutar update-initramfs me devuelve lo siguiente:
You must specify at least one of -c, -u, or -d.

Usage: /usr/sbin/update-initramfs [OPTION]...

Options:
-k [version] Specify kernel version or 'all'
-c Create a new initramfs
-u Update an existing initramfs
-d Remove an existing initramfs
-t Take over a custom initramfs with this one
-b Set alternate boot directory
-v Be verbose
-h This message
Y no sé que opción escoger.

Muchas gracias y saludos.

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

Hola Maria del Mar:

1- update-initramfs -u, es el comando, ya corregí el post.

2- el error de xserver-xorg es grave para las gráficas

intenta al final de la ejecución de ese comando, ejecutar

dpkg --configure -a
apt-get install xserver-xorg
apt-get install -f

Saludos.
Gabriel.



Solo doy soporte para Ubuntu - Existen muchas soluciones - Las equivocadas y la mia.
+1
0
-1
Imagen de mariadelmar_vera
+1
0
-1

Me sigue dando el mismo error xserver-xorg, pero da igual, pues las gráficas no me sirven.

Luego cuando hago umount no se encuentran los ficheros:
root@ubuntu:/# umount /mnt/sys
umount: /mnt/sys: no se ha encontrado
root@ubuntu:/# umount /mnt/dev
umount: /mnt/dev: no se ha encontrado
root@ubuntu:/# umount /mnt/proc
umount: /mnt/proc: no se ha encontrado

Muchas gracias y saludos.

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

Hola Maria del Mar:

Ya corregi los errores nuevos que encontraste, las ordenes son:

umount /mnt/ubuntu/sys
umount /mnt/ubuntu/dev
umount /mnt/ubuntu/proc

Saludos.
Gabriel.



Solo doy soporte para Ubuntu - Tengo la conciencia bien limpia. Y muy mala memoria.
+1
0
-1
Imagen de mariadelmar_vera
+1
0
-1

Hola Gabriel_M:

No entiendo porque la ubicación es la correcta, lo he comprobado, pero me ocurre esto:

root@ubuntu:/# umount /mnt/ubuntu/sys
umount: /mnt/ubuntu/sys: no se ha encontrado
root@ubuntu:/# umount /mnt/ubuntu/dev
umount: /mnt/ubuntu/dev: no se ha encontrado
root@ubuntu:/# umount /mnt/ubuntu/proc
umount: /mnt/ubuntu/proc: no se ha encontrado

Gracias y saludos,
Mª del Mar

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

Hola Maria del Mar:

Desmontar el sistema enjaulado, es solo una cuestión purista.

Ejecuta:

sudo reboot

Que todo lo montado se desmontará, antes de reiniciar
e intenta iniciar desde el disco para constatar, si
tu sistema dañado se reparó, y puedes ingresar a él.

Saludos.
Gabriel.



Solo doy soporte para Ubuntu - Hay tres clases de personas - Las que saben contar y las que no.
+1
0
-1
Imagen de mariadelmar_vera
+1
0
-1

Muchas gracias, ya esta todo solucionado.

Un placer haberos conocido, furtaxi y Gabriel.

Saludos,
Maria del Mar

+1
0
-1
Imagen de musicum
+1
0
-1

Después de tanto probar, y leer, y debido a las prisas expongo lo siguiente.

Asi está mi disco (desde LiveCD 9.10)

ubuntu@ubuntu:~$ sudo fdisk -l

Disco /dev/sda: 320.1 GB, 320072933376 bytes
255 cabezas, 63 sectores/pista, 38913 cilindros
Unidades = cilindros de 16065 * 512 = 8225280 bytes
Identificador de disco: 0x00000001

Disposit. Inicio    Comienzo      Fin      Bloques  Id  Sistema
/dev/sda1   *           1        6374    51199123+   7  HPFS/NTFS
/dev/sda2            6375       37011   246091702+   5  Extendida
/dev/sda3           24611       24853     1951866   82  Linux swap / Solaris
/dev/sda5            6375       24610   146480607   83  Linux

luego
FSTAB

# /etc/fstab: static file system information.
#
# Use 'vol_id --uuid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
#                
proc            /proc           proc    defaults        0       0
# / was on /dev/sda7 during installation
UUID=ab65aabb-de76-4a2c-8ccf-ac3f4a642136 /               ext4    relatime,errors=remount-ro 0       1
# /home was on /dev/sda6 during installation
UUID=f49dfafb-37b1-4a5a-ae22-edd33f74e62e /home           ext4    relatime        0       2
# swap was on /dev/sda5 during installation
UUID=b0bb9f40-3588-4e8a-bf62-e8d7484c8315 none            swap    sw              0       0
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0

Lo cierto es que me sale el famoso error de que no puede montar la partición correspondiente a /home; ésta la puse en partición aparte por la comodidad de reinstalar el sistema sin preocuparme por el respaldo de datos.

El error comenzó, cuando tuve que cambiar de XP al 7 en la NTFS.

Al intentar seguir la secuencia de comandos que propone Gabriel_M, me dá lo siguiente

root@ubuntu:/home/ubuntu# fsck -y /dev/sda1
fsck desde util-linux-ng 2.16
fsck: fsck.ntfs: no se encontró
fsck: Error 2 mientras se ejecutaba fsck. ntfs para /dev/sda1
root@ubuntu:/home/ubuntu# fsck -y /dev/sda2
fsck desde util-linux-ng 2.16
e2fsck 1.41.9 (22-Aug-2009)
fsck.ext2: Attempt to read block from filesystem resulted in short read mientras se intentaba abrir /dev/sda2
¿Esta podría ser una partición de longitud cero?
root@ubuntu:/home/ubuntu# fsck -y /dev/sda3
fsck desde util-linux-ng 2.16
fsck: fsck.swap: no se encontró
fsck: Error 2 mientras se ejecutaba fsck. swap para /dev/sda3
root@ubuntu:/home/ubuntu# fsck -y /dev/sda5
fsck desde util-linux-ng 2.16
e2fsck 1.41.9 (22-Aug-2009)
/dev/sda5: limpio, 220977/9158656 ficheros, 2050710/36620151 bloques
root@ubuntu:/home/ubuntu# fsck -y /dev/sda6
fsck desde util-linux-ng 2.16
e2fsck 1.41.9 (22-Aug-2009)
fsck.ext2: No existe el fichero ó directorio mientras se intentaba abrir /dev/sda6

El superbloque podría no ser leido o no describe un sistema de ficheros ext2 correcto.
Si el dispositivo es válido y en verdad contiene un sistema de ficheros ext2 (y no uno 
de intercambio, ufs o algo más), entonces el superbloque está corrompido
y podría intentarse ejecutar el e2fsck con un superbloque alternativo:
   e2fsck -b 8193 

root@ubuntu:/home/ubuntu# fsck -y /dev/sda7
fsck desde util-linux-ng 2.16
e2fsck 1.41.9 (22-Aug-2009)
fsck.ext2: No existe el fichero ó directorio mientras se intentaba abrir /dev/sda7

El superbloque podría no ser leido o no describe un sistema de ficheros ext2 correcto.
Si el dispositivo es válido y en verdad contiene un sistema de ficheros ext2 (y no uno 
de intercambio, ufs o algo más), entonces el superbloque está corrompido
y podría intentarse ejecutar el e2fsck con un superbloque alternativo:
   e2fsck -b 8193 

root@ubuntu:/home/ubuntu#

No he querido cambiar nada no sea que empeore las cosas...

agradeceré muchísimo que me orienten con éste problema!

+1
0
-1