Problemas con GRUB

Imagen de Yoyi
0 puntos

Buenas, soy totalmente nuevo en esto de Linux.
Comento brevemente mi caso.
Me bajé Ubuntu 9.10 Desktop con la intención de compartirlo con Windows en mi portátil ASUS.
Como leí, redimensioné la particion de Vista que tenía dejando 20 GB sin particionar.
Luego reinicié con el CD de UBUNTU e instalé en la opción de compartir ambos sistemas operativos.
Tras instalar y preguntarme en que S.O quería iniciar y probar W.Vista para ver si no habia perdido nada me salió un gran ERROR en rojo en la pantalla ... Intenté entrar en Ubuntu y lo único que consigo ver es un error que reza lo siguiente:
GRUB loading.
error: no such partition
grub rescue>

De aquí no paso. Lo único que consigo ahora mismo con el portátil es arrancar en modo "prueba" con ubuntu desde CD pero no puedo acceder ni a VISTA ni a UBUNTU. Tengo un pisapapeles ASUS muy bonito!!

Tengo dos intenciones bastante claras.
1º Poder recuperar mi SO de Vista que es donde tengo todo montadito
2º Aprender a instalar Ubuntu y usarlo sin destrozar nada alrededor :S

Muchas gracias

Imagen de arriero
+1
0
-1

Haz buscado primero con google, tu modelo exacto de Asus ladrillo y añadiendo ubuntu haber que sale.

Pero dices que haz intentado entrar en modo prueba ¿? No comprendo haz entrado en modo livecd ahora que tienes el fallo y anteriormente ¿no haz probado tu hardware de esta forma para ver si tenias fallos?

A otra cosa poniendo en google el fallo + asus salen unos pocos de post con fallos de grub, eso es peligrosamente raro.

Haber según lees tienes un fallo que no encuentra grub mira esto que te viene ni que pintado léete la parte de reinstalar grub2 con livecd.

Para un final feliz, un comienzo indeciso

Mi Blog

+1
0
-1

Si reparas tu problema, añade(Solucionado)en el asunto de tu primer post, así es mas fácil para el que busca después.Mi Blog

Imagen de Yoyi
+1
0
-1

Busco y rebusco, y sinceramente, lo que me faltan son clases teóricas de particiones, linux, y recuperación de arranque de Windows Vista.
Por una vez en mi vida me gustaría poder solucionar el problema sin tener que formatear!!
Cuando dices probar mi hardware para ver si tenia fallos, a que te refieres, buscar por internet si hay incompatibilidades de mi hard con ubuntu??
He probado esto: http://www.guia-ubuntu.org/index.php?title=Recuperar_GRUB ... pero me da el siguiente error.

$ sudo fdisk -l --> fdisk: opción incorrecta -- '1'
$ sudo mount /dev/sda1 /mnt --> sin mensaje
$ sudo mount --bind /dev /mnt/dev --> mount: el punto de montaje /mnt/dev no existe

Imagino que si de 3 comandos, me fallan 2 ... no tengo nada que hacer ...

Aunque básicamente quiero poder volver a entrar a Vista ... y no se comor!!

+1
0
-1
Imagen de nahuel_111
+1
0
-1

sudo fdisk -l (ele)

y el resultado del primer comando es necesario para introducir el segundo.

si metes comandos porque si vas a empeorar las cosas

+1
0
-1
Imagen de XDanteX
+1
0
-1

A lo que entendi que hiciste fue solo instalar ubuntu y punto.
muy bien esto es lo que tienes que hacer:
reinstalar ubuntu
1.- Despues de elegir el idioma de sistema y teclado, llega el particionado.

2.- hay una opcion que dice particionamiento manual, selecciona ese y espera a que cargue las particiones.

3.- La mayoria de los sistemas Linux tienen un sistema de ficheros Ext* (Es como un Ntfs de Win), Ubuntu tiene como defecto una particion Ext4 (cuarta actualizacion del sistema de ficheros Ext*), ademas una particion de respaldo llamada Swap que es como una memoria virtual por si no tienes suficiente memoria Ram.

4.- das click derecho donde dice Ext4, borras la particion.

5.- si tienes una particion que dice swap entonces no es necesario crearla.

5*.- si no tienes que crear la particion ¿Como? , pues dando click derecho al espacio libre, te da el espacio libre del disco en Mb. puedes ponerle 512, 1024 o cualquier valor (preferible si menor a 1024 pues te quita espacio en disco).

6.- para crear una particion Ext4 haces el mismo proceso de la particion swap. pero esta vez la particion ext4 te pide punto de montaje. el punto de montaje de todo sistema linux es / pones ese punto de montaje y la creas.

7.- listo para instalar ubuntu, pones instalar y luego de instalar espera a que te ordene sacar el disco y presionar enter.

ojala te haya servido de ayuda, suerte y no te preocupes que la mayoria empieza arruinando algo jejeje.

+1
0
-1
Imagen de arriero
+1
0
-1

Compañero xDantex se da por echo que antes de ponerte a instalar un S.O. te haz preocupado de leer, como poder hacerlo y como hacerlo, si no lo haces quizás te encuentres con problemas como estos, si lo haces sin informarte, al final conseguirás como decimos en mi tierra "unzizale"

Ahora el compañero deberá de sopesar que es mejor para él y para la vida de su ordenador, intentar la reinstalación o instalar mejor a ubuntu desde cero o ha windows.

Yoyi la 1ª orden es sudo fdisk -l (L en miniscula) y saldria algo asi

pepe@pepe-laptop:~$ sudo fdisk -l
[sudo] password for pepe: 

Disco /dev/sda: 250.0 GB, 250059350016 bytes
255 cabezas, 63 sectores/pista, 30401 cilindros
Unidades = cilindros de 16065 * 512 = 8225280 bytes
Identificador de disco: 0xaa1cfeb7

Disposit. Inicio    Comienzo      Fin      Bloques  Id  Sistema
/dev/sda1   *           1        1216     9767488+  83  Linux
/dev/sda2            1217       30401   234428512+   5  Extendida
/dev/sda5           29745       30401     5277321   82  Linux swap / Solaris
/dev/sda6            1217       29744   229151097   83  Linux

En mi caso es sda1 y en el del ejemplo por que no tenemos una partición de windows tu caso seria algo diferente.

Para un final feliz, un comienzo indeciso

Mi Blog

+1
0
-1

Si reparas tu problema, añade(Solucionado)en el asunto de tu primer post, así es mas fácil para el que busca después.Mi Blog

Imagen de Capa
+1
0
-1

Por favor, lee las normas antes de publicar.

Es nesario el uso de títulos descriptivos con tu problema.
Títulos como "Muy novato y tras leer varios post ... increiblemente perdido" no aportan ninguna información.

Título editado a: Problemas con GRUB.


Equipo de Ubuntu-es

+1
0
-1
Imagen de Yoyi
+1
0
-1

Perdón por el post sin título informativo y por ser tan triste de no saber diferenciar "1" de "l" xD
He conseguido instalarlo, ahora bien, tengo una duda-problema.
No me aparece la opción de escoger sistema operativo a la hora de arrancar (GRUB no?)
He leído que tengo que modificar el archivo de arranque pero antes de tocar nada os muestro como tengo el sistema:

Disco /dev/sda: 320.1 GB, 320072933376 bytes
71 cabezas, 5 sectores/pista, 1760964 cilindros
Unidades = cilindros de 355 * 512 = 181760 bytes
Identificador de disco: 0x00000bef

Disposit. Inicio Comienzo Fin Bloques Id Sistema
/dev/sda1 1 57691 10240150 1c Hidden W95 FAT32 (LBA)
/dev/sda2 * 57696 746757 122308207 7 HPFS/NTFS
/dev/sda3 746758 1760957 180020500 f W95 Ext'd (LBA)
/dev/sda5 1079666 1760957 120929280 7 HPFS/NTFS
/dev/sda6 746758 856791 19531030 83 Linux
/dev/sda7 856792 884300 4882845 82 Linux swap / Solaris
/dev/sda8 884301 1079662 34676752+ 83 Linux

Querria saber si almenos lo tengo bien instalado, o es que me funciona por cosas del azar.
En caso de estar bien instalado, que debería hacer para "crear" un grub para poder escoger.
Teóricamente todavía tengo W.Vista en lo que seria sda2.

Muchas gracias y perdón nuevamente

+1
0
-1
Imagen de arriero
+1
0
-1

Haber Yoyi ¿haz conseguido que ubuntu arranque? No te pregunto grub sino ubuntu.

Si lo haz conseguido, siguiendo el enlace que te puse hacia el manual de grub2, intenta añadir la opción del arranque de windows. Te aconsejo sigas el enlace que te puse ya que es de un compañero de ubuntu-es y siempre podemos acudir a él para que te eche una mano.
Disculpa pero es que grub2 nos coge a todos de nuevos, es algo implementado nuevo en ubuntu, por lo tanto poco usado y testeado.

Para un final feliz, un comienzo indeciso

Mi Blog

+1
0
-1

Si reparas tu problema, añade(Solucionado)en el asunto de tu primer post, así es mas fácil para el que busca después.Mi Blog

Imagen de Yoyi
+1
0
-1

He actualizado el grub con:

jordi@jordi:~$ sudo update-grub
[sudo] password for jordi:
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-2.6.31-16-generic
Found initrd image: /boot/initrd.img-2.6.31-16-generic
Found linux image: /boot/vmlinuz-2.6.31-14-generic
Found initrd image: /boot/initrd.img-2.6.31-14-generic
Found memtest86+ image: /boot/memtest86+.bin
Found Windows Vista (loader) on /dev/sda1
Found Windows Vista (loader) on /dev/sda2
done

Pero luego al intentar "ver" el grub con el comando me sale:

jordi@jordi:~$ cat /boot/grub/menu.lst
cat: /boot/grub/menu.lst: No existe el fichero ó directorio

He leído que debería modificar alguna linea como el tiempo de espera o alguna linea de comando para añadir Vista con su correspondiente partición, pero no se como acceder a grub :S

Gracias de antemano, me estáis ayudando a que no le coja gato a la primera de cambio!!

Pongo mal el comando? Dottor, dottor, qué me pasa!
Todavia tengo que probar reiniciar directamente y a ver que sucede.

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

Hola yoy...:

El Grub te informa:".....Generating grub.cfg ..."

Tu ordenas: "....cat /boot/grub/menu.lst..."

Y recibes la salida obvia: "...cat: /boot/grub/menu.lst: No existe el fichero ó directorio..."

Prueba con: cat /boot/grub/grub.cfg

Saludos.
Gabriel.



Solo doy soporte para Ubuntu: Un sistema operativo superior, moderno, optimizado, seguro, evolutivo y completo.
+1
0
-1
Imagen de arriero
+1
0
-1

Gabriel gracias de parte del compañero y del mio también, pero creo que lo que le ocurre es que confunde conceptos entre grub y grub2, viendo ya la causa, habrá que intentar hacer que comprenda el concepto y diferencias entre los gestores de arranque con los cuales se esta peleando, para que vea cual es la diferencia, para nosotros obvia por los años de uso y para él algo que le suena a chino por ahora.
Pongo en las palabras importantes los enlaces para aclararte un poco el tema y en grub2 una traducción de google que incluye las diferencias entre grub y grub2 saludos.

Para un final feliz, un comienzo indeciso

Mi Blog

+1
0
-1

Si reparas tu problema, añade(Solucionado)en el asunto de tu primer post, así es mas fácil para el que busca después.Mi Blog

Imagen de Yoyi
+1
0
-1

De vuelta al pasado, he recuperado Vista.
He vuelto a hacer las particiones:
1º ext4 "/" de 20GB
2º swap de 2GB
3º ext4 "/home" de 20GB
Hasta ahí creo que todo correcto.
Al instalar me he dado cuenta que hay una opción abajo en "Avanzado" que me permite poner el arranque en la partición que quiera, antes no cambiaba nada y metía el arranque en la partición de Vista (supongo que por eso no me arrancaba Vista y jodia el GRUB cuando lo intentaba), esta vez lo he puesto en la partición de "/".
Mi sorpresa es que al reiniciar me salta directamente Windows, no me aparece GRUB para poder escoger entre Windows y Ubuntu. Ahora estoy con Super Grub, pero exactamente no se que tengo que hacer porque no se cual es el problema.
No tengo GRUB?
No debería haber puesto el arranque en "/"?
No está correctamente instalado?
Y por último .. qué tengo que hacer para solucionarlo??

Gracias de antemano!!

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

Hola yoy....:

1- Te sugiero leas la documentación y tutoriales y trucos, esto que
sigue a continuación lo publique alli, e innumerables veces en los foros.

2- Recuperar reinstalar el Grub 2 via LiveCD

Antes te informa que para que un cargador de arranque (Lilo, Grub2
Grub Legacy) inicien, deben estar en el mbr del disco 0, /dev/sda

a- Inicia con un live-cd de ubuntu

b- Abre una consola (aplicaciones - Accesorios - Terminal)
Ejecuta

sudo su

Identifica la partición de la instalación de Ubuntu ejecutando:

fdisk -l

Suponiendo sea /dev/sda5, continuas ejecutando

mount /dev/sda5 /mnt
mount --bind /dev /mnt/dev
mount --bind /proc /mnt/proc
mount --bind /sys /mnt/sys
chroot /mnt
apt-get update
apt-get upgrade
apt-get install grub2 grub-pc grub-common
update-grub
grub-install /dev/sda
grub-install --recheck /dev/sda
Pulsar Ctrl+D 
umount /mnt/sys
umount /mnt/proc
umount /mnt/dev
umount /mnt
reboot

Saludos.
Gabriel.



Solo doy soporte para Ubuntu - Existen muchas soluciones - Las erróneas y la mia.
+1
0
-1
Imagen de Yoyi
+1
0
-1

Gracias de nuevo Gabriel.
Mientras ejecuto apt-get upgrade en ocasiones sale el mensaje:
No se pudo escribir en el registro, falló la llamada a <> (¿está montado /dev/pts?)
Luego me dice:
Hay una nueva versión del fichero de configuración /etc/default/grub, pero la versión que está instalada ha sido modificada localmente.
Que desea hacer con grub?

Instalar la versión del responsable del paquete
Conservar la versión local actualmente instalada (la conservo porque entiendo que la he modificado a mi necesidad)

Tras esto: update grub
No command 'update' found
...
He probado a proseguir pese a no poder hacer 'update'
grub-install --recheck /dev/sda
grub-setup: warn: You embedding area is unusually small. core.img win't fit in it.
grub-setup: Embedding is not possible. GRUB can only be installed in this setup by using blocklists. However, blocklists aree UNRELIABLE and its use is disouraged.
Instalation finished. No error reported
This is the contents of the device map /boot/grub/device.map.
Check if this is correct or not. If any of the lines is incorrect, fix it and re-run the script 'grub-install'

+1
0
-1
Imagen de Yoyi
+1
0
-1

Pese a esos errores parece que todo funciona como debería ...
Te mantendré informado :P

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

Hola yoy...:

1- Habia un error, es update-grub el comando.

2- ¿cómo puedes tener un grub personalizado si no se carga el sistema?
Acepta que se genere un nuevo grub.cfg o no se cargara Vista en el menu

Saludos.
Gabriel.



Solo doy soporte para Ubuntu - 6666 - Más malo que el diablo.
+1
0
-1
Imagen de Yoyi
+1
0
-1

He vuelto a usar los comandos y ahora voy a reiniciar.
Por cierto ya se porque al entrar en "Windows Vista" me petaba todo.
La primera partición de W.Vista que tengo en el portátil es la de RECOVERY, lo que no se es porque me eliminaba el GRUB
Que archivo debo editar para eliminar esa Opción del arranque?
He leido que el grub.cfg no se debe editar, que es el grub.c o algo así.
Con el "cat" leo y con el "nano" puedo editar??

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

Hola yoy...:

El Grub2 reconoce todos los operativos que pueden iniciar en el sistema
automáticamente, esto que parece ser una ventaja se convierte en un
incordio cuando se tienen particiones de recuperación.

Si deshabilitas el reconocimiento, en la próxima actualización perderás
la entrada del Vista, asi que solo queda dejarla o editar el grub.cfg
cada vez que se actualiza el sistema para eliminarla.

Saludos.
Gabriel.



Solo doy soporte para Ubuntu - 6666 - Más malo que el diablo.
+1
0
-1
Imagen de Yoyi
+1
0
-1

Podre sobrevivir a ese pequeño detalle.
Lo que me pasa ahora es que no se me escucha el sonido.
Ahora no recuerdo en que caso fue, si con el LiveCD o en otro de los múltiples intentos de instalación de UBUNTU pero antes sí se me reproducían los sonidos.
He leído por internet que tenía que modificar un archivo:
Try adding "options snd-hda-intel model=laptop" to your /etc/modprobe.d/alsa-base file (open file with sudo gedit). Save, reboot.
Tampoco me ha hecho efecto.
sudo lspci | grep Audio
00:0f.0 Audio device: Silicon Integrated Systems [SiS] Azalia Audio Controller00:0f.0 Audio device: Silicon Integrated Systems [SiS] Azalia Audio Controller
Subsystem: ASUSTeK Computer Inc. Device 1783
Flags: bus master, medium devsel, latency 0, IRQ 18
Memory at fddf8000 (32-bit, non-prefetchable) [size=16K]
Capabilities:
Kernel driver in use: HDA Intel
Kernel modules: snd-hda-intel
Esta es toda la información de que dispongo...

Esto no acaba nunca!!!

PD: Ya tengo Vista+Ubuntu ... por fin!!!

+1
0
-1
Imagen de facucampeon
+1
0
-1

+1
0
-1

Ubuntu 10.04 (Lucid)
Windows Xp Professional SP3
AMD Athlon(tm) 64 X2 Dual Core Processor 5000+ 1GHz
Placa de Video Onboard---> K8M800/K8N800/K8N800A [S3 UniChrome Pro]
Placa de Sonido Onboard--->VT8233/A/8235/8237 AC97 Audio Controller