A karmic le cuesta iniciar disco duro externo usb

Imagen de Paulita78
0 puntos

Hola Gente!Pues lo que comento en el título,que a karmic le cuesta un buen rato reconocer mi disco duro externo usb,cosa que con anteriores versiones de ubuntu no me sucedia.Hay veces que aparece nada mas iniciar,que era lo normal...otras tarda un buen rato,y otras tengo que reiniciar de nuevo porque ni aparece.Es raro porque hice instalación limpia y no metí la manaza en donde no debia(ya he aprendido a no hacerlo,jeje..)y oye,pues es ahi donde tengo la mayoria de archivos y a veces es bastante molesto.¿alguien sabe a que puede deberse esto?Agradeceria alguna solucion que me permitiera que arrancara desde el inicio,como asi ocurria en jaunty e intrepid,que son las versiones que usé antes que esta.
Saludos y feliz navidad!

Imagen de Paulita78
+1
0
-1

Ah se me olvidaba!El tipo del sistema de archivos es msdos por lo que he podido ver en propiedades.Este disco en su dia lo usaba en güindos y lo dejé tal cual,no sé,lo digo por si puede tener algo que ver en mi problema.

+1
0
-1
Imagen de miguelito08
+1
0
-1

El sistema de archivo debe ser FAT 32

Eso es estraño, porque actualmente poseo dos disco duros
externos y funcionan sin problemas, uno esta en FAT 32 y
el otro en NTFS

Suerte

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

Hola pau....:

Ejecuta en consola, con el disco conectado:

sudo fdisk -l (es ele minuscula)

Copia y pega la salida en el post

Saludos.
Gabriel.



Solo doy soporte para Ubuntu - Tengo la conciencia bien limpia. Y muy mala memoria.
+1
0
-1
Imagen de Paulita78
+1
0
-1

Hola Miguelito,hola Gabriel.Bueno,he hecho lo que me dices Gabriel y me tira esto:

Disco /dev/sda: 160.0 GB, 160041885696 bytes
255 cabezas, 63 sectores/pista, 19457 cilindros
Unidades = cilindros de 16065 * 512 = 8225280 bytes
Identificador de disco: 0x035e035e

Disposit. Inicio Comienzo Fin Bloques Id Sistema
/dev/sda1 * 1 18730 150448693+ 83 Linux
/dev/sda2 18731 19457 5839627+ 5 Extendida
/dev/sda5 18731 19457 5839596 82 Linux swap / Solaris

Disco /dev/sdg: 160.0 GB, 160041885696 bytes
255 cabezas, 63 sectores/pista, 19457 cilindros
Unidades = cilindros de 16065 * 512 = 8225280 bytes
Identificador de disco: 0xd5395d43

Disposit. Inicio Comienzo Fin Bloques Id Sistema
/dev/sdg1 1 19457 156288321 c W95 FAT32 (LBA)

Vamos,esto a mi me suena a arameo...No soy nada avanzada en esto,solo lo que os digo,en las otras versiones me chutaba bien,pero desde karmic me falla,ojo que no lo critico,que salvo esto va fenómeno

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

Hola pau...:
No, no es arameo 8)

fdisk informa:

1- Que tu disco interno, /dev/sda tiene
Una partición primaria, /dev/sda1, activa dedicada a /
Una partición extendida, /dev/sda2, donde esta la lógica
/dev/sda5 dedicada a swap

off topic on
(Mi sugerencia, es que el día que reinstales lo hagas
con particionamiento manual en tres particiones
Una primaria, activa, de no mas de 20 gigas para /
Una lógica de no mas de 1 giga para swap
Una lógica del resto para /home)

off topic off

Que tu disco externo /dev/sdg tambien de 160 gigas
Tiene una sola particion primaria /dev/sdg1 en
formato fat32

Al meollo:
fat32 es un sistema de archivos obsoleto e ineficiente, con
tendencia a fallos y franca defragmentación, que requiere
controles frecuentes.

1- Dejando todo como esta, deberías ejecutar:

sudo umount /dev/sdg1
sudo fsck.msdos -a /dev/sdg1

Con esto previo desmontar, revisas y reparas automáticamente
los errores que puedan existir.

2- Particularmente moveria todos los archivos al disco interno
y previo instalar:

sudo apt-get install ntfs-3g fuse-utils ntfs-config ntfsprogs gparted

Desde gparted, previo desmontrar el disco, borraria la partición y
crearía una nueva en sistema de archivos ntfs, para luego restaurar
los archivos del disco interno, previo activar desde Accesorios -
Herramientas de sistema - Herramienta de configuración NTFS la
lectura - escritura para dispositvos externos.
Esto para el caso de que la información se comparta con sistemas windows

Si no se compartiera con sistemas windows, el formato sería ext4

Saludos.
Gabriel.



Solo doy soporte para Ubuntu: Un sistema operativo superior, moderno, optimizado, seguro, evolutivo y completo.
+1
0
-1
Imagen de Paulita78
+1
0
-1

No hombre,decia lo del arameo porque ando muy pez en ubuntu y en la informática en general,soy una pinche usuaria básica pero con ganas de aprender,y como ya he metido la gamba muchas veces pues antes que nada pregunto.Pues en realidad no uso güindos para nada,lo tengo instalado en virtualbox,pero abandonado,y con intencion de deshacerme de el(unicamente lo usaba para conversion de video,pero habiendo ffmpeg con los problemas de los codecs ya resueltos pues como que ya no lo quiero),porque para el uso que hago de mi ordenador con ubuntu va muchisimo mejor.Osea que seria aconsejable darle formato ext4,¿verdad?creo entender(corrigeme si me equivoco)que asi es,pero como dices debo "hacer un traslado" de todos los datos,desmontar el disco y despues darle formato ext4 con Gparted,¿es asi?bien,pues vamos a ponernos al lio y ya te cuento como ha ido todo y si se me ha resuelto el problema del "reconocimiento".Muchas gracias por tu ayuda Gabriel!Un saludo

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

Hola pau.....:

Si, efectivamente, si solo usas el disco con Ubuntu:

Mueves los archivos al disco duro interno.

Desmontas el externo.

Instalas gparted si no esta instalado.

Cargas gparted, ubicas el disco externo /dev/sdg

Borras la partición.

Creas una nueva en sistema ext4

Aplicas los cambios.

Creas un directorio para montar el disco

mkdir /home/usuario/datos

Le das permisos de lectura escritura

sudo chmod -Rf 777 /home/usuario/datos

Lo montas

sudo mount /dev/sdg1 /home/usuario/datos

Averiguas la uuid de la partición:

sudo blkid /dev/sdg1

Editas /etc/fstab para que se monte al inicio
(Te cuidado siempre que al iniciar el ordenador este enchufado
o tendrás problemas para iniciar al no encontrarlo)

sudo gedit /etc/fstab

Agregas las líneas:

# /home/usuario/datos was on /dev/sdg1
UUID=xxxxxxxxxxxxxxxxxxxxxxxxxx /home/usuario/datos  ext4 defaults        0       2

Guardas el archivo

A partir de ahora al inicio se montará automáticamente.

Saludos.
Gabriel.



Solo doy soporte para Ubuntu - No se han reportado víctimas fatales
por consultas de documentacion y tutoriales.
+1
0
-1
Imagen de Paulita78
+1
0
-1

Bueno,estoy en ello ahora mismo(hay mucho archivo de dios ahi metido y me llevara un ratico).pero te cuento.Al final le he dado formato ntfs al disco,en principio no tengo ninguna intención de usar güindos porque me apaño muy bien en ubuntu,pero nunca se sabe...(por ejemplo tuve que "delinquir" por una cosica del gps para el coche,y ahi ya tengo que operar con el maligno)¿deberia cambiar algo en estas ultimas indicaciones que me has dado?porque claro,en principio iba a dar formato ext4,pero habiendo cambio de planes...Y luego otra cosa.al formatear he metido un pelin la gamba y ahora ya no es dev/sdg1 sino dev/sdf1.cambiaremos el nombre del dispositivo por el nuevo y listo¿no?y bueno,creo que no tengo ninguna duda mas.Ahora me toca esperar a que restaure todo y proceder al montaje.
Se agradece mucho tu interés,ya te comento como me ha ido.Saludos!

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

Hola pau...:

En general, ntfs-config (herramienta de configuracion ntfs)

Hace todo por si mismo, mas por las dudas

en el procedimiento manual

solo cambiarían las líneas del /etc/fstab

# /home/usuario/datos was on /dev/sdf1
UUID=xxxxxxxxxxxxxxxxxx    /home/usuario/datos     ntfs-3g     defaults,locale=es_ES.UTF-8    0    1

Saludos.
Gabriel.



Solo doy soporte para Ubuntu - Es preferible callar y pasar por idiota, que hablar y demostrarlo.
+1
0
-1
Imagen de Paulita78
+1
0
-1

¿Quieres decir que los pasos que me indicas arriba los hace la herramienta de configuracion ntfs?¿Osea que bastaria con activar el soporte de escritura?Ya me puedes perdonar que sea tan preguntona pero es que no quiero meter la gamba

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

Hola pau....:

1- Siempre antes de actuar si tienes dudas, pregunta, pregunta, pregunta.

2- Si habitualmente ntfs-config hace todo por si mismo, lo único que te
monta la partición ntfs en /media/disk

3- Si lo haces manual la montas donde mas te agrade.

Para ello sin usar ntfs-config, sigues los pasos descriptos:

crear directorio (carpeta) con mkdir
darle permisos con chmod al directorio
montar la partición con mount
averiguar la uuid con blkid
agregar los datos en fstab para que se monte al inicio

Saludos.
Gabriel.



Solo doy soporte para Ubuntu - 6666 - Más malo que el diablo.
+1
0
-1
Imagen de Paulita78
+1
0
-1

Bueno,finalmente lo hice con ntfs-config,y bueno he reiniciado y nada,sigue la cosa como siempre,esta vez me ha tardado un par de minutos en aparecer el disco.¿Deberia probar de forma manual?

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

Hola pau....:

No uno u otro hacen lo mismo.

Revisa en:

Sistema - Preferencias - Aplicaciones al inicio

Si no tienes demasiados demonios (aplicaciones) innecesarios
cargándose al inicio.

Saludos.
Gabriel.



Solo doy soporte para Ubuntu - Tengo la conciencia bien limpia. Y muy mala memoria.
+1
0
-1
Imagen de Paulita78
+1
0
-1

Que va,tengo lo de siempre,lo que tenia en las otras versiones,esto solo me ocurre en karmic.tanto en intrepid como en jaunty arrancaba y ya estabe el icono en el escritorio.Ahora me aparece el hueco vacio y cuando aparece el disco,en el escritorio,se abre el solo,como si le diera doble click...

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

Hola pau....:
Puede que se deba a un bug.
Prueba lo siguiente:
Ejecuta en consola:

sudo gedit /etc/initramfs-tools/modules

En el archivo que se abre agrega estas dos líneas

ehci_hcd
uhci_hcd

Guarda el archivo
Cierra gedit
Ejecuta

sudo update-initramfs

Reinicia y ve si mejoró.

Saludos.
Gabriel.



Solo doy soporte para Ubuntu - 6666 - Más malo que el diablo.
+1
0
-1
Imagen de Paulita78
+1
0
-1

Nada,sigue igual...que se le va a hacer...lo he reiniciado cuatro veces y la cosa está igual,eso si,por lo menos me aparece,tarda un poco mas un poco menos pero aparece.No quiero volverte loco asi que mira,tendré que tirar así,seguramente se trate de un bug como dices.si es asi lo reportaré a launchpad.
Muchas gracias por tu ayuda Gabriel,un detallazo tu interés en mi caso,ya me gustaria poder echarte una mano alguna otra vez pero creo que en esto no va a poder ser,eres muchisimo mas avanzado que yo y no creo que te sirva de ayuda,jeje...
saludos!! :D

+1
0
-1