Problemas inicio ubuntu 9.04

Imagen de ximon
0 puntos

Hola buenas,

Soy nuevo aquí y llevo bastante poco con el ubuntu, a ver si me podeis ayudar.

Tengo un AMD con tarjeta grafica ATI Radeon 9500

Tenía instalado el ubuntu 9.04, me iva bien pero como tenía problemas con la tarjeta de video con algunos juegos estuve salseando y decidí instalar el paquete xorg-driver-fglrx desde Synaptic. Al intentar arrancar el juego toda la pantalla se me puso oscuro, con parches de la pantalla, se volvio loco. No podía acceder a nada. Tampoco podía deshacer el cambio ni nada. Reiniciaba y empezaba a arrancar y se quedaba loco otra vez antes de pedir el nombre de usuario y contraseña. Estaba perdido.

Decidi instalar el ubuntu otra vez. Instale pero en otra partición diferente. DE esta manera ahora tengo 2 particiones de ubuntu 9.04 y puedo acceder a la información de los 2.

Salseando por internet ví que el error podía venir por la configuración de la tarjeta y cambie el fichero "xorg.conf". COgi la configuración de la nueva partición y lo pegue en la vieja por terminal. Pero nada. Al iniciar cambia algo pero nada, se me queda media pantalla con 2 simbolos de Ubuntu y la otra media con el dibujo del escritorio. Un desastre.

Ya no sé de qué puede ser ni lo que puedo hacer.

¿Alguién sabe algo?

Gracias

Imagen de Linubux
+1
0
-1

Yo tambien soy un novato. No sé mucho pero creo que deberías dejar solo un Ubuntu. Reinstalarlo desde 0.

Free Software

+1
0
-1

==================================================

Linux se crea y no se destruye, solo se transforma.

Imagen de blackhalo
+1
0
-1

Lo primero es dejar solo un Ubuntu instalado.
Lo segundo es instalar Envy (sudo aptitude install envyng-core, tienes que tener activado el repositorio universe) y probar si te puede arreglar la papeleta (para usarlo en una terminal es sudo envyng -t).

Suerte.

GNUine freedom.

+1
0
-1

GNUine freedom.
Imagen de ximon
+1
0
-1

HOla de nuevo,

Primero no quiero borrar todo lo que he hecho instalando por encima Ubuntu otra vez porque me ha costado mucho ponerlo al día. Eso si no hay más remedio claro.

Por otra parte, lo de instalar Envy puede que valga para algo pero quiero recordarte que no puedo entrar en la partición que tengo jodida. Solo puedo acceder a los archivos de la partición jodida arrancando de la partición nueva. Por lo que no puedo ahora quitar la partición nueva porque me quedaría colgado.

¿Alguna otra idea?

Gracias.

+1
0
-1
Imagen de ximon
+1
0
-1

Socorro!!

Esto es un lio enorme. Vaya desesperación.

Ahora estoy intentando copiar el /home y intentar guardar todos los datos. Para ello quiero apmliar la partición pero con Gparted tengo problemas. Ahora en lugar de 2 particiones tengo 3!!! Cada vez voy a peor. Vaya m............

Ayuda porfa

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

Hola xim....:

En principio, desde una sesión live, ejecuta en consola
(Aplicaciones - Accesorios - Terminal)

sudo su
fdisk -l (es ele minuscula)

copia y pega la salida en el post

Saludos.
Gabriel.



Solo doy soporte para Ubuntu - Conozco muchas frases ingeniosas, pero no las recuerdo - Alzheimer.
+1
0
-1
Imagen de ximon
+1
0
-1

hola,

La partición esta hecha.

Pero ahora no puedo arrancar desde el origen. Me da error 22.

Estoy trabajando desde el CD live.

¿Que me recomiendas que haga? Copia la /home a la partición? y luego instalo el ubuntu otra vez en la partición base?

No sé que hacer.

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

Hola xim...:

No soy mago ni adivino.
Si no das los datos pedidos nada puedo aconsejarte.

Saludos.
Gabriel.



Solo doy soporte para Ubuntu - 6666 - Más malo que el diablo.
+1
0
-1
Imagen de blackhalo
+1
0
-1

Yo te recomendaría que hicieras caso de lo que te dice Gabriel.

Sin saber qué es lo que has hecho es muy difícil saber cómo solucionarlo.


GNUine freedom.
+1
0
-1

GNUine freedom.
Imagen de ximon
+1
0
-1

Hola,

En primer lugar gracias por estar ahí.

Teneis razón que tampoco os he informado demasiado bien. Intentare explicar todo.

Soy bastante novato con ubuntu y al principio me costo un poco poner todo el ordenador en condiciones, quiero decir, la impresora, el scaner, los paquetes basicos de videos, wine,...y ya que lo tenía y como quería jugar a algunos juegos, me daba problemas. Creia que era por la tarjeta grafica ya que me ponía problemas de la memoria de video (creo). Instale paquetes desde el Synaptic y al ejecutar el juego...puffffffffff se me puso todo supero raro, la pantalla se volvio loca, reiniciar y igual, no me dejaba ni introducir usuario ni contraseña, aparecía 2 simbolos de ubuntu borrosos...

¿Que es lo que hice? Tenía el CD live y en lugar de resolver desde el CD Live, instale en otra partición otra de ubuntu, por lo que tenía 2 particiones con 2 sistemas operativos de ubuntu. ¿Vaya lio no? Pues si pero bueno. Salseando en internet pensaba que el error lo podría solucionar corregiendo el fichero xorg.conf. Consegui editar desde terminal y puse driver "Vesa" para que arrancara y luego corregir el error instalando el paquete de la tarjeta ATI Radeon 9500. Nada.

Ya andaba un poco desesperado y como tampoco tengo mucha idea, salseando, salseando,... decidi por lo menos guardar la carpeta /home en otra partición. Como tenía 2 particiones con 2 sistemas operativos... pues tenía tela ponerlo bien. Al final ya lo consegui.

Situación actual.

- Particion principal de 85Gb con la primera configuración. /dev/sda1.Quiero decir con lo que tenía inicialmente, toda la configuración, datos,...
- Segunda partición de 34Gb, vacia./dev/sda4
- Memoria Swat de 1Gb ma o meno./dev/sda3

Al arrancar me da error 22 y se queda ahi. Hay que tener en cuenta que el xorg.conf esta cambiada pero no sé si esto tiene algo que ver con eso.

Mi idea era copiar primero la /home a la partición pequeña, guardando toda la configuración que tenía. Todo lo que tanto me costo poner, y instalar luego el Ubuntu de nuevo en la partición principal.

No sé si es la correcta.

Para ello mirando en foros pensaba hacer

#cp -af /home/usuario /media/linux1/usuario

Pero no lo tengo claro. ¿Porque -af?

No sé si con esta información vale o necesitais algo más. Por favor, si es posible no me gustaría perder la configuración que tenía antes.

Por cierto, si guardo en la partición pequeña la /home y al instalar el ubuntu por encima, ¿no se va a perder la de la partición? Ira bien? No lo tengo claro como hacerlo.

Muchas gracias de ante mano.

Saludos,

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

Hola xim....:

Simplemente:

Inicia una sesión live.

Monta /dev/sda1 ejecutando en consola
(Aplicaciones - Accesorios - Terminal)

sudo su
chmod -Rf 777 /mnt
mount /dev/sda1 /mnt

Si cerrar la consola, carga nautilus
en la sesión live
Pulsa control+h para ver ocultos
Borra todos los directorios (carpetas)
menos /var y /home
en la consola ejecuta a continuación

cd /mnt/home
cp -ax . /mnt

Desde nautilus controla que tu directorio
de usuario de /home se ha copiado a /mnt,
y borra /home.
En /mnt deben quedar /var y /usuario solamente
en la consola ejecuta
umount /dev/sda1
cierra la consola y comienza la instalación
Instala con particionamiento manual en:
/dev/sda4, activa, booteable, punto de montaje /, formateada
/dev/sda1 punto de montaje /home, conservando los datos, sin formatear
/dev/sda3 montaje por defecto

Usa el mismo nombre de usuario y la misma contraseña
Terminada la instalación y reiniciado el sistema desde
el disco duro, copia los archivos desde /home/var/cache/apt/archives
a /var/cache/apt/archives

sudo su
nautilus
control+h
Ilumina todos los archivos
copiar
pasas al directorio
pegar

Luego borra /home/var
cuando instales las aplicaciones ya tendrás descargados los archivos
Saludos.
Gabriel.



Solo doy soporte para Ubuntu - Ben no conocia a Jacob
+1
0
-1
Imagen de cerimice
+1
0
-1

Estimado Ximon:

a mi me paso lo mismo que a ti ha sucedido, intentar actualizar el Driver de la grafica pensado todo funcionara mejor, yo lo hice fracase reinstale y me mori de miedo cada vez que cambiaba un driver en Linux, hoy gracias a Ubuntu uso a su papa, espero que sepas cual es el padre de Ubuntu, si no sabes buscale y dejaras de ser menos novato, siguiendo con el tema estoy seguro que si hubieras leido las primeras lineas de archivo "/etc/X11/xorg.conf" estoy casi seguro a menos que tengas muchas cosas raras en su sistema operativo que con ejecutar la lectura de esas lineas te habrias dado cuenta que ahi viene la soluciona tu problema y es:

sudo dpkg-reconfigure -phigh xserver-xorg

a mi me sucedio lo mismo en Debian, por instalar el Driver de Ati en mi RadeonX3100 cambie todo el archivo mencionado y no veia nada, mas que consola, en mis primeros momento de novato casi me muero, pero me puse ha leer la documentacion de los archivo que medio recordaba y leyendo encontre esa ayuda, ejecute el comando como root y todo regreso a la normalidad.

PD: no es malo tener dos particiones de Linux, es como tener dos Innombrables en el mismo disco duro, dos linux yo creo que es mejor.jajaja Saludos

CeRiMiCe
cerimice.ath.cx
SNK:The Future is now 

+1
0
-1

CeRiMiCe
cerimice.ath.cx
SNK:The Future is now 

Imagen de ximon
+1
0
-1

Gracias de antemano.

Perdona por mi torpeza pero ¿Como se carga nautilus? me he quedado bloqueado.

+1
0
-1
Imagen de ximon
+1
0
-1

Hola de nuevo.

Estoy siguiendo el tutorial de Gabriel pero me he atascado. No sé lo que es el nautilus, me imagino que será el navegador del ubuntu.
Bueno, he ido a la carpeta de "sistema de archivo" donde se encuentran todas las carpetas y he intentado borrar todas las carpetas y ficheros (incluiendo los ocultos) pero no me deja.

??

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

Hola xim....:

Nautilus es el administrador de archivos.

¿cómo se ejecuta?

Escribe en consola:

sudo su
(tu contraseña)
nautilus

En definitiva el procedimiento es:

sudo su
chmod -Rf 777 /mnt
mount /dev/sda1 /mnt
nautilus
Pulsa control+h para ver ocultos
Borra todos los directorios (carpetas)
menos /var y /home
cierra nautilus
cd /mnt/home
cp -ax . /mnt
nautilus
Navegar por /mnt
Controlar que tu directorio
de usuario de /mnt/home/usuario se ha copiado a /mnt/usuario,
borrar /home
En /mnt deben quedar /var y /usuario solamente
Cierra nautilus
en la consola ejecuta
umount /dev/sda1
cierra la consola y comienza la instalación

Saludos.
Gabriel.



Solo doy soporte para Ubuntu - Tengo la conciencia bien limpia. Y muy mala memoria.
+1
0
-1
Imagen de ximon
+1
0
-1

Hola Gabriel,

Ya lo siento pero sigo bloqueado en el mismo sitio.

Escribo nautilus y me sale la ventana, me sale en root. Aquí no hay ni /var ni /home.Si entro dentro sistema de archivos (creo que es el /), aquí si veo las carpetas, pero... no me deja borrar algunas carpetas como /etc.

¿Voy bien?

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

Hola xim....:

/ es de la sesión live, no puedes ni debes borrar nada.
Debes ir a /mnt, donde se montó /dev/sda1

Saludos.
Gabriel.



Solo doy soporte para Ubuntu - No tomo la vida en serio, pues no saldré vivo de ella.
+1
0
-1
Imagen de ximon
+1
0
-1

Muchisimas gracias Gabriel.

Ya estoy con la configuración nueva. Menos mal.

Pero no consigo rematarlo. Me falta esto:

copia los archivos desde /home/var/cache/apt/archives
a /var/cache/apt/archives

sudo su
nautilus
control+h
Ilumina todos los archivos
copiar
pasas al directorio
pegar

Luego borra /home/var
cuando instales las aplicaciones ya tendrás descargados los archivos

No puedo hacerlo por navegador. ¿Tengo que hacer por terminal? ¿Como?

Gracias otra vez.

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

Hola xim...:

Por terminal es:

sudo su
cd /home/var/cache/apt/archives
cp -ax . /var/cache/apt/archives

Saludos.
Gabriel.



Solo doy soporte para Ubuntu - No tomo la vida en serio, pues no saldré vivo de ella.
+1
0
-1
Imagen de ximon
+1
0
-1

Hola Gabriel,

Estaba yo contento con ver todo el menu de aplicación en su sitio, con los ficheros, capetas... pero nada, todavía estoy jodido. Me explico.

Todas las adecuaciones que hice. Instalación de paquetes, no los tengo instalados y los tengo reinstalar. por ejemplo los programas para ver ficheros .avi y .mpg y cosas asi. Como los plugings de java...
Todos los programas de Wine, no las puedo ejecutar
Tampoco la impresora, escaner.

Eso de lo que he visto hasta ahora.

Por lo que parece no ha copiado los paquetes o la configuración o...no sé pero todavía estoy jodido. Con lo que costo ponerlo bien....

Por cierto, hice todo lo que me pusiste en la lista menos lo de borrar el /home/var (Que no sé de donde, cómo)

SAludos,

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

Hola xim....:

Instala desde synaptic, si conservabas los paquetes en la
cache, ya los tienes descargados, asi que se instalaran
al instante.

Ejecuta sudo nautilus para navegar hasta /home/var y borrar /var
y su contenido.

Saludos.
Gabriel.



Solo doy soporte para Ubuntu - Malcolm Crowe está muerto
+1
0
-1
Imagen de ximon
+1
0
-1

Hola de nuevo.

Me comentas de instalarlo desde Synaptic pero... en Synaptic hay un monton de cosas para instalar y yo quiero solo lo que tenía antes. Los paquetes que tenía antes para la impresora, scaner,...

Lo de borrar la carpeta /var tampoco sé. Yo soy todavía muy novato con todo esto. Ya he ido desde nautilus hasta /home donde tengo /var y /usuario. No en /home/var. He intentado borrar en /home la carpeta /var pero no sé como se borran carpetas.

Saludos,

+1
0
-1
Imagen de ximon
+1
0
-1

Hola Gabriel,

Me comentabas de cargar desde Synaptic los programas, pero mi pregunta es ¿se puede cargar desde synaptic los paquetes que ya tenía instalado anteriormente? ¿Como?

Hasta ahora me has ayudado un monton, please necesito el ultimo empujoncito para dejarlo bien.

Lo quiero dejarlo listo pero no sé en synaptic cómo hacerlo. Es que sino tengo que empezar a instalar paquetes...

Te agareceria muchisimo.

Mil gracias y saludos,

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

Hola xim....:

Simplemente marcas los paquetes para instalar, si estos
se mantenian en el viejo directorio /archives y ahora
estan en el actual, no se descargaran nuevamente, solo
se descargaran las actualizaciones, los desaparecidos y
las dependencias que pudieran faltar. Instalándose en forma
acelerada, tardarás mas en marcarlos.
Si existieran paquetes extraños a la distribución, tipo
nerolix4 crossover 8 deberas instalarlos mediante gdebi
pulsando sobre ellos.

Una vez que tengas el sistema configurado genera desde
synaptic una lista de paquetes instalados, para así la
proxima vez, con solo cargar el archivo lograras se marquen
para instalar las aplicaciones.

Esto lo haces pulsando en Archivo -- Guardar selecciones como
-- Guardar estado completo
Saludos.
Gabriel.



Solo doy soporte para Ubuntu - Ben no conocia a Jacob
+1
0
-1
Imagen de ximon
+1
0
-1

Hola Gabriel.

Siento darte la lata con mi idiotez con el ubuntu pero...

No sé qué paquetes tengo que marcar.

¿No aparece en algún lado los que tengo guardado de la anterior version? ¿Como cargar desde la carpeta de /archives si yo no sé todas las que tenía? ¿Que tendría que hacer mirar quiza en la carpeta /archives apuntarlas y luego marcarlas? o algo así?

Saludos,

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

Hola ximmm.....:

Los paquetes básicos, Ubuntu los instala por si mismo.

Los que has ido instalando por necesidad, a medida que
los necesites los iras instalando.

Para que el sistema funcione no hace falta que hagas nada,
simplemente usa Ubuntu y a medida que necesites algo lo instalas.

Saludos.
Gabriel.



Solo doy soporte para Ubuntu - Ben no conocia a Jacob
+1
0
-1
Imagen de ximon
+1
0
-1

Hola Gabriel,

lo de instalar paquetes necesarios, esta claro que si no hemos podido cargar de antes y lo necesitamos ahora habra que instalarlo. Yo creia que con el proceso que me pasaste mantendría todos los paquetes instalados anteriormente sin que se tuviera que instalar nada. Por ejemplo, tenía programas que funcionaban con Wine, y no me iban aunque los iconos aparecian en "Aplicaiones". Al final he tenido que ir a añadir quitar programas e instalar el programa Wine otra vez. Una vez instalado ya me ha cogido los programas basados en wine.

Por otra parte, programas como para el scaner no me iban tampoco. Menos mal que tenía guardado por ahí la pagina esde donde pude instalar el escaner. He tenido que seguir el procedimiento y ya me va la impesora y el scaner. Bueno, lo del scaner me va a medias, ya que solo por el terminal poniendo iscan me va y no me arranca desde "Aplicaciones" ni por el lanzador que prepare en el escritorio. ¿Sabes por que? Antes ya me iva.

En fin que al final tendre que ir instalando cosas a medida que los necesite.

Saludos,

+1
0
-1