Problema con Libboost

Imagen de Er_DavidS
0 puntos

Buenas a todos, soy algo novato en Linux y tengo un problemilla con las Librerías "Boost". Estoy intentando compilar un programa escrito en C++ en Linux Ubuntu 8.04 Hardy, pero en los repositorios sólo llega hasta la versión 1.34 del Boost, y necesito de la 1.36 para arriba.

Ya he consultado en los repositorios de la Web de Ubuntu, tanto los normales como los "Unsupported updates" y los "hardy-backports" pero no he encontrado nada. ¿Hay alguna manera de que pueda hacerlo o me puedo ir despidiendo ya del programa?.

Saludos.

Imagen de DjUndertaker
+1
0
-1

Hola, pues mira que estaba yo intentando compilar un programa y a pesar de haber instalado libboost y paquetes de libboost a través de synaptics, me termina el configure con el mismo error y llevo ya asi ratito :S
checking for boostlib >= 1.42... yes
checking whether the Boost::Filesystem library is available... yes
checking for exit in -lboost_filesystem-mt... yes
checking whether the Boost::Signals library is available... yes
configure: error: Could not link against boost_filesystem-mt !

Voy a entrar en synaptics y marcar todo lo que me salga de libboost y te cuento

+1
0
-1
Imagen de DjUndertaker
+1
0
-1

Vale, si me ha servido, instalé todos los paquetes que no estaban en mi pc de la versión que tengo de liblo, eso si tuve que ir marcando los paquetes de 4 en 4 para instalarlos porque todos de golpe no me dejaba wtf, al final he solventado el error de liblo, ahora me pide otras librerias pero esas no creo que tenga problemas, ya las tenia antes de formatear, saludoos!

+1
0
-1