Actualizar Monodevelop

Imagen de benjavalero
0 puntos

Hola, últimamente he leído tantas lindezas de Mono que me he decidido a trastear un poco y me está gustando, aunque me costará dejar a mi querido Java por C#. Veo que en C# no hay "makefiles" o al menos no los he visto por ningún tutorial. Pero en ese caso la compilación es totalmente engorrosa desde consola. Me he decidí entonces a probar el Monodevelop. Está bastante bien, pero la versión que instalé (la que viene por defecto con Breezy) se me cuelga bastante, no me deja cerrar ventanas y cosas así, no sé si eso le pasará a más gente.

Para actualizarlo parece que lo único que puedo hacer es instalar la versión de Dapper, pero esta me pretende actualizar casi media distribución, y yo aún uso módem ;) ¿Existe algún back-port por ahí? ¿Tiro de compilación desde código fuente?

Por cierto, he leído algo también sobre un plug-in para Eclipse, lo tendré que probar en breve. Agradecería cualquier comentario, sugerencia y aclaración (sobre todo lo último, ando un pelín perdido). Gracias.

Benja

Imagen de Anónimo
+1
0
-1

Yo tengo instalado Monodevelop 0.9 y va de maravilla.

agregate este source

deb http://debian.meebey.net/ ./

mas info http://pkg-mono.alioth.debian.org/

Juanpe
http://juanpe.blogsome.com

+1
0
-1
Imagen de benjavalero
+1
0
-1

Muchas gracias por el enlace al repositorio, no lo vi en su momento. He actualizado, pero sigo teniendo el mismo problema, se me cuelga al cerrarlo, al cerrar ventanas y demás. Por lo visto, soy el único al que le ocurre, así que empiezo a mosquearme, jejeje. Gracias de todos modos.

Benja

+1
0
-1
Imagen de kastrapo
+1
0
-1

He instalado Mono en mi portatil, corriendo con una Ubuntu 5.04 y me he bajado el .bin de la web de mono (www.monoproject.com). En principio el bin viene tanto con mono como con el programa de development. Pero este solo funciona si tienes gtk2.4 y algunas dependencias más que mi repositorio no consigue encontrar.

Hago lo siguiente:

>: sudo apt-get install monodevelopment

Y me dice que faltan todas estas dependencias:

The following packages have unmet dependencies:
monodevelop: Depends: libgconf2.0-cil (>= 2.3.90) but it is not going to be installed
Depends: libgecko2.0-cil (>= 0.11) but it is not going to be installed
Depends: libglade2.0-cil (>= 2.3.90) but it is not going to be installed
Depends: libglib2.0-0 (>= 2.8.0) but 2.6.3-1 is to be installed
Depends: libglib2.0-cil (>= 2.3.90) but it is not going to be installed
Depends: libgnome2.0-cil (>= 2.3.90) but it is not going to be installed
Depends: libgtk2.0-cil (>= 2.3.90) but it is not going to be installed
Depends: libgtksourceview1.0-0 (>= 1.4) but 1.2.0-0ubuntu1 is to be installed
Depends: libgtksourceview2.0-cil (>= 0.10) but it is not going to be installed
Depends: libgtksourceview2.0-cil (= 1.1.4) but 1.0.5-2 is to be installed

¿Alguien me puede decir con qué repositorio puedo encontrar las dependencias? ¿Vosotros no tubisteis que bajarlas?

+1
0
-1
Imagen de benjavalero
+1
0
-1

Siento no poder responderte, yo uso la edición Breezy 5.10 y no he tenido ninguno de los problemas que comentas, pues esas dependencias se encuentran satisfechas en sus repositorios.

+1
0
-1
Imagen de Anónimo
+1
0
-1

Yo me he bajado la versión de monodevelop de breezy y es una 0.7 (mientras ahora están por la 0.9), le faltan muchas funcionalidades.

Para actualizar a la 0.9 me he bajado los fuentes pero se quejaba mucho así que añadí el repositorio que decían antes, hice un dist-upgrade y me pasa lo mismo que a kastrapo. Ahora no se salir de ahí :S.

+1
0
-1
Imagen de benjavalero
+1
0
-1

A una mala, instala el binario instalable, yo al final es lo que tuve que hacer (lo comento en una respuesta un poco más arriba ;)).

+1
0
-1
Imagen de Anónimo
+1
0
-1

he estado usado mono durante unas semanas y me he encontrado con un problema muy curioso se me habrían ventanas y perdia el control del raton pense que podia ser un ataque externo o un virus por lo que hice una auditoria en mi red y no habia nada, finalmente decidi desinstalar mono y se acabo el problema si alguien sabe lo que pasa que lo publique

+1
0
-1
Imagen de elhumano
+1
0
-1

Seguramente el mono y el ratón no se llevan bien..... ;)

+1
0
-1
Imagen de ChouK
+1
0
-1

Yo opino que si uno se enfoca a la programación es mejor que trabaje con la versión de ubuntu hoary, desde mi punto de vista es más estable y da menos problemas.

A mi la breezy me ha dado bastantes problemas.

+1
0
-1
Imagen de benjavalero
+1
0
-1

Definitivamente soy el único ser en el universo en el que se le cuelga Monodevelop, aunque creo que es más problema de Mono. Finalmente he instalado Mono desde el instalador binario de la web oficial http://www.go-mono.com y me va todo genial. Viene incluida la documentación, Monodevelop y los plugins de Boo y Java. Ya me pasaré a los paquetes en Dapper, de momento me quedo con este método, que además me permite tener funcionando varias versiones de Mono a la vez.

+1
0
-1
Imagen de Anónimo
+1
0
-1

a mi me pasa el mismo problema, creo que es la version actual que se encuentra en los repositorios de ubuntu... he tratado de instalarla, pero tengo problemas con las dependencias en LIBGLIB2.0-0 el cual en los repositorios está la version 2.8, pero para instalar monodevelop necesito la version 2.10, que no esta en los repositirios, he estado indagando, pero nada, nadie me da respuesta al problema...

+1
0
-1
Imagen de pochu
+1
0
-1

Eso debe de ser porque estás instalando una versión para Dapper, y por ello te pide librerías (libglib) con versiones superiores a las que soporta Breezy, y no te deja instalar. Prueba a instalar la versión que haya para Breezy de Monodevelop, o si no, actualiza a Dapper.

Pochu
------------------------
CÓMOs de la web | Lista de CÓMOs
CÓMOs de Pochu

+1
0
-1

Saludos Pochu ------------------------ CÓMOs de la web

Imagen de MP
+1
0
-1

Pero haber si alguien me puede decir por que no me parece la plantilla que habia antes para crear un proyecto GLADE2 desde mono. ahora no aparece nada mas que un ejemplo de una ventana con un boton.

Espero me podais decir algo pues me gustaria empezar a programar en mono develop + Glade2. Me gustaria crear un sistema de control de carpertas he impresoras en redes linux, al estilo del que lleva Fedora 5 que me a gustado mucho y a Ubuntu le vendria de perlas. Se que sera un trabajo duro pero alguien tiene que empezar no?.

Saludos Linuxeros :-)

Jesmar - Usuario de Ubuntu Dapper.

+1
0
-1

Jesmar - Usuario de Ubuntu Edgy.