No puedo instalar programas.

Imagen de falolu
0 puntos

Hola soy nuevo en ubuntu y tengo un problema, cada vez que voy a instalar algun programa ya sea manual por el terminal o por el centro de software de ubuntu, me dice que tengo este error

Tipo 'wget' desconocido en la línea 54 de lista de fuentes /etc/apt/sources.list
E: No se pudieron leer las listas de fuentes.

que puedo hacer para eliminar este error, es que no puedo actualizar, ni instalar ninguna aplicacion

Imagen de ketk
+1
0
-1

En primer lugar, por favor, edita el título y pon uno descriptivoque cumpla con las normas.
En segundo lugar el problema parece que es que tocaste el archivo de repositorios (sources.list). La solución debería ser fácil:
Abre un terminal e introduce:
sudo gedit /etc/apt/sources.list
Ve a la línea 54 de ese archivo y pónnosla aquí, a ver qué es lo que tiene raro (puedes poner alguna precedente y posterior por si hay algún problema más abajo).


TuVela.com información, tutoriales, curiosidades y más sobre Ubuntu, GNU/Linux y otros temas de mi interés. 6b 65 74 6b

+1
0
-1

TuVela.com información, tutoriales, curiosidades y más sobre Ubuntu, GNU/Linux y otros temas de mi interés. 6b 65 74 6b


Imagen de falolu
+1
0
-1

Disculpen por mi ignorancia. No volvera a suceder, al ser mi primera intervencion en el foro pues desconozco las normas, intentare ser mas descriptivo en los titulos
Dejo una copia de la lista de repositorios, asi creo que me podran ayudar mucho mejor, gracias

deb cdrom:[Ubuntu 9.04 _Jaunty Jackalope_ - Release i386 (20090420.1)]/ jaunty main restricted
# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.

deb http://es.archive.ubuntu.com/ubuntu/ karmic main restricted universe
deb-src http://es.archive.ubuntu.com/ubuntu/ karmic restricted main multiverse universe #Added by software-properties

## Major bug fix updates produced after the final release of the
## distribution.
deb http://es.archive.ubuntu.com/ubuntu/ karmic-updates main restricted universe
deb-src http://es.archive.ubuntu.com/ubuntu/ karmic-updates restricted main multiverse universe Added by software-properties

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://es.archive.ubuntu.com/ubuntu/ karmic universe
deb http://es.archive.ubuntu.com/ubuntu/ karmic-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://es.archive.ubuntu.com/ubuntu/ karmic multiverse
deb http://es.archive.ubuntu.com/ubuntu/ karmic-updates multiverse

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
# deb http://es.archive.ubuntu.com/ubuntu/ jaunty-backports main restricted universe multiverse
# deb-src http://es.archive.ubuntu.com/ubuntu/ jaunty-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu jaunty partner
# deb-src http://archive.canonical.com/ubuntu jaunty partner

deb http://security.ubuntu.com/ubuntu karmic-security main restricted universe
deb-src http://security.ubuntu.com/ubuntu karmic-security restricted main multiverse universe #Added by software-properties
deb http://security.ubuntu.com/ubuntu karmic-security universe
deb http://security.ubuntu.com/ubuntu karmic-security multiverse
# deb http://ppa.launchpad.net/corenominal/ubuntu gutsy main # (desactivado en la actualización a karmic)
# deb-src http://ppa.launchpad.net/corenominal/ubuntu gutsy main # (desactivado en la actualización a karmic)
deb http://apt.wxwidgets.org/ hardy-wx main
deb http://www.beerorkid.com/compiz/ dapper main
deb http://xgl.compiz.info/ dapper main
deb-src http://xgl.compiz.info/ dapper main
add -deb http://ubuntu.beryl-project.org feisty main
deb-src http://ubuntu.beryl-project.org feisty main
deb http://www.beerorkid.com/compiz/ dapper main
deb http://xgl.compiz.info/ dapper main
deb-src http://xgl.compiz.info/ dapper main
deb http://compiz-mirror.lupine.me.uk/ dapper main

wget http://media.blutkind.org/xgl/quinn.key.asc -O - | sudo apt-key add -
wget http://compiz-mirror.lupine.me.uk/quinn.key.asc -O - | sudo apt-key add -
wget http://ubuntu.compiz.net/quinn.key.asc -O - | sudo apt-key add -
deb http://ubuntu.beryl-project.org feisty main

deb http://ubuntu.beryl-project.org feisty main
deb http://es.archive.ubuntu.com/ubuntu/ karmic-proposed restricted main multiverse universe
deb-src http://es.archive.ubuntu.com/ubuntu/ karmic-proposed restricted main multiverse universe #Added by software-properties
deb-src http://ubuntu.beryl-project.org feisty main

+1
0
-1
Imagen de ketk
+1
0
-1

En primer lugar, añadiste muchas cosas a los repositorios, ¿verdad? Hay montado pequeño gran lío, tienes líneas que corresponden a fiesty, karmic, drapper, jaunty y gutsy, tienes un poco de todas las versiones... eso no es nada bueno.
En cuanto al problema concreto lo que te da problemas son las líneas que empiezan por wget, eso son comandos, no deberían estar ahí. Simplemente elimina esas líneas, abre un terminal e introduce:
sudo aptitude update
Después de eso todo debería ir bien.


TuVela.com información, tutoriales, curiosidades y más sobre Ubuntu, GNU/Linux y otros temas de mi interés. 6b 65 74 6b

+1
0
-1

TuVela.com información, tutoriales, curiosidades y más sobre Ubuntu, GNU/Linux y otros temas de mi interés. 6b 65 74 6b


Imagen de RagonichaFulva
+1
0
-1

Menudo cacao de sources.list! :D

Desde luego le has metido la mano a fondo, ¿verdad?

Mira, este respositorio es para un ubuntu Karmik 9.10:

deb http://es.archive.ubuntu.com/ubuntu/ karmic-proposed restricted main multiverse universe

y este es para un ubuntu feisty:

deb-src http://ubuntu.beryl-project.org feisty main

así que no puede ser. Has de tener respositorios de sólo tu sistema.

Respecto a como arreglar lo otro, ya te han comentado que las lineas de wget no son repositorios.

Léete esto para saber lo que estás haciendo, que el conocimiento es lo mejor en estas cosas:

http://doc.ubuntu-es.org/Repositorios_desde_Ubuntu
http://es.wikipedia.org/wiki/GNU_Wget

Un saludo.

"La perseverancia es un árbol de raíces amargas, pero de frutos muy dulces."

Reclutador sin escrúpulos de doc.ubuntu-es.org ;)

¡Sorteo de foto de los admins de Tux!

+1
0
-1

"La perseverancia es un árbol de raíces amargas, pero de frutos muy dulces."

Imagen de falolu
+1
0
-1

he eliminado las lineas que comienzan con wget pero me sigue dando el mismo error, sera mejor cambiar las lineas de repositorios por nuevas y que me sean compatible.

+1
0
-1
Imagen de RagonichaFulva
+1
0
-1

¿Pero me has leido?

Te va a dar errores si tienes mezclados repositorios de ambos sistemas Ubuntu.

Lee los enlaces que te he pasado. No podemos darte la receta. Has de trabajártelo un poco. Corrige tu sources.list y te lo verificamos, pero antes lee un poco para saber lo que estás haciendo.

"La perseverancia es un árbol de raíces amargas, pero de frutos muy dulces."

Reclutador sin escrúpulos de doc.ubuntu-es.org ;)

¡Sorteo de foto de los admins de Tux!

+1
0
-1

"La perseverancia es un árbol de raíces amargas, pero de frutos muy dulces."

Imagen de falolu
+1
0
-1

ya he intentado arreglarlo, incluso cuando he editado los repo y guarde, me comenzo el gestor de actualizacion, asi me ha quedado

deb cdrom:[Ubuntu 9.04 _Jaunty Jackalope_ - Release i386 (20090420.1)]/ jaunty main restricted
# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://es.archive.ubuntu.com/ubuntu/ karmic main restricted universe
## Major bug fix updates produced after the final release of the
## distribution.
deb http://es.archive.ubuntu.com/ubuntu/ karmic-updates main restricted universe
deb-src http://es.archive.ubuntu.com/ubuntu/ karmic-updates restricted main multiverse universe Added by software-properties
## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://es.archive.ubuntu.com/ubuntu/ karmic universe
deb http://es.archive.ubuntu.com/ubuntu/ karmic-updates universe
## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://es.archive.ubuntu.com/ubuntu/ karmic multiverse
deb http://es.archive.ubuntu.com/ubuntu/ karmic-updates multiverse
## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
# deb http://es.archive.ubuntu.com/ubuntu/ jaunty-backports main restricted universe multiverse
# deb-src http://es.archive.ubuntu.com/ubuntu/ jaunty-backports main restricted universe multiverse
## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu jaunty partner
deb http://security.ubuntu.com/ubuntu karmic-security main restricted universe
deb http://security.ubuntu.com/ubuntu karmic-security universe
deb http://security.ubuntu.com/ubuntu karmic-security multiverse
# deb http://ppa.launchpad.net/corenominal/ubuntu gutsy main # (desactivado en la actualización a karmic)
deb http://apt.wxwidgets.org/ hardy-wx main
deb http://www.beerorkid.com/compiz/ dapper main
deb http://xgl.compiz.info/ dapper main
deb http://www.beerorkid.com/compiz/ dapper main
deb http://xgl.compiz.info/ dapper main
deb http://compiz-mirror.lupine.me.uk/ dapper main
deb http://ubuntu.beryl-project.org feisty main
deb http://ubuntu.beryl-project.org feisty main
deb http://es.archive.ubuntu.com/ubuntu/ karmic-proposed restricted main multiverse universe

+1
0
-1
Imagen de RagonichaFulva
+1
0
-1

Ok. Buen intento. Me alegro que lo intentaras.

Presumo que usas karmic koala. Es importante dar los datos de tu equipo y sistema en las consultas, al igual que relatar lo que has hecho, y en este post esto último es más importante porque se ve que has toqueteado mucho y has seguido recetas de internet.

Te pongo en negrita lo que tienes mal en sources.list:

deb cdrom:[Ubuntu 9.04 _Jaunty Jackalope_ - Release i386 (20090420.1)]/ jaunty main restricted
# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://es.archive.ubuntu.com/ubuntu/ karmic main restricted universe
## Major bug fix updates produced after the final release of the
## distribution.
deb http://es.archive.ubuntu.com/ubuntu/ karmic-updates main restricted universe
deb-src http://es.archive.ubuntu.com/ubuntu/ karmic-updates restricted main multiverse universe Added by software-properties
## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://es.archive.ubuntu.com/ubuntu/ karmic universe
deb http://es.archive.ubuntu.com/ubuntu/ karmic-updates universe
## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://es.archive.ubuntu.com/ubuntu/ karmic multiverse
deb http://es.archive.ubuntu.com/ubuntu/ karmic-updates multiverse
## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
# deb http://es.archive.ubuntu.com/ubuntu/ jaunty-backports main restricted universe multiverse
# deb-src http://es.archive.ubuntu.com/ubuntu/ jaunty-backports main restricted universe multiverse
## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu jaunty partner
deb http://security.ubuntu.com/ubuntu karmic-security main restricted universe
deb http://security.ubuntu.com/ubuntu karmic-security universe
deb http://security.ubuntu.com/ubuntu karmic-security multiverse
# deb http://ppa.launchpad.net/corenominal/ubuntu gutsy main # (desactivado en la actualización a karmic)
deb http://apt.wxwidgets.org/ hardy-wx main
deb http://www.beerorkid.com/compiz/ dapper main
deb http://xgl.compiz.info/ dapper main
deb http://www.beerorkid.com/compiz/ dapper main
deb http://xgl.compiz.info/ dapper main
deb http://compiz-mirror.lupine.me.uk/ dapper main
deb http://ubuntu.beryl-project.org feisty main
deb http://ubuntu.beryl-project.org feisty main
deb http://es.archive.ubuntu.com/ubuntu/ karmic-proposed restricted main multiverse universe

porque pertenecen a Jaunty y dapper respectivamente (es más, seguro que los de dapper ya están hasta desconectados porque creo que ya no recibe soporte).

los de feisty hacen referencia a Beryl, pero en Karmic ya tienes en los repositorios oficiales Compiz-Fusion, así que no te hacen falta.

Con que elimines los que te marqué ya te irá bien.

Un saludo.

"La perseverancia es un árbol de raíces amargas, pero de frutos muy dulces."

Reclutador sin escrúpulos de doc.ubuntu-es.org ;)

¡Sorteo de foto de los admins de Tux!

+1
0
-1

"La perseverancia es un árbol de raíces amargas, pero de frutos muy dulces."

Imagen de falolu
+1
0
-1

si en efecto esta intentando instalar beryl, creo q por eso fue que añadi esas repo, pero he visto la configuracion de compiz-funsion, enseguida elimino la que me sobren en la lista.
Pues he estado buscando para darle apariencia 3D a ubuntu

+1
0
-1
Imagen de RagonichaFulva
+1
0
-1

Pues solo has de instalar el driver de la tarjeta grafica (En administración , lo de Controladores de hardware) y en Preferencias -Apariencia decirle que te ponga los efectos de escritorio.

No hace falta que te lo trabajes más... eso se tenía que hacer hace tiempo con las versiones antiguas de ubuntu. ;)

"La perseverancia es un árbol de raíces amargas, pero de frutos muy dulces."

Reclutador sin escrúpulos de doc.ubuntu-es.org ;)

¡Sorteo de foto de los admins de Tux!

+1
0
-1

"La perseverancia es un árbol de raíces amargas, pero de frutos muy dulces."

Imagen de falolu
+1
0
-1

bien he eliminado todo lo mal que me han señalado en negritas, pero estoy confundido no se si los simbolos # tambien los debo eliminar

+1
0
-1
Imagen de ketk
+1
0
-1

Cada línea es una instrucción, las líneas que tienen una # delante no serán leídas por el sistema.
Así que las líneas que empiezan con # puedes dejarlas o quitarlas (si las quitas quedará más ordenado) a efectos del sistema es indiferente.


TuVela.com información, tutoriales, curiosidades y más sobre Ubuntu, GNU/Linux y otros temas de mi interés. 6b 65 74 6b

+1
0
-1

TuVela.com información, tutoriales, curiosidades y más sobre Ubuntu, GNU/Linux y otros temas de mi interés. 6b 65 74 6b


Imagen de JORGEWIN32
+1
0
-1

hola soy nuevo en ubuntu y tengo un problema y nose como solucionarlo puesto que cada ves que deseo ingresar al gestor de actulizaciones o al sinaptic me aparese esto:

No se ha podido inicializar la información de los paquetes

Ha ocurrido un problema imposible de corregir cuando se inicializaba la información de los paquetes.

Por favor, informe de ésto como un fallo en el paquete «update-manager» e incluya el siguiente mensaje de error:

'E:Línea 1 mal formada en lista de fuentes /etc/apt/sources.list.d/pidgin-ppa.list (análisis de dist), E:No se pudieron leer las listas de fuentes.'

nose si me pueden dar una mano con esto gracias.........

+1
0
-1
Imagen de LyingB
+1
0
-1

tienes que buscar antes de preguntar, además si tienes dudas debes abrir un nuevo hilo en vez de usar el de otro usuario.

+1
0
-1


Agrega al final del título del post (solucionado) si has arreglado tu problema.