[solucionado] Problema de configuracion de Realtek RTL8191SE

Imagen de alberpilot
0 puntos

Buenas!

Estoy intentando configurar la tarjeta inalambrica(Realtek 8192Se) siguiendo estos pasos:

1.- Descargo el driver (http://launchpadlibrarian.net/34090404/rtl8192se_linux_2.6.0010.1012.200...)

2.-
sudo modprobe -r ndiswrapper

sudo ndiswrapper -r net8192se

3.-
sudo apt-get install build-essential (desde un dvd de debian, ya que no tengo internet para poder instalarlos)

4.- Copio el driver a "/usr/local/src".

5.- Descomprimo:

sudo tar -xvzf rtl8192se_linux_2.6.0010.1012.2009_64bit.tar.gz

6.-
cd rtl8192se_linux_2.6.0010.1020.2009_64bit

7.-
sudo su -
make
make install

8.- Todo correcto:

lsmod |grep r8192se_pci

Me pone que esta cargado

9.- En NetworkManager de Gnome me dice que la red inalambrica esta desactivada (mi pc es un toshiba t130-132, el cual no tiene boton de activacion de la inalambrica, se activa con Fn + F8, pero el led de la inalambrica esta encendido, o por lo menos el mismo led que esta encendido cuando en guindow utilizo la inalambrica). Escribo en el terminal: sudo ifconfig wlan0 up

No me lanza ningun error, pero no me detecta ninguna red con iwlist scan.

¿Alguna idea?

Muchas gracias, un saludo a todos.

PD: He probado las soluciones dadas en este foro, e googleado tanto aqui como en google. Creo haber encontrado algo de que no hay driver por ahora pero tengo la esperanza de que no ya que hace un año del mensaje de foro en el que leí eso.

Imagen de joan77
+1
0
-1

Estoy exactamente igual que tu he conseguido instalar el controlador, pero no puedo activar la casilla de red inalambrica, que sale arriba.
Tambien tengo un toshiba t130 y lo he intentado tanto con ubuntu 32 bits, como con ubuntu 64bits y estoy en el mismo punto.
He intentado instalar los controladores de windows con ndiswapper y con ndisgtk y ni me detecta la tarjeta de red.

Si consigo conectarme te dire como lo he conseguido hacer.
Si tu ya lo has solucionado dime como.

+1
0
-1
Imagen de Edwar522
+1
0
-1

Hola, soy nuevo en el foro.
He instalado Ubuntu 9.04, pero tengo un problema con el Internet; me reconoce la red pero la señal dice:"Intensidad 18%" y no me entra a Internet. Estoy intentando configurar la tarjeta Realtek RTL8187 siguiendo estos pasos:

ifconfig wlan0 down
rmmod r8187 rtl8187 2>/dev/null
wget http://dl.aircrack-ng.org/drivers/rtl8187_linux_26.1010.zip
unzip rtl8187_linux_26.1010.zip
cd rtl8187_linux_26.1010.0622.2006/
wget http://patches.aircrack-ng.org/rtl8187_2.6.27.patch
wget http://patches.aircrack-ng.org/rtl8187_2.6.32.patch
tar xzf drv.tar.gz
tar xzf stack.tar.gz
patch -Np1 -i rtl8187_2.6.27.patch********Aquí me saca un error "Dice que no encuentra el fichero"***********
patch -Np1 -i rtl8187_2.6.32.patch********Aquí me saca el mismo error "Dice que no encuentra el fichero"***********
make ******No he llegado a este paso********
make install ******No he llegado a este paso********

Este mensaje lo estoy mandando desde XP, porque en XP si me funciona el Internet.
Espero me puedan ayudar, de antemano muchas gracias.

+1
0
-1

El amor concede a los demás el poder para destruirte.

Imagen de alberpilot
+1
0
-1

Ya lo he solucionado. Consegui configurar un adaptador de red inalambrica a puerto usb (un d-link dwl-122) con ndiswrapper y el driver de windows. Una vez hice esto, la clave esta en actualizar el kernel, se me descargo uno nuevo cuando hice el apt-get update y apt-get upgrade y con el ya si pude compilar el driver y me funciona de escandalo.

Espero que esto os sirva chicos!!

+1
0
-1
Imagen de Edwar522
+1
0
-1

Pero ¿Cómo lo hago si desde Ubuntu no tengo Internet?

El amor concede a los demás el poder para destruirte.

+1
0
-1

El amor concede a los demás el poder para destruirte.

Imagen de joan77
+1
0
-1

Ok muchas gracias.

+1
0
-1
Imagen de alberpilot
+1
0
-1

Tambien puedes bajarte la ultima version estable del kernel generico en kernel.org y compilarlo e instalarlo. Ya se que es un poco burro pero podrias hacerlo asi:

Una vez descargado y descomprimido en /usr/local/src te metes dentro del directorio y como root haces:

PASO OPCIONAL: ya que estas podrías hacer un make menuconfig y seleccionar las opciones del kernel correspondientes a tu portatil, conseguiras un kernel especifico para tu maquina y mas ligero. Aunque es algo complicado, por lo que si no quieres no lo hagas.

make
make install
make modules_install
update-initramfs -c -k 2.6.32.9(es el nombre que le puesto yo a mi version)
update-grub

Te aparecera la nueva version la proxima vez que reinicies y ahi ya podras compilar el driver con make y luego make install (cuando reinicies funcionará)

Ya se que esta forma es un poco pesada, pero esta forma y lo del adaptador USB de red inalambrica han sido las 2 cosas que me han funcionado y he probado.

Si os falla algo seguire atento a esta hebra para echaros una mano en lo que pueda.

Un saludo, suerte

+1
0
-1
Imagen de joan77
+1
0
-1

muchas gracias tenias razon he actualizado el kernel y me ha ido bien, graciassssssss

+1
0
-1
Imagen de alberpilot
+1
0
-1

Me alegro que te haya servido :-) a ver si al amigo Edwar522 tambien le ha servido

Una pregunta, dado que tenemos el mismo portatil, tu has podido configurar el bluetooth? Yo no lo logro, la verdad es que ni eso, ni el modulo acpi de toshiba(mira que cuando me compilado el kernel e puesto todas las opciones referentes a toshiba). Por no hablar de que el brillo lo tengo siempre a tope... no puedo bajarlo...

Un saludo

+1
0
-1
Imagen de joan77
+1
0
-1

La verdad es que aun no lo he mirado, por que me ha llevado lo suyo lo del controlador de la wifi,(ufff llevaba dos dias googleando y mirando foros), pero si encuentro alguna solucion te lo dire. saludossss

+1
0
-1
Imagen de Edwar522
+1
0
-1

Muchas gracias, me funciona de maravilla. :)

El amor concede a los demás el poder para destruirte.

+1
0
-1

El amor concede a los demás el poder para destruirte.

Imagen de shutruk
+1
0
-1

Hola. Saludos al que lo lea, que ya es bastante, en especial a Albertpilot por su labor. A mí no me ha salido (y he intentado hacer tres o cutro cosas diferentes de distintos foros franceses e ingleses). Os cuento lo que he hecho en mi toshiba t130 132 bajo ubuntu 9.10 de 64 bit
Descargo desde otro ordenador el kernel 2.6.33 (luego lo intenté con el 2.6.32.9) y tampoco.

1.- Descomprimo con tar jvxf archivo.tar.bz2
2.- Terminal
2.1 sudo su
2.2 lo "llevo" a a /usr/local/src
3.- make
y aquí da ya la lata.... que si menuconfig xconfig que si no se qué librería.....

..alguna idea? Gracias y saludos desde Granada

+1
0
-1
Imagen de alberpilot
+1
0
-1

Supongo shutruk que me conoces, por eso me has puesto saludos de granada, si no es asi, pues eso, yo tambien soy de granada xD.

Bueno el caso es que, para no complicarte la vida con el kernel bajate e instala uno genérico. Aqui tienes la manera de hacerlo facil (en el mensaje "Existe el KERNEL ya compilado por Canonical"):

http://www.ubuntu-es.org/?q=node/128867

Sigue esos pasos, y, en cuanto tengas instalado el kernel nuevo generico, descargate el driver para la RTL8191SE que está aqui, recuerda que usas RTL8191SE-VA2 en Unix(Linux)

Descomprime y entra en el directorio.
Haces
sudo make
sudo make install

En cuanto reinicies, te debería de funkar

Un saludo, seguiré por aki por si te falla algo

+1
0
-1
Imagen de alberpilot
+1
0
-1

+1
0
-1
Imagen de shutruk
+1
0
-1

... en especial a Alberpilot. Creo que no nos conocemos, pero Granada es tan pequeña que quizás sí.

Este post está escrito desde mi toshiba t130-132 con wifi ;) He seguido los pasos del post anterior de albertpilot descargando el kernel 2.6.33 en "formato" .deb

Un saludo, ahora a instalar latex, texlive, texmaker, maxima, ....éstas son pistas para alberpilot ;).

Yo también seguiré por aquí...

+1
0
-1
Imagen de alberpilot
+1
0
-1

Estaré atento a un portatil como el mio por la facultad shutruk. Me alegro que funcione. Nos vemos.

+1
0
-1
Imagen de abele
+1
0
-1

hola yo tambien soy nuevo en el foro queria compartir mi problema ..tengo un netbook lg x140(x86) y descarge el driver realtek rtl8191se(32bits) y tengo instalado en mi equipo solamente el ubuntu 10.10 .. por que el windows tiene mucho bicho raro con virus troyanos...y toda esa mi...... bueno el punto es que intento interactuar con el terminal.. para poder instalar el driver de la wifi que me hacia falta y no entiendo mucho los pasos de configuracion ...puesto que tengo que aprenderme algunos comandos ...alguien puede decirme o explicar ..como se hace..esto .. me seria de gran ayuda .. gracias...

+1
0
-1
Imagen de alberpilot
+1
0
-1

Buenas

Para el tema de los comandos y tal tendrás que leerte manuales, sin miedo, yo te voy a dar una pequeña guia de instalar este driver en particular

Una vez descargado el driver abres un terminal y haces lo siguiente:

0.- Te diriges al directorio donde hayas descargado el driver

cd directorio_donde_te_has_descargado_el_driver

1.-Descomprimimos el archivo que te has descargado

 sudo tar -xvvf nombre_del_archivo 

2.-Ingresamos dentro de ese directorio

 cd nuevo_directorio_despues_de_descomprimir

3.- Ahora para hacer lo siguiente debes tener instalado el paquete build-essential. Compilamos el driver

 make

4.- Instalamos

sudo make install

5.- Por ultimo reinicias. No lo recuerdo muy bien pero creo que también tenias que tener instalado el linux-headers. De ser asi, solo te lo descargas y luego lo instalas. Para ver tu version escribe en una terminal

uname -r

Pero esto ultimo no estoy seguro de que te haga falta.
Si tienes algun error ya sabes, busca en google porque seguramente haya alguien a quien le haya pasado antes. Si no postea por aqui y ya vemos lo que hacemos, pero te recomiendo que seas mas concreto en cuanto a tus "dudas" :-D

Un saludo, suerte.

PD: Creo que la ultima version de ubuntu ya te coje el driver automaticamente y no tienes que hacer nada de esto. Aunque de todas maneras no te vendría mal intentarlo aunque solo fuera por curiosidad y aprender.

+1
0
-1