problemas con el vlc ubuntu 9.10 64 bits (solucionado)

Imagen de llacosta2602
0 puntos

Hola,
Soy nuevo en Linux y os agradecería un poco de ayuda con un problemilla que tengo. Creo haber instalado bien todas las librerías y codecs de vídeo y audio para el ubuntu 9.10 64 bits. El caso es que no puedo reproducir nada con el vlc. El error que me sale al abrirlo mediante el terminal es:

luis@ubuntu:~$ vlc
VLC media player 1.0.2 Goldeneye
[0x1edb888] main libvlc: Ejecutar vlc con el interfaz por defecto. Usa 'cvlc' para usar vlc sin interfaz.
[0x7f119c0a52c8] pulse audio output: No. of Audio Channels: 2
QPainter::begin: Paint device returned engine == 0, type: 1
QPainter::begin: Paint device returned engine == 0, type: 1
[????????] x11 video output error: X11 request 133.19 failed with error code 8:
BadMatch (invalid parameter attributes)
X Error of failed request: BadMatch (invalid parameter attributes)
Major opcode of failed request: 133 (XVideo)
Minor opcode of failed request: 19 ()
Serial number of failed request: 101
Current serial number in output stream: 102

El caso es que con el totem no tengo ningún problema a la hora de abrir los archivos de audio.
Muchas gracias por vuestra atención.

Salu2

Imagen de arturom
+1
0
-1

Hola,
al parecer la versión 1.0.2 que viene por defecto en los repositorios de Jaunty tiene un bug que produce ese error. Hay que usar un repositorio que tiene la última versión de VLC ya sin ese bug.

Esta puede ser tu solución:

Abre una consola y edita tu sources.list

sudo gedit /etc/apt/sources.list

Inserta al final del fichero las líneas siguientes con los repositorios que necesitas

# Servidor PPa con la última versión de VLC
deb http://ppa.launchpad.net/guido-iodice/vlc-by-guiodic/ubuntu karmic main 
deb-src http://ppa.launchpad.net/guido-iodice/vlc-by-guiodic/ubuntu karmic main

Guarda el fichero y cierra el editor.

En la consola escribe esta línea para instalar la clave de seguridad:

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 666270B8

Usa ahora synaptic para actualizar los repositorios con esta órden:

sudo aptitude update

y cuando termine de actualizar, instalas VLC

sudo aptitude install VLC

Eso es todo, espero haberte ayudado.
___________________________________________________________________
Un saludo
ArturoM
(http://www.hispalazarus.tk/)

+1
0
-1

Un saludo
ArturoM

Imagen de llacosta2602
+1
0
-1

He seguido tus instrucciones y ya me funciona a la perfección. Te estoy muy agradecido :-)

Saludos

+1
0
-1
Imagen de JUNIORCAS12
+1
0
-1

igualmente me funcionó, cuando lo abria se ivan todos los marcos de las ventanas y debia reiniciar, ahora correo bien :) gracias

viva el software para todos

+1
0
-1

viva el software para todos